source: projects/specs/branches/6/a/apache2/apache2-vl.spec @ 7502

Revision 7502, 25.3 KB checked in by iwamoto, 11 years ago (diff)

apache2: update to 2.2.24

Line 
1%define contentdir /var/www
2%define suexec_caller apache
3%define mmn 20051115
4%define pkgname apache2
5
6Summary: Apache HTTP Server
7Name: %{pkgname}
8Version: 2.2.24
9Release: 1%{_dist_release}
10URL: http://httpd.apache.org/
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
17Source1: index.html.ja
18Source3: apache2.logrotate
19Source4: apache2.init
20Source5: README.confd
21Source6: vine.png
22Source10: httpd.conf
23Source11: apache-ssl.conf
24Source12: migration.html
25Source13: migration.css
26Source14: mod_ssl-Makefile.crt
27Source15: mod_ssl-Makefile.crl
28# add vine entry to config.layout
29Source100: vine-config.layout
30# man files
31Source101: apache2.8
32Source102: apache2ctl.8
33#Source103: config_vars.mk
34# build/scripts patches
35Patch1: httpd-2.1.10-apctl.patch
36Patch2: httpd-2.2.3-apxs.patch
37Patch3: httpd-2.0.45-deplibs.patch
38Patch4: httpd-2.1.10-disablemods.patch
39# features/functional changes
40Patch21: httpd-2.0.40-xfsz.patch
41# Patch22: httpd-2.1.10-pod.patch
42Patch22: httpd-2.2.23-pod.patch
43Patch23: httpd-2.0.45-export.patch
44Patch24: httpd-2.0.48-corelimit.patch
45# Bug fixes
46Patch54: httpd-2.2.0-authnoprov.patch
47Patch60: httpd-2.2.3-sslusername.patch
48
49# Security fixes
50
51License: Apache Software License
52Group: System Environment/Daemons
53BuildRoot: %{_tmppath}/%{name}-%{version}-root
54BuildRequires: db4-devel, expat-devel
55BuildRequires: findutils, perl, openldap-devel, zlib-devel
56BuildRequires: apr-devel, apr-util-devel
57BuildRequires: pcre-devel, sqlite3-devel
58Requires: mailcap, gawk, file, findutils, apr, apr-util
59Requires(pre): chkconfig, mktemp, fileutils
60Requires(pre): sh-utils, textutils, shadow-utils
61Requires(post): alternatives
62Provides: webserver
63Provides: httpd = %{version}
64Provides: httpd-mmn = %{mmn}
65Obsoletes: apache2-apr, apache2-apr-devel
66
67%description
68Apache is a powerful, full-featured, efficient, and freely-available
69Web server. Apache is also the most popular Web server on the
70Internet.
71
72%package devel
73Group: Development/Libraries
74Summary: Development tools for the Apache HTTP server.
75Requires: libtool, httpd = %{version}
76Requires: apr-devel, apr-util-devel
77
78%description devel
79The httpd-devel package contains the APXS binary and other files
80that you need to build Dynamic Shared Objects (DSOs) for Apache.
81
82If you are installing the Apache HTTP server and you want to be
83able to compile or develop additional modules for Apache, you need
84to install this package.
85
86%package manual
87Group: Applications/Documentation
88Summary: Documentation for the Apache HTTP server.
89
90%description manual
91The httpd-manual package contains the complete manual and
92reference guide for the Apache HTTP server. The information can
93also be found at http://httpd.apache.org/docs/.
94
95%package -n mod_ssl-apache2
96Group: System Environment/Daemons
97Summary: SSL/TLS module for the Apache HTTP server
98Epoch: 1
99BuildRequires: openssl-devel
100Requires(pre): openssl, dev, /bin/cat
101Requires: httpd, make, httpd-mmn = %{mmn}
102
103%description -n mod_ssl-apache2
104The mod_ssl module provides strong cryptography for the Apache Web
105server via the Secure Sockets Layer (SSL) and Transport Layer
106Security (TLS) protocols.
107
108%prep
109%setup -q -n httpd-%{version}
110
111%patch1 -p1 -b .apctl
112%patch2 -p1 -b .apxs
113#patch3 -p1 -b .deplibs
114%patch4 -p1 -b .disablemods
115
116%patch21 -p0 -b .xfsz
117%patch22 -p1 -b .pod
118%patch23 -p1 -b .export
119%patch24 -p1 -b .corelimit
120
121%patch54 -p1 -b .authnoprov
122%patch60 -p1 -b .sslusername
123
124# copy across the migration guide and sed it's location into apachectl
125cp $RPM_SOURCE_DIR/migration.{html,css} .
126%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
127        support/apachectl.in
128
129
130# add Vine configure's option to config.layout
131sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
132  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
133
134# regenerate configure scripts
135./buildconf
136
137%build
138# remove bundled apr, apr-util, pcre
139rm -rf srclib/{apr,apr-util,pcre}
140
141#CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
142#AP_LIBS="-lssl -lcrypto"
143#export CFLAGS AP_LIBS
144CFLAGS="$RPM_OPT_FLAGS"
145SH_LDFLAGS="-Wl,-z,relro"
146export CFLAGS SH_LDFLAGS
147
148%define mpms worker prefork
149%define prefer_mpm prefork
150
151AP_CONFOPTS="\
152        --prefix=%{_sysconfdir}/apache2 \
153        --exec-prefix=%{_prefix} \
154        --bindir=%{_bindir} \
155        --sbindir=%{_sbindir} \
156        --mandir=%{_mandir} \
157        --libdir=%{_libdir} \
158        --sysconfdir=%{_sysconfdir}/apache2/conf \
159        --includedir=%{_includedir}/apache2 \
160        --libexecdir=%{_libdir}/apache2/modules \
161        --datadir=%{contentdir} \
162        --with-installbuilddir=%{_libdir}/apache2/build \
163        --enable-layout=Vine \
164        --with-program-name=apache2 \
165        --with-ldap \
166        --enable-ldap --enable-authnz-ldap \
167        --enable-mods-shared=all \
168        --enable-cache=shared \
169        --enable-cgi=shared \
170        --enable-cgid=shared \
171        --enable-rewrite=shared \
172        --enable-disk-cache=shared \
173        --enable-file-cache=shared \
174        --enable-mem-cache=shared \
175        --enable-authn-anon --enable-authn-alias \
176        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
177        --enable-suexec --with-suexec \
178        --with-suexec-caller=%{suexec_caller} \
179        --with-suexec-docroot=%{contentdir} \
180        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
181        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
182        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
183        --with-pcre \
184        --enable-ssl --with-ssl \
185        --enable-deflate \
186        --enable-proxy --enable-proxy-connect \
187        --enable-proxy-http --enable-proxy-ftp"
188#all  mpm build
189for mpm in %{mpms}; do
190   mkdir mpm-$mpm;
191   cd mpm-$mpm;
192   ../configure $AP_CONFOPTS --with-mpm=$mpm --srcdir=../ ;
193   make %{?_smp_mflags} ;
194#   mv apache2 apache2.$mpm ;
195   cd ../
196done
197
198%install
199rm -rf $RPM_BUILD_ROOT
200
201# install mpms binary
202pushd mpm-prefork
203  make DESTDIR=$RPM_BUILD_ROOT install
204  rm -f $RPM_BUILD_ROOT/%{_sbindir}/apache2
205popd
206
207for mpm in %{mpms}; do
208    install -m755 mpm-$mpm/apache2 $RPM_BUILD_ROOT/%{_sbindir}/apache2.$mpm
209done
210
211# install conf file/directory
212mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d
213install -m 644 $RPM_SOURCE_DIR/README.confd \
214   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
215install -m 644 $RPM_SOURCE_DIR/apache-ssl.conf \
216   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/ssl.conf
217
218rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
219install -m 644 $RPM_SOURCE_DIR/httpd.conf \
220   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
221
222# mod_ssl bits
223for suffix in crl crt csr key prm; do
224   mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${suffix}
225done
226
227# Makefiles for certificate management
228for ext in crt crl; do
229  install -m 644 $RPM_SOURCE_DIR/mod_ssl-Makefile.${ext} \
230        $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${ext}/Makefile.${ext}
231done
232ln -s ../../../usr/share/ssl/certs/Makefile $RPM_BUILD_ROOT/etc/apache2/conf
233
234# for holding mod_dav lock database
235mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
236
237# create a prototype session cache
238mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
239touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
240
241# move utilities to /usr/bin
242mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
243   $RPM_BUILD_ROOT%{_bindir}
244
245# Make the MMN accessible to module packages
246echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
247
248# docroot
249# mkdir $RPM_BUILD_ROOT%{contentdir}/html
250install -m 644 $RPM_SOURCE_DIR/index.html.ja \
251        $RPM_BUILD_ROOT%{contentdir}/error/noindex.html
252rm -r $RPM_BUILD_ROOT%{contentdir}/manual/style
253
254install -m 644 $RPM_SOURCE_DIR/vine.png \
255        $RPM_BUILD_ROOT%{contentdir}/icons
256
257# logs
258# rmdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/logs
259mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/apache2
260
261ln -sf %{_sysconfdir}/%{pkgname}/conf/httpd.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/conf/apache2.conf
262
263
264# symlinks for /etc/apache2
265ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
266ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/apache2/run
267ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
268ln -s ../..%{_libdir}/apache2/build $RPM_BUILD_ROOT/etc/apache2/build
269
270# install SYSV init stuff
271mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
272install -m755 $RPM_SOURCE_DIR/apache2.init \
273        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
274%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
275        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
276
277# install log rotation stuff
278mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
279install -m644 $RPM_SOURCE_DIR/apache2.logrotate \
280        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
281
282mv $RPM_BUILD_ROOT/%{_sbindir}/apachectl $RPM_BUILD_ROOT/%{_sbindir}/apache2ctl
283
284# fix man page paths
285sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
286    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
287    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
288    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
289    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
290    -e "s|/usr/local/apache2/logs/httpd.pid|/var/run/apache2.pid|" \
291    -e "s|/usr/local/apache2|/etc/httpd|" < $RPM_SOURCE_DIR/apache2.8 \
292  > $RPM_BUILD_ROOT%{_mandir}/man8/apache2.8
293
294install -m644 $RPM_SOURCE_DIR/apache2ctl.8 \
295        $RPM_BUILD_ROOT%{_mandir}/man8/apache2ctl.8
296
297# change command name to avoid conflict with apache1 pacjage
298%define cflcmd /usr/bin/htdigest /usr/bin/htpasswd /usr/sbin/rotatelogs
299
300for i in %{cflcmd}; do \
301  echo $i
302  mv $RPM_BUILD_ROOT$i $RPM_BUILD_ROOT$i"2";
303done;
304
305mv $RPM_BUILD_ROOT/%{_sbindir}/apxs $RPM_BUILD_ROOT/%{_bindir}/apxs
306
307%define cflman usr/share/man/man1/dbmmanage.1 usr/share/man/man1/htdigest.1 usr/share/man/man1/htpasswd.1 usr/share/man/man8/rotatelogs.8 usr/share/man/man8/suexec.8 usr/share/man/man8/apxs.8 usr/share/man/man8/httpd.8
308
309(cd $RPM_BUILD_ROOT;
310for i in %{cflman}; do \
311    echo $i | sed -e "s|\.1|2\.1|" -e "s|\.8|2\.8|" |    xargs mv $i ;
312   
313done;
314)
315
316#cp $RPM_SOURCE_DIR/config_vars.mk $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/build/.
317mv $RPM_BUILD_ROOT/%{_sbindir}/suexec $RPM_BUILD_ROOT/%{_libdir}/%{pkgname}/suexec
318
319
320rm -f $RPM_BUILD_ROOT%{_mandir}/man1/ab*
321rm -f $RPM_BUILD_ROOT%{_mandir}/man1/logresolve*
322# conflict with apache 1, so removed...
323rm -f $RPM_BUILD_ROOT%{_mandir}/man8/ab*
324rm -f $RPM_BUILD_ROOT%{_mandir}/man8/logresolve*
325
326# remove unpackaged files
327rm -f $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/mime.types \
328      $RPM_BUILD_ROOT%{_libdir}/*.la \
329      $RPM_BUILD_ROOT%{_libdir}/*.exp \
330      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
331      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
332      $RPM_BUILD_ROOT%{_sbindir}/{apache2,checkgid,dbmmanage,envvars*} \
333      $RPM_BUILD_ROOT%{contentdir}/html/* \
334      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
335
336%pre
337# Add the "apache" user
338/usr/sbin/useradd -c "Apache" -u 48 \
339        -s /sbin/nologin -r -d %{contentdir} apache 2> /dev/null || :
340
341%triggerpostun -- apache < 2.0
342/sbin/chkconfig --add apache2
343
344
345%post
346# Register the httpd service
347for mpm in %{mpms}; do
348  /sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.$mpm 20;
349done
350/sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.%{prefer_mpm} 30
351/sbin/chkconfig --add apache2
352
353%preun
354if [ $1 = 0 ]; then
355        /sbin/service apache2 stop > /dev/null 2>&1
356        /sbin/chkconfig --del apache2
357        for mpm in %{mpms}; do
358          /sbin/update-alternatives --remove apache2 %{_sbindir}/apache2.$mpm;
359        done 
360fi
361
362%postun
363if [ "$1" -ge 1 ]; then
364        /sbin/service apache2 condrestart
365fi
366/sbin/ldconfig
367
368%post -n mod_ssl-apache2
369/sbin/ldconfig ### is this needed?
370umask 077
371
372if [ ! -f %{_sysconfdir}/apache2/conf/ssl.key/server.key ] ; then
373%{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/apache2/conf/ssl.key/server.key 2> /dev/null
374fi
375
376FQDN=`hostname`
377if [ "x${FQDN}" = "x" ]; then
378   FQDN=localhost.localdomain
379fi
380
381if [ ! -f %{_sysconfdir}/apache2/conf/ssl.crt/server.crt ] ; then
382cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/apache2/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/apache2/conf/ssl.crt/server.crt 2>/dev/null
383--
384SomeState
385SomeCity
386SomeOrganization
387SomeOrganizationalUnit
388${FQDN}
389root@${FQDN}
390EOF
391fi
392
393%clean
394rm -rf $RPM_BUILD_ROOT
395
396%files
397%defattr(-,root,root)
398
399%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
400%doc migration.html migration.css
401
402%dir %{_sysconfdir}/apache2
403%{_sysconfdir}/apache2/modules
404%{_sysconfdir}/apache2/logs
405%{_sysconfdir}/apache2/run
406%dir %{_sysconfdir}/apache2/conf
407%config(noreplace) %{_sysconfdir}/apache2/conf/*.conf
408%config(noreplace) %{_sysconfdir}/apache2/conf/magic
409
410%config %{_sysconfdir}/logrotate.d/apache2
411%config %{_sysconfdir}/rc.d/init.d/apache2
412
413%dir %{_sysconfdir}/apache2/conf.d
414%{_sysconfdir}/apache2/conf.d/README
415
416%dir %{_sysconfdir}/apache2/conf/extra
417%config %{_sysconfdir}/apache2/conf/extra/*
418
419%dir %{_sysconfdir}/apache2/conf/original
420%{_sysconfdir}/apache2/conf/original/*
421
422%{_bindir}/ab
423%{_bindir}/ht*
424%{_bindir}/logresolve
425%{_sbindir}/ht*
426%{_sbindir}/apache2.*
427%{_sbindir}/apache2ctl
428%{_sbindir}/rotatelogs2
429%attr(4510,root,%{suexec_caller}) %{_libdir}/%{pkgname}/suexec
430
431%dir %{_libdir}/apache2
432%dir %{_libdir}/apache2/modules
433# everything but mod_ssl.so:
434%{_libdir}/apache2/modules/mod_[a-r]*.so
435%{_libdir}/apache2/modules/mod_s[petu]*.so
436%{_libdir}/apache2/modules/mod_[t-z]*.so
437
438%dir %{contentdir}
439%dir %{contentdir}/cgi-bin
440%dir %{contentdir}/html
441%dir %{contentdir}/icons
442%dir %{contentdir}/error
443%dir %{contentdir}/error/include
444%{contentdir}/icons/*
445%{contentdir}/error/README
446%{contentdir}/error/noindex.html
447%config(noreplace) %{contentdir}/error/*.var
448%config(noreplace) %{contentdir}/error/include/*.html
449
450%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
451
452%attr(0700,apache,apache) %dir %{_localstatedir}/lib/dav
453
454%{_mandir}/man1/*
455
456%{_mandir}/man8/*
457
458%files manual
459%defattr(-,root,root)
460%{contentdir}/manual
461
462%files -n mod_ssl-apache2
463%defattr(-,root,root)
464%{_libdir}/apache2/modules/mod_ssl.so
465%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
466%attr(0700,root,root) %dir %{_sysconfdir}/apache2/conf/ssl.*
467%config %{_sysconfdir}/apache2/conf/Makefile
468%config %{_sysconfdir}/apache2/conf/ssl.*/*
469%attr(0700,apache,root) %dir %{_localstatedir}/cache/mod_ssl
470%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
471%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
472%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
473
474%files devel
475%defattr(-,root,root)
476%{_includedir}/apache2
477%{_sysconfdir}/apache2/build
478%{_bindir}/apxs
479%{_mandir}/man?/apxs*
480%{_libdir}/apache2/build/*.mk
481%{_libdir}/apache2/build/*.sh
482
483%changelog
484* Wed Feb 27 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-1
485- new upstream release with security fix (CVE-2012-3499, 4558)
486
487* Sun Sep 16 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.23-1
488- new upstream release with security fix (CVE-2012-3502,CVE-2012-2687)
489- update patch22 to fit new release
490- update man filename convert list
491
492* Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.22-1
493- update to 2.2.22
494  - CVE-2012-0021 (mod_log_config)
495  - CVE-2012-0031
496  - CVE-2012-0053
497- remove upstreamed patches
498
499* Fri Dec  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-5
500- add patch120 for fix CVE-2011-4317 (mod_rewrite/mod_proxy)
501
502* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-4
503- add patch110 for fix CVE-2011-3607-4415 (ModSetEnvIf)
504
505* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
506- add patch70 for fix byterange filter
507
508* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
509- add Patch100 for fix CVE-2011-3368 (mod_proxy)
510
511* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
512- new upstream release with security fix (CVE-2011-3348)
513- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
514
515* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
516- update Patch101 (Thanks to debian team)
517
518* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
519- add Patch101 for fix CVE-2011-3192 regression
520
521* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
522- new upstream release with security fix (CVE-2011-3192)
523- drop patch100 (is included in new release)
524
525* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
526- add patch100 for fix CVE-2011-3192 (Range Header DoS)
527
528* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
529- update to 2.2.19
530
531* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
532- remove old Obsoletes/Conflicts
533
534* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
535- rebuild with openssl-1.0.0c
536
537* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
538- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
539
540* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
541- add R(post): alternatives
542
543* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
544- add patch110 for fix CVE-2010-0434 from mdk 2010
545
546* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
547- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
548
549* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
550- rebuilt with rpm-4.8.0-3 (on ppc)
551
552* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
553- rebuild with db4-4.8.0
554
555* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
556- new upstream release with security fix
557  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
558- fix ssl.conf (2.2.13-1 includes wrong file)
559
560* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
561- new upstream release
562
563* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
564- new upstream release
565  (including security fix for CVE-2009-1890, CVE-2009-1191,
566   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
567
568* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
569- rebuilt with openldap-2.4.11
570
571* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
572- new upstream release
573
574* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
575- new upstream release (including security fix for CVE-2008-2939)
576
577* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
578- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
579- built with db4-4.6.21, apr 1.3.0
580
581* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
582- add Patch60 (to fix bug#31418).
583
584* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
585- rebuild with expat-2.0.1
586
587* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
588- new upstream release
589
590* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
591- added postun script from VinePlus/4.0 package
592  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
593  - add postun script to restart daemon with message
594
595* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
596- updated Patch2: httpd-2.2.3-apxs.patch
597
598* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
599- modified libdir in config.layout for lib64 architecture
600
601* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
602- rebuilt with openssl-0.9.8e
603
604* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
605- rebuilt with new toolchain and db4-4.3.x
606
607* Tue Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
608- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
609
610* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
611- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
612
613* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
614- rebuilt with openldap-2.3.27-0vl1
615
616* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
617- new upstream release including security fix (CVE-2006-3747)
618
619* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
620- new upstream release
621  - update to 2.2.2
622- remove apr/apr-devel subpackage,
623  use external apr/apr-util instead of internal one.
624
625* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
626- new upstream release
627- use apache2.prefork as default.
628
629* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
630- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
631- remove unpackaged files in %%install section
632
633* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
634- fix logrotate configuration (use apache2.pid instead of httpd.pid)
635  (BTS:10)
636- use Epoch instead of Serial
637
638* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
639- new upstream release
640- drop obsolete security patches which is merged in upstream
641
642* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
643- new upstream release
644
645* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
646- added Patch122 to 125 for secutiry fix
647  (CAN-2004-{1268,2088,2700,2728})
648- fix %install section
649
650* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
651- new upstream release
652
653* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
654- new upstream release
655
656* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
657- rebuilt with db4-4.2.52
658
659* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
660- separate apr, apr-devel packages
661- add BuildPreReq: zlib-devel
662
663* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
664- fix %%files to include instdso.sh
665  thanks to jax <jax AT morejams DOT no-ip DOT com>
666- add %%{?_smp_mflags} to make option.
667
668* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
669- new upstream version
670
671* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
672- new upstream version
673
674* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
675- new upstream version
676- update apxs patch (Patch101)
677- fix dependency:
678    - change file name to package name in Requires and {Build,}Prereq
679- add BuildPrereq: openldap-devel
680- update %%files section
681- rename httpd.8 manpage
682
683* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
684- new upstream version
685- used vine-config.layout in srclib
686
687* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
688- rebuild
689
690* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
691- change pkg name from mod_ssl to mod_ssl-apache2
692- remove "apache-manual" entry from Obsoletes:
693
694* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
695- remove "mod_dav" and "apache-devel" from Obsoletes:
696- enable MPMS(worker %mpms )
697
698* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
699- add correct config_vars.mk
700
701* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
702- apply apxs's patch ( from Debian)
703
704* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
705- add apr-config,apu-config to devel's %file
706
707* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
708- change apxs path ( /usr/sbin -> /usr/bin
709- add symlink under /etc/apache2/conf
710  (logs, run), httpd.conf -> apache2.conf
711- fixed apache2 initscript.
712
713* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
714- build Vine Linux
715- new upstream version
716- sharing with apache1
717
718* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
719- link httpd with libssl to avoid library loading/unloading weirdness
720
721* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
722- add LoadModule lines for proxy modules in httpd.conf (#73349)
723- fix permissions of conf/ssl.*/ directories; add Makefiles for
724  certificate management (#73352)
725
726* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
727- provide "httpd-mmn" to manage module ABI compatibility
728
729* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
730- fix SSL session cache (#69699)
731- revert addition of LDAP support to apr-util
732
733* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
734- set SIGXFSZ disposition to "ignored" (#69520)
735- make dummy connections to the first listener in config (#72692)
736
737* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
738- allow "apachectl configtest" on a 1.3 httpd.conf
739- add mod_deflate
740- enable LDAP support in apr-util
741- don't package everything in /var/www/error as config(noreplace)
742
743* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
744- add trigger (#68657)
745
746* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
747- update to 2.0.40
748
749* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
750- improve comment on use of UserDir in default config (#66886)
751
752* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
753- use /sbin/nologin as shell for apache user (#68371)
754- add patch from CVS to fix possible infinite loop when processing
755  internal redirects
756
757* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
758- modify init script to detect 1.3.x httpd.conf's and direct users
759  to the migration guide
760
761* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
762- patch apachectl to detect 1.3.x httpd.conf's and direct users
763  to the migration guide
764- ship the migration guide
765
766* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
767- move /etc/httpd2 back to /etc/httpd
768- add noindex.html page and poweredby logo; tweak default config
769  to load noindex.html if no default "/" page is present.
770- add patch to prevent mutex errors on graceful restart
771
772* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
773- automated rebuild
774
775* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
776- add patch to fix SSL mutex handling
777
778* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
779- improved config directory patch
780
781* Mon May 20 2002 Joe Orton <jorton@redhat.com>
782- initial build; based heavily on apache.spec and mod_ssl.spec
783- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
784
Note: See TracBrowser for help on using the repository browser.