source: projects/specs/branches/6/a/anthy/anthy-vl.spec @ 1943

Revision 1943, 11.3 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1%define __libtoolize :
2
3%define emacsen_pkg     1
4%{?without_emacsen: %define emacsen_pkg 0}
5
6%if %{emacsen_pkg}
7%undefine without_emacsen
8%define anthy_el        anthy-el
9%define anthy           anthy
10%define emacsen_pkgdir /usr/lib/emacsen-common/packages
11%else
12%define without_emacsen 1
13%endif
14
15%define ut_patch_date   20100517
16
17Summary: A Japanese character input system library (with dictionary).
18Summary(ja): Anthy - 日本語入力システムおよび辞書
19Name: anthy
20Version: 9100h
21Release: 11%{?_dist_release}
22URL: http://www.sourceforge.jp/projects/anthy/
23Source: %{name}-%{version}.tar.gz
24Source1: anthy-el-install.sh
25Source2: anthy-el-remove.sh
26Source3: anthy-init.el
27Source4: vine-default-anthy.el
28# large dictionary and improvement patch made by UTSUMI at
29# http://www.geocities.jp/ep3797/anthy_dict_01.html
30Source100: anthy-ut-patches-%{ut_patch_date}.tar.bz2
31# anthy patches made by G-HAL
32# http://www.fenix.ne.jp/~G-HAL/soft/nosettle/#anthy
33Patch100: anthy-9100h.patch13B-23-iconv-ucdict.2010507.alt-depgraph-100120-patch100126.alt-cannadic-091230.patch
34Patch110: anthy-9100h.patch13B-23-iconv-jisx0213.patch
35Patch120: anthy-ut-patches-20100517-ANTHY_ENCODING_EUCJP.patch
36License: GPL, LGPL, BSD
37Group: Applications/System
38BuildRoot: %{_tmppath}/%{name}-%{version}-root
39BuildRequires: automake, autoconf
40
41Vendor: Project Vine
42Distribution: Vine Linux
43Packager: daisuke, kazutaka
44
45%description
46Anthy is free and secure Japanese input system.
47
48%description -l ja
49Anthy はフリーでセキュアな日本語入力システムです。
50
51%if %{emacsen_pkg}
52%package -n %{anthy_el}
53Summary: Emacs-lisp frontend for Anthy
54Summary(ja): Anthy 用 Emacs-lisp フロントエンド
55Group: Applications/Editors/Emacs
56BuildRequires: emacsen
57Requires(post,preun): emacsen, emacsen-common >= 0.1
58Requires: %{name} = %{version}-%{release}
59
60%description -n %{anthy_el}
61Emacs-lisp frontend for Anthy
62
63%description -n %{anthy_el} -l ja
64Anthy のための Emacs-lisp フロントエンド
65%endif
66
67%package devel
68Summary: Development files for libanthy
69Summary(ja): libanthy を使ったアプリケーションを開発するためのファイル
70Group: Development/Libraries
71Requires: %{name} = %{version}-%{release}
72Requires: pkgconfig
73
74%description devel
75Devepment files for anthy libraries.
76
77%description devel -l ja
78libanthy を利用したアプリケーションを開発するために必要なヘッダやライブラリ
79が含まれています。
80
81
82%prep
83%setup -q -a 100
84%patch100 -p1
85%patch110 -p1
86%patch120 -p1
87
88pushd anthy-ut-patches-%{ut_patch_date}
89./apply-patches.sh
90popd
91
92# fix file permission...
93chmod a+x ./depgraph/mkdepword \
94          ./calctrans/divide.sh \
95          ./mkworddic/mkucdic.pl
96
97%build
98#libtoolize --copy --force
99autoreconf -f -i
100%configure --localstatedir=%{_var}
101
102#%__make %{?_smp_mflags}
103# don't use smp option
104%__make
105
106
107%install
108%__rm -rf ${RPM_BUILD_ROOT}
109%makeinstall
110%if %{emacsen_pkg}
111%__mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
112#%__mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
113#%__mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
114%__cp -af %{SOURCE3} %{SOURCE4} \
115    ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
116%__mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
117%__mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
118%endif
119
120%if %{emacsen_pkg}
121%{?emacsen_pkg: %_installemacsenscript %{anthy} %{SOURCE1}}
122%{?emacsen_pkg: %_removeemacsenscript  %{anthy} %{SOURCE2}}
123%else
124%__rm -rf ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
125%endif
126
127## remove unuse files
128rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
129
130
131%if %{emacsen_pkg}
132%post -n %{anthy_el}
133if [ "$1" = 2 ]; then
134  %{?emacsen_pkg: %_emacsenPackageRemove %{anthy}}
135fi
136%{?emacsen_pkg: %_addemacsenlist %{anthy}}
137%{?emacsen_pkg: %_emacsenPackageInstall %{anthy}}
138
139
140%preun -n %{anthy_el}
141if [ "$1" = 0 ]; then
142  %{?emacsen_pkg: %_emacsenPackageRemove %{anthy}}
143
144  %{?emacsen_pkg: %_removeemacsenlist %{anthy}}
145
146fi
147%endif
148
149
150%clean
151%__rm -rf ${RPM_BUILD_ROOT}
152
153
154%post -p /sbin/ldconfig
155
156
157%postun -p /sbin/ldconfig
158
159
160%files
161%defattr(-,root,root)
162%{_bindir}/*
163%{_sysconfdir}/*
164%{_datadir}/anthy
165%{_libdir}/libanthy*.so
166%{_libdir}/libanthy*.so.*
167%doc AUTHORS COPYING ChangeLog DIARY NEWS README doc Doxyfile README.en
168
169%if %{emacsen_pkg}
170%files -n %{anthy_el}
171%defattr(-, root, root)
172%{_datadir}/emacs/site-lisp/%{anthy}
173#%{_prefix}/lib/emacsen-common/packages/install/%{anthy}
174#%{_prefix}/lib/emacsen-common/packages/remove/%{anthy}
175%{emacsen_pkgdir}/install/%{anthy}
176%{emacsen_pkgdir}/remove/%{anthy}
177%endif
178
179%files devel
180%defattr(-,root,root)
181%{_includedir}/*
182%{_libdir}/libanthy*.a
183#%{_libdir}/libanthy*.la
184%{_libdir}/pkgconfig/*.pc
185
186%changelog
187* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 9100h-11
188- rebuilt with rpm-4.8.1 for pkg-config
189
190* Sun Jun 06 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9100h-10
191- add patch110 to change EUCJP AS EUCJP/JISX0213
192- add patch120 to change default encoding to EUCJP for compatibility
193
194* Fri Jun 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9100h-9
195- move ut patch to Source100
196- add Patch100 to add G-HAL's patches
197  - diffed from G-HAL's modified anthy archive.
198  - new ut patch does not include G-HAL's patches
199
200* Wed May 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 9100h-8
201- update Patch100 (anthy-ut-patches-20100517.tar.bz2)
202- run autoreconf at %%build section
203
204* Tue Jul 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-7
205- updated vine-default-anthy.el
206  - set 1 for anthy-accept-timeout (because default timeout is too long)
207
208* Sat Jun 27 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-6
209- update Patch100 (anthy-ut-patches-20090604.tar.bz2)
210
211* Mon May 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-5
212- update Patch100 (anthy-ut-patches-20090507.tar.bz2)
213
214* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-4
215- updated anthy-el-install.sh
216  - *-init.el: changed from hard copy to symbolic link
217    on /etc/emacs-XX.YY/site-start.d
218- corrected byte-compiling messages of emacs flaver
219
220* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-3
221- added vine-default-anthy.el
222- updated anthy-el-install.sh, anthy-el-remove.sh for vine-default-anthy.el
223
224* Tue Apr 07 2009 Shu KONNO <owa@bg.wakwak.com> 9100h-2
225- removed %%{?_smp_mflags} at make
226
227* Sun Mar 15 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-1
228- new upstream release
229- update Patch100
230
231* Wed Jan 21 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100e-3
232- add patch100 to improve conversion logic and add large dirctionary
233- add License LGPL and BSD for added patches
234-
235
236* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 9100e-2vl5
237- added %%emacsen_pkgdir
238- removed *.la
239- spec in utf-8
240
241* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9100e-1vl5
242- new upstream release
243
2441* Fri Dec 28 2007 IWAI, Masaharu <iwai@alib.jp> 9100d-0vl1
245- new upstream release
246
247* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9100-0vl1
248- new upstream release
249
250* Fri Jun 15 2007 IWAI, Masaharu <iwai@alib.jp> 9011-0vl1
251- new upstream release
252
253* Tue Oct 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7900-0vl3
254- use %%{_prefix}/lib instead of %%{_libdir} for elisp directory
255
256* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7900-0vl2
257- changed anthy-el Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
258
259* Fri Aug 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7900-0vl1
260- new upstream release
261
262* Fri Apr 28 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7500b-0vl1
263- new upstream release
264
265* Sat Mar 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7500-0vl1
266- new upstream release
267
268* Fri Dec 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl3
269- add BuildRequires: emacsen instead of emacs
270- add Requires: %%{name} to anthy-el package
271- add libanthy*.la to devel package
272- update anthy-el-install.sh
273  - add anthy-azik.el, anthy-kyuri.el
274
275* Sun Dec 18 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl2
276- add BuildRequires: emacs
277
278* Tue Dec 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl1
279- new upstream release
280
281* Mon Oct 17 2005 IWAI, Masaharu <iwai@alib.jp> 7015-0vl1
282- new upstream release
283
284* Mon Oct 10 2005 IWAI, Masaharu <iwai@alib.jp> 6829-0vl1
285- new upstream release
286
287* Sun Jul 31 2005 IWAI, Masaharu <iwai@alib.jp> 6724-0vl1
288- new upstream release
289- add documents: Doxyfile and README.en
290
291* Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6700b-0vl1
292- new upstream release
293
294* Tue May 10 2005 IWAI, Masaharu <iwai@alib.jp> 6508-0vl1
295- new upstream release
296
297* Sat Apr  9 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6300d-0vl1
298- new upstream release
299- added %{_libdir}/pkgconfig/anthy.pc to devel package
300
301* Fri Oct 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5812-0vl1
302- new upstream release
303
304* Sat Oct 09 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5714-0vl1
305- new upstream release
306
307* Sun Jul 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5500-0vl1
308- new upstream release
309
310* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl3
311- move libanthy*.so to anthy main package. it is needed by some
312  anthy application.
313
314* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl2
315- split development files to anthy-devel
316
317* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl1
318- new upstream release
319
320* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5220-0vl1
321- new upstream release
322
323* Wed Mar 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5122-0vl1
324- new upstream release
325
326* Sun Feb 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5100-0vl1
327- new upstream release
328
329* Mon Feb 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5021-0vl1
330- new upstream release
331
332* Wed Feb 11 2004 IWAI, Masaharu <iwai@alib.jp> 5008-0vl1
333- new upstream release
334
335* Tue Jan 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4925-0vl1
336- new upstream release
337
338* Sun Jan 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4901-0vl1
339- new upstream release
340
341* Thu Nov 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4723-0vl1
342- new upstream release
343
344* Mon Nov 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4708-0vl1
345- new upstream release
346
347* Fri Sep 26 2003 IWAI, Masaharu <iwai@alib.jp> 4524-0vl1
348- new upstream release
349
350* Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 4520-0vl1
351- new upstream release
352
353* Tue Sep  9 2003 IWAI, Masaharu <iwai@alib.jp> 4507-0vl3
354- update anthy-el-install.sh (Source1): [VineSeed-Plus:01834]
355  - The files to byte-compile is made the same as the upstream.
356
357* Tue Sep  9 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4507-0vl2
358- not bytecompile leim-list.el for XEmacs
359
360* Sun Sep 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4507-0vl1
361- new upstream release
362
363* Sun Aug 31 2003 IWAI, Masaharu <iwai@alib.jp> 4431-0vl1
364- new upstream snapshot release
365- create anthy-el package for emacsen
366
367* Fri Aug 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4421-0vl1
368- new upstream snapshot release
369
370* Fri Jul 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4300-0vl1
371- initial build for Vine Linux
372
373* Thu Jul 10 2003 Yuhei Matsunaga <yuhei@users.sourceforge.jp>
374- up to 4200.
375- added description.
376
377* Fri Nov 25 2002 OGUMA "dellin" Hironori <dellin@team-ct.org>
378- 3500c-1
379- up to 3500c.
380- added some documents.
381
382* Fri Nov 22 2002 OGUMA "dellin" Hironori <dellin@team-ct.org>
383- up to 3500b.
384
385* Thu Jan  3 2002 Yusuke Tabata <yusuke@kmc.gr.jp>
386- changed my mail address and URL of web page
387
388* Thu Nov 11 2001 Takayoshi Nobuoka <taka@trans-nt.com>
389- add %{_sysconfdir}/* at %files
390
391* Wed Sep  9 2001 Takayoshi Nobuoka <taka@trans-nt.com>
392- use _bindir and so on.
393
394* Sun Aug 19 2001 Tabatee <yusuke@kmc.kyoto-u.ac.jp>
395- Initial build.
396
Note: See TracBrowser for help on using the repository browser.