source: projects/specs/trunk/a/anthy/anthy-vl.spec @ 7969

Revision 7969, 11.5 KB checked in by iwaim, 10 years ago (diff)

anthy 9100h-12

Line 
1%define __libtoolize :
2
3%define emacsen_pkg     1
4%{?without_emacsen: %define emacsen_pkg 0}
5
6%if %{emacsen_pkg}
7%undefine without_emacsen
8%define anthy_el        anthy-el
9%define anthy           anthy
10%define emacsen_pkgdir /usr/lib/emacsen-common/packages
11%else
12%define without_emacsen 1
13%endif
14
15%define ut_patch_date   20100517
16
17Summary: A Japanese character input system library (with dictionary).
18Summary(ja): Anthy - 日本語入力システムおよび辞書
19Name: anthy
20Version: 9100h
21Release: 12%{?_dist_release}
22URL: http://www.sourceforge.jp/projects/anthy/
23Source: %{name}-%{version}.tar.gz
24Source1: anthy-el-install.sh
25Source2: anthy-el-remove.sh
26Source3: anthy-init.el
27Source4: vine-default-anthy.el
28# large dictionary and improvement patch made by UTSUMI at
29# http://www.geocities.jp/ep3797/anthy_dict_01.html
30Source100: anthy-ut-patches-%{ut_patch_date}.tar.bz2
31# anthy patches made by G-HAL
32# http://www.fenix.ne.jp/~G-HAL/soft/nosettle/#anthy
33Patch100: anthy-9100h.patch13B-23-iconv-ucdict.2010507.alt-depgraph-100120-patch100126.alt-cannadic-091230.patch
34Patch110: anthy-9100h.patch13B-23-iconv-jisx0213.patch
35Patch120: anthy-ut-patches-20100517-ANTHY_ENCODING_EUCJP.patch
36Patch121: make-anthy.el-work-with-emacs-24.3.1.diff
37License: GPL, LGPL, BSD
38Group: Applications/System
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40BuildRequires: automake, autoconf
41
42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: daisuke, kazutaka
45
46%description
47Anthy is free and secure Japanese input system.
48
49%description -l ja
50Anthy はフリーでセキュアな日本語入力システムです。
51
52%if %{emacsen_pkg}
53%package -n %{anthy_el}
54Summary: Emacs-lisp frontend for Anthy
55Summary(ja): Anthy 用 Emacs-lisp フロントエンド
56Group: Applications/Editors/Emacs
57BuildRequires: emacsen
58Requires(post,preun): emacsen, emacsen-common >= 0.1
59Requires: %{name} = %{version}-%{release}
60
61%description -n %{anthy_el}
62Emacs-lisp frontend for Anthy
63
64%description -n %{anthy_el} -l ja
65Anthy のための Emacs-lisp フロントエンド
66%endif
67
68%package devel
69Summary: Development files for libanthy
70Summary(ja): libanthy を使ったアプリケーションを開発するためのファイル
71Group: Development/Libraries
72Requires: %{name} = %{version}-%{release}
73Requires: pkgconfig
74
75%description devel
76Devepment files for anthy libraries.
77
78%description devel -l ja
79libanthy を利用したアプリケーションを開発するために必要なヘッダやライブラリ
80が含まれています。
81
82
83%prep
84%setup -q -a 100
85%patch100 -p1
86%patch110 -p1
87%patch120 -p1
88pushd src-util
89%patch121 -p1
90popd
91
92pushd anthy-ut-patches-%{ut_patch_date}
93./apply-patches.sh
94popd
95
96# fix file permission...
97chmod a+x ./depgraph/mkdepword \
98          ./calctrans/divide.sh \
99          ./mkworddic/mkucdic.pl
100
101%build
102#libtoolize --copy --force
103autoreconf -f -i
104%configure --localstatedir=%{_var}
105
106#%__make %{?_smp_mflags}
107# don't use smp option
108%__make
109
110
111%install
112%__rm -rf ${RPM_BUILD_ROOT}
113%makeinstall
114%if %{emacsen_pkg}
115%__mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
116#%__mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
117#%__mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
118%__cp -af %{SOURCE3} %{SOURCE4} \
119    ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
120%__mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
121%__mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
122%endif
123
124%if %{emacsen_pkg}
125%{?emacsen_pkg: %_installemacsenscript %{anthy} %{SOURCE1}}
126%{?emacsen_pkg: %_removeemacsenscript  %{anthy} %{SOURCE2}}
127%else
128%__rm -rf ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
129%endif
130
131## remove unuse files
132rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
133
134
135%if %{emacsen_pkg}
136%post -n %{anthy_el}
137if [ "$1" = 2 ]; then
138  %{?emacsen_pkg: %_emacsenPackageRemove %{anthy}}
139fi
140%{?emacsen_pkg: %_addemacsenlist %{anthy}}
141%{?emacsen_pkg: %_emacsenPackageInstall %{anthy}}
142
143
144%preun -n %{anthy_el}
145if [ "$1" = 0 ]; then
146  %{?emacsen_pkg: %_emacsenPackageRemove %{anthy}}
147
148  %{?emacsen_pkg: %_removeemacsenlist %{anthy}}
149
150fi
151%endif
152
153
154%clean
155%__rm -rf ${RPM_BUILD_ROOT}
156
157
158%post -p /sbin/ldconfig
159
160
161%postun -p /sbin/ldconfig
162
163
164%files
165%defattr(-,root,root)
166%{_bindir}/*
167%{_sysconfdir}/*
168%{_datadir}/anthy
169%{_libdir}/libanthy*.so
170%{_libdir}/libanthy*.so.*
171%doc AUTHORS COPYING ChangeLog DIARY NEWS README doc Doxyfile README.en
172
173%if %{emacsen_pkg}
174%files -n %{anthy_el}
175%defattr(-, root, root)
176%{_datadir}/emacs/site-lisp/%{anthy}
177#%{_prefix}/lib/emacsen-common/packages/install/%{anthy}
178#%{_prefix}/lib/emacsen-common/packages/remove/%{anthy}
179%{emacsen_pkgdir}/install/%{anthy}
180%{emacsen_pkgdir}/remove/%{anthy}
181%endif
182
183%files devel
184%defattr(-,root,root)
185%{_includedir}/*
186%{_libdir}/libanthy*.a
187#%{_libdir}/libanthy*.la
188%{_libdir}/pkgconfig/*.pc
189
190%changelog
191* Tue Jun 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 9100h-12
192- add anthy.el patch for Emacs 24.3 (Patch:121) <VineLinux:2629>
193
194* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 9100h-11
195- rebuilt with rpm-4.8.1 for pkg-config
196
197* Sun Jun 06 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9100h-10
198- add patch110 to change EUCJP AS EUCJP/JISX0213
199- add patch120 to change default encoding to EUCJP for compatibility
200
201* Fri Jun 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9100h-9
202- move ut patch to Source100
203- add Patch100 to add G-HAL's patches
204  - diffed from G-HAL's modified anthy archive.
205  - new ut patch does not include G-HAL's patches
206
207* Wed May 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 9100h-8
208- update Patch100 (anthy-ut-patches-20100517.tar.bz2)
209- run autoreconf at %%build section
210
211* Tue Jul 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-7
212- updated vine-default-anthy.el
213  - set 1 for anthy-accept-timeout (because default timeout is too long)
214
215* Sat Jun 27 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-6
216- update Patch100 (anthy-ut-patches-20090604.tar.bz2)
217
218* Mon May 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-5
219- update Patch100 (anthy-ut-patches-20090507.tar.bz2)
220
221* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-4
222- updated anthy-el-install.sh
223  - *-init.el: changed from hard copy to symbolic link
224    on /etc/emacs-XX.YY/site-start.d
225- corrected byte-compiling messages of emacs flaver
226
227* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-3
228- added vine-default-anthy.el
229- updated anthy-el-install.sh, anthy-el-remove.sh for vine-default-anthy.el
230
231* Tue Apr 07 2009 Shu KONNO <owa@bg.wakwak.com> 9100h-2
232- removed %%{?_smp_mflags} at make
233
234* Sun Mar 15 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-1
235- new upstream release
236- update Patch100
237
238* Wed Jan 21 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100e-3
239- add patch100 to improve conversion logic and add large dirctionary
240- add License LGPL and BSD for added patches
241-
242
243* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 9100e-2vl5
244- added %%emacsen_pkgdir
245- removed *.la
246- spec in utf-8
247
248* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9100e-1vl5
249- new upstream release
250
2511* Fri Dec 28 2007 IWAI, Masaharu <iwai@alib.jp> 9100d-0vl1
252- new upstream release
253
254* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9100-0vl1
255- new upstream release
256
257* Fri Jun 15 2007 IWAI, Masaharu <iwai@alib.jp> 9011-0vl1
258- new upstream release
259
260* Tue Oct 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7900-0vl3
261- use %%{_prefix}/lib instead of %%{_libdir} for elisp directory
262
263* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7900-0vl2
264- changed anthy-el Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
265
266* Fri Aug 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7900-0vl1
267- new upstream release
268
269* Fri Apr 28 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7500b-0vl1
270- new upstream release
271
272* Sat Mar 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7500-0vl1
273- new upstream release
274
275* Fri Dec 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl3
276- add BuildRequires: emacsen instead of emacs
277- add Requires: %%{name} to anthy-el package
278- add libanthy*.la to devel package
279- update anthy-el-install.sh
280  - add anthy-azik.el, anthy-kyuri.el
281
282* Sun Dec 18 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl2
283- add BuildRequires: emacs
284
285* Tue Dec 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl1
286- new upstream release
287
288* Mon Oct 17 2005 IWAI, Masaharu <iwai@alib.jp> 7015-0vl1
289- new upstream release
290
291* Mon Oct 10 2005 IWAI, Masaharu <iwai@alib.jp> 6829-0vl1
292- new upstream release
293
294* Sun Jul 31 2005 IWAI, Masaharu <iwai@alib.jp> 6724-0vl1
295- new upstream release
296- add documents: Doxyfile and README.en
297
298* Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6700b-0vl1
299- new upstream release
300
301* Tue May 10 2005 IWAI, Masaharu <iwai@alib.jp> 6508-0vl1
302- new upstream release
303
304* Sat Apr  9 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6300d-0vl1
305- new upstream release
306- added %{_libdir}/pkgconfig/anthy.pc to devel package
307
308* Fri Oct 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5812-0vl1
309- new upstream release
310
311* Sat Oct 09 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5714-0vl1
312- new upstream release
313
314* Sun Jul 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5500-0vl1
315- new upstream release
316
317* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl3
318- move libanthy*.so to anthy main package. it is needed by some
319  anthy application.
320
321* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl2
322- split development files to anthy-devel
323
324* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl1
325- new upstream release
326
327* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5220-0vl1
328- new upstream release
329
330* Wed Mar 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5122-0vl1
331- new upstream release
332
333* Sun Feb 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5100-0vl1
334- new upstream release
335
336* Mon Feb 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5021-0vl1
337- new upstream release
338
339* Wed Feb 11 2004 IWAI, Masaharu <iwai@alib.jp> 5008-0vl1
340- new upstream release
341
342* Tue Jan 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4925-0vl1
343- new upstream release
344
345* Sun Jan 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4901-0vl1
346- new upstream release
347
348* Thu Nov 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4723-0vl1
349- new upstream release
350
351* Mon Nov 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4708-0vl1
352- new upstream release
353
354* Fri Sep 26 2003 IWAI, Masaharu <iwai@alib.jp> 4524-0vl1
355- new upstream release
356
357* Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 4520-0vl1
358- new upstream release
359
360* Tue Sep  9 2003 IWAI, Masaharu <iwai@alib.jp> 4507-0vl3
361- update anthy-el-install.sh (Source1): [VineSeed-Plus:01834]
362  - The files to byte-compile is made the same as the upstream.
363
364* Tue Sep  9 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4507-0vl2
365- not bytecompile leim-list.el for XEmacs
366
367* Sun Sep 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4507-0vl1
368- new upstream release
369
370* Sun Aug 31 2003 IWAI, Masaharu <iwai@alib.jp> 4431-0vl1
371- new upstream snapshot release
372- create anthy-el package for emacsen
373
374* Fri Aug 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4421-0vl1
375- new upstream snapshot release
376
377* Fri Jul 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4300-0vl1
378- initial build for Vine Linux
379
380* Thu Jul 10 2003 Yuhei Matsunaga <yuhei@users.sourceforge.jp>
381- up to 4200.
382- added description.
383
384* Fri Nov 25 2002 OGUMA "dellin" Hironori <dellin@team-ct.org>
385- 3500c-1
386- up to 3500c.
387- added some documents.
388
389* Fri Nov 22 2002 OGUMA "dellin" Hironori <dellin@team-ct.org>
390- up to 3500b.
391
392* Thu Jan  3 2002 Yusuke Tabata <yusuke@kmc.gr.jp>
393- changed my mail address and URL of web page
394
395* Thu Nov 11 2001 Takayoshi Nobuoka <taka@trans-nt.com>
396- add %{_sysconfdir}/* at %files
397
398* Wed Sep  9 2001 Takayoshi Nobuoka <taka@trans-nt.com>
399- use _bindir and so on.
400
401* Sun Aug 19 2001 Tabatee <yusuke@kmc.kyoto-u.ac.jp>
402- Initial build.
403
Note: See TracBrowser for help on using the repository browser.