source: projects/specs/branches/6/T/TrueType-sazanami/TrueType-sazanami-vl.spec @ 3385

Revision 3385, 12.6 KB checked in by daisuke, 13 years ago (diff)

TrueType?-sazanami: remove R: TrueType?-base, P: TrueTypeFonts_jp

Line 
1# Command macros
2%define __mkfontdir     umask 133;/usr/bin/mkfontdir
3%define __mkfontscale   umask 133;/usr/bin/mkfontscale
4# Use this macro to call fc-cache throughout the specfile.
5%define __fccache       umask 133;which fc-cache &> /dev/null && fc-cache -f
6
7%define version 4.2
8%define release 2%{?_dist_release}
9%define sazanami_date 20040629-vl-20061231
10%define ttfjp_version 6.0
11
12%define xfontdir %{_datadir}/fonts/TrueType-sazanami
13%define fontpathdir %{_sysconfdir}/X11/fontpath.d
14
15Summary: Free Japanese True Type Font (Sazanami)
16Summary(ja): フリーの日本語 True Type フォント(さざなみ明朝/さざなみゴシック)
17Name: TrueType-sazanami
18Version: %{version}
19Release: %{release}
20BuildArch: noarch
21
22Obsoletes: TrueTypeFonts_jp < 4.1
23Obsoletes: TrueType-kochi <= 4.4.1
24Provides: TrueType-kochi = %{ttfjp_version}
25
26Requires: %{name}-mincho = %{version}-%{release}
27Requires: %{name}-gothic = %{version}-%{release}
28
29# This is not really required, but usefull to upgrade.
30Requires: TrueType-vlgothic
31
32Source: %{name}.tar.bz2
33Source10: 60-sazanami-mincho.conf
34Source11: 60-sazanami-gothic.conf
35
36Source20: cidfmap.ja.sazanami-mincho
37Source21: cidfmap.ja.sazanami-gothic
38
39# Sazanami Font Family
40Source4: sazanami-%{sazanami_date}.tar.bz2
41
42License: distributable
43Group: User Interface/X
44Buildroot: %{_tmppath}/%{name}-root
45
46Distribution: Vine Linux
47Vendor: Project Vine
48Packager: daisuke
49
50%description
51This is meta package for Free Japanese True Type Font 'Sazanami Font'
52- Sazanami-Mincho
53- Sazanami-Gothic
54
55%description -l ja
56このパッケージはフリーの日本語 True Type フォント「さざなみフォント」
57の明朝、ゴシック両書体をインストールするためのメタパッケージです。この
58パッケージで以下のフォントがインストールされます。
59- さざなみ明朝
60- さざなみゴシック
61
62%package mincho
63Summary: Sazanami Mincho TrueType Fonts
64Summary(ja): さざなみ明朝 True Type フォント
65Group: User Interface/X
66Requires(post,postun): mktcapdir >= 0.5.4
67Requires(post,postun): fontconfig, xorg-x11-font-utils
68
69%description mincho
70This package includes Sazanami Mincho TrueType fonts.
71
72%description -l ja mincho
73このパッケージにはさざなみ明朝フォントが含まれています。
74
75%package gothic
76Summary: Sazanami Gothic TrueType Fonts
77Summary(ja): さざなみゴシック 日本語 True Type フォント
78Group: User Interface/X
79Requires(post,postun): mktcapdir >= 0.5.4
80Requires(post,postun): fontconfig, xorg-x11-font-utils
81
82%description gothic
83This package includes Sazanami Gothic TrueType fonts.
84
85%description -l ja gothic
86このパッケージにはさざなみゴシックフォントがふくまれています。
87
88%prep
89rm -rf ${RPM_BUILD_ROOT}
90
91%setup -n %{name} -a 4
92mv sazanami-%{sazanami_date}/* .
93
94%install
95
96# mkdir fontdirs
97mkdir -p $RPM_BUILD_ROOT/%{xfontdir}-{mincho,gothic}
98# install ttfconf
99install -m644 *-mincho.ttfconf *-mincho.ttf $RPM_BUILD_ROOT/%{xfontdir}-mincho
100install -m644 *-gothic.ttfconf *-gothic.ttf $RPM_BUILD_ROOT/%{xfontdir}-gothic
101# install fonts
102ln -sf sazanami-mincho.ttf $RPM_BUILD_ROOT/%{xfontdir}-mincho/kochi-mincho.ttf
103ln -sf sazanami-gothic.ttf $RPM_BUILD_ROOT/%{xfontdir}-gothic/kochi-gothic.ttf
104
105# install fontpath.d symlink
106mkdir -p $RPM_BUILD_ROOT/%{fontpathdir}
107ln -sf %{xfontdir}-mincho $RPM_BUILD_ROOT/%{fontpathdir}/%{name}-mincho
108ln -sf %{xfontdir}-gothic $RPM_BUILD_ROOT/%{fontpathdir}/%{name}-gothic
109
110# install fontconfig files
111mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.{avail,d}
112install -m644 %{SOURCE10} %{SOURCE11} $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/
113for i in $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/*.conf
114do
115  ln -sf ../conf.avail/$(basename $i) $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.d/
116done
117
118# install ghostscript8 cidfmap
119mkdir -p $RPM_BUILD_ROOT%{_datadir}/ghostscript/conf.d
120install -m644 %{SOURCE20} %{SOURCE21} $RPM_BUILD_ROOT%{_datadir}/ghostscript/conf.d
121
122
123%post mincho
124%{_bindir}/mktcapdir %{xfontdir}-mincho %{xfontdir}-mincho/*.ttfconf
125( %__fccache %{xfontdir}-mincho ) ||:
126
127%post gothic
128%{_bindir}/mktcapdir %{xfontdir}-gothic %{xfontdir}-gothic/*.ttfconf
129( %__fccache %{xfontdir}-gothic ) ||:
130
131%postun mincho
132%{_bindir}/mktcapdir %{xfontdir}-mincho %{xfontdir}-mincho/*.ttfconf
133( %__fccache %{xfontdir}-mincho ) ||:
134
135%postun gothic
136%{_bindir}/mktcapdir %{xfontdir}-gothic %{xfontdir}-gothic/*.ttfconf
137( %__fccache %{xfontdir}-gothic ) ||:
138
139%clean
140rm -rf $RPM_BUILD_ROOT
141
142%files
143%defattr(-,root,root)
144%doc README doc/
145
146%files mincho
147%defattr(-,root,root)
148%{xfontdir}-mincho/*
149%{fontpathdir}/%{name}-mincho
150%{_sysconfdir}/fonts/conf.avail/60-sazanami-mincho.conf
151%config(missingok,noreplace) %{_sysconfdir}/fonts/conf.d/60-sazanami-mincho.conf
152%config %{_datadir}/ghostscript/conf.d/cidfmap.ja.sazanami-mincho
153
154%files gothic
155%defattr(-,root,root)
156%{xfontdir}-gothic/*
157%{fontpathdir}/%{name}-gothic
158%{_sysconfdir}/fonts/conf.avail/60-sazanami-gothic.conf
159%config(missingok,noreplace) %{_sysconfdir}/fonts/conf.d/60-sazanami-gothic.conf
160%config %{_datadir}/ghostscript/conf.d/cidfmap.ja.sazanami-gothic
161
162%changelog
163* Sun Apr 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2-2
164- remove R: TrueType-base
165- remove P: TrueTypeFonts_jp
166
167* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2-1
168- add gs8 cidfmap for sazanami
169
170* Sat Jun 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
171- split mincho and gothic to its own fontdir
172- add fontpath.d symlink
173
174* Thu May 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0-1
175- build for xorg-x11-7.3
176  - change font location to %{_datadir}/fonts/TrueType-sazanami
177  - require(post,postun) fontconfig and xorg-x11-font-utils
178- split to TrueType-sazanami-mincho and TrueType-sazanami-gothic
179
180* Sat Sep 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0-0vl1
181- split out VLGothic to TrueType-vlgothic package.
182
183* Sat Sep 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10-0vl1
184- update VLGothic to 20070901
185  - update some kanji glyphs
186
187* Thu Aug 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-0vl1
188- update VLGothic to 20070830
189  - update M+1C/M+1M to CVS head
190  - update some kanji glyphs
191
192* Mon Jul 31 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8-0vl1
193- update VLGothic to 20070731
194  - update M+1C/M+1M to CVS head
195  - add new glyphs to VL-PGothic/VL-Gothic
196    - add Roman Numeral Glyphs (some part of Number Forms)
197    - update some glyphs
198
199* Mon May 07 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-0vl1
200- update VLGothic to 20070507
201  - add new glyphs to VL-Gothic
202    - add ISO8859-1 Glyphs (Latin-1 Supplement)
203    - add ISO8859-15 Glyphs (some part of Latin Extended-A)
204
205* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6-0vl1
206- update VLGothic to 20070506
207  - add new glyphs to VL-PGothic
208    - add ISO8859-1 Glyphs (Latin-1 Supplement)
209    - add ISO8859-15 Glyphs (some part of Latin Extended-A)
210
211* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5-0vl1
212- update VLGothic to 20070503
213  - update M+1C/1M to CVS head
214
215* Wed Mar 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4-0vl1
216- update VLGothic to 20070328
217  - update M+1C/1M to CVS head
218  - fix embolden problem on freetype-2.2
219
220* Sat Mar 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3-0vl1
221- update VLGothic to 20070317
222  - update M+1C/1M to CVS head
223    - include M+ Kanji glyphs
224  - update some glyphs
225  - add some special sign characters
226  - fix broken glyphs
227
228* Mon Jan 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2-0vl1
229- update VLGothic to 20070101
230  - fix embolden problem on freetype-2.2
231
232* Sun Dec 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-0vl1
233- update VLGothic to 20061231
234  - update M+1C/M+1M to cvs head 20061231
235  - update kanji glyphs
236- update Sazanami to 20040629-vl-20061231
237  - fix broken glyphs of sazanami-mincho
238
239* Sat Oct 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl1
240- bump up version to 2.0
241- update VLGothic to 20061026
242  - update greek letter glyphs
243  - split license information file from README.
244  - add english version of license.
245
246* Sat Oct 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.29-0vl1
247- update VLGothic to 20061021
248
249* Fri Oct 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.28-0vl1
250- update VLGothic to 20061020 (<BTS:221>)
251  - update M+1C/M+1M to TESTFILGHT012
252  - update some glyphs
253  - fix outline direction
254  - remove overlap path
255
256* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.27-0vl1
257- update VLGothic to 20061005 (<BTS:221>)
258  - update some glyphs
259  - fix outline direction
260  - remove overlap path
261
262* Sat Sep 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26-0vl1
263- update VLGothic to 20060930 (<BTS:221>)
264  - fix outline direction
265  - remove overlap path
266
267* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.25-0vl1
268- update VLGothic to 20060929
269  - update some glyphs
270  - fix outline direction
271  - remove overlap path
272
273* Mon Sep 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24-0vl1
274- update VLGothic to 20060925
275  - update some glyphs
276  - add minimum gsub table for vertical writing
277
278* Thu Sep 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.23-0vl1
279- update VLGothic to 20060921
280  - update few glyphs
281  - update M+1C/M+1M to cvs head 2006/09/21
282
283* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22-0vl1
284- update VLGothic to 20060913
285  - update some glyphs
286  - fix half width space
287
288* Mon Sep 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.21-0vl1
289- update VLGothic to 20060911
290  - update M+1C/M+1M to cvs head 2006/09/11
291- use VL-PGothic for -alias-gothic-p- (legacy core font)
292
293* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20-0vl1
294- update VLGothic to 20060831
295  - add VL-Gothic-Regular.ttf for
296  - use M+1C for VLPGothic instead of M+1P
297
298* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.19-0vl1
299- fix sazanami.ttfconf
300
301* Tue Aug 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18-0vl1
302- change the fontname to VLPGothic
303- update VLPGothic
304- TODO:
305  - split VLGothic family to new package.
306  - add M+1M based VLGothic for monospace font.
307
308* Wed Aug 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.17-0vl1
309- update M+1P+Sazanami.ttf
310  - refine more glyphs
311
312* Wed Aug 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16-0vl1
313- update M+1P+Sazanami.ttf
314  - refine more glyphs
315  - add some glyphs for windows compatibility
316- update sazanami.ttfconf
317  - add -fake-kochi gothic-, -fake-kochi mincho- without TTCap
318    for Flash Plugin. (<BTS:0100>)
319
320* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.15-0vl1
321- update M+1P+Sazanami.ttf
322  - refine more glyphs
323  - add new full-width alphabets and numeric letters based on M+1P
324
325* Mon Jul 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-0vl1
326- update M+1P+Sazanami.ttf
327  - refine more glyphs
328
329* Sun Jul 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13-0vl1
330- update M+1P+Sazanami.ttf
331  - refine more glyphs
332  - redesign greek letter based on M+ 1P fonts
333
334* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12-0vl1
335- update M+1P+Sazanami.ttf
336  - refine more glyphs
337
338* Sun Jul 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11-0vl1
339- update M+1P+Sazanami.ttf
340  - refine more glyphs
341
342* Fri Jul 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-0vl1
343- update M+1P+Sazanami.ttf
344  - refine more glyphs
345  - fix encoding
346
347* Thu Jul 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-0vl1
348- update M+1P+Sazanami.ttf
349  - refine more glyphs
350  - fix outline direction (fix corruption on emboldening)
351
352* Wed Jul 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8-0vl1
353- update M+1P+Sazanami.ttf
354  - refine more glyphs
355  - fix broken glyph
356  - refine greek letters
357
358* Tue Jul 18 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7-0vl1
359- update M+1P+Sazanami.ttf
360  - refine more glyphs
361  - TODO: should rename the fontname?
362
363* Sun Jul 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-0vl1
364- update M+1P+Sazanami.ttf
365  - fix outline direction (fix corruption of some glyphs)
366  - refine more glyphs
367
368* Wed Jul 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl1
369- update M+1P+Sazanami.ttf
370  - refine some glyphs.. (modified 200 or more)
371- update sazanami.ttfconf to use M+1P+Sazanami for alias-{sans,gothic}-p
372
373* Mon Jul 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-0vl1
374- update M+1P+Sazanami.ttf
375  - refine some glyphs.. (modified 100 or more)
376
377* Mon Jul 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-0vl1
378- update M+1P-Sazanami.ttf
379  - fix corruption of some glyphs
380  - refine some glyphs to make it more usable..
381
382* Thu May 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-0vl1
383- add M+1P+Sazanami.ttf (Mplus 1P Font + Sazanami Gothic)
384
385* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
386- new upstream release
387
388* Wed Jun 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
389- initial build for Vine Linux based on TrueType-kochi-subst package
390- Provides TrueType-kochi, TrueTypeFonts_jp
391- include Kochi-{mincho,gothic}.ttf symlinks for compatibility
Note: See TracBrowser for help on using the repository browser.