source: projects/specs/trunk/T/TrueType-sazanami/TrueType-sazanami-vl.spec @ 521

Revision 521, 12.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Command macros
2%define __mkfontdir     umask 133;/usr/bin/mkfontdir
3%define __mkfontscale   umask 133;/usr/bin/mkfontscale
4# Use this macro to call fc-cache throughout the specfile.
5%define __fccache       umask 133;which fc-cache &> /dev/null && fc-cache -f
6
7%define version 4.2
8%define release 1%{?_dist_release}
9%define sazanami_date 20040629-vl-20061231
10%define ttfjp_version 6.0
11
12%define xfontdir %{_datadir}/fonts/TrueType-sazanami
13%define fontpathdir %{_sysconfdir}/X11/fontpath.d
14
15Summary: Free Japanese True Type Font (Sazanami)
16Summary(ja): フリーの日本語 True Type フォント(さざなみ明朝/さざなみゴシック)
17Name: TrueType-sazanami
18Version: %{version}
19Release: %{release}
20BuildArch: noarch
21
22PreReq: TrueType-base >= 4.4.1
23Requires: TrueType-base >= 4.4.1
24Provides: TrueTypeFonts_jp = %{ttfjp_version}
25
26Obsoletes: TrueTypeFonts_jp < 4.1
27Obsoletes: TrueType-kochi <= 4.4.1
28Provides: TrueType-kochi = %{ttfjp_version}
29
30Requires: %{name}-mincho = %{version}-%{release}
31Requires: %{name}-gothic = %{version}-%{release}
32
33# This is not really required, but usefull to upgrade.
34Requires: TrueType-vlgothic
35
36Source: %{name}.tar.bz2
37Source10: 60-sazanami-mincho.conf
38Source11: 60-sazanami-gothic.conf
39
40Source20: cidfmap.ja.sazanami-mincho
41Source21: cidfmap.ja.sazanami-gothic
42
43# Sazanami Font Family
44Source4: sazanami-%{sazanami_date}.tar.bz2
45
46License: distributable
47Group: User Interface/X
48Buildroot: %{_tmppath}/%{name}-root
49
50Distribution: Vine Linux
51Vendor: Project Vine
52
53%description
54This is meta package for Free Japanese True Type Font 'Sazanami Font'
55- Sazanami-Mincho
56- Sazanami-Gothic
57
58%description -l ja
59このパッケージはフリーの日本語 True Type フォント「さざなみフォント」
60の明朝、ゴシック両書体をインストールするためのメタパッケージです。この
61パッケージで以下のフォントがインストールされます。
62- さざなみ明朝
63- さざなみゴシック
64
65%package mincho
66Summary: Sazanami Mincho TrueType Fonts
67Summary(ja): さざなみ明朝 True Type フォント
68Group: User Interface/X
69Requires(post,postun): mktcapdir >= 0.5.4
70Requires(post,postun): fontconfig, xorg-x11-font-utils
71
72%description mincho
73This package includes Sazanami Mincho TrueType fonts.
74
75%description -l ja mincho
76このパッケージにはさざなみ明朝フォントが含まれています。
77
78%package gothic
79Summary: Sazanami Gothic TrueType Fonts
80Summary(ja): さざなみゴシック 日本語 True Type フォント
81Group: User Interface/X
82Requires(post,postun): mktcapdir >= 0.5.4
83Requires(post,postun): fontconfig, xorg-x11-font-utils
84
85%description gothic
86This package includes Sazanami Gothic TrueType fonts.
87
88%description -l ja gothic
89このパッケージにはさざなみゴシックフォントがふくまれています。
90
91%prep
92rm -rf ${RPM_BUILD_ROOT}
93
94%setup -n %{name} -a 4
95mv sazanami-%{sazanami_date}/* .
96
97%install
98
99# mkdir fontdirs
100mkdir -p $RPM_BUILD_ROOT/%{xfontdir}-{mincho,gothic}
101# install ttfconf
102install -m644 *-mincho.ttfconf *-mincho.ttf $RPM_BUILD_ROOT/%{xfontdir}-mincho
103install -m644 *-gothic.ttfconf *-gothic.ttf $RPM_BUILD_ROOT/%{xfontdir}-gothic
104# install fonts
105ln -sf sazanami-mincho.ttf $RPM_BUILD_ROOT/%{xfontdir}-mincho/kochi-mincho.ttf
106ln -sf sazanami-gothic.ttf $RPM_BUILD_ROOT/%{xfontdir}-gothic/kochi-gothic.ttf
107
108# install fontpath.d symlink
109mkdir -p $RPM_BUILD_ROOT/%{fontpathdir}
110ln -sf %{xfontdir}-mincho $RPM_BUILD_ROOT/%{fontpathdir}/%{name}-mincho
111ln -sf %{xfontdir}-gothic $RPM_BUILD_ROOT/%{fontpathdir}/%{name}-gothic
112
113# install fontconfig files
114mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.{avail,d}
115install -m644 %{SOURCE10} %{SOURCE11} $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/
116for i in $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/*.conf
117do
118  ln -sf ../conf.avail/$(basename $i) $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.d/
119done
120
121# install ghostscript8 cidfmap
122mkdir -p $RPM_BUILD_ROOT%{_datadir}/ghostscript/conf.d
123install -m644 %{SOURCE20} %{SOURCE21} $RPM_BUILD_ROOT%{_datadir}/ghostscript/conf.d
124
125
126%post mincho
127%{_bindir}/mktcapdir %{xfontdir}-mincho %{xfontdir}-mincho/*.ttfconf
128( %__fccache %{xfontdir}-mincho ) ||:
129
130%post gothic
131%{_bindir}/mktcapdir %{xfontdir}-gothic %{xfontdir}-gothic/*.ttfconf
132( %__fccache %{xfontdir}-gothic ) ||:
133
134%postun mincho
135%{_bindir}/mktcapdir %{xfontdir}-mincho %{xfontdir}-mincho/*.ttfconf
136( %__fccache %{xfontdir}-mincho ) ||:
137
138%postun gothic
139%{_bindir}/mktcapdir %{xfontdir}-gothic %{xfontdir}-gothic/*.ttfconf
140( %__fccache %{xfontdir}-gothic ) ||:
141
142%clean
143rm -rf $RPM_BUILD_ROOT
144
145%files
146%defattr(-,root,root)
147%doc README doc/
148
149%files mincho
150%defattr(-,root,root)
151%{xfontdir}-mincho/*
152%{fontpathdir}/%{name}-mincho
153%{_sysconfdir}/fonts/conf.avail/60-sazanami-mincho.conf
154%config(missingok,noreplace) %{_sysconfdir}/fonts/conf.d/60-sazanami-mincho.conf
155%config %{_datadir}/ghostscript/conf.d/cidfmap.ja.sazanami-mincho
156
157%files gothic
158%defattr(-,root,root)
159%{xfontdir}-gothic/*
160%{fontpathdir}/%{name}-gothic
161%{_sysconfdir}/fonts/conf.avail/60-sazanami-gothic.conf
162%config(missingok,noreplace) %{_sysconfdir}/fonts/conf.d/60-sazanami-gothic.conf
163%config %{_datadir}/ghostscript/conf.d/cidfmap.ja.sazanami-gothic
164
165%changelog
166* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2-1
167- add gs8 cidfmap for sazanami
168
169* Sat Jun 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
170- split mincho and gothic to its own fontdir
171- add fontpath.d symlink
172
173* Thu May 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0-1
174- build for xorg-x11-7.3
175  - change font location to %{_datadir}/fonts/TrueType-sazanami
176  - require(post,postun) fontconfig and xorg-x11-font-utils
177- split to TrueType-sazanami-mincho and TrueType-sazanami-gothic
178
179* Sat Sep 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0-0vl1
180- split out VLGothic to TrueType-vlgothic package.
181
182* Sat Sep 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10-0vl1
183- update VLGothic to 20070901
184  - update some kanji glyphs
185
186* Thu Aug 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-0vl1
187- update VLGothic to 20070830
188  - update M+1C/M+1M to CVS head
189  - update some kanji glyphs
190
191* Mon Jul 31 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8-0vl1
192- update VLGothic to 20070731
193  - update M+1C/M+1M to CVS head
194  - add new glyphs to VL-PGothic/VL-Gothic
195    - add Roman Numeral Glyphs (some part of Number Forms)
196    - update some glyphs
197
198* Mon May 07 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-0vl1
199- update VLGothic to 20070507
200  - add new glyphs to VL-Gothic
201    - add ISO8859-1 Glyphs (Latin-1 Supplement)
202    - add ISO8859-15 Glyphs (some part of Latin Extended-A)
203
204* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6-0vl1
205- update VLGothic to 20070506
206  - add new glyphs to VL-PGothic
207    - add ISO8859-1 Glyphs (Latin-1 Supplement)
208    - add ISO8859-15 Glyphs (some part of Latin Extended-A)
209
210* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5-0vl1
211- update VLGothic to 20070503
212  - update M+1C/1M to CVS head
213
214* Wed Mar 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4-0vl1
215- update VLGothic to 20070328
216  - update M+1C/1M to CVS head
217  - fix embolden problem on freetype-2.2
218
219* Sat Mar 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3-0vl1
220- update VLGothic to 20070317
221  - update M+1C/1M to CVS head
222    - include M+ Kanji glyphs
223  - update some glyphs
224  - add some special sign characters
225  - fix broken glyphs
226
227* Mon Jan 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2-0vl1
228- update VLGothic to 20070101
229  - fix embolden problem on freetype-2.2
230
231* Sun Dec 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-0vl1
232- update VLGothic to 20061231
233  - update M+1C/M+1M to cvs head 20061231
234  - update kanji glyphs
235- update Sazanami to 20040629-vl-20061231
236  - fix broken glyphs of sazanami-mincho
237
238* Sat Oct 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl1
239- bump up version to 2.0
240- update VLGothic to 20061026
241  - update greek letter glyphs
242  - split license information file from README.
243  - add english version of license.
244
245* Sat Oct 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.29-0vl1
246- update VLGothic to 20061021
247
248* Fri Oct 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.28-0vl1
249- update VLGothic to 20061020 (<BTS:221>)
250  - update M+1C/M+1M to TESTFILGHT012
251  - update some glyphs
252  - fix outline direction
253  - remove overlap path
254
255* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.27-0vl1
256- update VLGothic to 20061005 (<BTS:221>)
257  - update some glyphs
258  - fix outline direction
259  - remove overlap path
260
261* Sat Sep 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26-0vl1
262- update VLGothic to 20060930 (<BTS:221>)
263  - fix outline direction
264  - remove overlap path
265
266* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.25-0vl1
267- update VLGothic to 20060929
268  - update some glyphs
269  - fix outline direction
270  - remove overlap path
271
272* Mon Sep 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24-0vl1
273- update VLGothic to 20060925
274  - update some glyphs
275  - add minimum gsub table for vertical writing
276
277* Thu Sep 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.23-0vl1
278- update VLGothic to 20060921
279  - update few glyphs
280  - update M+1C/M+1M to cvs head 2006/09/21
281
282* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22-0vl1
283- update VLGothic to 20060913
284  - update some glyphs
285  - fix half width space
286
287* Mon Sep 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.21-0vl1
288- update VLGothic to 20060911
289  - update M+1C/M+1M to cvs head 2006/09/11
290- use VL-PGothic for -alias-gothic-p- (legacy core font)
291
292* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20-0vl1
293- update VLGothic to 20060831
294  - add VL-Gothic-Regular.ttf for
295  - use M+1C for VLPGothic instead of M+1P
296
297* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.19-0vl1
298- fix sazanami.ttfconf
299
300* Tue Aug 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18-0vl1
301- change the fontname to VLPGothic
302- update VLPGothic
303- TODO:
304  - split VLGothic family to new package.
305  - add M+1M based VLGothic for monospace font.
306
307* Wed Aug 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.17-0vl1
308- update M+1P+Sazanami.ttf
309  - refine more glyphs
310
311* Wed Aug 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16-0vl1
312- update M+1P+Sazanami.ttf
313  - refine more glyphs
314  - add some glyphs for windows compatibility
315- update sazanami.ttfconf
316  - add -fake-kochi gothic-, -fake-kochi mincho- without TTCap
317    for Flash Plugin. (<BTS:0100>)
318
319* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.15-0vl1
320- update M+1P+Sazanami.ttf
321  - refine more glyphs
322  - add new full-width alphabets and numeric letters based on M+1P
323
324* Mon Jul 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-0vl1
325- update M+1P+Sazanami.ttf
326  - refine more glyphs
327
328* Sun Jul 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13-0vl1
329- update M+1P+Sazanami.ttf
330  - refine more glyphs
331  - redesign greek letter based on M+ 1P fonts
332
333* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12-0vl1
334- update M+1P+Sazanami.ttf
335  - refine more glyphs
336
337* Sun Jul 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11-0vl1
338- update M+1P+Sazanami.ttf
339  - refine more glyphs
340
341* Fri Jul 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-0vl1
342- update M+1P+Sazanami.ttf
343  - refine more glyphs
344  - fix encoding
345
346* Thu Jul 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-0vl1
347- update M+1P+Sazanami.ttf
348  - refine more glyphs
349  - fix outline direction (fix corruption on emboldening)
350
351* Wed Jul 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8-0vl1
352- update M+1P+Sazanami.ttf
353  - refine more glyphs
354  - fix broken glyph
355  - refine greek letters
356
357* Tue Jul 18 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7-0vl1
358- update M+1P+Sazanami.ttf
359  - refine more glyphs
360  - TODO: should rename the fontname?
361
362* Sun Jul 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-0vl1
363- update M+1P+Sazanami.ttf
364  - fix outline direction (fix corruption of some glyphs)
365  - refine more glyphs
366
367* Wed Jul 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl1
368- update M+1P+Sazanami.ttf
369  - refine some glyphs.. (modified 200 or more)
370- update sazanami.ttfconf to use M+1P+Sazanami for alias-{sans,gothic}-p
371
372* Mon Jul 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-0vl1
373- update M+1P+Sazanami.ttf
374  - refine some glyphs.. (modified 100 or more)
375
376* Mon Jul 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-0vl1
377- update M+1P-Sazanami.ttf
378  - fix corruption of some glyphs
379  - refine some glyphs to make it more usable..
380
381* Thu May 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-0vl1
382- add M+1P+Sazanami.ttf (Mplus 1P Font + Sazanami Gothic)
383
384* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
385- new upstream release
386
387* Wed Jun 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
388- initial build for Vine Linux based on TrueType-kochi-subst package
389- Provides TrueType-kochi, TrueTypeFonts_jp
390- include Kochi-{mincho,gothic}.ttf symlinks for compatibility
Note: See TracBrowser for help on using the repository browser.