source: projects/web/trunk/vlmagazine/20111128/netcdf-vl.spec @ 5211

Revision 5211, 3.8 KB checked in by kenta, 12 years ago (diff)

added sample spec file

Line 
1
2# Basic Information
3Name:           netcdf
4Version:        4.1.3
5Release:        1%{?_dist_release}
6License:        distributable
7Group:          Development/Libraries
8URL:            http://www.unidata.ucar.edu/software/netcdf/
9Source0:        http://www.unidata.ucar.edu/downloads/%{name}/ftp/%{name}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       kenta
15
16Summary:        Libraries for the Unidata network Common Data Form (NetCDF)
17Summary(ja):    Unidata network Common Data Form (NetCDF) 用のライブラリ
18
19# Dependency
20BuildRequires:  gcc-gfortran, gawk
21# BuildRequires:  hdf5-devel >= 1.8.4
22# BuildRequires:  libcurl-devel
23# BuildRequires:  zlib-devel
24
25%description
26NetCDF (network Common Data Form) is an interface for array-oriented
27data access and a freely-distributed collection of software libraries
28for C, Fortran, C++, and perl that provides an implementation of the
29interface.  The NetCDF library also defines a machine-independent
30format for representing scientific data.  Together, the interface,
31library, and format support the creation, access, and sharing of
32scientific data. The NetCDF software was developed at the Unidata
33Program Center in Boulder, Colorado.
34
35%description -l ja
36NetCDF (network Common Data Form) は配列指向のデータアクセスのためのインター
37フェース群と、インターフェースを実装するための配布可能な C, Fortran, C++ と
38perl用ライブラリ群です。また、NetCDF はマシン非依存な科学データの表現フォー
39マットを定義しており、インターフェース、ライブラリとフォーマットが科学データの
40作成、参照、共有を容易化します。
41NetCDF ソフトウェアは米国コロラド州ボルダーの Unidataプログラム・センターで
42開発されています。
43
44%package devel
45Summary:        Development files for netcdf
46Summary(ja):    NetCDF の開発パッケージ
47Group:          Development/Libraries
48Requires:       %{name} = %{version}-%{release}
49Requires:       gcc-gfortran%{_isa}
50Requires:       pkgconfig
51# Requires:       hdf5-devel
52# Requires:       libcurl-devel
53
54%description devel
55This package contains the netCDF header files, shared devel libs, and
56man pages.
57
58%description -l ja devel
59このパッケージには netCDF のヘッダーファイルと開発用の共有ライブラリ、
60man のファイルが含まれています。
61
62%package static
63Summary:        Static libs for netcdf
64Summary(ja):    NetCDF の静的リンク用ライブラリ
65Group:          Development/Libraries
66Requires:       %{name} = %{version}-%{release}
67
68%description static
69This package contains the netCDF static libs.
70
71%description -l ja static
72このパッケージには netCDF の静的リンク用ライブラリが含まれています
73
74%prep
75%setup -q
76
77%build
78%configure --disable-netcdf-4
79%{__make} %{?_smp_mflags}
80
81%install
82%{__rm} -rf ${RPM_BUILD_ROOT}
83%{__make} install DESTDIR=${RPM_BUILD_ROOT}
84/bin/rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
85/bin/rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
86
87%clean
88%{__rm} -rf ${RPM_BUILD_ROOT}
89
90%post
91/sbin/ldconfig
92/sbin/install-info %{_infodir}/netcdf.info \
93    %{_infodir}/dir 2>/dev/null || :
94
95%postun
96/sbin/ldconfig
97if [ "$1" = 0 ]; then
98  /sbin/install-info --delete %{_infodir}/netcdf.info \
99    %{_infodir}/dir 2>/dev/null || :
100fi
101
102%files
103%defattr(-,root,root)
104%doc COPYRIGHT README RELEASE_NOTES
105%{_bindir}/nccopy
106%{_bindir}/ncdump
107%{_bindir}/ncgen
108%{_bindir}/ncgen3
109%{_libdir}/*.so.*
110%{_mandir}/man1/*
111%{_infodir}/*
112
113%files devel
114%defattr(-,root,root,-)
115%{_bindir}/nc-config
116%{_includedir}/*
117%{_libdir}/*.so
118%{_libdir}/pkgconfig/netcdf.pc
119%{_mandir}/man3/*
120
121%files static
122%defattr(-,root,root,-)
123%{_libdir}/*.a
124
125%changelog
126* Sun Nov 27 2011 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.3-1
127- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.