source: projects/vbootstrap/trunk/vbootstrap.spec @ 519

Revision 519, 5.0 KB checked in by shaolin, 14 years ago (diff)
  • remove Retry_vbootstrap-post() from the vbuilder script:
    • the trick (implemented in 0.0.18-1) moved to vbootstrap/scripts/* instead
    • so that proper rpmdb is available even executing vbootstrap only
  • vbuilder 内の Retry_vbootstrap-post() を廃止
    • 代わりに vbootstrap/scripts/* 内で同等の内容を実行
    • これにより vbootstrap のみ実行した直後でも rpmdb が正しい状態にできる
Line 
1# This package is maintained on trac svn repository. Please do not change on local.
2# If you find a BUG, please report to Vine@vinelinux.org or mailing list or BTS.
3
4%define version 0.0.19
5
6Summary: bootstrap scripts to create a basic Vine Linux system
7Summary(ja): Vine Linux の基本システムを作成するためのスクリプト
8Name: vbootstrap
9Version: %{version}
10Release: 1%{?_dist_release}
11License: public domain
12Group: Development/Tools
13Url: http://trac.vinelinux.org/wiki/VineBootstrap
14
15Source0: %{name}-%{version}.tar.bz2
16
17Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildArch: noarch
19BuildRequires: sed
20Requires: bash, apt
21Requires: unionfs-utils
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke, munepi
26
27%description
28vbootstrap is used to create a basic Vine Linux system on existing Vine Linux
29system. It uses rpm and apt to install basic rpm package into a directory
30which can be chrooted into.
31
32%description -l ja
33vbootstrap は Vine Linux の基本システムを既存の Vine Linux システム上で
34作成するスクリプトです。rpm および apt を利用して、指定したディレクトリ
35以下に基本の rpm パッケージをインストールし、chroot できるようにします。
36
37
38%prep
39[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
40
41%setup
42
43%build
44%__make
45
46%install
47%__make DESTDIR=$RPM_BUILD_ROOT install
48
49%clean
50[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
51
52
53%files
54%defattr(-,root,root)
55%{_sbindir}/vbootstrap
56%{_sbindir}/vbuilder
57%dir %{_datadir}/vbootstrap
58%{_datadir}/vbootstrap/*
59%{_sysconfdir}/bash_completion.d/vbuilder
60%config(noreplace) %{_sysconfdir}/vbootstrap/vbuilder.conf
61
62
63%changelog
64* Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.19-1
65- remove Retry_vbootstrap-post() from the vbuilder script:
66  the trick (implemented in 0.0.18-1) moved to vbootstrap/scripts/* instead
67
68* Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.18-1
69- vbuilder:Retry_vbootstrap-post(): pass --justdb option to rpm
70  so that apt-get don't have to actually install packages again
71  (this will help avoid creating annoying .rpmorig/.rpmnew files)
72
73* Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.17-1
74- add --help option to vbuilder
75- ensure all files/subdirectories under BUILT_RPMS_DIR
76  (i.e. $HOME/vbuilder/{5.1,VineSeed}/{RPMS/{i686,ppc,x86_64},SRPMS}/*)
77  have ownerships of the user/group who executed "sudo vbuilder"
78
79* Mon Feb 22 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.16-1
80- added Requires: unionfs-utils
81- updated vbuilder.sh.in
82  - added --unionfs option
83- supported 5.1 (by iwai-san)
84
85* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.15-1
86- added vbuilder-bash-completion.sh
87
88* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.14-1
89- updated vbuilder.sh.in
90  - used __chroot_sh
91  - improved some functions for mounting file systems
92  - defined Retry_vbootstrap-post()
93
94* Sat Feb 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.13-1
95- updated vbuilder.sh.in
96  - fixed /home/vbuilder/.rpmmacros for VineSeed_i386, VineSeed
97  - improved some mounting processes
98    - defined mount_cache_dir()
99
100* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.12-1
101- added 4.2_i386
102- updated vbuilder.sh.in
103  - supported 4.2_i386 chroot on x86_64
104
105* Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.11-1
106- updated vbuilder.sh.in
107  - added Japanese translations for error messages
108  - improved some mounting processes
109    - defined some mount functions
110    - defined apt-get-update() function
111  - defined check-parameter() function
112
113* Tue Dec 29 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.10-1
114- updated vbuilder.sh.in
115  - added --dist-upgrade option which provides a flag to build
116    VineSeed bootstrap via stable relase version
117
118* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.9-1
119- fixed vbuilder.sh.in around --target option
120
121* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.8-1
122- updated vbuilder.sh.in
123  - added --target option which gives a build target of source rpm
124
125* Sun Nov 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.7-1
126- updated vbuilder.sh.in
127
128* Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.6-1
129- updated vbuilder.sh.in, little
130
131* Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.5-1
132- updated vbuilder.sh.in and vbuilder.conf.in
133  - extended to store built rpms on chroot env. in each arch. of home rpm dir.
134
135* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.4-1
136- added vine-release in BASE_PKGS of scripts/*
137- added vbuilder.conf
138- updated vbuilder.sh.in
139
140* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-2
141- rebuilt to add signature
142
143* Mon Aug 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-1
144- support 5.0 (by daisuke-san)
145- update vbuilder.sh.in
146  - check chroot archtecture
147
148* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.2-1
149- add vbuilder
150
151* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.1-1
152- initial build
Note: See TracBrowser for help on using the repository browser.