source: projects/vbootstrap/trunk/vbootstrap-vl.spec @ 709

Revision 709, 6.0 KB checked in by munepi, 14 years ago (diff)

updated vbuilder.sh.in: added --bootstrap-dir --built-rpms-dir options

Line 
1# This package is maintained on trac svn repository. Please do not change on local.
2# If you find a BUG, please report to Vine@vinelinux.org or mailing list or BTS.
3
4%define version 0.0.22
5
6Summary: bootstrap scripts to create a basic Vine Linux system
7Summary(ja): Vine Linux の基本システムを作成するためのスクリプト
8Name: vbootstrap
9Version: %{version}
10Release: 1%{?_dist_release}
11License: public domain
12Group: Development/Tools
13Url: http://trac.vinelinux.org/wiki/VineBootstrap
14
15Source0: %{name}-%{version}.tar.bz2
16
17Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildArch: noarch
19BuildRequires: sed
20Requires: bash, apt
21Requires: unionfs-utils
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke, munepi
26
27%description
28vbootstrap is used to create a basic Vine Linux system on existing Vine Linux
29system. It uses rpm and apt to install basic rpm package into a directory
30which can be chrooted into.
31
32vbuilder constracts a chroot environment with vbootstrap, and builds
33a rpm package inside the chroot.
34it is a useful system to check that a package has correct BuildRequires
35dependencies.
36
37
38%description -l ja
39vbootstrap は Vine Linux の基本システムを既存の Vine Linux システム上で
40作成するスクリプトです。rpm および apt を利用して、指定したディレクトリ
41以下に基本の rpm パッケージをインストールし、chroot できるようにします。
42
43vbuilder は vbootstrap を利用して chroot 環境の構築し、
44その chroot の中でパッケージをビルドします。
45パッケージが正しい BuildRequires 依存関係を持っているかを確認するために
46有用なシステムです。
47
48
49%prep
50[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
51
52%setup
53
54%build
55%__make
56
57%install
58%__make DESTDIR=$RPM_BUILD_ROOT install
59
60%clean
61[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
62
63
64%files
65%defattr(-,root,root)
66%{_sbindir}/vbootstrap
67%{_sbindir}/vbuilder
68%dir %{_datadir}/vbootstrap
69%{_datadir}/vbootstrap/*
70%{_sysconfdir}/bash_completion.d/vbuilder
71%config(noreplace) %{_sysconfdir}/vbootstrap/vbuilder.conf
72
73
74%changelog
75* Mon Mar 29 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.22-1
76- updated vbuilder.sh.in:
77  - added --bootstrap-dir --built-rpms-dir options
78- updated vbuilder-bash-completion.sh
79
80* Fri Mar 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.21-1
81- updated vbuilder.sh.in:
82  - added a compatible name for actions:
83    dropped two hyphens "--" from the head of an action "--hoge"
84    (e.g. build-rpm = --build-rpm)
85- added about vbuilder in %%description and %%description -l ja
86- updated vbuilder-bash-completion.sh: s/5.0/5.1/
87
88* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.20-1
89- fixed RPM_Build()
90
91* Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.19-1
92- remove Retry_vbootstrap-post() from the vbuilder script:
93  the trick (implemented in 0.0.18-1) moved to vbootstrap/scripts/* instead
94
95* Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.18-1
96- vbuilder:Retry_vbootstrap-post(): pass --justdb option to rpm
97  so that apt-get don't have to actually install packages again
98  (this will help avoid creating annoying .rpmorig/.rpmnew files)
99
100* Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.17-1
101- add --help option to vbuilder
102- ensure all files/subdirectories under BUILT_RPMS_DIR
103  (i.e. $HOME/vbuilder/{5.1,VineSeed}/{RPMS/{i686,ppc,x86_64},SRPMS}/*)
104  have ownerships of the user/group who executed "sudo vbuilder"
105
106* Mon Feb 22 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.16-1
107- added Requires: unionfs-utils
108- updated vbuilder.sh.in
109  - added --unionfs option
110- supported 5.1 (by iwai-san)
111
112* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.15-1
113- added vbuilder-bash-completion.sh
114
115* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.14-1
116- updated vbuilder.sh.in
117  - used __chroot_sh
118  - improved some functions for mounting file systems
119  - defined Retry_vbootstrap-post()
120
121* Sat Feb 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.13-1
122- updated vbuilder.sh.in
123  - fixed /home/vbuilder/.rpmmacros for VineSeed_i386, VineSeed
124  - improved some mounting processes
125    - defined mount_cache_dir()
126
127* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.12-1
128- added 4.2_i386
129- updated vbuilder.sh.in
130  - supported 4.2_i386 chroot on x86_64
131
132* Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.11-1
133- updated vbuilder.sh.in
134  - added Japanese translations for error messages
135  - improved some mounting processes
136    - defined some mount functions
137    - defined apt-get-update() function
138  - defined check-parameter() function
139
140* Tue Dec 29 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.10-1
141- updated vbuilder.sh.in
142  - added --dist-upgrade option which provides a flag to build
143    VineSeed bootstrap via stable relase version
144
145* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.9-1
146- fixed vbuilder.sh.in around --target option
147
148* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.8-1
149- updated vbuilder.sh.in
150  - added --target option which gives a build target of source rpm
151
152* Sun Nov 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.7-1
153- updated vbuilder.sh.in
154
155* Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.6-1
156- updated vbuilder.sh.in, little
157
158* Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.5-1
159- updated vbuilder.sh.in and vbuilder.conf.in
160  - extended to store built rpms on chroot env. in each arch. of home rpm dir.
161
162* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.4-1
163- added vine-release in BASE_PKGS of scripts/*
164- added vbuilder.conf
165- updated vbuilder.sh.in
166
167* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-2
168- rebuilt to add signature
169
170* Mon Aug 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-1
171- support 5.0 (by daisuke-san)
172- update vbuilder.sh.in
173  - check chroot archtecture
174
175* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.2-1
176- add vbuilder
177
178* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.1-1
179- initial build
Note: See TracBrowser for help on using the repository browser.