source: projects/vbootstrap/trunk/vbootstrap-vl.spec @ 689

Revision 689, 5.8 KB checked in by munepi, 14 years ago (diff)

vbootstrap-vl.specを更新。%%descriptionにvbuilderについて加筆しました。

Line 
1# This package is maintained on trac svn repository. Please do not change on local.
2# If you find a BUG, please report to Vine@vinelinux.org or mailing list or BTS.
3
4%define version 0.0.21
5
6Summary: bootstrap scripts to create a basic Vine Linux system
7Summary(ja): Vine Linux の基本システムを作成するためのスクリプト
8Name: vbootstrap
9Version: %{version}
10Release: 1%{?_dist_release}
11License: public domain
12Group: Development/Tools
13Url: http://trac.vinelinux.org/wiki/VineBootstrap
14
15Source0: %{name}-%{version}.tar.bz2
16
17Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildArch: noarch
19BuildRequires: sed
20Requires: bash, apt
21Requires: unionfs-utils
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke, munepi
26
27%description
28vbootstrap is used to create a basic Vine Linux system on existing Vine Linux
29system. It uses rpm and apt to install basic rpm package into a directory
30which can be chrooted into.
31
32vbuilder constracts a chroot environment with vbootstrap, and builds
33a rpm package inside the chroot.
34it is a useful system to check that a package has correct BuildRequires
35dependencies.
36
37
38%description -l ja
39vbootstrap は Vine Linux の基本システムを既存の Vine Linux システム上で
40作成するスクリプトです。rpm および apt を利用して、指定したディレクトリ
41以下に基本の rpm パッケージをインストールし、chroot できるようにします。
42
43vbuilder は vbootstrap を利用して chroot 環境の構築し、
44その chroot の中でパッケージをビルドします。
45パッケージが正しい BuildRequires 依存関係を持っているかを確認するために
46有用なシステムです。
47
48
49%prep
50[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
51
52%setup
53
54%build
55%__make
56
57%install
58%__make DESTDIR=$RPM_BUILD_ROOT install
59
60%clean
61[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
62
63
64%files
65%defattr(-,root,root)
66%{_sbindir}/vbootstrap
67%{_sbindir}/vbuilder
68%dir %{_datadir}/vbootstrap
69%{_datadir}/vbootstrap/*
70%{_sysconfdir}/bash_completion.d/vbuilder
71%config(noreplace) %{_sysconfdir}/vbootstrap/vbuilder.conf
72
73
74%changelog
75* Fri Mar 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.21-1
76- updated vbuilder.sh.in:
77  - added a compatible name for actions:
78    dropped two hyphens "--" from the head of an action "--hoge"
79    (e.g. build-rpm = --build-rpm)
80- added about vbuilder in %%description and %%description -l ja
81
82* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.20-1
83- fixed RPM_Build()
84
85* Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.19-1
86- remove Retry_vbootstrap-post() from the vbuilder script:
87  the trick (implemented in 0.0.18-1) moved to vbootstrap/scripts/* instead
88
89* Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.18-1
90- vbuilder:Retry_vbootstrap-post(): pass --justdb option to rpm
91  so that apt-get don't have to actually install packages again
92  (this will help avoid creating annoying .rpmorig/.rpmnew files)
93
94* Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.17-1
95- add --help option to vbuilder
96- ensure all files/subdirectories under BUILT_RPMS_DIR
97  (i.e. $HOME/vbuilder/{5.1,VineSeed}/{RPMS/{i686,ppc,x86_64},SRPMS}/*)
98  have ownerships of the user/group who executed "sudo vbuilder"
99
100* Mon Feb 22 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.16-1
101- added Requires: unionfs-utils
102- updated vbuilder.sh.in
103  - added --unionfs option
104- supported 5.1 (by iwai-san)
105
106* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.15-1
107- added vbuilder-bash-completion.sh
108
109* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.14-1
110- updated vbuilder.sh.in
111  - used __chroot_sh
112  - improved some functions for mounting file systems
113  - defined Retry_vbootstrap-post()
114
115* Sat Feb 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.13-1
116- updated vbuilder.sh.in
117  - fixed /home/vbuilder/.rpmmacros for VineSeed_i386, VineSeed
118  - improved some mounting processes
119    - defined mount_cache_dir()
120
121* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.12-1
122- added 4.2_i386
123- updated vbuilder.sh.in
124  - supported 4.2_i386 chroot on x86_64
125
126* Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.11-1
127- updated vbuilder.sh.in
128  - added Japanese translations for error messages
129  - improved some mounting processes
130    - defined some mount functions
131    - defined apt-get-update() function
132  - defined check-parameter() function
133
134* Tue Dec 29 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.10-1
135- updated vbuilder.sh.in
136  - added --dist-upgrade option which provides a flag to build
137    VineSeed bootstrap via stable relase version
138
139* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.9-1
140- fixed vbuilder.sh.in around --target option
141
142* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.8-1
143- updated vbuilder.sh.in
144  - added --target option which gives a build target of source rpm
145
146* Sun Nov 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.7-1
147- updated vbuilder.sh.in
148
149* Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.6-1
150- updated vbuilder.sh.in, little
151
152* Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.5-1
153- updated vbuilder.sh.in and vbuilder.conf.in
154  - extended to store built rpms on chroot env. in each arch. of home rpm dir.
155
156* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.4-1
157- added vine-release in BASE_PKGS of scripts/*
158- added vbuilder.conf
159- updated vbuilder.sh.in
160
161* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-2
162- rebuilt to add signature
163
164* Mon Aug 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-1
165- support 5.0 (by daisuke-san)
166- update vbuilder.sh.in
167  - check chroot archtecture
168
169* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.2-1
170- add vbuilder
171
172* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.1-1
173- initial build
Note: See TracBrowser for help on using the repository browser.