source: projects/vbootstrap/trunk/vbootstrap-vl.spec @ 934

Revision 934, 7.1 KB checked in by munepi, 14 years ago (diff)

set %%version to 0.0.28

Line 
1# This package is maintained on trac svn repository. Please do not change on local.
2# If you find a BUG, please report to Vine@vinelinux.org or mailing list or BTS.
3
4%define version 0.0.28
5
6Summary: bootstrap scripts to create a basic Vine Linux system
7Summary(ja): Vine Linux の基本システムを作成するためのスクリプト
8Name: vbootstrap
9Version: %{version}
10Release: 1%{?_dist_release}
11License: public domain
12Group: Development/Tools
13Url: http://trac.vinelinux.org/wiki/VineBootstrap
14
15Source0: %{name}-%{version}.tar.bz2
16
17Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildArch: noarch
19BuildRequires: sed
20Requires: bash, apt
21Requires: unionfs-utils
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke, munepi
26
27%description
28vbootstrap is used to create a basic Vine Linux system on existing Vine Linux
29system. It uses rpm and apt to install basic rpm package into a directory
30which can be chrooted into.
31
32vbuilder constracts a chroot environment with vbootstrap, and builds
33a rpm package inside the chroot.
34it is a useful system to check that a package has correct BuildRequires
35dependencies.
36
37
38%description -l ja
39vbootstrap は Vine Linux の基本システムを既存の Vine Linux システム上で
40作成するスクリプトです。rpm および apt を利用して、指定したディレクトリ
41以下に基本の rpm パッケージをインストールし、chroot できるようにします。
42
43vbuilder は vbootstrap を利用して chroot 環境の構築し、
44その chroot の中でパッケージをビルドします。
45パッケージが正しい BuildRequires 依存関係を持っているかを確認するために
46有用なシステムです。
47
48
49%prep
50[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
51
52%setup
53
54%build
55%__make
56
57%install
58%__make DESTDIR=$RPM_BUILD_ROOT install
59
60%clean
61[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
62
63
64%files
65%defattr(-,root,root)
66%{_sbindir}/vbootstrap
67%{_sbindir}/vbuilder
68%dir %{_datadir}/vbootstrap
69%{_datadir}/vbootstrap/*
70%{_sysconfdir}/bash_completion.d/vbuilder
71%config(noreplace) %{_sysconfdir}/vbootstrap/vbuilder.conf
72
73
74%changelog
75* Xxx Yyy ZZ 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.28-1
76
77* Tue May 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.27-1
78- changed an order of BASE_PKGS in vbootstrap/scripts/*, respectively
79  - apt package has Requires: rpm dependence
80  - dropped "rpm" from $$BASE_PKGS
81
82* Mon May 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.26-1
83- updated vbuilder.sh.in
84  - made /dev/random on chroot in Build()
85
86* Sat Apr 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.25-1
87- updated vbuilder.sh.in
88  - supported "test" category
89  - added some comments for mount-chroot()
90- updated vbuilder-bash-completion.sh
91
92* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.24-1
93- updated vbootstrap.sh.in (daisuke-san)
94  - changed to cache /var/lib/apt/lists, /var/cache/apt/archives
95    in bootstrap (not in host)
96  - set Dir::State and Dir::Cache in APT_OPTS
97
98* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.23-1
99- updated vbuilder.sh.in
100  - added --category option
101
102* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.22-1
103- updated vbuilder.sh.in:
104  - added --bootstrap-dir, --built-rpms-dir, --cache-dir options
105  - added show-info action
106    - defined write-vbuilder-log()
107- added CACHE_DIR in vbuilder.conf.in
108- updated vbuilder-bash-completion.sh
109
110* Fri Mar 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.21-1
111- updated vbuilder.sh.in:
112  - added a compatible name for actions:
113    dropped two hyphens "--" from the head of an action "--hoge"
114    (e.g. build-rpm = --build-rpm)
115- added about vbuilder in %%description and %%description -l ja
116- updated vbuilder-bash-completion.sh: s/5.0/5.1/
117
118* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.20-1
119- fixed RPM_Build()
120
121* Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.19-1
122- remove Retry_vbootstrap-post() from the vbuilder script:
123  the trick (implemented in 0.0.18-1) moved to vbootstrap/scripts/* instead
124
125* Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.18-1
126- vbuilder:Retry_vbootstrap-post(): pass --justdb option to rpm
127  so that apt-get don't have to actually install packages again
128  (this will help avoid creating annoying .rpmorig/.rpmnew files)
129
130* Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.17-1
131- add --help option to vbuilder
132- ensure all files/subdirectories under BUILT_RPMS_DIR
133  (i.e. $HOME/vbuilder/{5.1,VineSeed}/{RPMS/{i686,ppc,x86_64},SRPMS}/*)
134  have ownerships of the user/group who executed "sudo vbuilder"
135
136* Mon Feb 22 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.16-1
137- added Requires: unionfs-utils
138- updated vbuilder.sh.in
139  - added --unionfs option
140- supported 5.1 (by iwai-san)
141
142* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.15-1
143- added vbuilder-bash-completion.sh
144
145* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.14-1
146- updated vbuilder.sh.in
147  - used __chroot_sh
148  - improved some functions for mounting file systems
149  - defined Retry_vbootstrap-post()
150
151* Sat Feb 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.13-1
152- updated vbuilder.sh.in
153  - fixed /home/vbuilder/.rpmmacros for VineSeed_i386, VineSeed
154  - improved some mounting processes
155    - defined mount_cache_dir()
156
157* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.12-1
158- added 4.2_i386
159- updated vbuilder.sh.in
160  - supported 4.2_i386 chroot on x86_64
161
162* Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.11-1
163- updated vbuilder.sh.in
164  - added Japanese translations for error messages
165  - improved some mounting processes
166    - defined some mount functions
167    - defined apt-get-update() function
168  - defined check-parameter() function
169
170* Tue Dec 29 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.10-1
171- updated vbuilder.sh.in
172  - added --dist-upgrade option which provides a flag to build
173    VineSeed bootstrap via stable relase version
174
175* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.9-1
176- fixed vbuilder.sh.in around --target option
177
178* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.8-1
179- updated vbuilder.sh.in
180  - added --target option which gives a build target of source rpm
181
182* Sun Nov 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.7-1
183- updated vbuilder.sh.in
184
185* Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.6-1
186- updated vbuilder.sh.in, little
187
188* Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.5-1
189- updated vbuilder.sh.in and vbuilder.conf.in
190  - extended to store built rpms on chroot env. in each arch. of home rpm dir.
191
192* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.4-1
193- added vine-release in BASE_PKGS of scripts/*
194- added vbuilder.conf
195- updated vbuilder.sh.in
196
197* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-2
198- rebuilt to add signature
199
200* Mon Aug 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-1
201- support 5.0 (by daisuke-san)
202- update vbuilder.sh.in
203  - check chroot archtecture
204
205* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.2-1
206- add vbuilder
207
208* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.1-1
209- initial build
Note: See TracBrowser for help on using the repository browser.