source: projects/vbootstrap/tags/0.0.27/vbootstrap-vl.spec @ 933

Revision 933, 7.0 KB checked in by munepi, 14 years ago (diff)

tagging 0.0.27

Line 
1# This package is maintained on trac svn repository. Please do not change on local.
2# If you find a BUG, please report to Vine@vinelinux.org or mailing list or BTS.
3
4%define version 0.0.27
5
6Summary: bootstrap scripts to create a basic Vine Linux system
7Summary(ja): Vine Linux の基本システムを作成するためのスクリプト
8Name: vbootstrap
9Version: %{version}
10Release: 1%{?_dist_release}
11License: public domain
12Group: Development/Tools
13Url: http://trac.vinelinux.org/wiki/VineBootstrap
14
15Source0: %{name}-%{version}.tar.bz2
16
17Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildArch: noarch
19BuildRequires: sed
20Requires: bash, apt
21Requires: unionfs-utils
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke, munepi
26
27%description
28vbootstrap is used to create a basic Vine Linux system on existing Vine Linux
29system. It uses rpm and apt to install basic rpm package into a directory
30which can be chrooted into.
31
32vbuilder constracts a chroot environment with vbootstrap, and builds
33a rpm package inside the chroot.
34it is a useful system to check that a package has correct BuildRequires
35dependencies.
36
37
38%description -l ja
39vbootstrap は Vine Linux の基本システムを既存の Vine Linux システム上で
40作成するスクリプトです。rpm および apt を利用して、指定したディレクトリ
41以下に基本の rpm パッケージをインストールし、chroot できるようにします。
42
43vbuilder は vbootstrap を利用して chroot 環境の構築し、
44その chroot の中でパッケージをビルドします。
45パッケージが正しい BuildRequires 依存関係を持っているかを確認するために
46有用なシステムです。
47
48
49%prep
50[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
51
52%setup
53
54%build
55%__make
56
57%install
58%__make DESTDIR=$RPM_BUILD_ROOT install
59
60%clean
61[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
62
63
64%files
65%defattr(-,root,root)
66%{_sbindir}/vbootstrap
67%{_sbindir}/vbuilder
68%dir %{_datadir}/vbootstrap
69%{_datadir}/vbootstrap/*
70%{_sysconfdir}/bash_completion.d/vbuilder
71%config(noreplace) %{_sysconfdir}/vbootstrap/vbuilder.conf
72
73
74%changelog
75* Tue May 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.27-1
76- changed an order of BASE_PKGS in vbootstrap/scripts/*, respectively
77  - apt package has Requires: rpm dependence
78  - dropped "rpm" from $$BASE_PKGS
79
80* Mon May 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.26-1
81- updated vbuilder.sh.in
82  - made /dev/random on chroot in Build()
83
84* Sat Apr 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.25-1
85- updated vbuilder.sh.in
86  - supported "test" category
87  - added some comments for mount-chroot()
88- updated vbuilder-bash-completion.sh
89
90* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.24-1
91- updated vbootstrap.sh.in (daisuke-san)
92  - changed to cache /var/lib/apt/lists, /var/cache/apt/archives
93    in bootstrap (not in host)
94  - set Dir::State and Dir::Cache in APT_OPTS
95
96* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.23-1
97- updated vbuilder.sh.in
98  - added --category option
99
100* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.22-1
101- updated vbuilder.sh.in:
102  - added --bootstrap-dir, --built-rpms-dir, --cache-dir options
103  - added show-info action
104    - defined write-vbuilder-log()
105- added CACHE_DIR in vbuilder.conf.in
106- updated vbuilder-bash-completion.sh
107
108* Fri Mar 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.21-1
109- updated vbuilder.sh.in:
110  - added a compatible name for actions:
111    dropped two hyphens "--" from the head of an action "--hoge"
112    (e.g. build-rpm = --build-rpm)
113- added about vbuilder in %%description and %%description -l ja
114- updated vbuilder-bash-completion.sh: s/5.0/5.1/
115
116* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.20-1
117- fixed RPM_Build()
118
119* Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.19-1
120- remove Retry_vbootstrap-post() from the vbuilder script:
121  the trick (implemented in 0.0.18-1) moved to vbootstrap/scripts/* instead
122
123* Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.18-1
124- vbuilder:Retry_vbootstrap-post(): pass --justdb option to rpm
125  so that apt-get don't have to actually install packages again
126  (this will help avoid creating annoying .rpmorig/.rpmnew files)
127
128* Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.17-1
129- add --help option to vbuilder
130- ensure all files/subdirectories under BUILT_RPMS_DIR
131  (i.e. $HOME/vbuilder/{5.1,VineSeed}/{RPMS/{i686,ppc,x86_64},SRPMS}/*)
132  have ownerships of the user/group who executed "sudo vbuilder"
133
134* Mon Feb 22 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.16-1
135- added Requires: unionfs-utils
136- updated vbuilder.sh.in
137  - added --unionfs option
138- supported 5.1 (by iwai-san)
139
140* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.15-1
141- added vbuilder-bash-completion.sh
142
143* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.14-1
144- updated vbuilder.sh.in
145  - used __chroot_sh
146  - improved some functions for mounting file systems
147  - defined Retry_vbootstrap-post()
148
149* Sat Feb 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.13-1
150- updated vbuilder.sh.in
151  - fixed /home/vbuilder/.rpmmacros for VineSeed_i386, VineSeed
152  - improved some mounting processes
153    - defined mount_cache_dir()
154
155* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.12-1
156- added 4.2_i386
157- updated vbuilder.sh.in
158  - supported 4.2_i386 chroot on x86_64
159
160* Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.11-1
161- updated vbuilder.sh.in
162  - added Japanese translations for error messages
163  - improved some mounting processes
164    - defined some mount functions
165    - defined apt-get-update() function
166  - defined check-parameter() function
167
168* Tue Dec 29 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.10-1
169- updated vbuilder.sh.in
170  - added --dist-upgrade option which provides a flag to build
171    VineSeed bootstrap via stable relase version
172
173* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.9-1
174- fixed vbuilder.sh.in around --target option
175
176* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.8-1
177- updated vbuilder.sh.in
178  - added --target option which gives a build target of source rpm
179
180* Sun Nov 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.7-1
181- updated vbuilder.sh.in
182
183* Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.6-1
184- updated vbuilder.sh.in, little
185
186* Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.5-1
187- updated vbuilder.sh.in and vbuilder.conf.in
188  - extended to store built rpms on chroot env. in each arch. of home rpm dir.
189
190* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.4-1
191- added vine-release in BASE_PKGS of scripts/*
192- added vbuilder.conf
193- updated vbuilder.sh.in
194
195* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-2
196- rebuilt to add signature
197
198* Mon Aug 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-1
199- support 5.0 (by daisuke-san)
200- update vbuilder.sh.in
201  - check chroot archtecture
202
203* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.2-1
204- add vbuilder
205
206* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.1-1
207- initial build
Note: See TracBrowser for help on using the repository browser.