source: projects/vbootstrap/tags/0.0.25/vbootstrap-vl.spec @ 884

Revision 884, 6.7 KB checked in by munepi, 14 years ago (diff)

tagging 0.0.25

Line 
1# This package is maintained on trac svn repository. Please do not change on local.
2# If you find a BUG, please report to Vine@vinelinux.org or mailing list or BTS.
3
4%define version 0.0.25
5
6Summary: bootstrap scripts to create a basic Vine Linux system
7Summary(ja): Vine Linux の基本システムを作成するためのスクリプト
8Name: vbootstrap
9Version: %{version}
10Release: 1%{?_dist_release}
11License: public domain
12Group: Development/Tools
13Url: http://trac.vinelinux.org/wiki/VineBootstrap
14
15Source0: %{name}-%{version}.tar.bz2
16
17Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildArch: noarch
19BuildRequires: sed
20Requires: bash, apt
21Requires: unionfs-utils
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke, munepi
26
27%description
28vbootstrap is used to create a basic Vine Linux system on existing Vine Linux
29system. It uses rpm and apt to install basic rpm package into a directory
30which can be chrooted into.
31
32vbuilder constracts a chroot environment with vbootstrap, and builds
33a rpm package inside the chroot.
34it is a useful system to check that a package has correct BuildRequires
35dependencies.
36
37
38%description -l ja
39vbootstrap は Vine Linux の基本システムを既存の Vine Linux システム上で
40作成するスクリプトです。rpm および apt を利用して、指定したディレクトリ
41以下に基本の rpm パッケージをインストールし、chroot できるようにします。
42
43vbuilder は vbootstrap を利用して chroot 環境の構築し、
44その chroot の中でパッケージをビルドします。
45パッケージが正しい BuildRequires 依存関係を持っているかを確認するために
46有用なシステムです。
47
48
49%prep
50[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
51
52%setup
53
54%build
55%__make
56
57%install
58%__make DESTDIR=$RPM_BUILD_ROOT install
59
60%clean
61[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
62
63
64%files
65%defattr(-,root,root)
66%{_sbindir}/vbootstrap
67%{_sbindir}/vbuilder
68%dir %{_datadir}/vbootstrap
69%{_datadir}/vbootstrap/*
70%{_sysconfdir}/bash_completion.d/vbuilder
71%config(noreplace) %{_sysconfdir}/vbootstrap/vbuilder.conf
72
73
74%changelog
75* Sat Apr 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.25-1
76- updated vbuilder.sh.in
77  - supported "test" category
78  - added some comments for mount-chroot()
79- updated vbuilder-bash-completion.sh
80
81* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.24-1
82- updated vbootstrap.sh.in (daisuke-san)
83  - changed to cache /var/lib/apt/lists, /var/cache/apt/archives
84    in bootstrap (not in host)
85  - set Dir::State and Dir::Cache in APT_OPTS
86
87* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.23-1
88- updated vbuilder.sh.in
89  - added --category option
90
91* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.22-1
92- updated vbuilder.sh.in:
93  - added --bootstrap-dir, --built-rpms-dir, --cache-dir options
94  - added show-info action
95    - defined write-vbuilder-log()
96- added CACHE_DIR in vbuilder.conf.in
97- updated vbuilder-bash-completion.sh
98
99* Fri Mar 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.21-1
100- updated vbuilder.sh.in:
101  - added a compatible name for actions:
102    dropped two hyphens "--" from the head of an action "--hoge"
103    (e.g. build-rpm = --build-rpm)
104- added about vbuilder in %%description and %%description -l ja
105- updated vbuilder-bash-completion.sh: s/5.0/5.1/
106
107* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.20-1
108- fixed RPM_Build()
109
110* Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.19-1
111- remove Retry_vbootstrap-post() from the vbuilder script:
112  the trick (implemented in 0.0.18-1) moved to vbootstrap/scripts/* instead
113
114* Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.18-1
115- vbuilder:Retry_vbootstrap-post(): pass --justdb option to rpm
116  so that apt-get don't have to actually install packages again
117  (this will help avoid creating annoying .rpmorig/.rpmnew files)
118
119* Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.17-1
120- add --help option to vbuilder
121- ensure all files/subdirectories under BUILT_RPMS_DIR
122  (i.e. $HOME/vbuilder/{5.1,VineSeed}/{RPMS/{i686,ppc,x86_64},SRPMS}/*)
123  have ownerships of the user/group who executed "sudo vbuilder"
124
125* Mon Feb 22 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.16-1
126- added Requires: unionfs-utils
127- updated vbuilder.sh.in
128  - added --unionfs option
129- supported 5.1 (by iwai-san)
130
131* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.15-1
132- added vbuilder-bash-completion.sh
133
134* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.14-1
135- updated vbuilder.sh.in
136  - used __chroot_sh
137  - improved some functions for mounting file systems
138  - defined Retry_vbootstrap-post()
139
140* Sat Feb 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.13-1
141- updated vbuilder.sh.in
142  - fixed /home/vbuilder/.rpmmacros for VineSeed_i386, VineSeed
143  - improved some mounting processes
144    - defined mount_cache_dir()
145
146* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.12-1
147- added 4.2_i386
148- updated vbuilder.sh.in
149  - supported 4.2_i386 chroot on x86_64
150
151* Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.11-1
152- updated vbuilder.sh.in
153  - added Japanese translations for error messages
154  - improved some mounting processes
155    - defined some mount functions
156    - defined apt-get-update() function
157  - defined check-parameter() function
158
159* Tue Dec 29 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.10-1
160- updated vbuilder.sh.in
161  - added --dist-upgrade option which provides a flag to build
162    VineSeed bootstrap via stable relase version
163
164* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.9-1
165- fixed vbuilder.sh.in around --target option
166
167* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.8-1
168- updated vbuilder.sh.in
169  - added --target option which gives a build target of source rpm
170
171* Sun Nov 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.7-1
172- updated vbuilder.sh.in
173
174* Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.6-1
175- updated vbuilder.sh.in, little
176
177* Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.5-1
178- updated vbuilder.sh.in and vbuilder.conf.in
179  - extended to store built rpms on chroot env. in each arch. of home rpm dir.
180
181* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.4-1
182- added vine-release in BASE_PKGS of scripts/*
183- added vbuilder.conf
184- updated vbuilder.sh.in
185
186* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-2
187- rebuilt to add signature
188
189* Mon Aug 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-1
190- support 5.0 (by daisuke-san)
191- update vbuilder.sh.in
192  - check chroot archtecture
193
194* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.2-1
195- add vbuilder
196
197* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.1-1
198- initial build
Note: See TracBrowser for help on using the repository browser.