source: projects/vbootstrap/tags/0.0.22/vbootstrap-vl.spec @ 726

Revision 726, 6.1 KB checked in by munepi, 14 years ago (diff)

tagging 0.0.22

RevLine 
[315]1# This package is maintained on trac svn repository. Please do not change on local.
2# If you find a BUG, please report to Vine@vinelinux.org or mailing list or BTS.
[118]3
[709]4%define version 0.0.22
[118]5
6Summary: bootstrap scripts to create a basic Vine Linux system
7Summary(ja): Vine Linux の基本システムを作成するためのスクリプト
8Name: vbootstrap
9Version: %{version}
[314]10Release: 1%{?_dist_release}
[118]11License: public domain
12Group: Development/Tools
13Url: http://trac.vinelinux.org/wiki/VineBootstrap
14
15Source0: %{name}-%{version}.tar.bz2
16
17Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildArch: noarch
19BuildRequires: sed
20Requires: bash, apt
[485]21Requires: unionfs-utils
[118]22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke, munepi
26
27%description
28vbootstrap is used to create a basic Vine Linux system on existing Vine Linux
29system. It uses rpm and apt to install basic rpm package into a directory
30which can be chrooted into.
31
[689]32vbuilder constracts a chroot environment with vbootstrap, and builds
33a rpm package inside the chroot.
34it is a useful system to check that a package has correct BuildRequires
35dependencies.
36
37
[118]38%description -l ja
39vbootstrap は Vine Linux の基本システムを既存の Vine Linux システム上で
40作成するスクリプトです。rpm および apt を利用して、指定したディレクトリ
41以下に基本の rpm パッケージをインストールし、chroot できるようにします。
42
[689]43vbuilder は vbootstrap を利用して chroot 環境の構築し、
44その chroot の中でパッケージをビルドします。
45パッケージが正しい BuildRequires 依存関係を持っているかを確認するために
46有用なシステムです。
[118]47
[689]48
[118]49%prep
50[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
51
52%setup
53
54%build
[513]55%__make
[118]56
57%install
[513]58%__make DESTDIR=$RPM_BUILD_ROOT install
[118]59
60%clean
61[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
62
63
64%files
65%defattr(-,root,root)
66%{_sbindir}/vbootstrap
67%{_sbindir}/vbuilder
68%dir %{_datadir}/vbootstrap
69%{_datadir}/vbootstrap/*
[484]70%{_sysconfdir}/bash_completion.d/vbuilder
[323]71%config(noreplace) %{_sysconfdir}/vbootstrap/vbuilder.conf
[118]72
73
74%changelog
[725]75* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.22-1
[709]76- updated vbuilder.sh.in:
[725]77  - added --bootstrap-dir, --built-rpms-dir, --cache-dir options
78  - added show-info action
79    - defined write-vbuilder-log()
80- added CACHE_DIR in vbuilder.conf.in
[709]81- updated vbuilder-bash-completion.sh
82
[679]83* Fri Mar 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.21-1
[688]84- updated vbuilder.sh.in:
85  - added a compatible name for actions:
86    dropped two hyphens "--" from the head of an action "--hoge"
87    (e.g. build-rpm = --build-rpm)
[689]88- added about vbuilder in %%description and %%description -l ja
[691]89- updated vbuilder-bash-completion.sh: s/5.0/5.1/
[679]90
[628]91* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.20-1
92- fixed RPM_Build()
93
[519]94* Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.19-1
95- remove Retry_vbootstrap-post() from the vbuilder script:
96  the trick (implemented in 0.0.18-1) moved to vbootstrap/scripts/* instead
97
[518]98* Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.18-1
99- vbuilder:Retry_vbootstrap-post(): pass --justdb option to rpm
100  so that apt-get don't have to actually install packages again
101  (this will help avoid creating annoying .rpmorig/.rpmnew files)
102
[516]103* Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.17-1
104- add --help option to vbuilder
105- ensure all files/subdirectories under BUILT_RPMS_DIR
106  (i.e. $HOME/vbuilder/{5.1,VineSeed}/{RPMS/{i686,ppc,x86_64},SRPMS}/*)
107  have ownerships of the user/group who executed "sudo vbuilder"
108
[485]109* Mon Feb 22 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.16-1
110- added Requires: unionfs-utils
111- updated vbuilder.sh.in
112  - added --unionfs option
[513]113- supported 5.1 (by iwai-san)
[485]114
[484]115* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.15-1
116- added vbuilder-bash-completion.sh
117
[464]118* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.14-1
[455]119- updated vbuilder.sh.in
120  - used __chroot_sh
121  - improved some functions for mounting file systems
[464]122  - defined Retry_vbootstrap-post()
[455]123
[452]124* Sat Feb 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.13-1
125- updated vbuilder.sh.in
126  - fixed /home/vbuilder/.rpmmacros for VineSeed_i386, VineSeed
127  - improved some mounting processes
128    - defined mount_cache_dir()
129
[423]130* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.12-1
131- added 4.2_i386
132- updated vbuilder.sh.in
133  - supported 4.2_i386 chroot on x86_64
134
[418]135* Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.11-1
136- updated vbuilder.sh.in
137  - added Japanese translations for error messages
138  - improved some mounting processes
139    - defined some mount functions
[455]140    - defined apt-get-update() function
141  - defined check-parameter() function
[412]142
[411]143* Tue Dec 29 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.10-1
144- updated vbuilder.sh.in
145  - added --dist-upgrade option which provides a flag to build
146    VineSeed bootstrap via stable relase version
147
[407]148* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.9-1
149- fixed vbuilder.sh.in around --target option
150
[406]151* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.8-1
152- updated vbuilder.sh.in
153  - added --target option which gives a build target of source rpm
154
[396]155* Sun Nov 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.7-1
156- updated vbuilder.sh.in
157
[371]158* Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.6-1
159- updated vbuilder.sh.in, little
160
[370]161* Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.5-1
162- updated vbuilder.sh.in and vbuilder.conf.in
163  - extended to store built rpms on chroot env. in each arch. of home rpm dir.
[330]164
[323]165* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.4-1
166- added vine-release in BASE_PKGS of scripts/*
167- added vbuilder.conf
[314]168- updated vbuilder.sh.in
169
[305]170* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-2
171- rebuilt to add signature
172
[304]173* Mon Aug 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-1
174- support 5.0 (by daisuke-san)
[135]175- update vbuilder.sh.in
[304]176  - check chroot archtecture
[135]177
[118]178* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.2-1
179- add vbuilder
180
181* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.1-1
182- initial build
Note: See TracBrowser for help on using the repository browser.