source: projects/vbootstrap/tags/0.0.20/vbootstrap-vl.spec @ 681

Revision 681, 5.1 KB checked in by munepi, 14 years ago (diff)

tagging 0.0.20

Line 
1# This package is maintained on trac svn repository. Please do not change on local.
2# If you find a BUG, please report to Vine@vinelinux.org or mailing list or BTS.
3
4%define version 0.0.20
5
6Summary: bootstrap scripts to create a basic Vine Linux system
7Summary(ja): Vine Linux の基本システムを作成するためのスクリプト
8Name: vbootstrap
9Version: %{version}
10Release: 1%{?_dist_release}
11License: public domain
12Group: Development/Tools
13Url: http://trac.vinelinux.org/wiki/VineBootstrap
14
15Source0: %{name}-%{version}.tar.bz2
16
17Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildArch: noarch
19BuildRequires: sed
20Requires: bash, apt
21Requires: unionfs-utils
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke, munepi
26
27%description
28vbootstrap is used to create a basic Vine Linux system on existing Vine Linux
29system. It uses rpm and apt to install basic rpm package into a directory
30which can be chrooted into.
31
32%description -l ja
33vbootstrap は Vine Linux の基本システムを既存の Vine Linux システム上で
34作成するスクリプトです。rpm および apt を利用して、指定したディレクトリ
35以下に基本の rpm パッケージをインストールし、chroot できるようにします。
36
37
38%prep
39[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
40
41%setup
42
43%build
44%__make
45
46%install
47%__make DESTDIR=$RPM_BUILD_ROOT install
48
49%clean
50[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
51
52
53%files
54%defattr(-,root,root)
55%{_sbindir}/vbootstrap
56%{_sbindir}/vbuilder
57%dir %{_datadir}/vbootstrap
58%{_datadir}/vbootstrap/*
59%{_sysconfdir}/bash_completion.d/vbuilder
60%config(noreplace) %{_sysconfdir}/vbootstrap/vbuilder.conf
61
62
63%changelog
64* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.20-1
65- fixed RPM_Build()
66
67* Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.19-1
68- remove Retry_vbootstrap-post() from the vbuilder script:
69  the trick (implemented in 0.0.18-1) moved to vbootstrap/scripts/* instead
70
71* Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.18-1
72- vbuilder:Retry_vbootstrap-post(): pass --justdb option to rpm
73  so that apt-get don't have to actually install packages again
74  (this will help avoid creating annoying .rpmorig/.rpmnew files)
75
76* Thu Mar 04 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.0.17-1
77- add --help option to vbuilder
78- ensure all files/subdirectories under BUILT_RPMS_DIR
79  (i.e. $HOME/vbuilder/{5.1,VineSeed}/{RPMS/{i686,ppc,x86_64},SRPMS}/*)
80  have ownerships of the user/group who executed "sudo vbuilder"
81
82* Mon Feb 22 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.16-1
83- added Requires: unionfs-utils
84- updated vbuilder.sh.in
85  - added --unionfs option
86- supported 5.1 (by iwai-san)
87
88* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.15-1
89- added vbuilder-bash-completion.sh
90
91* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.14-1
92- updated vbuilder.sh.in
93  - used __chroot_sh
94  - improved some functions for mounting file systems
95  - defined Retry_vbootstrap-post()
96
97* Sat Feb 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.13-1
98- updated vbuilder.sh.in
99  - fixed /home/vbuilder/.rpmmacros for VineSeed_i386, VineSeed
100  - improved some mounting processes
101    - defined mount_cache_dir()
102
103* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.12-1
104- added 4.2_i386
105- updated vbuilder.sh.in
106  - supported 4.2_i386 chroot on x86_64
107
108* Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.11-1
109- updated vbuilder.sh.in
110  - added Japanese translations for error messages
111  - improved some mounting processes
112    - defined some mount functions
113    - defined apt-get-update() function
114  - defined check-parameter() function
115
116* Tue Dec 29 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.10-1
117- updated vbuilder.sh.in
118  - added --dist-upgrade option which provides a flag to build
119    VineSeed bootstrap via stable relase version
120
121* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.9-1
122- fixed vbuilder.sh.in around --target option
123
124* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.8-1
125- updated vbuilder.sh.in
126  - added --target option which gives a build target of source rpm
127
128* Sun Nov 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.7-1
129- updated vbuilder.sh.in
130
131* Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.6-1
132- updated vbuilder.sh.in, little
133
134* Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.5-1
135- updated vbuilder.sh.in and vbuilder.conf.in
136  - extended to store built rpms on chroot env. in each arch. of home rpm dir.
137
138* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.4-1
139- added vine-release in BASE_PKGS of scripts/*
140- added vbuilder.conf
141- updated vbuilder.sh.in
142
143* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-2
144- rebuilt to add signature
145
146* Mon Aug 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-1
147- support 5.0 (by daisuke-san)
148- update vbuilder.sh.in
149  - check chroot archtecture
150
151* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.2-1
152- add vbuilder
153
154* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.1-1
155- initial build
Note: See TracBrowser for help on using the repository browser.