source: projects/synaptic/trunk/synaptic-suse.spec @ 280

Revision 280, 3.5 KB checked in by yasumichi, 15 years ago (diff)

first import

RevLine 
[280]1# File:           $RCSfile: synaptic.spec,v $
2# Revision:       $Revision: 1.10 $
3# Last change:    $Date: 2004/05/16 19:47:31 $
4
5%define _datadir /opt/gnome/share
6
7Summary:        Graphical package management program using apt
8Name:           synaptic
9Version:        0.53
10Release:        0.1.suse91
11License:        GPL
12Group:          System/Packages
13Packager:       Sebastian Heinlein <sebastian.heinlein@web.de>
14Source:         synaptic-0.53.tar.gz
15#Source:        http://savannah.nongnu.org/download/synaptic/synaptic.pkg/%{version}/%{name}-%{version}.tar.gz
16Source1:        synaptic.desktop
17URL:            http://www.nongnu.org/synaptic/
18Requires:       apt >= 0.1.15, gtk2, libglade2
19Requires:       libstdc++ libzvt2 libart_lgpl
20Requires:       scrollkeeper
21BuildRequires:  apt-devel >= 0.5.5 rpm-devel >= 4.1 gtk2-devel libglade2-devel
22BuildRequires:  libstdc++-devel libxml2-devel libglade2-devel libart_lgpl-devel
23BuildRequires:  atk-devel pango-devel glib2-devel pkgconfig libzvt-devel
24BuildRequires:  XFree86-devel scrollkeeper
25BuildRoot:      %{_tmppath}/making_of_%{name}-%{version}
26
27%description
28Synaptic is a graphical package management tool based on GTK+ and APT.
29Synaptic enables you to install, upgrade and remove software packages in
30a user friendly way.
31
32Besides these basic functions the following features are provided:
33 * Search and filter the list of available packages
34 * Perform smart system upgrades
35 * Fix broken package dependencies
36 * Edit the list of used repositories (sources.list)
37 * Download the latest changelog of a package
38 * Configure packages through the debconf system
39 * Browse all available documentation related to a package (dwww is required)
40
41%prep
42%setup -n %{name}-0.53
43
44%build
45install -m 644 %{SOURCE1} data/%{name}.desktop
46PKG_CONFIG_PATH="/opt/gnome/lib/pkgconfig" \
47CPPFLAGS="-I/usr/include/g++/i586-suse-linux" CFLAGS=-O2 ./configure    \
48  --with-zvt            \
49  --prefix=%{_prefix}   \
50  --mandir=%{_mandir}   \
51  --datadir=%{_datadir} \
52  --libdir=%{_libdir}   \
53  --includedir=%{_includedir} \
54  --sysconfdir=%{_sysconfdir} \
55  --enable-docdir=%{_defaultdocdir}
56make
57
58%install
59
60# Replace gksu by kdesu
61sed -ie "s/^Exec=gksu -u root \/usr\/sbin\/synaptic/Exec=kdesu -u root -c synaptic/" data/%{name}.desktop
62
63make DESTDIR=%{buildroot} install
64
65# locales must be located in /usr/share otherwise synaptic does not pick them up
66mv %{buildroot}%{_datadir}/locale %{buildroot}%{_prefix}/share/
67
68%clean
69[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT
70
71%post
72scrollkeeper-update -q
73
74%postun
75scrollkeeper-update -q
76
77%files
78%defattr(-, root, root)
79%doc AUTHORS ChangeLog COPYING NEWS README TODO
80%{_sbindir}/%{name}
81%{_datadir}/%{name}
82%{_datadir}/omf/%{name}
83%{_datadir}/gnome/help/%{name}
84%{_mandir}/man8/%{name}.8*
85/usr/share/locale/*/LC_MESSAGES/%{name}.mo
86/etc/X11/sysconfig/synaptic.desktop
87/opt/gnome/share/applications/synaptic.desktop
88/opt/gnome/share/pixmaps/synaptic.png
89
90
91%changelog
92* Thu Aug 26 2004 Sebastian Heinlein <sebastian.heinlein@web.de>
93- Use sed to replace gksu by kdesu
94- Do not install any kde menu items, since the SuSE menu already integrates
95  the GNOME stuff
96* Tue Nov 18 2003 Richard Bos <rbos@users.sourceforge.net>
97- Use /opt/gnome as for datadir
98  However move the locate directory to /usr/share/
99* Sat Jun 21 2003 Richard Bos <rbos@users.sourceforge.net>
100- Updated to release 0.38
101- Added CFLAGS=-O2 to prevent debug code to be added to the end product
102  (per default -g is added to gcc)
103
104* Wed Jun 18 2003 Richard Bos <rbos@users.sourceforge.net>
105- Updated to release 0.37
106
107* Tue Jun 15 2003 Richard Bos <rbos@users.sourceforge.net>
108- Initial release, version 0.36.1
109
Note: See TracBrowser for help on using the repository browser.