source: projects/specs/trunk/z/zziplib/zziplib-vl.spec @ 3289

Revision 3289, 5.9 KB checked in by munepi, 13 years ago (diff)

added zziplib, self-build-swftools

Line 
1Summary: Lightweight library to easily extract data from zip files
2Name: zziplib
3Version: 0.13.59
4Release: 1%{?_dist_release}
5License: LGPLv2+ or MPLv1.1
6Group: Applications/Archiving
7URL: http://zziplib.sourceforge.net/
8Source: http://dl.sf.net/zziplib/zziplib-%{version}.tar.bz2
9Patch0: zziplib-0.13.59-multilib.patch
10BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11BuildRequires: perl
12BuildRequires: python
13BuildRequires: zip
14BuildRequires: xmlto
15BuildRequires: zlib-devel
16BuildRequires: SDL-devel
17BuildRequires: pkgconfig
18#BuildRequires: autoconf
19#BuildRequires: automake
20
21%description
22The zziplib library is intentionally lightweight, it offers the ability to
23easily extract data from files archived in a single zip file. Applications
24can bundle files into a single zip archive and access them. The implementation
25is based only on the (free) subset of compression with the zlib algorithm
26which is actually used by the zip/unzip tools.
27
28
29%package utils
30Summary: Utilities for the zziplib library
31Group: Applications/Archiving
32Requires: %{name} = %{version}-%{release}
33
34%description utils
35The zziplib library is intentionally lightweight, it offers the ability to
36easily extract data from files archived in a single zip file. Applications
37can bundle files into a single zip archive and access them. The implementation
38is based only on the (free) subset of compression with the zlib algorithm
39which is actually used by the zip/unzip tools.
40
41This packages contains all the utilities that come with the zziplib library.
42
43
44%package devel
45Summary: Development files for the zziplib library
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48Requires: pkgconfig
49Requires: zlib-devel
50Requires: SDL-devel
51
52%description devel
53The zziplib library is intentionally lightweight, it offers the ability to
54easily extract data from files archived in a single zip file. Applications
55can bundle files into a single zip archive and access them. The implementation
56is based only on the (free) subset of compression with the zlib algorithm
57which is actually used by the zip/unzip tools.
58
59This package contains files required to build applications that will use the
60zziplib library.
61
62
63%prep
64%setup -q
65%patch0 -p1
66# Save the common patched _config.h file to overwrite the generated one
67%{__cp} -a zzip/_config.h _config.h
68
69
70%build
71%configure \
72    --disable-static \
73    --enable-sdl \
74    --enable-frame-pointer
75# Remove rpath on 64bit archs
76sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' */libtool
77sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' */libtool
78%{__make} %{?_smp_mflags}
79
80
81%install
82%{__rm} -rf %{buildroot}
83%{__make} install DESTDIR=%{buildroot}
84# Overwrite the platform specific _config.h with our own modified common one
85%{__rm} -f %{buildroot}%{_includedir}/zzip/_config.h
86%{__install} -p -m 0644 _config.h %{buildroot}%{_includedir}/zzip/_config.h
87
88
89%clean
90%{__rm} -rf %{buildroot}
91
92
93%post -p /sbin/ldconfig
94
95%postun -p /sbin/ldconfig
96
97
98%files
99%defattr(-,root,root,-)
100%doc docs/COPYING* ChangeLog README TODO
101%{_libdir}/*.so.*
102
103%files utils
104%defattr(-,root,root,-)
105%{_bindir}/*
106
107%files devel
108%defattr(-,root,root,-)
109%doc docs/README.SDL docs/*.htm
110%{_includedir}/*
111%exclude %{_libdir}/*.la
112%{_libdir}/*.so
113%{_libdir}/pkgconfig/*.pc
114%{_datadir}/aclocal/*.m4
115%{_mandir}/man3/*
116
117
118%changelog
119* Fri Apr 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.13.59-1
120- initial build based on Fedora rawhide
121
122* Thu Dec  9 2010 Hans de Goede <hdegoede@redhat.com> 0.13.59-2
123- Fix broken zzip/_config.h which causes apps using zziplib to fail to compile
124
125* Sat Dec  4 2010 Matthias Saou <http://freshrpms.net/> 0.13.59-1
126- Update to 0.13.59.
127- Remove no longer needed 'open' patch.
128- Rebase the multilib patch, still required.
129- Re-enable _smp_mflags, build works again with it apparently.
130
131* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13.49-8
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
133
134* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13.49-7
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
136
137* Mon Dec 22 2008 Matthias Saou <http://freshrpms.net/> 0.13.49-6
138- Patch _config.h to make it identical for 32bit and 64bit archs (#343521).
139
140* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org>
141- Autorebuild for GCC 4.3
142
143* Wed Aug  8 2007 Matthias Saou <http://freshrpms.net/> 0.13.49-4
144- Include patch to fix fd.open calls with recent glibc.
145- Disable _smp_mflags since the docs fail to build.
146
147* Fri Aug  3 2007 Matthias Saou <http://freshrpms.net/> 0.13.49-3
148- Update License field.
149
150* Tue Jun 19 2007 Matthias Saou <http://freshrpms.net/> 0.13.49-2
151- Disable static lib build instead of excluding it later.
152- Remove rpath on 64bit archs.
153- Switch to using DESTDIR install method.
154
155* Mon Mar 26 2007 Matthias Saou <http://freshrpms.net/> 0.13.49-1
156- Update to 0.13.49 to fix CVE-2007-1614 (rhbz #233700).
157- Include new man3 pages to the devel sub-package.
158
159* Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 0.13.47-1
160- Update to 0.13.47.
161- FC6 rebuild.
162
163* Mon Jul 24 2006 Matthias Saou <http://freshrpms.net/> 0.13.45-3
164- Split off -utils sub-package (#199467). Could have been plain "zzip"?
165- Have sub-packages require exact release too.
166- Build require automake to make the aclocal-1.9 check happy.
167- Use --enable-frame-pointer otherwise -g gets removed from the CFLAGS.
168
169* Mon Mar  6 2006 Matthias Saou <http://freshrpms.net/> 0.13.45-2
170- FC5 rebuild.
171
172* Thu Feb  9 2006 Matthias Saou <http://freshrpms.net/> 0.13.45-1
173- Update to 0.13.45.
174- Exclude static library.
175
176* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 0.13.38-2
177- rebuild on all arches
178
179* Tue Apr  5 2005 Matthias Saou <http://freshrpms.net/> 0.13.38-1
180- Update to 0.13.38, fixes gcc4 compile issues (Adrian Reber).
181
182* Tue Nov 16 2004 Matthias Saou <http://freshrpms.net/> 0.13.36-2
183- Bump release to provide Extras upgrade path.
184
185* Tue Jun  8 2004 Matthias Saou <http://freshrpms.net/> 0.13.36-1
186- Initial RPM release.
187
Note: See TracBrowser for help on using the repository browser.