source: projects/specs/trunk/z/zsh/zsh-vl.spec @ 9928

Revision 9928, 14.2 KB checked in by iwaim, 8 years ago (diff)

zsh 5.2-1

Line 
1# -*- Mode: rpm-spec -*-
2
3%define name zsh
4%define version 5.2
5%define rversion %{version}
6%define dversion %{version}
7%define release 1%{?_dist_release}
8## %define _sysconfdir /etc
9
10Summary: A shell with lots of features.
11Summary(ja): 多機能シェル
12Name: %{name}
13Version: %{version}
14Release: %{release}
15License: distributable (see LICENCE file)
16Group: System Environment/Shells
17Url: http://www.zsh.org
18Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.xz
19Source1: zcfg-vine.tar.bz2
20# fixed that _apt fail  completions rpm package name.
21Patch0: zsh-4.3.4-apt4rpm.patch
22Patch1: zsh-4.3.4-sshcomp.patch
23Patch2: zsh-4.2.0-completion_tar_archive.patch
24Patch3: zsh-5.0.7-fixpath.patch
25Requires(post,preun): /sbin/install-info
26Requires(post,postun): grep
27BuildRoot: %{_tmppath}/%{name}-buildroot
28BuildRequires: texinfo, ncurses-devel
29BuildRequires: findutils grep
30BuildRequires: man-db
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: iwaim
35Epoch: 1
36
37%description
38Zsh is a UNIX command interpreter (shell) usable as an
39interactive login shell and as a shell script command
40processor. Of the standard shells, zsh most closely resembles
41ksh but includes many enhancements. Zsh has command-line editing,
42built-in spelling correction, programmable command completion,
43shell functions (with autoloading), a history mechanism, and a
44lots of other features
45
46Install the zsh package if you'd like to try out a different shell.
47
48%description -l ja
49Zsh 対話的に使える コマンドラインインタプリタ(シェル)です。
50規格上Zsh はksh ににているが多くの拡張がされている。
51スペルコレクション,プログラマブル補完,
52シェルファンクションズ(オートロード),等の多くの機能がある。
53
54%prep
55%setup -q -a 1 -n %{name}-%{rversion}
56#%patch0 -p1
57#%patch1 -p1
58#%patch2 -p1
59%patch3 -p1
60
61# remove temporary files
62find|grep '~$'|xargs rm -f
63
64%build
65
66%ifnarch sparc
67%configure \
68           --enable-etcdir=%{_sysconfdir} \
69           --enable-fndir=%{_datadir}/zsh/functions \
70           --enable-site-fndir=%{_datadir}/zsh/site-functions \
71           --enable-function-subdirs \
72           --enable-scriptdir=%{_datadir}/zsh/scripts \
73           --enable-site-scriptdir=%{_datadir}/zsh/site-scripts \
74           --with-tcsetpgrp
75%else
76%configure \
77           --enable-etcdir=%{_sysconfdir} \
78           --enable-fndir=%{_datadir}/zsh/functions \
79           --enable-site-fndir=%{_datadir}/zsh/site-functions \
80           --enable-function-subdirs \
81           --enable-scriptdir=%{_datadir}/zsh/scripts \
82           --enable-site-scriptdir=%{_datadir}/zsh/site-scripts
83           --disable-lfs
84%endif
85make
86
87%install
88rm -rf $RPM_BUILD_ROOT
89%makeinstall fndir=%{buildroot}%{_datadir}/zsh/functions sitefndir=%{buildroot}%{_datadir}/zsh/site-functions scriptdir=%{buildroot}%{_datadir}/zsh/scripts sitescriptdir=%{buildroot}%{_datadir}/zsh/site-scripts \
90             runhelpdir=%{buildroot}%{_datadir}/zsh/${VERSION}/help
91
92make install.info DESTDIR=$RPM_BUILD_ROOT
93
94mkdir -p %{buildroot}%{_sysbindir}
95pushd %{buildroot}%{_sysbindir} && {
96    ln -s ..%{_bindir}/zsh ./zsh
97} && popd
98
99# copy Mandrake Configuration files.
100mkdir -p %{buildroot}%{_sysconfdir}
101cp -a zcfg/* %{buildroot}%{_sysconfdir}
102
103# Copy documentation.
104#rm -rf docroot
105mkdir -p docroot/{Info_html,Examples,Documentation}/
106cp -a README docroot/
107cp -a Functions/Misc/* Misc/* Util/* docroot/Examples/
108cp -a INSTALL ChangeLog* docroot/Documentation
109cp -a StartupFiles docroot/
110cp -a Etc/* docroot/Documentation
111cp -a NEWS docroot/
112#cp -a Doc/*html docroot/Info_html/
113
114find docroot/ -type f|xargs perl -p -i -e 's|^#!%{prefix}/local/bin/zsh|#!%{_bi
115ndir}/zsh|'
116find docroot/ -type f|xargs perl -p -i -e 's|^#!%{prefix}/local/bin/perl|#!%{_b
117indir}/perl|'
118
119rm -f docroot/StartupFiles/.distfiles
120rm -f docroot/Examples/{Makefile*,*.yo}
121rm -f docroot/Documentation/{Makefile*,*.yo}
122mv docroot/Examples/compctl-examples docroot/StartupFiles
123
124find docroot/ -name 'Makefile*' -o -name '.yo'|xargs rm -f
125
126%clean
127rm -rf %{buildroot}
128
129%post
130if [ ! -f %{_sysconfdir}/shells ]; then
131        echo "/bin/zsh" > %{_sysconfdir}/shells
132else
133        grep '^/bin/zsh' %{_sysconfdir}/shells > /dev/null || echo "/bin/zsh" >> /etc/shells
134fi
135/sbin/install-info %{_infodir}/zsh.info.gz %{_infodir}/dir
136
137%preun
138if [ "$1" = 0 ]; then
139    /sbin/install-info --delete %{_infodir}/zsh.info.gz %{_infodir}/dir
140fi
141
142%postun
143if [ ! -x /bin/zsh ]; then
144        grep -v '^/bin/zsh$' %{_sysconfdir}/shells | grep -v '^/bin/zsh$'> /etc/shells.rpm
145        mv %{_sysconfdir}/shells.rpm /etc/shells
146fi
147
148%files
149%defattr(-,root,root,0755)
150%doc LICENCE
151%doc docroot/README docroot/NEWS
152%doc docroot/Documentation/ docroot/Examples/ docroot/Info_html/ docroot/StartupFiles/
153%config %{_sysconfdir}/z*
154%{_sysbindir}/zsh
155%{_bindir}/zsh*
156%{_libdir}/zsh
157%{_infodir}/*.info*
158%exclude %{_infodir}/dir*
159%{_mandir}/man*/*
160%{_datadir}/zsh
161
162%changelog
163* Thu Dec 31 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 5.2-1
164- update to 5.2
165- fix buit date for 5.0.7-1 in changelog
166
167* Thu Jan  1 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 5.0.7-1
168- update to 5.0.7
169- add BuildRequires: man-db
170- update fixpath patch (Patch3)
171- add install path 'runhelpdir'
172- add help files
173- drop too old Zsh Guide (Source3)
174
175* Tue Dec 31 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 5.0.2-2
176- rebuild with current VineSeed
177
178* Tue Dec 25 2012 IWAI, Masaharu <iwai@alib.jp> 5.0.2-1
179- new upstream release
180
181* Thu Nov 29 2012 IWAI, Masaharu <iwai@alib.jp> 5.0.0-1
182- new upstream release
183
184* Sat Aug  6 2011 IWAI, Masaharu <iwai@alib.jp> 4.3.12-1
185- new upstream release
186
187* Tue Dec 21 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.11-1
188- new upstream release
189
190* Sun Aug 15 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.10-2
191- rebuild with new toolchain
192
193* Tue Feb 23 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.10-1
194- new upstream release
195- update fixpath patch (Patch3)
196- drop unnecessary patch: fix subversion completion patch (Patch4)
197- fix '--with-tcsetpgrp' option: apply besides SPARC arch
198- add LICENCE file in %%doc directory: fixed typo
199- exclude %%{_infodir}/dir* in %%files section
200- drop Prefix tag
201- replace Prereq to Requires(*)
202- BuildRequires: findutils grep
203
204* Wed Jan 27 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.3.4-4
205- fix files error (LICENSE is no longer exist)
206
207* Wed Jan 27 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.3.4-3
208- add --with-tcsetpgrp into configure section
209- add BR: texinfo, ncurses-devel
210
211* Thu Jan  7 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.4-2
212- add fix subversion completion patch (Patch4): <BTS:VineLinux:869>
213  - see http://svn.haxx.se/users/archive-2008-06/0095.shtml
214- add Packager tag
215- add LICENSE file in %%doc directory
216- fix License tag's value
217
218* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 4.3.4-1vl5
219- applied new versioning policy, spec in utf-8
220
221* Wed Oct 31 2007 IWAI, Masaharu <iwai@alib.jp> 4.3.4-0vl1
222- new upstream release
223- update apt4rpm patch ( Patch0 )
224- update sshcomp patch ( Patch1 )
225- add fixpath patch ( Patch3 )
226- update %%build and %%install section
227
228* Tue Apr 12 2005 IWAI, Masaharu <iwai@alib.jp> 4.2.5-0vl1
229- new upstream release
230
231* Tue Mar  8 2005 IWAI, Masaharu <iwai@alib.jp> 4.2.4-0vl1
232- new upstream release
233
234* Sat Aug 14 2004 IWAI, Masaharu <iwai@alib.jp> 4.2.1-0vl1
235- new upstream release
236- update apt4rpm patch ( Patch0 )
237- drop unnecessary patch for fixed upstream: job_table_full patch ( Patch3 )
238- update 'Copy documentation' script: moved NEWS document in upstream archive
239
240* Sat Jul 7 2004 HAYASHI Kentarou <linjian@gigo-ice.org> 4.2.0-0vl2
241- add job_table_full.patch (Patch3)
242  see Zsh Mailing List 2004/msg00488.html
243
244* Mon Mar 29 2004 IWAI, Masaharu <iwai@alib.jp> 4.2.0-0vl1
245- new upstream release
246- update completion tar archive patch (Patch2)
247- update file list: include directories in %%{_libdir} and %%{_datadir}
248
249* Sun Dec 28 2003 IWAI, Masaharu <iwai@alib.jp> 4.0.9-0vl1
250- upstream update
251- update apt4rpm.patch (Patch0)
252
253* Fri Jun 20 2003 IWAI Masaharu <iwai@alib.jp> 4.0.7-0vl1
254- upstream update
255- update apt4rpm.patch(Patch0)
256
257* Sat May  3 2003 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl3
258- add completion_tar_archive.patch (Patch2)
259  for tar's "z" option to accept bz2 tarball with zsh completion.
260
261* Mon Dec  2 2002 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl2
262- add apt-cache showsrc option in apt4rpm patch (Patch0)
263
264* Thu Aug 15 2002 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl1
265- upstream update
266
267* Sun Aug 11 2002 IWAI Masaharu <iwai@alib.jp> 4.0.5-0vl1
268- upstream update
269- apt-cache showsrc option changed unavailable in apt4rpm patch (Patch0)
270
271* Tue Dec  4 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.4-0vl1
272- loading vine specific profile scripts moved from zshrc to zprofile
273- fixed other bug($PATH,zmodload)
274
275
276* Mon Aug 27 2001 Shoji Matsumoto <shom@vinelinux.org> 4.0.2-0vl3
277- rebuilding current Seed
278- change ssh completion (Patch1)
279
280* Thu Aug 16 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.2-0vl2
281- fixed bug rpm package name completions in _apt
282
283* Thu Jul 19 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.2-0vl1
284- 4.0.2
285
286* Sun Jun  3 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl1
287- upstream 4.0.1 release
288- fixed bug zshrc( add /usr/X11R6/bin $PATH)
289- fixed lack 'Epoch:'
290
291* Thu Apr 26 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.4.pre.3
292- fixed version number invalid
293
294* Fri Apr 20 2001 <sagami@vinelinux.org>
295- 4.0.1-0vl0.3.pre.4
296- install infopage/manpage and added PreReq = /sbin/install-info
297- fixed/added scripts in post/postun/preun for install-info
298
299* Fri Apr 13 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.3.pre.3
300- upstream update
301- fixed /etc/zshrc bugs
302
303* Tue Apr  3 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.0.pre.2
304- upstream update
305- remove all patches
306
307* Tue Oct  3 2000 Kazuhisa TAKEI<takei@vinelinux.org> 3.1.9-4vl1
308- can read /etc/profile.d/*.sh
309
310* Wed Sep 13 2000 Kazuhisa TAKEI<takei@vinelinux.org>
311- 3.1.9-4vl0
312- convert from Mandrake Linux to Vine Linux
313- add Japanise Summary and description
314
315* Sat Aug 26 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-4mdk
316- Set some %config file to (noreplace).
317- Make -A to complete spec file for _rpm.
318
319* Thu Jul 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-3mdk
320- Get /usr/share/man also in the completion for perl manpages.
321- BM.
322
323* Wed Jul  5 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-2mdk
324- Fix buildroot hardcoded in binary.
325
326* Wed Jun 21 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-1mdk
327- Use makeinstall macros (not easy this one :\).
328- 3.1.9.
329
330* Mon Jun  5 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.8-1mdk
331- 3.1.8.
332
333* Sun May 28 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-3mdk
334- Fix path (%{prefix}/ucb -> %{_bindir}/X11)
335- Fix keys (home-end-suppr-delete) directly in the zsh binary.
336
337* Sun Apr 16 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-2mdk
338- Remove doble .so in %{_libdir}/zsh/*.
339
340* Thu Apr 13 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-1mdk
341- 3.1.6dev22.
342
343* Fri Mar 31 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-3mdk
344- Fix completion of rpm with -qp*.
345
346* Mon Mar 27 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-2mdk
347- Upgrade zshguide.
348
349* Sat Mar 25 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-1mdk
350- 3.1.6-dev20
351
352* Wed Mar 22 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-3mdk
353- Move global configuration here.
354- Adjust groups.
355
356* Tue Feb 22 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-2mdk
357- Add new zshguide from pws.
358- Separate the doc to the doc package
359
360* Sun Feb 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-1mdk
361- Clean Up spec (thanks specs-helper).
362- Remove all our patchs (now all is commited to upstream main).
363- 3.1.6dev19.
364
365* Fri Feb 18 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-3mdk
366- Recompile with glibc2.1.3 (first one).
367
368* Thu Feb 17 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-2mdk
369- Add --freshen completion.
370
371* Tue Feb 15 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-1mdk
372- Fix descriptions and summary.
373- 3.1.6dev18.
374
375* Thu Feb 10 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev17-2mdk
376- Remove Makefile in %doc.
377- BuildRequires: autoconf tetex.
378- Lot of modications in the default config as suggested by Bart
379  Schaefer <schaefer@zsh.org>.
380- 3.1.6dev17.
381
382* Mon Jan 24 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev16-1mdk
383- dev16.
384- Redo the tar_archive patchs.
385
386* Tue Jan 18 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev15-1mdk
387- dev15.
388- Fix doc generation with dev15.
389- remove META-FAQ.
390- disable lfs on sparc.
391
392* Thu Jan  6 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev14-1mdk
393- dev14 (note the name change).
394
395* Mon Jan  3 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6pws13-3mdk
396- Remove temporary files.
397
398* Fri Dec 31 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
399- 3.1.6pws13 (mainly bug fixes).
400- fix %post.
401- fix rpm completion
402
403* Thu Dec 09 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
404- 3.1.6pws11 (mainly bug fixes).
405
406* Tue Dec  7 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
407- Add run-help and perl-build the documentation.
408
409* Tue Nov 30 1999 Francis Galiegue <francis@mandrakesoft.com>
410
411- Completion machine patch - we use GNU make and GNU tar
412- Small fix to %post script
413
414* Tue Nov 30 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
415- 3.1.6pws10
416- Fix zprofile.
417- Clean-up Franciseries.
418- Clean-up specs.
419
420* Mon Nov 29 1999 Francis Galiegue <francis@mandrakesoft.com>
421- Grrr... Rebuilt on kenobi, toy ain't a cooker
422
423* Mon Nov 29 1999 Francis Galiegue <francis@mandrakesoft.com>
424
425- Completion system now handles bzip2'ed manpages and tarballs
426- Some cool options
427
428* Wed Nov 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
429- Add zshguide.txt to documentation.
430
431* Thu Oct 07 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
432
433- Fix bug in %{_sysconfdir}/zsh use USERNAME instead of USER.
434- Improve %{_sysconfdir}/z* to source the /etc/profile.d/ files.
435
436* Mon Oct 04 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
437
438- 3.1.6-pws6
439- Fix bad link.
440- Fix bad manpages.
441
442* Tue Aug 17 1999 Thierry Vignaud <tvignaud@mandrakesoft.com>
443- fix typo in examples directory name
444
445* Sun Aug  8 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
446
447- Copy documentation (yes a lot).
448- Remove the completion machine and put them in [[ {etc,root}(skel|files) ]] package.
449
450* Sat Aug  7 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
451
452- By defaut we launch the completion machine.
453- Put zsh in %{_bindir}/
454- Rewrite of Spec file for this new major version.
455
456# end of file
Note: See TracBrowser for help on using the repository browser.