source: projects/specs/trunk/z/znc/znc-vl.spec @ 10079

Revision 10079, 14.3 KB checked in by tomop, 8 years ago (diff)

znc-1.6.3-1

Line 
1# Define variables to use in conditionals
2%define use_systemd 0
3
4%define use_systemd 0
5
6%global __python %{__python3}
7
8Summary:        An advanced IRC bouncer
9Name:           znc
10Version:        1.6.3
11Release:        1%{?_dist_release}
12License:        Apache Software License
13Group:          System Environment/Daemons
14URL:            http://znc.in
15Source0:        http://znc.in/releases/znc-%{version}.tar.gz
16
17Vendor:         Project Vine
18Distribution:   Vine Linux
19Packager:       tomop
20
21%if %{use_systemd}
22Source1:        znc.service
23%endif
24
25%if !%{use_systemd}
26Source1:        znc.init
27%endif
28
29# git clone https://github.com/znc/znc.git
30# cd znc
31# git archive --prefix=znc/ HEAD | xz > ../znc-0.097.tar.xz
32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
34BuildRequires:  gcc-c++ perl
35BuildRequires:  openssl-devel >= 0.9.8
36BuildRequires:  cyrus-sasl-devel
37#BuildRequires:  c-ares-devel
38BuildRequires:  automake
39BuildRequires:  tcl-devel perl(ExtUtils::Embed)
40Obsoletes:      znc-extra <= %{version}-%{release}
41
42%if %{use_systemd}
43BuildRequires: systemd-units
44%endif
45Requires(pre):  shadow-utils
46%if %{use_systemd}
47Requires(post): systemd-units
48Requires(post): systemd-sysv
49Requires(preun): systemd-units
50Requires(postun): systemd-units
51%endif
52
53%if !%{use_systemd}
54Requires(post): chkconfig
55Requires(preun): chkconfig
56# This is for /sbin/service
57Requires(preun): initscripts
58%endif
59
60%description
61ZNC is an IRC bouncer with many advanced features like detaching,
62multiple users, per channel playback buffer, SSL, IPv6, transparent
63DCC bouncing, Perl and C++ module support to name a few.
64
65%package devel
66Summary:        Development files needed to compile ZNC modules
67Group:          Development/Libraries
68Requires:       %{name} = %{version}-%{release} pkgconfig
69Requires:       openssl-devel glibc-devel
70#Requires:       c-ares-devel
71BuildRequires: pkgconfig
72
73%description devel
74All includes and program files you need to compile your own znc
75modules.
76
77%package modtcl
78Summary:       TCL module for ZNC
79Group:         Development/Libraries
80Requires:      %{name} = %{version}-%{release}
81Requires:      tcl
82
83%description modtcl
84TCL module for ZNC
85
86%prep
87%setup -q -n %{name}-%{version}
88#%setup -q -n znc-1.0-beta1
89#%patch0 -p1
90%__perl -pi.add_release -e 's|(?<="ZNC \%1\.3f)|-%{release}|' znc.cpp
91chmod -x modules/q.cpp
92
93%build
94%configure \
95     --with-module-prefix=%{_libdir}/znc \
96     --enable-ipv6 --enable-sasl --disable-perl --enable-tcl
97%__make %{?_smp_mflags}
98
99%pre
100#%if %{use_systemd}
101getent group znc >/dev/null || groupadd -r znc
102getent passwd znc >/dev/null || \
103    useradd -r -g znc -d /var/lib/znc -s /sbin/nologin \
104    -c "Account for ZNC to run as" znc
105mkdir -p /var/lib/znc
106chown znc:znc /var/lib/znc
107#exit 0
108#%endif
109
110%install
111%__rm -Rf "%{buildroot}"
112%__make install DESTDIR="%{buildroot}"
113%if %{use_systemd}
114mkdir -p %buildroot%{_unitdir}
115install -m 0644 %{SOURCE1} %buildroot%{_unitdir}/znc.service
116%endif
117%if !%{use_systemd}
118mkdir -p %buildroot%{_initrddir}
119install -Dp -m0755 %{SOURCE1} %{buildroot}%{_initrddir}/znc
120%endif
121
122%clean
123%__rm -Rf "%{buildroot}"
124
125%post
126
127%if %{use_systemd}
128if [ $1 -eq 1 ] ; then
129    # Initial installation
130    /bin/systemctl daemon-reload >/dev/null 2>&1 || :
131fi
132%endif
133
134%if !%{use_systemd}
135# This adds the proper /etc/rc*.d links for the script
136/sbin/chkconfig --add znc
137%endif
138
139%postun
140
141%if %{use_systemd}
142/bin/systemctl daemon-reload >/dev/null 2>&1 || :
143if [ $1 -ge 1 ] ; then
144    # Package upgrade, not uninstall
145    /bin/systemctl try-restart znc.service >/dev/null 2>&1 || :
146fi
147%endif
148
149%if !%{use_systemd}
150if [ "$1" -ge "1" ] ; then
151    /sbin/service znc condrestart >/dev/null 2>&1 || :
152fi
153%endif
154
155%preun
156
157%if %{use_systemd}
158if [ $1 -eq 0 ] ; then
159    # Package removal, not upgrade
160    /bin/systemctl --no-reload disable znc.service > /dev/null 2>&1 || :
161    /bin/systemctl stop znc.service > /dev/null 2>&1 || :
162fi
163%endif
164
165%if !%{use_systemd}
166if [ $1 -eq 0 ] ; then
167    /sbin/service znc stop >/dev/null 2>&1 || :
168    /sbin/chkconfig --del znc || :
169fi
170%endif
171
172%files
173%defattr(-,root,root)
174%doc AUTHORS ChangeLog.md LICENSE NOTICE README.md
175%{_bindir}/znc
176%{_mandir}/man1/*
177%{_libdir}/znc/*.so
178%exclude %{_libdir}/znc/modtcl.so
179%{_datadir}/znc/
180%if %{use_systemd}
181%{_unitdir}/znc.service
182%endif
183%if !%{use_systemd}
184%{_initrddir}/znc
185%endif
186
187%files devel
188%defattr(-,root,root)
189%{_bindir}/znc-buildmod
190#%{_bindir}/znc-config
191%{_libdir}/pkgconfig/%{name}.pc
192%{_includedir}/znc/
193
194%files modtcl
195%defattr(-,root,root)
196%{_libdir}/znc/modtcl.so
197
198%changelog
199* Sat Jun 27 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.0-1
200- new upstream release.
201
202* Wed Jun 18 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4-1
203- new upstream release.
204
205* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2-1
206- new upstream release.
207
208* Tue Mar 12 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0-2
209- initial build for Vine Linux.
210
211* Tue Nov 13 2012 Nick Bebout <nb@fedoraproject.org> - 1.0-1
212- Update to 1.0
213
214* Thu Oct 18 2012 Nick Bebout <nb@fedoraproject.org> - 1.0-0.2.beta1
215- Update to 1.0-beta1
216
217* Thu Sep 13 2012 Nick Bebout <nb@fedoraproject.org> - 1.0-0.1.alpha1
218- Update to 1.0-alpha1
219
220* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.206-2
221- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
222
223* Mon Apr 16 2012 Nick Bebout <nb@fedoraproject.org> - 0.206-1
224- Upgrade to 0.206
225
226* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.204-4
227- Rebuilt for c++ ABI breakage
228
229* Mon Jan 23 2012 Nick Bebout <nb@fedoraproject.org> - 0.204-2
230- Add init script for EPEL
231
232* Mon Jan 23 2012 Nick Bebout <nb@fedoraproject.org> - 0.204-1
233- Update to 0.204 to fix security issue CVE-2012-0033
234
235* Mon Jan 09 2012 Nick Bebout <nb@fedoraproject.org> - 0.202-2
236- Add glibc-devel, openssl-devel, c-ares-devel to requires for
237- znc-devel so znc-buildmod will work
238
239* Sun Sep 25 2011 Nick Bebout <nb@fedoraproject.org> - 0.202-1
240- Update to 0.202
241
242* Tue Aug 23 2011 Nick Bebout <nb@fedoraproject.org> - 0.200-1
243- Update to 0.200
244
245* Mon Aug 15 2011 Nick Bebout <nb@fedoraproject.org> - 0.200-0.5.rc1
246- Don't create the znc user on Fedora 14 and lower and on EPEL
247
248* Mon Aug 15 2011 Nick Bebout <nb@fedoraproject.org> - 0.200-0.4.rc1
249- Change znc's homedir to /var/lib/znc
250
251* Sun Aug 14 2011 Nick Bebout <nb@fedoraproject.org> - 0.200-0.3.rc1
252- Re-add modpython, it somehow got disabled accidentally
253- Also re-add modperl, it works now
254
255* Sun Aug 14 2011 Nick Bebout <nb@fedoraproject.org> - 0.200-0.2.rc1
256- Create /home/znc upon install
257
258* Sat Aug 13 2011 Nick Bebout <nb@fedoraproject.org> - 0.200-0.1.rc1
259- Update to 0.200-rc1
260
261* Sat Aug 6 2011 Nick Bebout <nb@fedoraproject.org> - 0.2-0.2.beta1
262- Update to 0.2-beta1, disable perl for now
263
264* Fri Aug 5 2011 Nick Bebout <nb@fedoraproject.org> - 0.2-0.1.alpha1
265- Update to 0.2-alpha1
266
267* Mon Aug 1 2011 Nick Bebout <nb@fedoraproject.org> - 0.099-0.1.20110801git
268- Update to latest git
269
270* Sat Apr 2 2011 Nick Bebout <nb@fedoraproject.org> - 0.098-2
271- Add provides for ZNC::Module to znc-modperl
272
273* Tue Mar 29 2011 Nick Bebout <nb@fedoraproject.org> - 0.098-1
274- Update to znc-0.098
275
276* Sat Mar 12 2011 Nick Bebout <nb@fedoraproject.org> - 0.098-0.3.rc1
277- Update to znc-0.098-rc1
278
279* Wed Mar 02 2011 Nick Bebout <nb@fedoraproject.org> - 0.098-0.2.beta
280- Update to znc-0.098-beta
281
282* Wed Feb 23 2011 Nick Bebout <nb@fedoraproject.org> - 0.098-0.1.alpha1
283- Update to znc 0.098-alpha1
284
285* Tue Feb 15 2011 Nick Bebout <nb@fedoraproject.org> - 0.097-8.20110215git
286- Update to latest git
287
288* Wed Feb 09 2011 Nick Bebout <nb@fedoraproject.org> - 0.097-7.svn2277
289- Update to svn2277
290
291* Mon Jan 24 2011 Nick Bebout <nb@fedoraproject.org> - 0.097-6.svn2272
292- Update to svn2272
293
294* Mon Jan 17 2011 Nick Bebout <nb@fedoraproject.org> - 0.097-5.svn2269
295- Update to svn2269
296
297* Fri Jan 7 2011 Nick Bebout <nb@fedoraproject.org> - 0.097-4.svn2255
298- Update to svn2255
299
300* Mon Jan  3 2011 David Malcolm <dmalcolm@redhat.com> - 0.097-3.svn2214
301- rebuild for newer python3 (see rhbz#666429)
302
303* Fri Dec 24 2010 Nick Bebout <nb@fedoraproject.org> - 0.097-2.svn2214
304- Patch has been upstreamed, update to svn2214
305
306* Wed Dec 22 2010 Nick Bebout <nb@fedoraproject.org> - 0.097-1.svn2213
307- Update to znc 0.097-svn2213 which also adds modpython
308
309* Sun Nov 7 2010 Nick Bebout <nb@fedoraproject.org> - 0.096-2
310- Build TCL module, move modperl and modtcl to separate subpackages
311
312* Sat Nov 6 2010 Nick Bebout <nb@fedoraproject.org> - 0.096-1
313- Update to znc 0.096
314
315* Fri Sep 10 2010 Nick Bebout <nb@fedoraproject.org> - 0.094-1
316- Update to znc 0.094
317
318* Tue Aug 10 2010 Nick Bebout <nb@fedoraproject.org> - 0.093-2.svn2101
319- Update to znc 0.093.svn2101 to fix CVE-2010-2812 and CVE-2010-2934
320
321* Tue Aug 3 2010 Nick Bebout <nb@fedoraproject.org> - 0.093-1.svn2098
322- Update to znc 0.093 svn2098
323
324* Wed Jul 14 2010 Nick Bebout <nb@fedoraproject.org> - 0.092-1
325- Update to znc 0.092
326
327* Wed Jun 16 2010 Nick Bebout <nb@fedoraproject.org> - 0.090-2
328- Backport r2026 of ZNC subversion repo to fix bug 603915
329- NULL pointer dereference flaw leads to segfault under certain conditions
330
331* Sun Jun 06 2010 Nick Bebout <nb@fedoraproject.org> - 0.090-1
332- Update to znc 0.090
333
334* Thu May 27 2010 Nick Bebout <nb@fedoraproject.org> - 0.090-0.1.rc1
335- Update to znc 0.090-rc1
336
337* Thu May 27 2010 Nick Bebout <nb@fedoraproject.org> - 0.089-7.svn2004
338- Update to znc 0.089.svn2004
339
340* Tue May 18 2010 Nick Bebout <nb@fedoraproject.org> - 0.089-6.svn2000
341- Re-enable saslauth
342
343* Tue May 18 2010 Nick Bebout <nb@fedoraproject.org> - 0.089-5.svn2000
344- Re-enable modperl
345
346* Tue May 18 2010 Nick Bebout <nb@fedoraproject.org> - 0.089-4.svn2000
347- Update to znc 0.089.svn2000
348
349* Sun Apr 25 2010 Nick Bebout <nb@fedoraproject.org> - 0.089-3.svn1944
350- Update to znc 0.089.svn1944
351
352* Wed Apr 7 2010 Nick Bebout <nb@fedoraproject.org> - 0.081-2.svn1897
353- Update to znc 0.081.svn1897
354
355* Mon Mar 29 2010 Nick Bebout <nb@fedoraproject.org> - 0.081-1.svn1850
356- Update to znc 0.081.svn1850
357
358* Thu Feb 18 2010 Nick Bebout <nb@fedoraproject.org> - 0.080-1
359- Update to znc 0.080
360
361* Wed Dec 30 2009 Nick Bebout <nb@fedoraproject.org> - 0.078-1
362- Update to znc 0.078
363
364* Sun Dec 13 2009 Nick Bebout <nb@fedoraproject.org> - 0.078-0.1.rc1
365- Update to znc 0.078.rc1
366
367* Mon Dec 7 2009 Nick Bebout <nb@fedoraproject.org> - 0.077-1.svn1672
368- Add a DCCVHost config option which specifies the VHost (IP only!) for DCC bouncing. (r1647)
369- Users cloned via the admin module no longer automatically connect into IRC. (r1653)
370- Inform new clients about their /away status. (r1655)
371- The "BUG" messages from route_replies can now be turned off via /msg *route_replies silent yes. (r1660)
372- Rewrite znc.conf on SIGUSR1. (r1666)
373- ISpoofFormat now supports ExpandString. (r1670)
374- Allow specifing port and password for delserver. (r1640)
375- Write the config file on restart and shutdown. (r1641)
376- Disable c-ares if it is not found unless --enable-c-ares was used. (r1644) (r1645)
377- blockuser was missing an admin check. (r1648)
378- Sometimes, removing a server caused znc to lose track of which server it is connected to. (r1659)
379- Include a more portable header for uint32_t in SHA256.h. (r1665)
380- Fixed cases where ZNC didn't properly block PONG replies to its own PINGs. (r1668)
381- Fixed a possible crash if a client disconnected before an auth module was able to verify the login. (r1669)
382- Away allowed to accidentally execute IRC commands. (r1672)
383- Comment out some weird code in Client.cpp. (r1646)
384- Remove connect_throttle since it's obsoleted by fail2ban. (r1649)
385- Remove outdated sample znc.conf. (r1654)
386- route_replies now got a higher timeout before it generates a "BUG" message. (r1657)
387- Documented the signals on which znc reacts better. (r1667)
388- New module hook OnIRCConnecting(). (r1638)
389- Remove obsolete CUtils::GetHashPass(). (r1642)
390- A module's GetDescription() now returns a C-String. (r1661) (r1662)
391- When opening a module, check the version number first and don't do anything on a mismatch. (r1663)
392
393* Fri Dec  4 2009 Stepan Kasal <skasal@redhat.com> - 0.076-3
394- rebuild against perl 5.10.1
395
396* Fri Sep 25 2009 Nick Bebout <nb@fedoraproject.org> - 0.076-2
397- Fix missing dist tag
398
399* Fri Sep 25 2009 Nick Bebout <nb@fedoraproject.org> - 0.076-1
400- Upgrade to ZNC 0.076
401- http://en.znc.in/wiki/ChangeLog/0.076
402
403* Fri Aug 28 2009 Nick Bebout <nb@fedoraproject.org> - 0.075-8.svn1613
404- Rebuild with new openssl and svn 1613
405- build 0.075-7.svn1610 existed but I had to remove it from the spec because
406- the date was earlier than the date tmraz build the new openssl one
407
408* Wed Aug 26 2009 Tomas Mraz <tmraz@redhat.com> - 0.075-6.svn1608
409- rebuilt with new openssl
410
411* Thu Aug 20 2009 Nick Bebout <nb@fedoraproject.org> - 0.075-5.svn1608
412- Upgrade to svn 1608
413
414* Tue Aug 18 2009 Nick Bebout <nb@fedoraproject.org> - 0.075-4.20090818svn1602
415- Upgrade to svn 1602
416
417* Sat Aug 8 2009 Nick Bebout <nb@fedoraproject.org> - 0.075-3.20090807svn1594
418- Fix source filename
419
420* Fri Aug 7 2009 Nick Bebout <nb@fedoraproject.org> - 0.075-2.20090807svn1594
421- Fix broken source tarball
422
423* Fri Aug 7 2009 Nick Bebout <nb@fedoraproject.org> - 0.075-1.20090807svn1594
424- Upgrade to svn 1594
425
426* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.074-2
427- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
428
429* Thu Jul 23 2009 Nick Bebout <nb@fedoraproject.org> - 0.074-1
430- Update to 0.074
431
432* Wed Jul 22 2009 Nick Bebout <nb@fedoraproject.org> - 0.072-3
433- Fix date in changelog, disable c-ares
434
435* Wed Jul 22 2009 Nick Bebout <nb@fedoraproject.org> - 0.072-2
436- Backport patch to fix webadmin skins issue introduced in 0.072
437
438* Wed Jul 22 2009 Nick Bebout <nb@fedoraproject.org> - 0.072-1
439- Upgrade to 0.072 of ZNC, fixes security issue in bug # 513152
440
441* Sun Jul 12 2009 Nick Bebout <nb@fedoraproject.org> - 0.070-7
442- Fix License: to be GPLv2 with exceptions
443
444* Sat Jul 11 2009 Nick Bebout <nb@fedoraproject.org> - 0.070-6
445- Fix permissions error in %%prep, not in source
446
447* Sat Jul 11 2009 Nick Bebout <nb@fedoraproject.org> - 0.070-5
448- Fix permissions error on q.cpp and add LICENSE.OpenSSL
449
450* Sat Jul 11 2009 Nick Bebout <nb@fedoraproject.org> - 0.070-4
451- Remove switch to enable debug, fix %%files section
452
453* Fri Jul 10 2009 Nick Bebout <nb@fedoraproject.org> - 0.070-3
454- Move fixfreenode and log into separate znc-extra package
455- Move awayping into separate znc-awayping package
456
457* Thu Jul 9 2009 Nick Bebout <nb@fedoraproject.org> - 0.070-2
458- Include modules with main package
459
460* Wed Jul 8 2009 Nick Bebout <nb@fedoraproject.org> - 0.070-1
461- Initial Fedora package based on 0.070 of upstream
Note: See TracBrowser for help on using the repository browser.