source: projects/specs/trunk/z/zlib/zlib-vl.spec @ 12358

Revision 12358, 10.5 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

btrfs-progs-5.4.1-1

gsm-1.0.18-1

lzo-2.10-2

libusb1-1.0.23-1

usbutils-012-1

wireless-tools-29-5

zlib-1.2.11-3

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary: The zlib compression and decompression library.
3Summary(ja): zlib 圧縮/展開ライブラリ
4Name: zlib
5Version: 1.2.11
6Release: 3%{?_dist_release}
7Group: System Environment/Libraries
8Source: http://www.zlib.net/zlib-%{version}.tar.xz
9# Patch0: zlib-1.2.5-lfs-decls.patch
10
11Requires(post): /sbin/ldconfig
12Requires(postun): /sbin/ldconfig
13
14URL: http://www.zlib.net/
15License: zlib and Boost
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18Vendor: Project Vine
19Distribution: Vine Linux
20
21%global __provides_exclude_from ^%{_libdir}/pkgconfig/.*$
22
23%description
24The zlib compression library provides in-memory compression and
25decompression functions, including integrity checks of the
26uncompressed data.  This version of the library supports only one
27compression method (deflation), but other algorithms may be added
28later, which will have the same stream interface.  The zlib library is
29used by many different system programs.
30
31%description -l ja
32zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
33のデータの整合性チェックを行う関数を提供します。今バージョンのラ
34イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
35ートしていますが、今後同じストリームインターフェースを持つ他の圧
36縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
37用されています。
38
39%package devel
40Summary: Header files and libraries for developing apps which will use zlib.
41Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
44Provides: pkgconfig(zlib) = %{version}
45
46%description devel
47The zlib-devel package contains the header files and libraries needed
48to develop programs that use the zlib compression and decompression
49library.
50
51%package static
52Summary: Static libraries for  %{name}
53Summary(ja): %{name} のスタティックライブラリ
54Group: Development/Libraries
55Requires: %{name}-devel = %{version}-%{release}
56
57%description static
58The zlib-static package contains the static library for %{name}
59
60## to build compat32 for x86_64 architecture support
61%package -n compat32-%{name}
62Summary: The zlib compression and decompression library.
63Summary(ja): zlib 圧縮/展開ライブラリ
64Group: System Environment/Libraries
65Requires: %{name} = %{version}-%{release}
66Requires(post): /sbin/ldconfig
67Requires(postun): /sbin/ldconfig
68
69%description -n compat32-%{name}
70The zlib compression library provides in-memory compression and
71decompression functions, including integrity checks of the
72uncompressed data.  This version of the library supports only one
73compression method (deflation), but other algorithms may be added
74later, which will have the same stream interface.  The zlib library is
75used by many different system programs.
76
77%description -n compat32-%{name} -l ja
78zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
79のデータの整合性チェックを行う関数を提供します。今バージョンのラ
80イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
81ートしていますが、今後同じストリームインターフェースを持つ他の圧
82縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
83用されています。
84
85%package -n compat32-%{name}-devel
86Summary: Header files and libraries for developing apps which will use zlib.
87Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
88Group: Development/Libraries
89Requires: %{name} = %{version}-%{release}
90Requires: %{name}-devel = %{version}-%{release}
91
92%description -n compat32-%{name}-devel
93The zlib-devel package contains the header files and libraries needed
94to develop programs that use the zlib compression and decompression
95library.
96
97Install the zlib-devel package if you want to develop applications that
98will use the zlib library.
99
100
101%prep
102%setup -q
103# %patch0 -p1
104
105%build
106mkdir static shared
107
108# build shared lib
109CFLAGS="$RPM_OPT_FLAGS -fPIC" ./configure --shared --prefix=%{_prefix}
110
111make %{?_smp_mflags}
112mv -f Makefile zconf.h *.o *.so* shared/
113
114# build static lib
115CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}
116make %{?_smp_mflags}
117mv -f Makefile zconf.h *.o *.a static/
118
119
120%install
121rm -rf ${RPM_BUILD_ROOT}
122mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
123
124mv -f shared/* .
125make install prefix=${RPM_BUILD_ROOT}%{_prefix}
126
127mv -f Makefile zconf.h *.o *.so* shared/
128mv -f static/* .
129make install prefix=${RPM_BUILD_ROOT}%{_prefix}
130
131install -m644 zutil.h ${RPM_BUILD_ROOT}%{_includedir}/zutil.h
132mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man3
133install -m644 zlib.3 ${RPM_BUILD_ROOT}%{_mandir}/man3
134
135if [ "%{_prefix}/lib" != "%{_libdir}" ]; then
136    mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
137    mv ${RPM_BUILD_ROOT}%{_prefix}/lib/* ${RPM_BUILD_ROOT}%{_libdir}
138    rmdir ${RPM_BUILD_ROOT}%{_prefix}/lib
139fi
140
141cat %{buildroot}/usr/include/zlib.h | sed -n '1,/*\//p' > LICENSE
142
143%clean
144rm -rf ${RPM_BUILD_ROOT}
145
146%post -p /sbin/ldconfig
147
148%postun -p /sbin/ldconfig
149
150%post -n compat32-%{name} -p /sbin/ldconfig
151
152%postun -n compat32-%{name} -p /sbin/ldconfig
153
154%files
155%defattr(-,root,root)
156%license LICENSE
157%doc README
158%{_libdir}/*.so
159%{_libdir}/libz.so.*
160
161%files devel
162%defattr(-,root,root)
163%doc ChangeLog doc/algorithm.txt
164%{_libdir}/pkgconfig/zlib.pc
165%{_includedir}/*
166%{_mandir}/man3/zlib.3*
167
168%files static
169%defattr(-,root,root)
170%{_libdir}/*.a
171
172%if %{build_compat32}
173%files -n compat32-%{name}
174%defattr(-,root,root)
175%{_libdir}/libz.so.*
176
177%files -n compat32-%{name}-devel
178%defattr(-,root,root)
179%{_libdir}/*.so
180%{_libdir}/pkgconfig/zlib.pc
181%endif
182
183%changelog
184* Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.11-3
185- fixed "Provides:".
186
187* Sat Mar 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.11-2
188- dropped "Provides:pkgconfig(zlib)" from compat32-zlib-devel.
189
190* Wed Jan 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.11-1
191- new upstream release.
192- added license text.
193- reverted moving libz.so for compat32 package.
194
195* Sat Mar 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.8-2
196- moved libz.so into the main package.
197
198* Fri Mar 21 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.8-1
199- new upstream release
200- changed archive type bz2 to xz
201
202* Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.2.7-1
203- new upstream release
204- drop patch0 (resolved by upstream)
205- use smp flag in make section
206
207* Fri Oct 1 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.5-2
208- added patch0 from gentoo to fix zlib.h errors on i686 compiling some applications
209
210* Wed Sep 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.5-1
211- new upstream release (built with rpm-4.8.1-1 for pkg-config file)
212- changed License: BSD to zlib and Boost
213- added %%{_libdir}/pkgconfig/zlib.pc in -devel package
214- fixed %%doc files in -devel package
215
216* Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-7
217- add Requires(post,pre): /sbin/ldconfig
218
219* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-6
220- rebuilt with gcc-4.4.3-3 on ppc
221
222* Mon Feb  8 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-5
223- rebuilt with new toolchain
224
225* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-4
226- split static library to zlib-static
227  - needed by tuxonice-userui
228
229* Wed Dec 17 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-3
230- change spec into UTF-8
231
232* Sun May 18 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.3-2
233- removed %%if !%%{build_compat32} case condition
234
235* Sat May 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
236- applied new versioning policy
237- rebuilt with new toolchains
238
239* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl5
240- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
241
242* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl4
243- added compat32-* packages for x86_64 architecture support
244
245* Tue Oct 25 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.2.3-0vl3
246- added compat32- packages for x86_64 architecture support
247
248* Tue Oct 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl2
249- clean up specfile (do not build twice..)
250
251* Tue Jul 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
252- new upstream release
253
254* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2.2-0vl1
255- new upstream release
256- add Patch1 for CAN-2005-2096
257
258* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
259- new upstream version
260- add translated descriptions (thanks to spec file translation project)
261
262* Sun Apr 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.1.4-0vl3
263- fixed buffer overrun on gzprintf
264        -- added zlib-1.1.4-vsnprintf.patch from http://archives.neohapsis.com/archives/bugtraq/2003-02/0290.html
265
266* Fri Sep 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.4-0vl2
267- changed URL to more preferable site
268
269* Tue Mar 12 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.4-0vl1
270- upstream release
271
272* Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
273- 1.1.3-14vl1
274- based on 1.1.3-14 from Rawhide
275- added Japanese summary
276
277* Fri Sep 15 2000 Florian La Roche <Florian.LaRoche@redhat.de>
278- add -fPIC for shared libs (patch by Fritz Elfert)
279
280* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
281- on 64bit systems, make sure libraries are located correctly.
282
283* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
284- summaries from specspo.
285
286* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
287- automatic rebuild
288
289* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
290- rebuild
291
292* Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
293- FHS packaging to build on solaris2.5.1.
294
295* Wed Jun 07 2000 Trond Eivind Glomsr <teg@redhat.com>
296- use %%{_mandir} and %%{_tmppath}
297
298* Fri May 12 2000 Trond Eivind Glomsr <teg@redhat.com>
299- updated URL and source location
300- moved README to main package
301
302* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
303- compress man page.
304
305* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
306- auto rebuild in the new build environment (release 5)
307
308* Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
309- link against glibc
310
311* Mon Jul 27 1998 Jeff Johnson <jbj@redhat.com>
312- upgrade to 1.1.3
313
314* Fri May 08 1998 Prospector System <bugs@redhat.com>
315- translations modified for de, fr, tr
316
317* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
318- upgraded to 1.1.2
319- buildroot
320
321* Tue Oct 07 1997 Donnie Barnes <djb@redhat.com>
322- added URL tag (down at the moment so it may not be correct)
323- made zlib-devel require zlib
324
325* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
326- built against glibc
Note: See TracBrowser for help on using the repository browser.