source: projects/specs/trunk/z/zint/zint-vl.spec @ 10583

Revision 10583, 4.8 KB checked in by tomop, 8 years ago (diff)

zint-2.4.2-3

Line 
1Summary: A barcode generator and library
2Summary(ja): Zintバーコード作成プログラム
3Name: zint
4Version: 2.4.2
5Release: 3%{?_dist_release}
6License: GPLv3+
7URL: http://www.zint.org.uk
8Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
9Patch0: zint-2.4.0-qr-kanji.patch
10Patch1: %{name}-rpath.patch
11Patch2: %{name}-2.4.2-libpng16.patch
12Group: Applications/Engineering
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14BuildRequires: cmake
15BuildRequires: libpng-devel
16BuildRequires: zlib-devel
17BuildRequires: qt4-devel
18BuildRequires: desktop-file-utils
19Distribution: Vine Linux
20Vendor: Project Vine
21Packager: owa
22
23%description
24Zint is a C library for encoding data in several barcode variants. The
25bundled command-line utility provides a simple interface to the library.
26Features of the library:
27- Over 50 symbologies including all ISO/IEC standards, like QR codes.
28- Unicode translation for symbologies which support Latin-1 and
29  Kanji character sets.
30- Full GS1 support including data verification and automated insertion of
31  FNC1 characters.
32- Support for encoding binary data including NULL (ASCII 0) characters.
33- Health Industry Barcode (HIBC) encoding capabilities.
34- Output in PNG, EPS and SVG formats with user adjustable sizes and colors.
35- Verification stage for SBN, ISBN and ISBN-13 data.
36
37%package devel
38Summary: Library and header files for %{name}
39Summary(ja): Zintバーコードの開発用ライブラリとヘッダファイル
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description devel
44C library and header files needed to develop applications using %{name}.
45The API documentation can be found ont the project website:
46http://www.zint.org.uk/zintSite/Manual.aspx
47
48%package qt
49Summary: Zint Barcode Studio GUI and library
50Summary(ja): Zintバーコード作成GUI(QT)とライブラリ
51Group: Applications/Engineering
52Requires: %{name} = %{version}-%{release}
53BuildRequires: qt4-devel >= 4.4
54BuildRequires: desktop-file-utils
55
56%description qt
57Zint Barcode Studio is a Qt-based GUI which allows desktop users to generate
58barcodes which can then be embedded in documents or HTML pages, and a library
59which can be used to incorporate barcode generation functionality into other
60software.
61
62%package qt-devel
63Summary: Library and header files for %{name}-qt
64Summary(ja): ZintバーコードのGUI(QT)開発用ライブラリとヘッダファイル
65Group: Development/Libraries
66Requires: %{name}-devel = %{version}-%{release}
67Requires: %{name}-qt = %{version}-%{release}
68
69%description qt-devel
70C library and header files needed to develop applications using %{name}-qt.
71
72
73%prep
74%setup -q
75%patch0 -p 1 -b .qr-kanji
76%patch1 -p 1 -b .rpath
77%patch2 -p1 -b .libpng16
78
79# remove BSD-licensed file required for Windows only
80# (just to ensure that this package is plain GPLv3+)
81rm -f backend/ms_stdint.h
82# remove bundled getopt sources (we use the corresponding Fedora package instead)
83rm -f frontend/getopt*.*
84
85
86%build
87%cmake CMakeLists.txt
88make VERBOSE=1 %{?_smp_mflags}
89
90
91%install
92rm -rf $RPM_BUILD_ROOT
93make install DESTDIR=$RPM_BUILD_ROOT
94
95rm -rf $RPM_BUILD_ROOT/%{_datadir}/cmake
96
97cat <<EOF >%{name}-qt.desktop
98[Desktop Entry]
99Encoding=UTF-8
100Name=Zint Barcode Studio
101Name[ja]=Zintバーコードスタジオ
102Comment=Zint Barcode Studio
103Comment[ja]=バーコードを作成するツールです
104GenericName=Zint Barcode Studio
105Exec=zint-qt
106Icon=zint
107Terminal=false
108Type=Application
109Categories=Utility;
110EOF
111
112install -D -p -m 644 %{name}.png %{buildroot}/usr/share/pixmaps/%{name}.png
113install -D -p -m 644 %{name}-qt.desktop %{buildroot}%{_datadir}/applications/%{name}-qt.desktop
114desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}-qt.desktop
115
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%post -p /sbin/ldconfig
121%postun -p /sbin/ldconfig
122%post qt -p /sbin/ldconfig
123%postun qt -p /sbin/ldconfig
124%files
125%defattr(-,root,root,-)
126%license COPYING
127%doc INSTALL README* TODO
128%{_bindir}/%{name}
129%{_libdir}/libzint.so.*
130
131%files devel
132%defattr(-,root,root,-)
133%{_includedir}/%{name}.h
134%{_libdir}/libzint.so
135
136%files qt
137%defattr(-,root,root,-)
138%{_bindir}/%{name}-qt
139%{_libdir}/libQZint.so.*
140%{_datadir}/applications/%{name}-qt.desktop
141%{_datadir}/pixmaps/%{name}.png
142
143%files qt-devel
144%defattr(-,root,root,-)
145%{_includedir}/qzint.h
146%{_libdir}/libQZint.so
147
148
149%changelog
150* Sun Jul 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.2-3
151- rebuilt with new toolchain.
152
153* Sun Jul  6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.2-2
154- rebuilt with current environment.
155- added Patch2 for libpng16.
156
157* Sat May 07 2011 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
158- updated zint to 2.4.2
159- added %{name}-rpath.patch
160- added BR: qt4-devel, desktop-file-utils
161
162* Sat Nov 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.4.0-2
163- added zint-2.4.0-qr-kanji.patch (BTS:1062)
164- install %{name}.png
165
166* Thu Oct 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.4.0-1
167- initial build for Vine
168
Note: See TracBrowser for help on using the repository browser.