source: projects/specs/trunk/z/zinnia/zinnia-vl.spec @ 10446

Revision 10446, 7.6 KB checked in by tomop, 8 years ago (diff)

zinnia-0.07-1

Line 
1Summary:        Online handwriting recognition system with machine learning
2Summary(ja):    機械学習ベースのポータブルなオンライン手書き文字認識エンジン
3Name:           zinnia
4Version:        0.07
5Release:        1%{?_dist_release}
6Group:          System Environment/Libraries
7License:        BSD
8URL:            http://zinnia.sourceforge.net/
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12Source0:        http://downloads.sourceforge.net/zinnia/%{name}-%{version}.tar.xz
13Source1:        http://zinnia.svn.sourceforge.net/viewvc/zinnia/zinnia/tomoe2s.pl
14Source2:        Makefile.tomoe
15Patch0:         zinnia-0.05-bindings.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires:  libdb-devel
19BuildRequires:  perl(ExtUtils::MakeMaker)
20BuildRequires:  python-devel
21BuildRequires:  tomoe
22
23%description
24Zinnia provides a simple, customizable, and portable dynamic OCR
25system for hand-written input, based on Support Vector Machines.
26
27Zinnia simply receives user pen strokes as coordinate data and outputs
28the best matching characters sorted by SVM confidence. To maintain
29portability, it has no rendering functionality. In addition to
30recognition, Zinnia provides a training module capable of creating
31highly efficient handwriting recognition models.
32
33This package contains the shared libraries.
34
35%description -l ja
36Zinnia は機械学習アルゴリズム SVM を用いたポータブルで汎用的なオンライン手書き文字認識エンジンです。
37Zinniaは組み込みの容易さと汎用性を高めるために、文字のレンダリング機能は持っていません。Zinniaは文字のストローク情報を座標の連続として受け取り、確からしい順にスコア付きでN文字の認識結果を返すだけに機能を限定しています。また、認識エンジンは完全に機械学習ベースであるために、文字のみならずユーザの任意のマウス・ペンストロークに対して任意の文字列をマッピングするような認識エンジンを小コスト作成することができます。
38
39%package        devel
40Summary:        Development files for %{name}
41Summary(ja):    %{name} の開発用ファイル
42Group:          Development/Libraries
43Requires:       %{name} = %{version}-%{release}
44
45%description    devel
46The %{name}-devel package contains libraries and header files for
47developing applications that use %{name}.
48
49%package        utils
50Summary:        Utils for the zinnia library
51Group:          Applications/System
52Requires:       %{name} = %{version}-%{release}
53
54%description    utils
55The %{name}-utils package provides utilities for zinnia library that
56use %{name}.
57
58%package        doc
59Summary:        Documents for the zinnia library
60Group:          Documentation
61Requires:       %{name} = %{version}-%{release}
62#BuildArch:     noarch
63
64%description    doc
65The %{name}-doc package provide documents for zinnia library that
66use %{name}.
67
68%package        perl
69Summary:        Perl bindings for %{name}
70Group:          Development/Libraries
71Requires:       %{name} = %{version}-%{release}
72Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
73Provides:       perl-zinnia = %{version}-%{release}
74
75%description    perl
76This package contains perl bindings for %{name}.
77
78%package        python
79Summary:        Python bindings for %{name}
80Group:          Development/Libraries
81Requires:       %{name} = %{version}-%{release}
82Provides:       tegaki-recognition-engine
83
84%description    python
85This package contains python bindings for %{name}.
86
87%package        tomoe
88Summary:        Tomoe Ja model file for %{name}
89Group:          System Environment/Libraries
90Requires:       %{name} = %{version}-%{release}
91Provides:       %{name}-model
92Provides:       %{name}-tomoe-ja
93#BuildArch:     noarch
94
95%description    tomoe
96This package contains tomoe Ja model files for %{name}.
97
98%package        tomoe-zh_CN
99Summary:        Tomoe model zh_CN file for %{name}
100Group:          System Environment/Libraries
101Requires:       %{name} = %{version}-%{release}
102Provides:       %{name}-model
103#BuildArch:     noarch
104
105%description    tomoe-zh_CN
106This package contains tomoe zh_CN model files for %{name}.
107
108%prep
109%setup -q -n %{name}
110%patch0 -p1 -b .bindings
111find . -type f -name ChangeLog -size 0c -exec rm -f {} ';'
112find . -type f -name "*.pyc" -exec rm -f {} ';'
113cp %{SOURCE1} .
114cp %{SOURCE2} .
115pushd doc
116iconv -f latin1 -t utf8 zinnia.css > zinnia.css.bak
117mv -f zinnia.css.bak zinnia.css
118popd
119
120%build
121%configure --disable-static
122sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
123sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
124make %{?_smp_mflags}
125make -f Makefile.tomoe build
126
127pushd perl
128perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
129make %{?_smp_mflags}
130popd
131
132pushd python
133CFLAGS="$RPM_OPT_FLAGS -I../" LDFLAGS="-L../.libs" python setup.py build
134popd
135
136%install
137rm -rf $RPM_BUILD_ROOT
138make install DESTDIR=$RPM_BUILD_ROOT
139make -f Makefile.tomoe install DESTDIR=$RPM_BUILD_ROOT
140
141#install -d -m 0755 -p $RPM_BUILD_ROOT%{_docdir}/%{name}
142#cp -pfr doc $RPM_BUILD_ROOT%{_docdir}/%{name}
143
144pushd perl
145make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
146popd
147
148pushd python
149python setup.py install --root $RPM_BUILD_ROOT
150pushd
151
152#remove something unnecessary
153find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
154find $RPM_BUILD_ROOT -type f -name "*.bs" -size 0c -exec rm -f {} ';'
155find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
156
157#change the privilege of some files
158chmod 0755 $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.so
159
160
161%clean
162rm -rf $RPM_BUILD_ROOT
163
164
165%post -p /sbin/ldconfig
166
167%postun -p /sbin/ldconfig
168
169
170%files
171%defattr(-,root,root,-)
172%doc README COPYING
173%{_libdir}/*.so.*
174
175%files devel
176%defattr(-,root,root,-)
177%{_includedir}/*
178%{_libdir}/lib%{name}.so
179
180%{_libdir}/pkgconfig/%{name}.pc
181
182%files utils
183%defattr(-,root,root,-)
184%{_bindir}/zinnia
185%{_bindir}/zinnia_convert
186%{_bindir}/zinnia_learn
187
188%files doc
189%defattr(-,root,root,-)
190%doc doc/*
191
192%files  perl
193%defattr(-,root,root,-)
194%{perl_vendorarch}/auto/%{name}/
195%{perl_vendorarch}/%{name}.pm
196
197%files  python
198%defattr(-,root,root,-)
199%{python_sitearch}/_%{name}.so
200%{python_sitearch}/%{name}*
201
202%files tomoe
203%defattr(-,root,root,-)
204%dir %{_datadir}/zinnia/model/tomoe/
205%{_datadir}/zinnia/model/tomoe/handwriting-ja.model
206
207%files tomoe-zh_CN
208%defattr(-,root,root,-)
209%dir %{_datadir}/zinnia/model/tomoe/
210%{_datadir}/zinnia/model/tomoe/handwriting-zh_CN.model
211
212
213%changelog
214* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.07-1
215- new upstream release.
216- dropped Patch1: fixed in upstream.
217
218* Mon Nov 10 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.06-5
219- rebuilt with perl 5.16.3
220
221* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.06-4
222- rebuild with python-2.7.2
223
224* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 0.06-3vl6
225- build with perl 5.12.3
226
227* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.06-2
228- rebuild with rpm-4.8.1 for pkg-config file
229
230* Tue Jun  8 2010 IWAI, Masaharu <iwai@alib.jp> 0.06-1
231- initial build for Vine Linux
232
233* Fri Jun 04 2010  Peng Wu <pwu@redhat.com> - 0.06-4
234- Add a patch(zinnia-0.06-fixes-ppc-float.patch),
235  to fixes ppc/ppc64 zinnia tomoe model generating error.
236
237* Wed Jun 02 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.06-3
238- Mass rebuild with perl-5.12.0
239
240* Thu May 20 2010  Peng Wu <pwu@redhat.com> - 0.06-2
241- Auto generate zinnia tomoe model files,
242  and includes all model files in zinnia-tomoe noarch sub-package.
243
244* Thu May 20 2010  Peng Wu <pwu@redhat.com> - 0.06-1
245- Update to version 0.06.
246
247* Wed Mar 10 2010 Liang Suilong <liangsuilong@gmail.com> - 0.05-4
248- Fix the bugs of SPEC file
249
250* Thu Mar 04 2010 Liang Suilong <liangsuilong@gmail.com> - 0.05-3
251- Fix something wrong of spec file
252
253* Tue Mar 02 2010 Liang Suilong <liangsuilong@gmail.com> - 0.05-2
254- Rename Subpackage for perl and python
255
256* Tue Feb 02 2010 Liang Suilong <liangsuilong@gmail.com> - 0.05-1
257- Initial Package
Note: See TracBrowser for help on using the repository browser.