source: projects/specs/trunk/z/zabbix/zabbix-vl.spec @ 12431

Revision 12431, 17.4 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

control-center-3.30.3-2

docker-ce-19.03.9-1

docker-compose-1.26.2-1

golang-1.14.6-1

polkit-0.116-2

postfix-3.5.6-1

unbound-1.11.0-1

webkitgtk4-2.28.3-1

zabbix-5.0.2-1

Line 
1%bcond_with systemd
2
3%define only_agent 0
4
5%if %{only_agent}
6%bcond_with server
7%bcond_with proxy
8%bcond_with frontend
9%else
10%bcond_without server
11%bcond_without proxy
12%bcond_without frontend
13%endif
14
15%bcond_without agent
16
17Summary: The Enterprise-class Monitoring Solution for Everyone
18Name: zabbix
19Version: 5.0.2
20Release: 1%{?_dist_release}%{?with_systemd:.systemd}
21Group: Applications/Services
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: iwaim
25
26License: GPLv2
27URL: https://www.zabbix.com/
28%global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
29Source0: https://cdn.zabbix.com/zabbix/sources/stable/%{shortver}/%{name}-%{version}.tar.gz
30Source1: zabbix_server.init
31Source2: zabbix_proxy.init
32Source3: zabbix_agentd.init
33Source4: zabbix_server.logrotate
34Source5: zabbix_proxy.logrotate
35Source6: zabbix_agentd.logrotate
36
37Source9:        %{name}-tmpfiles-zabbix.conf
38# systemd units -- Alternatives switches between them (they state their dependencies)
39# https://support.zabbix.com/browse/ZBXNEXT-1593
40Source10:       %{name}-agent.service
41Source11:       %{name}-proxy-mysql.service
42Source12:       %{name}-proxy-pgsql.service
43Source14:       %{name}-server-mysql.service
44Source15:       %{name}-server-pgsql.service
45Source17:       %{name}-tmpfiles-zabbixsrv.conf
46
47BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
48%if %{with server}%{with proxy}
49BuildRequires: libpq-devel
50BuildRequires: libmariadb-devel
51%endif
52BuildRequires: libevent-devel
53BuildRequires: pcre-devel
54BuildRequires: curl-devel
55BuildRequires: net-snmp-devel
56BuildRequires: OpenIPMI-devel
57BuildRequires: unixODBC-devel
58BuildRequires: libssh2-devel
59BuildRequires: openssl-devel
60
61Requires(pre): glibc-common
62Requires(pre): shadow-utils
63%if %{with systemd}
64BuildRequires:   systemd
65%endif
66
67%description
68The Enterprise-class Monitoring Solution for Everyone.
69
70
71%if %{with server}
72%package server-common
73Summary: common files for Zabbix Server
74Requires: %{name} == %{version}-%{release}
75%if %{with systemd}
76%{?systemd_requires}
77%else
78Requires(post,preun): chkconfig
79Requires(preun,postun): initscripts
80%endif
81
82%description server-common
83This package include common files for Zabbix Server.
84
85
86%package server-mysql
87Summary: Zabbix Server for MySQL/MariaDB
88Provides: %{name}-server
89Requires: %{name}-server-common == %{version}-%{release}
90
91%description server-mysql
92Zabbix Server for MySQL/MariaDB
93
94
95%package server-postgresql
96Summary: Zabbix Server for PostgreSQL
97Provides: %{name}-server
98Requires: %{name}-server-common == %{version}-%{release}
99
100%description server-postgresql
101Zabbix Server for PostgreSQL
102
103%endif
104
105
106%if %{with agent}
107%package agent
108Summary: Zabbix Agent
109Requires: %{name} == %{version}-%{release}
110%if %{with systemd}
111%{?systemd_requires}
112%else
113Requires(post,preun): chkconfig
114Requires(preun,postun): initscripts
115%endif
116
117%description agent
118Zabbix Agent
119
120%endif
121
122
123%if %{with proxy}
124%package proxy-common
125Summary: common files for Zabbix Proxy
126Requires: %{name} == %{version}-%{release}
127%if %{with systemd}
128%{?systemd_requires}
129%else
130Requires(post,preun): chkconfig
131Requires(preun,postun): initscripts
132%endif
133
134%description proxy-common
135This package include common files for Zabbix Proxy
136
137
138%package proxy-mysql
139Summary: Zabbix Proxy for MySQL/MariaDB
140Provides: %{name}-proxy
141Requires: %{name}-proxy-common == %{version}-%{release}
142
143%description proxy-mysql
144Zabbix Proxy for MySQL/MariaDB
145
146
147%package proxy-postgresql
148Summary: Zabbix Proxy for PostgreSQL
149Provides: %{name}-proxy
150Requires: %{name}-proxy-common == %{version}-%{release}
151
152%description proxy-postgresql
153Zabbix Proxy for PostgreSQL
154
155%endif
156
157
158%if %{with frontend}
159%package frontend-php
160Summary: Zabbix web frontend with PHP
161Group: Applications/Internet
162Requires: php74
163Requires: TrueType-vlgothic
164
165%description frontend-php
166Zabbix web frontend with PHP.
167
168
169%package frontend-php-mysql
170Summary: Zabbix web frontend with PHP and MySQL/MariaDB
171Group: Applications/Internet
172Provides: %{name}-frontend-php == %{version}-%{release}
173Requires: php74-mysql
174
175%description frontend-php-mysql
176Zabbix web frontend with PHP and MySQL/MariaDB.
177
178
179%package frontend-php-postgresql
180Summary: Zabbix web frontend with PHP and PostgreSQL
181Group: Applications/Internet
182Provides: %{name}-frontend-php == %{version}-%{release}
183Requires: php74-pgsql
184
185%description frontend-php-postgresql
186Zabbix web frontend with PHP and PostgreSQL.
187
188%endif
189
190
191%prep
192%setup -q -T -a 0 -c -n zabbix-%{version}
193mv zabbix-%{version} zabbix_mysql
194
195%if %{with server}%{with proxy}
196%setup -q -D -T -a 0 -n zabbix-%{version}
197mv zabbix-%{version} zabbix_pgsql
198%endif
199
200for v in mysql pgsql; do
201pushd zabbix_$v
202sed -i -e 's/DejaVuSans/VL-Gothic-Regular/g' ./ui/include/defines.inc.php
203
204sed -i \
205    -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_agentd.pid' \
206    -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_agentd.log|' \
207    conf/zabbix_agentd.conf
208
209sed -i \
210    -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_proxy.pid' \
211    -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_proxy.log|' \
212    conf/zabbix_proxy.conf
213
214sed -i \
215    -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_server.pid' \
216    -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_server.log|' \
217    conf/zabbix_server.conf
218popd
219done
220
221
222%build
223Build()
224{
225perl -pi -e 's|/usr/bin/traceroute|/bin/traceroute|' \
226    ./database/{ibm_db2,mysql,oracle,postgresql,sqlite3}/data.sql
227
228%configure \
229           %{?with_server:--enable-server} \
230           %{?with_proxy:--enable-proxy} \
231           %{?with_agent:--enable-agent} \
232           --enable-ipv6 \
233           --sysconfdir=%{_sysconfdir}/zabbix \
234           --with-libcurl \
235           --with-openipmi \
236           --with-net-snmp \
237           --with-unixodbc \
238           --with-ssh2 \
239           --with-openssl \
240           $@
241
242%__make
243}
244
245%if %{with server}%{with proxy}
246pushd zabbix_mysql
247Build --with-mysql
248popd
249
250pushd zabbix_pgsql
251Build --with-postgresql
252popd
253%else
254pushd zabbix_mysql
255Build
256popd
257%endif
258
259
260%install
261%__rm -rf %{buildroot}
262pushd zabbix_mysql
263make DESTDIR=%{buildroot} install
264
265%if %{with server}
266mv -f %{buildroot}%{_sbindir}/zabbix_server %{buildroot}%{_sbindir}/zabbix_server.mysql
267%endif
268%if %{with proxy}
269mv -f %{buildroot}%{_sbindir}/zabbix_proxy %{buildroot}%{_sbindir}/zabbix_proxy.mysql
270%endif
271
272# make directories
273%__mkdir_p %{buildroot}%{_localstatedir}/{log,run}/%{name}
274
275# DB
276%__mkdir_p %{buildroot}%{_datadir}/zabbix
277%if %{with server}%{with proxy}
278%__cp -a database/postgresql %{buildroot}%{_datadir}/zabbix/
279%__cp -a database/mysql %{buildroot}%{_datadir}/zabbix/
280%endif
281
282%if %{with systemd}
283# unit files
284%__mkdir_p %{buildroot}%{_unitdir}
285# Install different systemd units because of the requirements for DBMS daemons
286install -m 0644 -p %{SOURCE10} %{buildroot}%{_unitdir}/zabbix-agent.service
287install -m 0644 -p %{SOURCE11} %{buildroot}%{_unitdir}/zabbix-proxy-mysql.service
288install -m 0644 -p %{SOURCE12} %{buildroot}%{_unitdir}/zabbix-proxy-pgsql.service
289install -m 0644 -p %{SOURCE14} %{buildroot}%{_unitdir}/zabbix-server-mysql.service
290install -m 0644 -p %{SOURCE15} %{buildroot}%{_unitdir}/zabbix-server-pgsql.service
291
292# systemd tmpfiles
293mkdir -p %{buildroot}%{_prefix}/lib/tmpfiles.d
294install -m 0644 -p %{SOURCE9} %{buildroot}%{_prefix}/lib/tmpfiles.d/zabbix.conf
295
296%else
297# init.d
298%__mkdir_p %{buildroot}%{_initddir}
299%if %{with server}
300%__cp %{SOURCE1} %{buildroot}%{_initddir}/zabbix_server
301%endif
302%if %{with proxy}
303%__cp %{SOURCE2} %{buildroot}%{_initddir}/zabbix_proxy
304%endif
305%if %{with agent}
306%__cp %{SOURCE3} %{buildroot}%{_initddir}/zabbix_agentd
307%endif
308%endif
309
310# logrotate
311%__mkdir_p %{buildroot}%{_sysconfdir}/logrotate.d
312%if %{with server}
313%__cp %{SOURCE4}  %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_server
314%endif
315%if %{with proxy}
316%__cp %{SOURCE5}  %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_proxy
317%endif
318%if %{with agent}
319%__cp %{SOURCE6}  %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_agentd
320%endif
321
322%if %{with frontend}
323# frontend-php
324%__mkdir_p %{buildroot}%{_datadir}/zabbix-frontend
325%__cp -a ui %{buildroot}%{_datadir}/zabbix-frontend/php
326%__rm -f %{buildroot}%{_datadir}/zabbix-frontend/php/assets/fonts/DejaVuSans.ttf
327
328ln -s /usr/share/fonts/TrueType-vlgothic/VL-Gothic-Regular.ttf \
329      %{buildroot}%{_datadir}/zabbix-frontend/php/assets/fonts/
330%endif
331
332%if %{with proxy}
333# proxy
334mkdir -p %{buildroot}%{_datadir}/zabbix-proxy
335ln -sf ../zabbix/mysql %{buildroot}%{_datadir}/zabbix-proxy/
336ln -sf ../zabbix/postgresql %{buildroot}%{_datadir}/zabbix-proxy/
337%endif
338
339popd
340
341%if %{with server}%{with proxy}
342pushd zabbix_pgsql
343install -m755 src/zabbix_server/zabbix_server %{buildroot}%{_sbindir}/zabbix_server.pgsql
344install -m755 src/zabbix_proxy/zabbix_proxy %{buildroot}%{_sbindir}/zabbix_proxy.pgsql
345popd
346%endif
347
348
349%clean
350%__rm -rf %{buildroot}
351
352
353%pre
354getent group zabbix >/dev/null || groupadd -r zabbix
355getent passwd zabbix >/dev/null || \
356useradd -r -g zabbix -d %{_sysconfdir}/zabbix -s /sbin/nologin \
357-c "Zabbix Monitoring Solution" zabbix
358exit 0
359
360%if %{with server}
361%post server-mysql
362%if %{with systemd}
363%systemd_post zabbix-server-mysql.service
364%else
365/sbin/update-alternatives --install /usr/sbin/zabbix_server \
366        zabbix_server /usr/sbin/zabbix_server.mysql 10
367%endif
368
369%post server-postgresql
370%if %{with systemd}
371%systemd_post zabbix-server-pgsql.service
372%else
373/sbin/update-alternatives --install /usr/sbin/zabbix_server \
374        zabbix_server /usr/sbin/zabbix_server.pgsql 10
375/sbin/chkconfig --add zabbix_server
376%endif
377%endif
378
379%if %{with proxy}
380%post proxy-mysql
381%if %{with systemd}
382%systemd_post zabbix-proxy-mysql.service
383%else
384/sbin/update-alternatives --install /usr/sbin/zabbix_proxy \
385        zabbix_proxy /usr/sbin/zabbix_proxy.mysql 10
386/sbin/chkconfig --add zabbix_proxy
387%endif
388
389%post proxy-postgresql
390%if %{with systemd}
391%systemd_post zabbix-proxy-pgsql.service
392%else
393/sbin/update-alternatives --install /usr/sbin/zabbix_proxy \
394        zabbix_proxy /usr/sbin/zabbix_proxy.pgsql 10
395/sbin/chkconfig --add zabbix_proxy
396%endif
397%endif
398
399%if %{with agent}
400%post agent
401%if %{with systemd}
402%systemd_post zabbix-agent.service
403%else
404/sbin/chkconfig --add zabbix_agentd
405%endif
406
407%endif
408
409%if %{with server}
410%preun server-mysql
411%if %{with systemd}
412%systemd_preun zabbix-server-mysql.service
413%else
414if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
415        /sbin/service zabbix_server stop >/dev/null 2>&1
416        /sbin/chkconfig --del zabbix_server
417        /sbin/update-alternatives --remove zabbix_server \
418                /usr/sbin/zabbix_server.mysql
419fi
420%endif
421
422%preun server-postgresql
423%if %{with systemd}
424%systemd_preun zabbix-server-pgysql.service
425%else
426if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
427        /sbin/service zabbix_server stop >/dev/null 2>&1
428        /sbin/chkconfig --del zabbix_server
429        /sbin/update-alternatives --remove zabbix_server \
430                /usr/sbin/zabbix_server.pgsql
431fi
432%endif
433%endif
434
435%if %{with proxy}
436%preun proxy-mysql
437%if %{with systemd}
438%systemd_preun zabbix-proxy-mysql.service
439%else
440if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
441        /sbin/service zabbix_proxy stop >/dev/null 2>&1
442        /sbin/chkconfig --del zabbix_proxy
443        /sbin/update-alternatives --remove zabbix_proxy \
444                /usr/sbin/zabbix_proxy.mysql
445fi
446%endif
447
448%preun proxy-postgresql
449%if %{with systemd}
450%systemd_preun zabbix-proxy-pgsql.service
451%else
452if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
453        /sbin/service zabbix_proxy stop >/dev/null 2>&1
454        /sbin/chkconfig --del zabbix_proxy
455        /sbin/update-alternatives --remove zabbix_proxy \
456                /usr/sbin/zabbix_proxy.pgsql
457fi
458%endif
459%endif
460
461%if %{with agent}
462%preun agent
463%if %{with systemd}
464%systemd_preun zabbix-agent.service
465%else
466if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
467        /sbin/service zabbix_agentd stop >/dev/null 2>&1
468        /sbin/chkconfig --del zabbix_agentd
469fi
470%endif
471%endif
472
473%if %{with server}
474%postun server-mysql
475%if %{with systemd}
476%systemd_postun_with_restart zabbix-server-mysql.service
477%else
478if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
479        /sbin/service zabbix_server condrestart >/dev/null 2>&1 || :
480fi
481%endif
482
483%postun server-postgresql
484%if %{with systemd}
485%systemd_postun_with_restart zabbix-server-pgsql.service
486%else
487if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
488        /sbin/service zabbix_server condrestart >/dev/null 2>&1 || :
489fi
490%endif
491%endif
492
493%if %{with proxy}
494%postun proxy-mysql
495%if %{with systemd}
496%systemd_postun_with_restart zabbix-proxy-mysql.service
497%else
498if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
499        /sbin/service zabbix_proxy condrestart >/dev/null 2>&1 || :
500fi
501%endif
502
503%postun proxy-postgresql
504%if %{with systemd}
505%systemd_postun_with_restart zabbix-proxy-pgsql.service
506%else
507if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
508        /sbin/service zabbix_proxy condrestart >/dev/null 2>&1 || :
509fi
510%endif
511
512%postun agent
513%if %{with systemd}
514%systemd_postun_with_restart zabbix-agent.service
515%else
516if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
517        /sbin/service zabbix_agentd condrestart >/dev/null 2>&1 || :
518fi
519%endif
520
521%endif
522
523
524%files
525%defattr(-,root,root,-)
526%license zabbix_mysql/COPYING
527%doc zabbix_mysql/AUTHORS zabbix_mysql/ChangeLog zabbix_mysql/NEWS zabbix_mysql/README
528%attr(0755,zabbix,zabbix) %dir %{_localstatedir}/log/%{name}
529%dir %{_datadir}/zabbix
530%if %{with server}%{with proxy}
531%{_datadir}/zabbix/mysql
532%{_datadir}/zabbix/postgresql
533%endif
534%if %{with systemd}
535%{_prefix}/lib/tmpfiles.d/zabbix.conf
536%endif
537%{_bindir}/zabbix_js
538
539%if %{with server}
540%files server-common
541%defattr(-,root,root,-)
542%dir %{_sysconfdir}/zabbix
543%config(noreplace) %{_sysconfdir}/zabbix/zabbix_server.conf
544%config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_server
545%if !%{with systemd}
546%{_initddir}/zabbix_server*
547%endif
548%{_mandir}/man8/zabbix_server.8*
549
550%files server-mysql
551%defattr(-,root,root,-)
552%{_sbindir}/zabbix_server.mysql
553%if %{with systemd}
554%{_unitdir}/zabbix-server-mysql.service
555%endif
556
557%files server-postgresql
558%defattr(-,root,root,-)
559%{_sbindir}/zabbix_server.pgsql
560%if %{with systemd}
561%{_unitdir}/zabbix-server-pgsql.service
562%endif
563
564%endif
565
566%if %{with agent}
567%files agent
568%defattr(-,root,root,-)
569%dir %{_sysconfdir}/zabbix
570%config(noreplace) %{_sysconfdir}/zabbix/zabbix_agentd.conf
571%config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_agentd
572%{_bindir}/zabbix_get
573%{_bindir}/zabbix_sender
574%{_sbindir}/zabbix_agentd
575%if %{with systemd}
576%{_unitdir}/zabbix-agent.service
577%else
578%{_initddir}/zabbix_agentd
579%endif
580%{_mandir}/man1/zabbix_get.1*
581%{_mandir}/man1/zabbix_sender.1*
582%{_mandir}/man8/zabbix_agentd.8*
583
584%endif
585
586%if %{with proxy}
587%files proxy-common
588%defattr(-,root,root,-)
589%dir %{_sysconfdir}/zabbix
590%config(noreplace) %{_sysconfdir}/zabbix/zabbix_proxy.conf
591%config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_proxy
592%if !%{with systemd}
593%{_initddir}/zabbix_proxy
594%endif
595%{_mandir}/man8/zabbix_proxy.8*
596%{_datadir}/zabbix-proxy
597
598%files proxy-mysql
599%defattr(-,root,root,-)
600%{_sbindir}/zabbix_proxy.mysql
601%if %{with systemd}
602%{_unitdir}/zabbix-proxy-mysql.service
603%endif
604
605%files proxy-postgresql
606%defattr(-,root,root,-)
607%{_sbindir}/zabbix_proxy.pgsql
608%if %{with systemd}
609%{_unitdir}/zabbix-proxy-pgsql.service
610%endif
611
612%endif
613
614%if %{with frontend}
615%files frontend-php
616%defattr(-,root,root,-)
617%license zabbix_mysql/COPYING
618%doc zabbix_mysql/AUTHORS zabbix_mysql/ChangeLog zabbix_mysql/NEWS zabbix_mysql/README
619%dir %{_datadir}/zabbix-frontend
620%{_datadir}/zabbix-frontend/php
621
622%files frontend-php-mysql
623
624%files frontend-php-postgresql
625
626%endif
627
628
629%changelog
630* Thu Jul 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-1
631- new upstream release.
632- dropped all patches: made to get the same effect by another method.
633
634* Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.19-2
635- rebuilt with libevent-2.1.11.
636
637* Mon Apr 06 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.19-1
638- new upstream release.
639- dropped Patch3: fixed in upstream.
640- changed R:php5 to R:php74.
641- added systemd support (disabled as default).
642
643* Thu Dec 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.15-1
644- new upstream release.
645- imported Patch13 from upstream to support php74.
646
647* Thu Oct 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.13-1
648- new upstream release.
649- updated patches.
650
651* Wed May 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
652- new upstream release.
653- switched to 4.0 LTS.
654- dropped Patch0: made to get same effect by another method.
655- updated Patch1 and 2.
656
657* Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.23-1
658- new upstream release.
659
660* Tue Jun 12 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 3.0.13-2
661- accept building only agent
662
663* Thu Dec 21 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.13-1
664- new upstream release.
665
666* Fri Apr 21 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.8-1
667- new upstream release.
668
669* Fri Mar 18 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.1-1
670- new upstream release.
671- disabled jabber support.
672
673* Wed Sep  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-1
674- new upstream release.
675
676* Sat Apr 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.9-1
677- new upstream release.
678
679* Sun Jul  6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.4-1
680- new upstream release.
681- built with both of mysql and postgresql.
682
683* Mon Oct 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
684- update to 2.0.8
685
686* Wed Feb 20 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.5-2
687- use %%bcond_with mysql to build with mysql
688
689* Tue Feb 19 2013 IWAI, Masaharu <iwai@alib.jp> 2.0.5-1
690- update to 2.0.5
691- add using MySQL client library switch: default no
692  - define use_postfix and use_mysql
693  - add BuildRequires: MySQL-devel
694  - add configure option: --with-mysql
695
696* Thu Feb  7 2013 IWAI, Masaharu <iwai@alib.jp> 2.0.4-1
697- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.