source: projects/specs/trunk/z/zabbix/zabbix-vl.spec @ 12517

Revision 12517, 17.7 KB checked in by tomop, 3 years ago (diff)

updated 2 packages

gd-2.3.0-2

zabbix-5.0.6-1

RevLine 
[12366]1%bcond_with systemd
[7440]2
[11716]3%define only_agent 0
4
5%if %{only_agent}
6%bcond_with server
7%bcond_with proxy
8%bcond_with frontend
9%else
10%bcond_without server
11%bcond_without proxy
12%bcond_without frontend
13%endif
14
15%bcond_without agent
16
[12486]17%global php_pkgname php74
18
[7440]19Summary: The Enterprise-class Monitoring Solution for Everyone
20Name: zabbix
[12517]21Version: 5.0.6
[12431]22Release: 1%{?_dist_release}%{?with_systemd:.systemd}
[12486]23Group: system
[12366]24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: iwaim
27
[7440]28License: GPLv2
29URL: https://www.zabbix.com/
[12431]30%global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
31Source0: https://cdn.zabbix.com/zabbix/sources/stable/%{shortver}/%{name}-%{version}.tar.gz
[7440]32Source1: zabbix_server.init
33Source2: zabbix_proxy.init
34Source3: zabbix_agentd.init
35Source4: zabbix_server.logrotate
36Source5: zabbix_proxy.logrotate
37Source6: zabbix_agentd.logrotate
[12366]38
39Source9:        %{name}-tmpfiles-zabbix.conf
40# systemd units -- Alternatives switches between them (they state their dependencies)
41# https://support.zabbix.com/browse/ZBXNEXT-1593
42Source10:       %{name}-agent.service
43Source11:       %{name}-proxy-mysql.service
44Source12:       %{name}-proxy-pgsql.service
45Source14:       %{name}-server-mysql.service
46Source15:       %{name}-server-pgsql.service
47Source17:       %{name}-tmpfiles-zabbixsrv.conf
48
[7440]49BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
[11716]50%if %{with server}%{with proxy}
[8748]51BuildRequires: libpq-devel
[11880]52BuildRequires: libmariadb-devel
[11716]53%endif
[12073]54BuildRequires: libevent-devel
55BuildRequires: pcre-devel
[7440]56BuildRequires: curl-devel
57BuildRequires: net-snmp-devel
58BuildRequires: OpenIPMI-devel
59BuildRequires: unixODBC-devel
60BuildRequires: libssh2-devel
[12431]61BuildRequires: openssl-devel
62
[7440]63Requires(pre): glibc-common
64Requires(pre): shadow-utils
[12366]65%if %{with systemd}
66BuildRequires:   systemd
67%endif
[7440]68
69%description
70The Enterprise-class Monitoring Solution for Everyone.
71
[12431]72
[11716]73%if %{with server}
[8748]74%package server-common
75Summary: common files for Zabbix Server
[12486]76Group: servers
[7440]77Requires: %{name} == %{version}-%{release}
[12366]78%if %{with systemd}
79%{?systemd_requires}
80%else
[7440]81Requires(post,preun): chkconfig
82Requires(preun,postun): initscripts
[12366]83%endif
[7440]84
[8748]85%description server-common
86This package include common files for Zabbix Server.
[7440]87
[12431]88
[8748]89%package server-mysql
90Summary: Zabbix Server for MySQL/MariaDB
[12486]91Group: servers
[8748]92Provides: %{name}-server
93Requires: %{name}-server-common == %{version}-%{release}
94
95%description server-mysql
96Zabbix Server for MySQL/MariaDB
97
[12431]98
[8748]99%package server-postgresql
100Summary: Zabbix Server for PostgreSQL
[12486]101Group: servers
[8748]102Provides: %{name}-server
103Requires: %{name}-server-common == %{version}-%{release}
104
105%description server-postgresql
106Zabbix Server for PostgreSQL
107
[11716]108%endif
109
[12431]110
[11716]111%if %{with agent}
[7440]112%package agent
113Summary: Zabbix Agent
[12486]114Group: system
[7440]115Requires: %{name} == %{version}-%{release}
[12366]116%if %{with systemd}
117%{?systemd_requires}
118%else
[7440]119Requires(post,preun): chkconfig
120Requires(preun,postun): initscripts
[12366]121%endif
[7440]122
123%description agent
124Zabbix Agent
125
[11716]126%endif
127
[12431]128
[11716]129%if %{with proxy}
[8748]130%package proxy-common
131Summary: common files for Zabbix Proxy
[12486]132Group: servers
[7440]133Requires: %{name} == %{version}-%{release}
[12366]134%if %{with systemd}
135%{?systemd_requires}
136%else
[7440]137Requires(post,preun): chkconfig
138Requires(preun,postun): initscripts
[12366]139%endif
[7440]140
[8748]141%description proxy-common
142This package include common files for Zabbix Proxy
[7440]143
[12431]144
[8748]145%package proxy-mysql
146Summary: Zabbix Proxy for MySQL/MariaDB
[12486]147Group: servers
[8748]148Provides: %{name}-proxy
149Requires: %{name}-proxy-common == %{version}-%{release}
150
151%description proxy-mysql
152Zabbix Proxy for MySQL/MariaDB
153
[12431]154
[8748]155%package proxy-postgresql
156Summary: Zabbix Proxy for PostgreSQL
[12486]157Group: servers
[8748]158Provides: %{name}-proxy
159Requires: %{name}-proxy-common == %{version}-%{release}
160
161%description proxy-postgresql
162Zabbix Proxy for PostgreSQL
163
[11716]164%endif
165
[12431]166
[11716]167%if %{with frontend}
[7440]168%package frontend-php
169Summary: Zabbix web frontend with PHP
[12486]170Group: servers
171Requires: %{php_pkgname}
[7440]172Requires: TrueType-vlgothic
173
174%description frontend-php
175Zabbix web frontend with PHP.
176
[12431]177
[8748]178%package frontend-php-mysql
179Summary: Zabbix web frontend with PHP and MySQL/MariaDB
[12486]180Group: servers
[8748]181Provides: %{name}-frontend-php == %{version}-%{release}
[12486]182Requires: %{php_pkgname}-mysql
[8748]183
184%description frontend-php-mysql
185Zabbix web frontend with PHP and MySQL/MariaDB.
186
[12431]187
[8748]188%package frontend-php-postgresql
189Summary: Zabbix web frontend with PHP and PostgreSQL
[12486]190Group: servers
[8748]191Provides: %{name}-frontend-php == %{version}-%{release}
[12486]192Requires: %{php_pkgname}-pgsql
[8748]193
194%description frontend-php-postgresql
195Zabbix web frontend with PHP and PostgreSQL.
196
[11716]197%endif
198
[12431]199
[12486]200%debug_package
201
202
[7440]203%prep
[8748]204%setup -q -T -a 0 -c -n zabbix-%{version}
205mv zabbix-%{version} zabbix_mysql
[7440]206
[11716]207%if %{with server}%{with proxy}
[8748]208%setup -q -D -T -a 0 -n zabbix-%{version}
209mv zabbix-%{version} zabbix_pgsql
[11716]210%endif
[8748]211
[12366]212for v in mysql pgsql; do
213pushd zabbix_$v
[12431]214sed -i -e 's/DejaVuSans/VL-Gothic-Regular/g' ./ui/include/defines.inc.php
215
[12366]216sed -i \
217    -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_agentd.pid' \
218    -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_agentd.log|' \
219    conf/zabbix_agentd.conf
220
221sed -i \
222    -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_proxy.pid' \
223    -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_proxy.log|' \
224    conf/zabbix_proxy.conf
225
226sed -i \
227    -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_server.pid' \
228    -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_server.log|' \
229    conf/zabbix_server.conf
230popd
231done
232
233
[7440]234%build
[8748]235Build()
236{
[12073]237perl -pi -e 's|/usr/bin/traceroute|/bin/traceroute|' \
238    ./database/{ibm_db2,mysql,oracle,postgresql,sqlite3}/data.sql
239
[8748]240%configure \
[11716]241           %{?with_server:--enable-server} \
242           %{?with_proxy:--enable-proxy} \
[12277]243           %{?with_agent:--enable-agent} \
[8748]244           --enable-ipv6 \
[7440]245           --sysconfdir=%{_sysconfdir}/zabbix \
246           --with-libcurl \
247           --with-openipmi \
248           --with-net-snmp \
249           --with-unixodbc \
[8748]250           --with-ssh2 \
[12431]251           --with-openssl \
[8748]252           $@
[7440]253
254%__make
[8748]255}
[7440]256
[11716]257%if %{with server}%{with proxy}
[8748]258pushd zabbix_mysql
[11716]259Build --with-mysql
[8748]260popd
261
262pushd zabbix_pgsql
263Build --with-postgresql
264popd
[11716]265%else
266pushd zabbix_mysql
267Build
268popd
269%endif
[8748]270
[12431]271
[7440]272%install
[12366]273%__rm -rf %{buildroot}
[8748]274pushd zabbix_mysql
[12366]275make DESTDIR=%{buildroot} install
[7440]276
[11716]277%if %{with server}
[8748]278mv -f %{buildroot}%{_sbindir}/zabbix_server %{buildroot}%{_sbindir}/zabbix_server.mysql
[11716]279%endif
280%if %{with proxy}
[8748]281mv -f %{buildroot}%{_sbindir}/zabbix_proxy %{buildroot}%{_sbindir}/zabbix_proxy.mysql
[11716]282%endif
[8748]283
[7440]284# make directories
[12366]285%__mkdir_p %{buildroot}%{_localstatedir}/{log,run}/%{name}
[7440]286
287# DB
[12366]288%__mkdir_p %{buildroot}%{_datadir}/zabbix
[11716]289%if %{with server}%{with proxy}
[12366]290%__cp -a database/postgresql %{buildroot}%{_datadir}/zabbix/
291%__cp -a database/mysql %{buildroot}%{_datadir}/zabbix/
[11716]292%endif
[7440]293
[12366]294%if %{with systemd}
295# unit files
296%__mkdir_p %{buildroot}%{_unitdir}
297# Install different systemd units because of the requirements for DBMS daemons
298install -m 0644 -p %{SOURCE10} %{buildroot}%{_unitdir}/zabbix-agent.service
299install -m 0644 -p %{SOURCE11} %{buildroot}%{_unitdir}/zabbix-proxy-mysql.service
300install -m 0644 -p %{SOURCE12} %{buildroot}%{_unitdir}/zabbix-proxy-pgsql.service
301install -m 0644 -p %{SOURCE14} %{buildroot}%{_unitdir}/zabbix-server-mysql.service
302install -m 0644 -p %{SOURCE15} %{buildroot}%{_unitdir}/zabbix-server-pgsql.service
303
304# systemd tmpfiles
305mkdir -p %{buildroot}%{_prefix}/lib/tmpfiles.d
306install -m 0644 -p %{SOURCE9} %{buildroot}%{_prefix}/lib/tmpfiles.d/zabbix.conf
307
308%else
[7440]309# init.d
[12366]310%__mkdir_p %{buildroot}%{_initddir}
[11716]311%if %{with server}
[12366]312%__cp %{SOURCE1} %{buildroot}%{_initddir}/zabbix_server
[11716]313%endif
314%if %{with proxy}
[12366]315%__cp %{SOURCE2} %{buildroot}%{_initddir}/zabbix_proxy
[11716]316%endif
317%if %{with agent}
[12366]318%__cp %{SOURCE3} %{buildroot}%{_initddir}/zabbix_agentd
[11716]319%endif
[12366]320%endif
[7440]321
322# logrotate
[12366]323%__mkdir_p %{buildroot}%{_sysconfdir}/logrotate.d
[11716]324%if %{with server}
[12366]325%__cp %{SOURCE4}  %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_server
[11716]326%endif
327%if %{with proxy}
[12366]328%__cp %{SOURCE5}  %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_proxy
[11716]329%endif
330%if %{with agent}
[12366]331%__cp %{SOURCE6}  %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_agentd
[11716]332%endif
[7440]333
[11716]334%if %{with frontend}
[7440]335# frontend-php
[12366]336%__mkdir_p %{buildroot}%{_datadir}/zabbix-frontend
[12431]337%__cp -a ui %{buildroot}%{_datadir}/zabbix-frontend/php
[12366]338%__rm -f %{buildroot}%{_datadir}/zabbix-frontend/php/assets/fonts/DejaVuSans.ttf
[7440]339
340ln -s /usr/share/fonts/TrueType-vlgothic/VL-Gothic-Regular.ttf \
[12366]341      %{buildroot}%{_datadir}/zabbix-frontend/php/assets/fonts/
[11716]342%endif
[7440]343
[11716]344%if %{with proxy}
[8748]345# proxy
346mkdir -p %{buildroot}%{_datadir}/zabbix-proxy
347ln -sf ../zabbix/mysql %{buildroot}%{_datadir}/zabbix-proxy/
348ln -sf ../zabbix/postgresql %{buildroot}%{_datadir}/zabbix-proxy/
[11716]349%endif
[8748]350
351popd
352
[11716]353%if %{with server}%{with proxy}
[8748]354pushd zabbix_pgsql
355install -m755 src/zabbix_server/zabbix_server %{buildroot}%{_sbindir}/zabbix_server.pgsql
356install -m755 src/zabbix_proxy/zabbix_proxy %{buildroot}%{_sbindir}/zabbix_proxy.pgsql
357popd
[11716]358%endif
[8748]359
[12431]360
[7440]361%clean
[12366]362%__rm -rf %{buildroot}
[7440]363
[12431]364
[7440]365%pre
366getent group zabbix >/dev/null || groupadd -r zabbix
367getent passwd zabbix >/dev/null || \
368useradd -r -g zabbix -d %{_sysconfdir}/zabbix -s /sbin/nologin \
369-c "Zabbix Monitoring Solution" zabbix
370exit 0
371
[11716]372%if %{with server}
[8748]373%post server-mysql
[12366]374%if %{with systemd}
375%systemd_post zabbix-server-mysql.service
376%else
[8748]377/sbin/update-alternatives --install /usr/sbin/zabbix_server \
378        zabbix_server /usr/sbin/zabbix_server.mysql 10
[12366]379%endif
[8748]380
381%post server-postgresql
[12366]382%if %{with systemd}
383%systemd_post zabbix-server-pgsql.service
384%else
[8748]385/sbin/update-alternatives --install /usr/sbin/zabbix_server \
386        zabbix_server /usr/sbin/zabbix_server.pgsql 10
387/sbin/chkconfig --add zabbix_server
[11716]388%endif
[12366]389%endif
[11716]390
391%if %{with proxy}
[8748]392%post proxy-mysql
[12366]393%if %{with systemd}
394%systemd_post zabbix-proxy-mysql.service
395%else
[8748]396/sbin/update-alternatives --install /usr/sbin/zabbix_proxy \
397        zabbix_proxy /usr/sbin/zabbix_proxy.mysql 10
[7440]398/sbin/chkconfig --add zabbix_proxy
[12366]399%endif
[7440]400
[8748]401%post proxy-postgresql
[12366]402%if %{with systemd}
403%systemd_post zabbix-proxy-pgsql.service
404%else
[8748]405/sbin/update-alternatives --install /usr/sbin/zabbix_proxy \
406        zabbix_proxy /usr/sbin/zabbix_proxy.pgsql 10
407/sbin/chkconfig --add zabbix_proxy
[11716]408%endif
[12366]409%endif
[11716]410
411%if %{with agent}
[7440]412%post agent
[12366]413%if %{with systemd}
414%systemd_post zabbix-agent.service
415%else
[7440]416/sbin/chkconfig --add zabbix_agentd
[12366]417%endif
[7440]418
[11716]419%endif
420
421%if %{with server}
[8748]422%preun server-mysql
[12366]423%if %{with systemd}
424%systemd_preun zabbix-server-mysql.service
425%else
426if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
[7440]427        /sbin/service zabbix_server stop >/dev/null 2>&1
428        /sbin/chkconfig --del zabbix_server
[8748]429        /sbin/update-alternatives --remove zabbix_server \
430                /usr/sbin/zabbix_server.mysql
[7440]431fi
[12366]432%endif
[7440]433
[8748]434%preun server-postgresql
[12366]435%if %{with systemd}
436%systemd_preun zabbix-server-pgysql.service
437%else
438if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
[8748]439        /sbin/service zabbix_server stop >/dev/null 2>&1
440        /sbin/chkconfig --del zabbix_server
441        /sbin/update-alternatives --remove zabbix_server \
442                /usr/sbin/zabbix_server.pgsql
443fi
[11716]444%endif
[12366]445%endif
[11716]446
447%if %{with proxy}
[8748]448%preun proxy-mysql
[12366]449%if %{with systemd}
450%systemd_preun zabbix-proxy-mysql.service
451%else
452if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
[7440]453        /sbin/service zabbix_proxy stop >/dev/null 2>&1
454        /sbin/chkconfig --del zabbix_proxy
[8748]455        /sbin/update-alternatives --remove zabbix_proxy \
456                /usr/sbin/zabbix_proxy.mysql
[7440]457fi
[12366]458%endif
[7440]459
[8748]460%preun proxy-postgresql
[12366]461%if %{with systemd}
462%systemd_preun zabbix-proxy-pgsql.service
463%else
464if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
[8748]465        /sbin/service zabbix_proxy stop >/dev/null 2>&1
466        /sbin/chkconfig --del zabbix_proxy
467        /sbin/update-alternatives --remove zabbix_proxy \
468                /usr/sbin/zabbix_proxy.pgsql
469fi
[11716]470%endif
[12366]471%endif
[11716]472
473%if %{with agent}
[7440]474%preun agent
[12431]475%if %{with systemd}
[12366]476%systemd_preun zabbix-agent.service
477%else
[12374]478if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
[7440]479        /sbin/service zabbix_agentd stop >/dev/null 2>&1
480        /sbin/chkconfig --del zabbix_agentd
481fi
[11716]482%endif
[12366]483%endif
[11716]484
485%if %{with server}
[8748]486%postun server-mysql
[12366]487%if %{with systemd}
488%systemd_postun_with_restart zabbix-server-mysql.service
489%else
[12374]490if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
[7440]491        /sbin/service zabbix_server condrestart >/dev/null 2>&1 || :
492fi
[12366]493%endif
[7440]494
[8748]495%postun server-postgresql
[12366]496%if %{with systemd}
497%systemd_postun_with_restart zabbix-server-pgsql.service
498%else
[12374]499if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
[8748]500        /sbin/service zabbix_server condrestart >/dev/null 2>&1 || :
501fi
[11716]502%endif
[12366]503%endif
[11716]504
505%if %{with proxy}
[8748]506%postun proxy-mysql
[12366]507%if %{with systemd}
508%systemd_postun_with_restart zabbix-proxy-mysql.service
509%else
[12374]510if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
[7440]511        /sbin/service zabbix_proxy condrestart >/dev/null 2>&1 || :
512fi
[12366]513%endif
[7440]514
[8748]515%postun proxy-postgresql
[12366]516%if %{with systemd}
517%systemd_postun_with_restart zabbix-proxy-pgsql.service
518%else
[12374]519if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
[8748]520        /sbin/service zabbix_proxy condrestart >/dev/null 2>&1 || :
521fi
[12366]522%endif
[8748]523
[7440]524%postun agent
[12366]525%if %{with systemd}
526%systemd_postun_with_restart zabbix-agent.service
527%else
[12374]528if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
[7440]529        /sbin/service zabbix_agentd condrestart >/dev/null 2>&1 || :
530fi
[12366]531%endif
[7440]532
[11716]533%endif
534
[12431]535
[7440]536%files
537%defattr(-,root,root,-)
[12073]538%license zabbix_mysql/COPYING
539%doc zabbix_mysql/AUTHORS zabbix_mysql/ChangeLog zabbix_mysql/NEWS zabbix_mysql/README
[7440]540%attr(0755,zabbix,zabbix) %dir %{_localstatedir}/log/%{name}
541%dir %{_datadir}/zabbix
[11716]542%if %{with server}%{with proxy}
[8748]543%{_datadir}/zabbix/mysql
[7440]544%{_datadir}/zabbix/postgresql
[11716]545%endif
[12366]546%if %{with systemd}
547%{_prefix}/lib/tmpfiles.d/zabbix.conf
548%endif
[12431]549%{_bindir}/zabbix_js
[7440]550
[11716]551%if %{with server}
[8748]552%files server-common
[7440]553%defattr(-,root,root,-)
554%dir %{_sysconfdir}/zabbix
555%config(noreplace) %{_sysconfdir}/zabbix/zabbix_server.conf
556%config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_server
[12366]557%if !%{with systemd}
[7440]558%{_initddir}/zabbix_server*
[12366]559%endif
[7440]560%{_mandir}/man8/zabbix_server.8*
561
[8748]562%files server-mysql
563%defattr(-,root,root,-)
564%{_sbindir}/zabbix_server.mysql
[12366]565%if %{with systemd}
566%{_unitdir}/zabbix-server-mysql.service
567%endif
[8748]568
569%files server-postgresql
570%defattr(-,root,root,-)
571%{_sbindir}/zabbix_server.pgsql
[12366]572%if %{with systemd}
573%{_unitdir}/zabbix-server-pgsql.service
574%endif
[8748]575
[11716]576%endif
577
578%if %{with agent}
[7440]579%files agent
580%defattr(-,root,root,-)
581%dir %{_sysconfdir}/zabbix
582%config(noreplace) %{_sysconfdir}/zabbix/zabbix_agentd.conf
583%config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_agentd
584%{_bindir}/zabbix_get
585%{_bindir}/zabbix_sender
586%{_sbindir}/zabbix_agentd
[12366]587%if %{with systemd}
588%{_unitdir}/zabbix-agent.service
589%else
[7440]590%{_initddir}/zabbix_agentd
[12366]591%endif
[7440]592%{_mandir}/man1/zabbix_get.1*
593%{_mandir}/man1/zabbix_sender.1*
594%{_mandir}/man8/zabbix_agentd.8*
595
[11716]596%endif
597
598%if %{with proxy}
[8748]599%files proxy-common
[7440]600%defattr(-,root,root,-)
601%dir %{_sysconfdir}/zabbix
602%config(noreplace) %{_sysconfdir}/zabbix/zabbix_proxy.conf
603%config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_proxy
[12366]604%if !%{with systemd}
[7440]605%{_initddir}/zabbix_proxy
[12366]606%endif
[7440]607%{_mandir}/man8/zabbix_proxy.8*
[8748]608%{_datadir}/zabbix-proxy
[7440]609
[8748]610%files proxy-mysql
611%defattr(-,root,root,-)
612%{_sbindir}/zabbix_proxy.mysql
[12366]613%if %{with systemd}
614%{_unitdir}/zabbix-proxy-mysql.service
615%endif
[8748]616
617%files proxy-postgresql
618%defattr(-,root,root,-)
619%{_sbindir}/zabbix_proxy.pgsql
[12366]620%if %{with systemd}
621%{_unitdir}/zabbix-proxy-pgsql.service
622%endif
[8748]623
[11716]624%endif
625
626%if %{with frontend}
[7440]627%files frontend-php
628%defattr(-,root,root,-)
[12073]629%license zabbix_mysql/COPYING
630%doc zabbix_mysql/AUTHORS zabbix_mysql/ChangeLog zabbix_mysql/NEWS zabbix_mysql/README
[7440]631%dir %{_datadir}/zabbix-frontend
632%{_datadir}/zabbix-frontend/php
633
[8748]634%files frontend-php-mysql
635
636%files frontend-php-postgresql
637
[11716]638%endif
639
[12431]640
[7440]641%changelog
[12517]642* Sun Dec 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.6-1
643- new upstream release.
644
[12486]645* Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.3-1
646- new upstream release.
647
[12431]648* Thu Jul 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-1
649- new upstream release.
650- dropped all patches: made to get the same effect by another method.
651
[12374]652* Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.19-2
653- rebuilt with libevent-2.1.11.
654
[12366]655* Mon Apr 06 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.19-1
656- new upstream release.
657- dropped Patch3: fixed in upstream.
658- changed R:php5 to R:php74.
659- added systemd support (disabled as default).
660
[12317]661* Thu Dec 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.15-1
662- new upstream release.
663- imported Patch13 from upstream to support php74.
664
[12277]665* Thu Oct 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.13-1
666- new upstream release.
667- updated patches.
668
[12073]669* Wed May 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
670- new upstream release.
671- switched to 4.0 LTS.
672- dropped Patch0: made to get same effect by another method.
673- updated Patch1 and 2.
674
[11880]675* Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.23-1
676- new upstream release.
677
[11716]678* Tue Jun 12 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 3.0.13-2
679- accept building only agent
680
[11300]681* Thu Dec 21 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.13-1
682- new upstream release.
683
[11058]684* Fri Apr 21 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.8-1
685- new upstream release.
686
[10091]687* Fri Mar 18 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.1-1
688- new upstream release.
689- disabled jabber support.
690
[9746]691* Wed Sep  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-1
692- new upstream release.
693
[9497]694* Sat Apr 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.9-1
695- new upstream release.
696
[8748]697* Sun Jul  6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.4-1
698- new upstream release.
699- built with both of mysql and postgresql.
700
[7879]701* Mon Oct 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
702- update to 2.0.8
703
704* Wed Feb 20 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.5-2
705- use %%bcond_with mysql to build with mysql
706
[7480]707* Tue Feb 19 2013 IWAI, Masaharu <iwai@alib.jp> 2.0.5-1
708- update to 2.0.5
709- add using MySQL client library switch: default no
710  - define use_postfix and use_mysql
711  - add BuildRequires: MySQL-devel
712  - add configure option: --with-mysql
713
[7440]714* Thu Feb  7 2013 IWAI, Masaharu <iwai@alib.jp> 2.0.4-1
715- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.