source: projects/specs/trunk/y/ypserv/ypserv-vl.spec @ 12100

Revision 12100, 12.5 KB checked in by tomop, 5 years ago (diff)

ypserv-4.1-1

Line 
1##%define initdir /etc/rc.d/init.d
2
3Summary: The NIS (Network Information Service) server.
4Summary(ja): NIS (Network Information Service) サーバ
5Name: ypserv
6Version: 4.1
7Release: 1%{_dist_release}
8License: GPLv2
9Group: System Environment/Daemons
10URL: https://github.com/thkukuk/ypserv
11Source0: https://github.com/thkukuk/ypserv/releases/download/v%{version}/ypserv-%{version}.tar.xz
12Source1: ypserv-ypserv.init
13Source2: ypserv-yppasswdd.init
14Source3: ypserv-ypxfrd.init
15
16Patch0: ypserv-2.5-redhat.patch
17Patch2: ypserv-2.5-nfsnobody2.patch
18Patch3: ypserv-2.13-ypxfr-zeroresp.patch
19Patch4: ypserv-2.13-nonedomain.patch
20Patch5: ypserv-2.19-slp-warning.patch
21Patch6: ypserv-4.0-manfix.patch
22Patch7: ypserv-2.24-aliases.patch
23Patch8: ypserv-2.27-confpost.patch
24Patch10: ypserv-2.31-netgrprecur.patch
25Patch12: ypserv-4.0-headers.patch
26
27Buildroot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: gdbm-devel
29BuildRequires: libxcrypt-devel
30BuildRequires: libnsl2-devel
31BuildRequires: libtirpc-devel
32Requires: gawk portmap tcp_wrappers bash gdbm
33Requires(post): /sbin/chkconfig
34Requires(preun): /sbin/chkconfig /sbin/service
35Requires(postun): /sbin/service
36Obsoletes: yppasswd
37
38Vendor: Project Vine
39Distribution: Vine Linux
40
41%description
42The Network Information Service (NIS) is a system which provides
43network information (login names, passwords, home directories, group
44information) to all of the machines on a network.  NIS can enable
45users to login on any machine on the network, as long as the machine
46has the NIS client programs running and the user's password is
47recorded in the NIS passwd database.  NIS was formerly known as Sun
48Yellow Pages (YP).
49
50This package provides the NIS server, which will need to be running on
51your network.  NIS clients do not need to be running the server.
52
53Install ypserv if you need an NIS server for your network.  You'll
54also need to install the yp-tools and ypbind packages onto any NIS
55client machines.
56
57%description -l ja
58Network Information Service (NIS) とは各種ネットワーク情報
59(ログイン名,パスワード,ホームディレクトリ,グループ情報等) を
60ネットワーク上の全マシンに提供する為のシステムです.
61NIS を使うと,そのユーザのパスワードが NIS データベースに登録されて
62さえいれば,NIS クライアントが動作しているどのマシンからでも
63ログインすることが出来ます.NIS はかつて Sun Yellow Pages (YP) と
64して広く知られていました.
65
66このパッケージは NIS サーバを提供します.NIS サーバは
67NIS サービスを利用する際ネットワーク上に必ず稼働していなければなりません.
68NIS クライアント機上で動作する必要はありません.
69
70ネットワーク上に NIS サーバが必要な場合,この ypserv パッケージを
71インストールして下さい.同時に NIS クライアント機に yp-tools と
72ypbind パッケージをインストールする必要があります.
73
74
75%prep
76%setup -q
77%patch0 -p1 -b .redhat
78%patch2 -p1 -b .nfsnobody
79%patch3 -p1 -b .respzero
80%patch4 -p1 -b .nonedomain
81%patch5 -p1 -b .slp-warning
82%patch6 -p1 -b .manfix
83%patch7 -p1 -b .aliases
84%patch8 -p1 -b .confpost
85%patch10 -p1 -b .netgrprecur
86%patch12  -b .headers
87
88autoreconf -vif
89
90%build
91cp etc/README etc/README.etc
92export CFLAGS="$RPM_OPT_FLAGS -fpic"
93%configure \
94        --enable-checkroot \
95        --enable-fqdn \
96        --enable-yppasswd \
97        --libexecdir=%{_libdir}/yp \
98    --localstatedir=%{_localstatedir}
99
100make %{?_smp_mflags}
101
102%install
103rm -rf $RPM_BUILD_ROOT
104
105make install DESTDIR=%{buildroot}
106
107mkdir -p $RPM_BUILD_ROOT%{_initdir}
108install -m644 etc/ypserv.conf $RPM_BUILD_ROOT%{_sysconfdir}
109install -m755 %{SOURCE1} $RPM_BUILD_ROOT%{_initdir}/ypserv
110install -m755 %{SOURCE2} $RPM_BUILD_ROOT%{_initdir}/yppasswdd
111install -m755 %{SOURCE3} $RPM_BUILD_ROOT%{_initdir}/ypxfrd
112
113mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
114cat > $RPM_BUILD_ROOT/etc/sysconfig/yppasswdd <<EOF
115# The passwd and shadow files are located under the specified
116# directory path. rpc.yppasswdd will use these files, not /etc/passwd
117# and /etc/shadow.
118#ETCDIR=/etc
119
120# This options tells rpc.yppasswdd to use a different source file
121# instead of /etc/passwd
122# You can't mix usage of this with ETCDIR
123#PASSWDFILE=/etc/passwd
124
125# This  options  tells rpc.yppasswdd to use a different source file
126# instead of /etc/passwd.
127# You can't mix usage of this with ETCDIR
128#SHADOWFILE=/etc/shadow
129
130# Additional arguments passed to yppasswd
131YPPASSWDD_ARGS=
132EOF
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%post
138/sbin/chkconfig --add ypserv
139/sbin/chkconfig --add yppasswdd
140/sbin/chkconfig --add ypxfrd
141
142%triggerpostun -- yppasswd
143/sbin/chkconfig --add yppasswdd
144
145%preun
146if [ $1 = 0 ]; then
147        /sbin/service ypserv stop > /dev/null 2>&1
148        /sbin/chkconfig --del ypserv
149        /sbin/service yppasswdd stop > /dev/null 2>&1
150        /sbin/chkconfig --del yppasswdd
151        /sbin/service ypxfrd stop > /dev/null 2>&1
152        /sbin/chkconfig --del ypxfrd
153fi
154
155%postun
156if [ "$1" -ge "1" ]; then
157        /sbin/service ypserv condrestart > /dev/null 2>&1
158        /sbin/service yppasswdd condrestart > /dev/null 2>&1
159        /sbin/service ypxfrd condrestart > /dev/null 2>&1
160fi
161exit 0
162
163 
164%files
165%defattr(-,root,root)
166%license COPYING
167%doc AUTHORS README INSTALL ChangeLog TODO NEWS
168%doc etc/ypserv.conf etc/securenets etc/README.etc
169%doc etc/netgroup etc/locale etc/netmasks etc/timezone
170%config(noreplace) %{_sysconfdir}/ypserv.conf
171%config(noreplace) %{_sysconfdir}/sysconfig/yppasswdd
172%config(noreplace) /var/yp/*
173%dir /var/yp
174%config %{initdir}/*
175%{_libdir}/yp
176%{_sbindir}/*
177%{_mandir}/*/*
178%{_includedir}/*/*
179
180%changelog
181* Mon May 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.1-1
182- new upstream release.
183- dropped all patches.
184- imported patches from rawhide.
185
186* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.19-5
187- rebuild with VineSeed environment
188
189* Sun Dec  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.19-4
190- added Patches from Fedora
191  * Tue Mar  3 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.19-12
192  - Mark apropriate config files as noreplace
193  * Thu Sep 25 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.19-10
194  - Rediff all patches to work with patch --fuzz=0
195  * Wed Feb 13 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.19-9
196  - Mark /var/yp/Makefile as %%config(noreplace)
197    Resolves: #432582
198  - Comment "slp" part of ypserv.conf to avoid ypserv warnings
199    Resolves: #154806
200  - Spec file cleanup - remove period from end of Summary,
201    fix license, remove macros from Changelog
202  * Mon Feb  4 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.19-8
203  - Fix Buildroot
204  - Fix /var/yp/Makefile
205    Resolves: #431008
206  * Tue Jan  8 2008 Steve Dickson <steved@redhat.com> 2.19-7
207  - Changed Makefiles.in so binaries are not stripped.
208  * Sat Sep 15 2007 Steve Dickson <steved@redhat.com> 2.19-6
209  - Fixed init scripts to return correct exit code on
210   'service status' (bz 248097)
211  * Tue Jul 31 2007 Steve Dickson <steved@redhat.com> 2.19-5
212  - Changed install process to create an useful debuginfo package (bz 249961)
213  * Fri Dec 22 2006 Steve Dickson <steved@redhat.com> - 2.19-4
214  - Made ypserver less verbose on common errors (bz #199236)
215  - Don't allow a make for empty domainname's or domainname's set to (none)
216    (bz #197646)
217  * Wed Sep 13 2006 Steve Dickson <steved@redhat.com> - 2.19-3
218  - Added range checks to port values given on command line
219    (bz 205354)
220  * Tue Jul 25 2006 Steve Dickson <steved@redhat.com> - 2.19-2
221  - fixed typo in ypxfrd initscript (bz 185403)
222
223* Mon May  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.19-3
224- spec in UTF-8
225
226* Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.19-2
227- rebuilt without openslp-devel
228
229* Thu Apr 10 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.19-1
230- new upstream release.
231
232* Sun May 21 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.18-0vl2
233- use License instead of Copyright
234
235* Tue Sep  6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.18-0vl1
236- new upstream release.
237
238* Sun Jun 20 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.13-0vl1
239- new upstream release.
240- remove patch2 (no longer needed).
241
242* Fri Apr  9 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.12.1-0vl1
243- new upstream release.
244- replace patch3.
245
246* Mon Dec  8 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.9-0vl1
247- add gdbm[-devel] to 'Requires:' / 'BuildPreReq:'.
248- new upstream release.
249
250* Mon May 19 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.8-1vl1
251- new upstream release.
252
253* Fri Feb  7 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.7-1vl1
254- updated ypserv-2.7
255
256* Fri Dec 13 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.5-1vl3
257- rebuild with new toolchain.
258
259* Tue Oct 22 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.5-1vl2
260- updated ypserv-2.5
261- merge patches from RedHat-8.0.
262- add some files to %%doc.
263
264* Thu Jun 06 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2-10-0vl1
265- updated ypserv-2.2
266- fixed patches
267        -- merged Rawhide's ypserv-2.2-10
268       
269* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
270- 1.3.11-9vl1
271- based on 1.3.11-9 from Rawhide
272- %%{initdir} -> %%{_initdir}
273- added Japanese summary and description
274
275* Wed Aug 16 2000 Than Ngo <than@redhat.com>
276- fix typo in startup script (Bug #15999)
277
278* Wed Jul 19 2000 Than Ngo <than@redhat.de>
279- inits back to rc.d/init.d, using service
280- fix initscript again
281
282* Mon Jul 17 2000 Bill Nottingham <notting@redhat.com>
283- move initscript back
284- fix format syslog bug
285
286* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
287- automatic rebuild
288
289* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
290- prereq /etc/init.d
291
292* Tue Jun 27 2000 Than Ngo <than@redhat.de>
293- /etc/rc.d/init.d -> /etc/init.d
294- fix initscript
295
296* Sun Jun 18 2000 Than Ngo <than@redhat.de>
297- FHS fixes,
298- fix docdir
299
300* Fri May 19 2000 Florian La Roche <Florian.LaRoche@redhat.com>
301- disable "netgrp" target in default all: (/var/yp/Makefile)
302
303* Thu May 18 2000 Florian La Roche <Florian.LaRoche@redhat.com>
304- update to 1.3.11
305
306* Mon Mar 06 2000 Cristian Gafton <gafton@redhat.com>
307- add patch to avoid potential deadlock on the server (fix #9968)
308
309* Wed Feb  2 2000 Florian La Roche <Florian.LaRoche@redhat.com>
310- fix typo in %triggerpostun
311
312* Mon Oct 25 1999 Bill Nottingham <notting@redhat.com>
313- update to 1.3.9
314- use gdbm, move back to /usr/sbin
315
316* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
317- initscript munging
318- ypserv goes on root partition
319
320* Fri Aug 13 1999 Cristian Gafton <gafton@redhat.com>
321- version 1.3.7
322
323* Thu Jul  1 1999 Bill Nottingham <notting@redhat.com>
324- start after network FS
325
326* Tue Jun  1 1999 Jeff Johnson <jbj@redhat.com>
327- update to 1.3.6.94.
328
329* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
330- improved daemonization.
331
332* Sat May 29 1999 Jeff Johnson <jbj@redhat.com>
333- fix buffer overflow in rpc.yppasswd (#3126).
334
335* Fri May 28 1999 Jeff Johnson <jbj@redhat.com>
336- update to 1.3.6.92.
337
338* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
339- version 1.3.6.91
340
341* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
342- auto rebuild in the new build environment (release 4)
343
344* Mon Feb  8 1999 Bill Nottingham <notting@redhat.com>
345- move to start before ypbind
346
347* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
348- build for glibc 2.1
349- upgraded to 1.3.5
350
351* Tue Aug  4 1998 Jeff Johnson <jbj@redhat.com>
352- yppasswd.init: lock file must have same name as init.d script, not daemon
353
354* Sat Jul 11 1998 Cristian Gafton <gafton@redhat.com>
355- upgraded to 1.3.4
356- fixed the fubared Makefile
357- link against gdbm instead of ndbm (it seems to work better)
358
359* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
360- upgraded to 1.3.1
361- enhanced init scripts
362
363* Fri May 01 1998 Jeff Johnson <jbj@redhat.com>
364- added triggerpostun
365- Use libdb fro dbp_*().
366
367* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
368- translations modified for de, fr, tr
369
370* Mon Apr 13 1998 Cristian Gafton <gafton@redhat.com>
371- updated to 1.3.0
372
373* Wed Dec 03 1997 Cristian Gafton <gafton@redhat.com>
374- updated to 1.2.5
375- added buildroot; updated spec file
376- added yppasswdd init file
377
378* Tue Nov 04 1997 Erik Troan <ewt@redhat.com>
379- init script shouldn't set the domain name
380
381* Tue Oct 14 1997 Erik Troan <ewt@redhat.com>
382- supports chkconfig
383- updated initscript for status and restart
384- turned off in all runlevels, by default
385- removed postinstall script which didn't do anything
386
387* Thu Oct 09 1997 Erik Troan <ewt@redhat.com>
388- added patch to build against later glibc
389
390* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
391- built against glibc
392
393* Wed Apr 23 1997 Erik Troan <ewt@redhat.com>
394- updated to 1.1.7.
395
396* Fri Mar 14 1997 Erik Troan <ewt@redhat.com>
397- Updated to ypserv 1.1.5, ported to Alpha (glibc).
398
399* Fri Mar 07 1997 Erik Troan <ewt@redhat.com>
400- Removed -pedantic which confuses the SPARC :-(
Note: See TracBrowser for help on using the repository browser.