source: projects/specs/trunk/y/ypbind/ypbind-vl.spec @ 521

Revision 521, 8.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:     The NIS daemon which binds NIS clients to an NIS domain.
2Summary(ja): NIS クライアントを NIS ドメインにバインドするデーモン
3Name: ypbind
4Version: 1.20.5
5Release: 4%{?_dist_release}
6License: GPLv2
7URL: http://www.linux-nis.org/
8Group: System Environment/Daemons
9Source0: ftp://ftp.kernel.org/pub/linux/utils/net/NIS/ypbind-mt-%{version}.tar.bz2
10Source1: ypbind-vine.init
11Source2: nis.sh
12Source100: ypbind-vine.sysconfig
13Patch1: ypbind-1.11-broadcast.patch
14Patch2: ypbind-1.11-gettextdomain.patch
15Patch3: ypbind-mt-1.19-port-leak.patch
16Patch4: ypbind-mt-1.19-log-binds.patch
17Patch5: ypbind-mt-1.20.4-smartwrite.patch
18Patch6: ypbind-mt-1.20.5-man-port.patch
19Patch7: ypbind-mt-1.20.4-nm.patch
20
21Patch100: ypbind-mt-1.20.5-nm-fix.patch
22
23Epoch: 3
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: dbus-glib-devel
26BuildRequires: NetworkManager-devel >= 0.7.0
27Requires(post): chkconfig
28Requires(preun): chkconfig
29# This is for /sbin/service
30Requires(preun): initscripts
31Requires(postun): initscripts
32Requires: portmap yp-tools bash
33
34%description
35The Network Information Service (NIS) is a system which provides
36network information (login names, passwords, home directories, group
37information) to all of the machines on a network.  NIS can enable
38users to login on any machine on the network, as long as the machine
39has the NIS client programs running and the user's password is
40recorded in the NIS passwd database.  NIS was formerly known as Sun
41Yellow Pages (YP).
42
43This package provides the ypbind daemon.  The ypbind daemon binds NIS
44clients to an NIS domain.  Ypbind must be running on any machines
45which are running NIS client programs.
46
47Install the ypbind package on any machines which are running NIS client
48programs (included in the yp-tools package).  If you need an NIS server,
49you'll also need to install the ypserv package to a machine on your
50network.
51
52%description -l ja
53Network Information Service (NIS) とは各種ネットワーク情報
54(ログイン名,パスワード,ホームディレクトリ,グループ情報等) を
55ネットワーク上の全マシンに提供する為のシステムです.
56NIS を使うと,そのユーザのパスワードが NIS データベースに登録されて
57さえいれば,NIS クライアントが動作しているどのマシンからでも
58ログインすることが出来ます.NIS はかつて Sun Yellow Pages (YP) と
59して広く知られていました.
60
61このパッケージは ypbind デーモンを提供します.ypbind デーモンは
62NIS クライアントを NIS ドメインにバインドします.
63ypbind は,NIS クライアントプログラムが動作している全てのマシン上で
64動作している必要があります.
65
66NIS クライアントプログラム (yp-tools パッケージに含まれます) を
67動作させるマシンには必ず ypbind パッケージをインストールして下さい.
68NIS サーバが必要ならば,ネットワーク上の1台に ypserv パッケージを
69インストールして下さい.
70
71
72%prep
73%setup -q -n ypbind-mt-%{version}
74%patch1 -p1 -b .broadcast
75%patch2 -p1 -b .gettextdomain
76%patch3 -p1
77%patch4 -p1
78%patch5 -p1 -b .smartwrite
79%patch6 -p1 -b .man-port
80%patch7 -p1 -b .nm
81
82%patch100 -p1 -b .nm-fix
83
84
85%build
86#configure --disable-nls --disable-dbus-nm --sbindir=%{_syssbindir}
87%configure --disable-nls --sbindir=%{_syssbindir}
88make
89
90
91%install
92rm -rf $RPM_BUILD_ROOT
93make install DESTDIR=$RPM_BUILD_ROOT
94
95mkdir -p $RPM_BUILD_ROOT%{_initdir} \
96    $RPM_BUILD_ROOT/var/yp/binding \
97    $RPM_BUILD_ROOT/etc/dhcp/dhclient.d \
98    $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
99install -m 644 etc/yp.conf $RPM_BUILD_ROOT%{_sysconfdir}/yp.conf
100install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initdir}/ypbind
101install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/dhcp/dhclient.d/nis.sh
102install -m 644 %{SOURCE100} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ypbind
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107
108%post
109/sbin/chkconfig --add ypbind
110
111
112%preun
113if [ "$1" = 0 ] ; then
114    /sbin/service ypbind stop > /dev/null 2>&1
115    /sbin/chkconfig --del ypbind
116fi
117exit 0
118
119
120%postun
121if [ "$1" -ge 1 ]; then
122    /sbin/service ypbind condrestart > /dev/null 2>&1
123fi
124exit 0
125
126
127%files
128%defattr(-,root,root)
129%{_syssbindir}/ypbind
130%{_mandir}/*/*
131%config %{_initdir}/*
132%{_sysconfdir}/dhcp/dhclient.d/*
133%config(noreplace) %{_sysconfdir}/yp.conf
134%config(noreplace) %{_sysconfdir}/sysconfig/ypbind
135%dir /var/yp
136%dir /var/yp/binding
137%doc AUTHORS COPYING NEWS README THANKS TODO
138
139
140%changelog
141* Sun Dec  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.20.5-4
142- added Source100 for launching ypbind with -no-dbus option
143
144* Mon Oct 19 2009 MATSUBAYSHI Kohji <shaolin@vinelinux.org> - 1.20.5-3
145- add Patch100 to fix build w/ NetworkManager-devel >= 0.7.0
146- add BuildRequires: NetworkManager-devel >= 0.7.0
147
148* Sat Oct 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.5-2
149- removed --disable-dbus-nm
150- added Patch5, 6 and 7
151
152* Mon May 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.5-1
153- updated to 1.20.5
154- added --disable-dbus-nm
155- spec in UTF-8
156
157* Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.4-1
158- new upstream release
159- update ypbind-vine.init
160
161* Sun Jul  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.19.1-0vl3
162- update ypbind-vine.init
163- added Patch4 and 5 from Fedora development
164  * Fri Dec  1 2006 Steve Dickson <steved@redhat.com> - 3:1.19-7
165  - Fixed leaking ports (bz 217874)
166  - Log all server bindings (bz 217782)
167
168* Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.19.1-0vl2
169- use License instead of Copyright
170
171* Tue Sep  6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.19.1-0vl1
172- new upstream release.
173
174* Sun Jun 20 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.17.3-0vl1
175- new upstream release.
176
177* Fri Apr  9 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.17.2-0vl2
178- new upstream release.
179
180* Fri Feb  7 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> ypbind-1.12-0vl3
181- build with new toolchain.
182
183* Fri Dec 13 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> ypbind-1.12-0vl2
184- build with new toolchain.
185
186* Tue Oct 22 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> ypbind-1.12-0vl1
187- updated ypbind-mt-1.12
188- add some files to %%doc.
189- merge patches from RedHat-8.0
190
191* Thu Jun 06 2002 Satoshi MACHINO <machino@vinelinux.org> ypbind-1.10-0vl1
192- updated ypbind-mt-1.10
193- added patches from Rawhide
194- fixed ypbind-vine.init
195        -- changed /etc/rc.d/init.d/functions
196
197* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
198- 1.7-2vl1
199- based on 1.7-2 from Rawhide
200- removed /etc/init.d from PreReq: line
201- use better macros (%%{_syssbindir}, %%{_initdir}, %%{_sysconfdir})
202- added Japanese summary and description
203
204* Wed Nov 29 2000 Bill Nottingham <notting@redhat.com>
205- set NIS domain name if it's not already set
206
207* Mon Oct 02 2000 Florian La Roche <Florian.LaRoche@redhat.de>
208- update to 1.7
209
210* Thu Aug 31 2000 Florian La Roche <Florian.LaRoche@redhat.de>
211- add again automatic fallback to broadcast
212
213* Sun Aug 20 2000 Florian La Roche <Florian.LaRoche@redhat.de>
214- fix condrestart #16615
215- security fix for syslog() call
216
217* Sun Aug  6 2000 Florian La Roche <Florian.LaRoche@redhat.de>
218- do not include broadcast fallback until it is more tested
219
220* Sun Aug  6 2000 Florian La Roche <Florian.LaRoche@redhat.de>
221- add automatic fallback to broadcast
222- add "exit 0" to the scripts
223
224* Wed Aug  2 2000 Bill Nottingham <notting@redhat.com>
225- turn off broadcast; authconfig will enable this...
226- put the pid that's actually listening to signals in the pidfile
227
228* Thu Jul 20 2000 Bill Nottingham <notting@redhat.com>
229- move initscript back
230
231* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
232- automatic rebuild
233
234* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.com>
235- prereq init.d
236
237* Wed Jul  5 2000 Florian La Roche <Florian.LaRoche@redhat.com>
238- re-enable broadcasts
239
240* Tue Jul  4 2000 Florian La Roche <Florian.LaRoche@redhat.com>
241- fix scripts
242
243* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
244- bump epoch
245
246* Mon Jul  3 2000 Florian La Roche <Florian.LaRoche@redhat.com>
247- switch from ypbind to ypbind-mt
Note: See TracBrowser for help on using the repository browser.