source: projects/specs/trunk/y/yelp/yelp-vl.spec @ 521

Revision 521, 10.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define glib2_version 2.20.0
2%define pango_version 1.16.0
3%define gtk2_version 2.16.0
4%define desktop_file_utils_version 0.9
5%define gnome_doc_utils_version 0.18.0
6%define rarian_version 0.7.0
7%define gecko_version 1.9.2
8%define gnome_common_version 2.24.0
9
10Summary: A system documentation reader from the Gnome project.
11Summary(ja): GNOME プロジェクトのシステムドキュメントリーダ
12Name: yelp
13Version: 2.28.1
14Release: 1%{?_dist_release}
15
16URL: http://live.gnome.org/Yelp
17Source0: %{name}-%{version}.tar.bz2
18Source10: man-convert-helper
19# http://bugzilla.gnome.org/show_bug.cgi?id=319096
20Patch1: yelp-2.15.5-fedora-docs.patch
21Patch2: yelp-2.13.2-add-mime-handling.patch
22Patch3: yelp-2.15.91-use-pango.patch
23# http://bugzilla.gnome.org/show_bug.cgi?id=497559
24Patch6: hp.patch
25Patch7: yelp-libxul.patch
26Patch10: yelp-2.26.0-convert-euc-manpages.patch
27
28# https://bugzilla.gnome.org/show_bug.cgi?id=603561
29# http://git.gnome.org/browse/yelp/commit/?id=a5588114ed94d00ca64913aa5b248e09a5e13edc
30Patch11: yelp-2.28.1-xul192.patch
31
32License: GPL
33Group: User Interface/Desktops
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35Requires: gtk2 >= %{gtk2_version}
36Requires: gnome-doc-utils >= %{gnome_doc_utils_version}
37Requires: gecko-libs >= %{gecko_version}
38Requires: nkf
39BuildRequires: glib2-devel >= %{glib2_version}
40BuildRequires: pango-devel >= %{pango_version}
41BuildRequires: gtk2-devel >= %{gtk2_version}
42BuildRequires: GConf2-devel
43BuildRequires: libxml2-devel >= 2.6.5
44BuildRequires: libxslt-devel >= 1.1.4
45BuildRequires: zlib-devel
46BuildRequires: lzma-devel
47BuildRequires: bzip2-devel
48BuildRequires: startup-notification-devel >= 0.8
49BuildRequires: dbus-glib-devel
50BuildRequires: rarian-devel >= %{rarian_version}
51BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
52BuildRequires: gecko-devel >= %{gecko_version}
53BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
54BuildRequires: gnome-common >= %{gnome_common_version}
55
56%description
57Yelp is the Gnome 2 help/documentation browser. It is designed
58to help you browse all the documentation on your system in
59one central tool.
60
61%description -l ja
62Yelp は Gnome 2 のヘルプ/ドキュメントブラウザです。このツール
63によってシステム内の全てのドキュメントを参照できることを目標に
64作られています。
65
66%prep
67%setup -q
68%patch1 -p1 -b .fedora-docs
69%patch2 -p1 -b .add-mime-handling
70%patch3 -p1 -b .use-pango
71%patch6 -p1 -b .hp
72%patch7 -p1 -b .libxul
73%patch10 -p1 -b .convert
74%patch11 -p1 -b .xul192
75
76autoreconf -f -i
77
78%build
79%configure \
80    --with-gecko=libxul-embedding \
81    --with-search=basic \
82    --disable-schemas-install
83make
84
85%install
86rm -rf $RPM_BUILD_ROOT
87export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
88%makeinstall
89unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
90
91desktop-file-install --vendor=gnome --delete-original       \
92  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
93  --add-only-show-in GNOME                                  \
94  $RPM_BUILD_ROOT%{_datadir}/applications/*
95
96mkdir -p -m 755 $RPM_BUILD_ROOT/%{_datadir}/gnome/help
97
98install -m755 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/yelp/
99
100%find_lang %{name}
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%post
106export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
107gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/yelp.schemas > /dev/null
108update-desktop-database %{_datadir}/applications >& /dev/null ||:
109
110touch %{_datadir}/icons/hicolor
111if [ -x /usr/bin/gtk-update-icon-cache ]; then
112  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
113fi
114
115%pre
116if [ "$1" -eq 0 ]; then
117  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
118  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/yelp.schemas >& /dev/null || :
119fi
120
121%preun
122if [ "$1" -eq 0 ]; then
123  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
124  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/yelp.schemas >& /dev/null || :
125fi
126
127%postun
128update-desktop-database %{_datadir}/applications >& /dev/null ||:
129
130%files -f %{name}.lang
131%defattr(-,root,root)
132%{_sysconfdir}/gconf/schemas/yelp.schemas
133%{_bindir}/*
134%{_datadir}/applications/*
135%dir %{_datadir}/gnome/help
136%{_datadir}/icons/hicolor/*
137%{_datadir}/yelp
138
139
140%changelog
141* Mon Mar 01 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-1
142- new upstream release
143- build with xulrunner-1.9.2 (gecko-1.9.2)
144  - BR: gecko-devel instead of gecko-unstable-devel
145  - add patch11 to fix xulrunner-1.9.2 problem
146    - https://bugzilla.gnome.org/show_bug.cgi?id=603561
147    - http://git.gnome.org/browse/yelp/commit/?id=a5588114ed94d00ca64913aa5b248e09a5e13edc
148
149* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
150- new upstream release
151
152* Tue Aug 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
153- convert manpages from euc to utf8
154
155* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
156- rebuild with gecko-1.9.1
157
158* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
159- new upstream release
160- remove BR: libgnomeprintui-devel
161
162* Mon Jun 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1-2
163- use xulrunner-1.9 for gecko libs instead of firefox
164- add Patch7,8,9 to build with xulrunner-1.9
165
166* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
167- new upstream release
168
169* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
170- new upstream release
171- added Patches from Fedora Core
172  * Mon Mar 31 2008 Jon McCann <jmccann@redhat.com> - 2.22.0-4
173  - Disallow launchers when running under GDM.
174  * Thu Mar 13 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2
175  - Add patch for RH bug #437328 (searching with Beagle broken).
176  * Fri Nov 16 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-7
177  - Handle .HP tags in man pages
178  * Wed Sep  6 2006 Matthias Clasen  <mclasen@redhat.com> - 2.16.0-2.fc6
179  - Actually apply the Pango patch
180  * Thu Dec 15 2005 David Malcolm <dmalcolm@redhat.com> - 2.13.2-2
181  - Patched to include DocBook mimetype in desktop file, and added preun and
182    post hooks to update-desktop-database (#175880)
183  - Patched to ensure that Yelp recognizes that it can handle the mimetype of
184    the documentation as reported by gnomevfs (also #175880)
185
186* Sat Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
187- new upstream release
188- added BuildRequires: rarian-devel
189
190* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
191- rebuild with new environment/toolchain
192
193* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
194- new upstream release
195- drop Patch20
196
197* Thu Nov 16 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl3
198- added Patch20 (<BTS:0314>)
199- add BuildRequires: libgnomeprintui-devel
200
201* Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
202- rebuild with firefox-2.0
203
204* Sun Oct 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
205- updated to 2.14.3
206- changed Group to User Interface/Desktops
207
208* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl2
209- add Patch10 to fix corruption of help option message.
210- add Japanese summary and description
211
212* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
213- new upstream release
214
215* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
216- rebuild with firefox-1.5.0.2-0vl4
217
218* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
219- new upstream release
220- build with firefox-1.5.0.2
221
222* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
223- run gtk-update-icon-cache in %%post script.
224
225* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
226- new upstream release
227
228* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.6-0vl1
229- new upstream release
230
231* Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl2
232- rebuild with firefox-1.5.0.1
233
234* Fri Dec 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
235- new upstream release
236- build with firefox-1.5
237
238* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
239- new upstream release
240- build with mozilla-1.7.12
241
242* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
243- new upstream release
244
245* Sat Aug 20 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl4
246- rebuilt with mozilla-1.7.11 (doh! 0vl3 had stupid mistake in the changelog)
247
248* Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
249- rebuild with mozilla-1.7.8
250
251* Mon May 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
252- new upstream release
253
254* Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl4
255- rebuild with mozilla-1.7.7
256
257* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl3
258- add Requires/BuildRequires to gnome-doc-utils
259
260* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl2
261- include yelp.schemas
262- add versioned requires to mozilla
263
264* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl1
265- new upstream version
266- use mozilla's gecko engine, add Requires: mozilla
267
268* Mon Nov 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
269- new upstream release
270
271* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
272- new upstream release
273- rebuild with new toolchains
274
275* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
276- new upstream release
277
278* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
279- new upstream release
280
281* Thu May 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0-0vl1
282- new upstream release
283
284* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
285- new upstream release
286
287* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
288- new upstream release
289- build for Vine Linux
290
291* Mon Nov 18 2002 Tim Powers <timp@redhat.com>
292- rebuild for all arches
293
294* Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com>
295- Remove the strange copyright on the start page. Fixes #69106
296
297* Thu Aug  8 2002 Havoc Pennington <hp@redhat.com>
298- 1.0.2
299- include libexecdir stuff
300
301* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
302- rebuild with new gail
303- 1.0.1
304
305* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
306- automated rebuild
307
308* Tue Jun 18 2002 Havoc Pennington <hp@redhat.com>
309- put all the binaries in the file list... why is this package so hard?
310
311* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
312- put images in file list, this thing will be non-ugly yet
313
314* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
315- 1.0
316- use desktop-file-install to install/munge .desktop files
317- put the sgml stuff in file list
318
319* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
320- rebuild in different environment
321
322* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
323- 0.10
324
325* Sun May 26 2002 Tim Powers <timp@redhat.com>
326- automated rebuild
327
328* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
329- rebuild in different environment
330
331* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
332- 0.8
333
334* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
335- 0.6.1
336
337* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
338- 0.6
339
340* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
341- Rebuild for new gnome2 libraries
342
343* Mon Jan 28 2002 Alex Larsson <alexl@redhat.com>
344- Initial build.
Note: See TracBrowser for help on using the repository browser.