source: projects/specs/trunk/y/yelp/yelp-vl.spec @ 5038

Revision 5038, 11.7 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2.1

Line 
1%define glib2_version 2.30.0
2%define pango_version 1.28.4
3%define gtk3_version 3.2.0
4%define desktop_file_utils_version 0.17
5%define gnome_doc_utils_version 0.20.0
6%define rarian_version 0.7.0
7%define gnome_common_version 2.31.0
8
9Summary: A system documentation reader from the Gnome project.
10Summary(ja): GNOME プロジェクトのシステムドキュメントリーダ
11Name: yelp
12Version: 3.2.1
13Release: 1%{?_dist_release}
14
15URL: http://live.gnome.org/Yelp
16Source0: %{name}-%{version}.tar.xz
17Source10: man-convert-helper
18
19License: GPL
20Group: User Interface/Desktops
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22Requires: gtk3 >= %{gtk3_version}
23Requires: gnome-user-docs
24Requires: nkf
25Requires: yelp-xsl
26BuildRequires: glib2-devel >= %{glib2_version}
27BuildRequires: pango-devel >= %{pango_version}
28BuildRequires: gtk3-devel >= %{gtk3_version}
29BuildRequires: GConf2-devel
30BuildRequires: libxml2-devel >= 2.6.5
31BuildRequires: libxslt-devel >= 1.1.4
32BuildRequires: zlib-devel
33BuildRequires: xz-devel
34BuildRequires: bzip2-devel
35BuildRequires: startup-notification-devel >= 0.8
36BuildRequires: dbus-glib-devel
37BuildRequires: rarian-devel >= %{rarian_version}
38BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
39BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
40BuildRequires: gnome-common >= %{gnome_common_version}
41BuildRequires: yelp-xsl-devel
42BuildRequires: WebKit3-gtk-devel
43BuildRequires: sqlite3-devel
44BuildRequires: libSM-devel
45
46Vendor: Project Vine
47Distribution: Vine Linux
48Packager: Takemikaduchi
49
50%description
51Yelp is the Gnome 2 help/documentation browser. It is designed
52to help you browse all the documentation on your system in
53one central tool.
54
55%description -l ja
56Yelp は Gnome 2 のヘルプ/ドキュメントブラウザです。このツール
57によってシステム内の全てのドキュメントを参照できることを目標に
58作られています。
59
60%package libs
61Summary: Libraries for yelp
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64
65%description libs
66This package contains libraries used by the yelp help browser.
67
68%package devel
69Summary: Development files for yelp-libs
70Group: Development/Libraries
71Requires: %{name}-libs = %{version}-%{release}
72
73%description devel
74This package contains header files and documentation for
75the libraries in the yelp-libs package.
76
77%prep
78%setup -q
79
80# autoreconf -f -i
81
82%build
83%configure \
84        --disable-static
85make
86
87%install
88rm -rf $RPM_BUILD_ROOT
89export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
90make install DESTDIR=$RPM_BUILD_ROOT
91unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
92
93mkdir -p -m 755 $RPM_BUILD_ROOT/%{_datadir}/gnome/help
94
95install -m755 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/yelp/
96
97rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
98
99%find_lang %{name}
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%post
105update-desktop-database %{_datadir}/applications >& /dev/null ||:
106update-mime-database %{_datadir}/mime >& /dev/null ||:
107
108touch %{_datadir}/icons/hicolor
109#if [ -x /usr/bin/gtk-update-icon-cache ]; then
110#  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
111#fi
112
113%postun
114update-desktop-database %{_datadir}/applications >& /dev/null ||:
115update-mime-database %{_datadir}/mime >& /dev/null ||:
116glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
117
118%posttrans
119glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
120
121%files -f %{name}.lang
122%defattr(-,root,root)
123%{_bindir}/*
124%{_datadir}/applications/*
125%{_datadir}/glib-2.0/schemas/org.gnome.yelp.gschema.xml
126%dir %{_datadir}/gnome/help
127%{_datadir}/%{name}
128#%{_datadir}/icons/hicolor/*
129
130%files libs
131%defattr(-,root,root,-)
132%{_libdir}/libyelp.so.*
133
134%files devel
135%defattr(-,root,root,-)
136%{_libdir}/libyelp.so
137%{_includedir}/libyelp
138%{_datadir}/gtk-doc/html/libyelp
139
140
141
142%changelog
143* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
144- new upstream release
145
146* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
147- new upstream release
148
149* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
150- new upstream release
151- add BuildRequires: libSM-devel
152
153* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-1
154- new upstream release
155
156* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.1-1
157- new upstream release
158- create -libs and -devel sub package
159- add BuildRequires: yelp-xsl-devel, WebKit3-gtk-devel, sqlite3-devel
160- remove BuildRequires: xulrunner-devel
161- change BuildRequires: gtk3-devel instead of gtk2-devel
162- change BuildRequires: xz-devel instead of lzma-devel
163- drop old Patches
164
165* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
166- update Patch2: yelp-2.30.2-add-mime-handling.patch
167
168* Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.2-2
169- rebuild with xulrunner-2.0
170- add Patch11 to build with xulrunner-2.0
171
172* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
173- new upstream release
174
175* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
176- new upstream release
177
178* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
179- new upstream release
180- change Requires: gecko-libs -> xulrunner
181- change BuildRequires: gecko-devel -> xulrunner-devel
182- drop Patch11
183
184* Mon Mar 01 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-1
185- new upstream release
186- build with xulrunner-1.9.2 (gecko-1.9.2)
187  - BR: gecko-devel instead of gecko-unstable-devel
188  - add patch11 to fix xulrunner-1.9.2 problem
189    - https://bugzilla.gnome.org/show_bug.cgi?id=603561
190    - http://git.gnome.org/browse/yelp/commit/?id=a5588114ed94d00ca64913aa5b248e09a5e13edc
191
192* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
193- new upstream release
194
195* Tue Aug 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
196- convert manpages from euc to utf8
197
198* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
199- rebuild with gecko-1.9.1
200
201* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
202- new upstream release
203- remove BR: libgnomeprintui-devel
204
205* Mon Jun 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1-2
206- use xulrunner-1.9 for gecko libs instead of firefox
207- add Patch7,8,9 to build with xulrunner-1.9
208
209* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
210- new upstream release
211
212* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
213- new upstream release
214- added Patches from Fedora Core
215  * Mon Mar 31 2008 Jon McCann <jmccann@redhat.com> - 2.22.0-4
216  - Disallow launchers when running under GDM.
217  * Thu Mar 13 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2
218  - Add patch for RH bug #437328 (searching with Beagle broken).
219  * Fri Nov 16 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-7
220  - Handle .HP tags in man pages
221  * Wed Sep  6 2006 Matthias Clasen  <mclasen@redhat.com> - 2.16.0-2.fc6
222  - Actually apply the Pango patch
223  * Thu Dec 15 2005 David Malcolm <dmalcolm@redhat.com> - 2.13.2-2
224  - Patched to include DocBook mimetype in desktop file, and added preun and
225    post hooks to update-desktop-database (#175880)
226  - Patched to ensure that Yelp recognizes that it can handle the mimetype of
227    the documentation as reported by gnomevfs (also #175880)
228
229* Sat Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
230- new upstream release
231- added BuildRequires: rarian-devel
232
233* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
234- rebuild with new environment/toolchain
235
236* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
237- new upstream release
238- drop Patch20
239
240* Thu Nov 16 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl3
241- added Patch20 (<BTS:0314>)
242- add BuildRequires: libgnomeprintui-devel
243
244* Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
245- rebuild with firefox-2.0
246
247* Sun Oct 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
248- updated to 2.14.3
249- changed Group to User Interface/Desktops
250
251* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl2
252- add Patch10 to fix corruption of help option message.
253- add Japanese summary and description
254
255* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
256- new upstream release
257
258* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
259- rebuild with firefox-1.5.0.2-0vl4
260
261* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
262- new upstream release
263- build with firefox-1.5.0.2
264
265* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
266- run gtk-update-icon-cache in %%post script.
267
268* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
269- new upstream release
270
271* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.6-0vl1
272- new upstream release
273
274* Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl2
275- rebuild with firefox-1.5.0.1
276
277* Fri Dec 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
278- new upstream release
279- build with firefox-1.5
280
281* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
282- new upstream release
283- build with mozilla-1.7.12
284
285* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
286- new upstream release
287
288* Sat Aug 20 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl4
289- rebuilt with mozilla-1.7.11 (doh! 0vl3 had stupid mistake in the changelog)
290
291* Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
292- rebuild with mozilla-1.7.8
293
294* Mon May 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
295- new upstream release
296
297* Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl4
298- rebuild with mozilla-1.7.7
299
300* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl3
301- add Requires/BuildRequires to gnome-doc-utils
302
303* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl2
304- include yelp.schemas
305- add versioned requires to mozilla
306
307* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl1
308- new upstream version
309- use mozilla's gecko engine, add Requires: mozilla
310
311* Mon Nov 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
312- new upstream release
313
314* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
315- new upstream release
316- rebuild with new toolchains
317
318* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
319- new upstream release
320
321* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
322- new upstream release
323
324* Thu May 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0-0vl1
325- new upstream release
326
327* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
328- new upstream release
329
330* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
331- new upstream release
332- build for Vine Linux
333
334* Mon Nov 18 2002 Tim Powers <timp@redhat.com>
335- rebuild for all arches
336
337* Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com>
338- Remove the strange copyright on the start page. Fixes #69106
339
340* Thu Aug  8 2002 Havoc Pennington <hp@redhat.com>
341- 1.0.2
342- include libexecdir stuff
343
344* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
345- rebuild with new gail
346- 1.0.1
347
348* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
349- automated rebuild
350
351* Tue Jun 18 2002 Havoc Pennington <hp@redhat.com>
352- put all the binaries in the file list... why is this package so hard?
353
354* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
355- put images in file list, this thing will be non-ugly yet
356
357* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
358- 1.0
359- use desktop-file-install to install/munge .desktop files
360- put the sgml stuff in file list
361
362* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
363- rebuild in different environment
364
365* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
366- 0.10
367
368* Sun May 26 2002 Tim Powers <timp@redhat.com>
369- automated rebuild
370
371* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
372- rebuild in different environment
373
374* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
375- 0.8
376
377* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
378- 0.6.1
379
380* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
381- 0.6
382
383* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
384- Rebuild for new gnome2 libraries
385
386* Mon Jan 28 2002 Alex Larsson <alexl@redhat.com>
387- Initial build.
Note: See TracBrowser for help on using the repository browser.