source: projects/specs/trunk/y/yelp/yelp-vl.spec @ 4812

Revision 4812, 11.5 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.1.92

Line 
1%define glib2_version 2.28.6
2%define pango_version 1.28.4
3%define gtk3_version 3.0.9
4%define desktop_file_utils_version 0.17
5%define gnome_doc_utils_version 0.20.0
6%define rarian_version 0.7.0
7%define gnome_common_version 2.28.0
8
9Summary: A system documentation reader from the Gnome project.
10Summary(ja): GNOME プロジェクトのシステムドキュメントリーダ
11Name: yelp
12Version: 3.1.4
13Release: 1%{?_dist_release}
14
15URL: http://live.gnome.org/Yelp
16Source0: %{name}-%{version}.tar.xz
17Source10: man-convert-helper
18
19License: GPL
20Group: User Interface/Desktops
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22Requires: gtk3 >= %{gtk3_version}
23Requires: gnome-user-docs
24Requires: nkf
25Requires: yelp-xsl
26BuildRequires: glib2-devel >= %{glib2_version}
27BuildRequires: pango-devel >= %{pango_version}
28BuildRequires: gtk3-devel >= %{gtk3_version}
29BuildRequires: GConf2-devel
30BuildRequires: libxml2-devel >= 2.6.5
31BuildRequires: libxslt-devel >= 1.1.4
32BuildRequires: zlib-devel
33BuildRequires: xz-devel
34BuildRequires: bzip2-devel
35BuildRequires: startup-notification-devel >= 0.8
36BuildRequires: dbus-glib-devel
37BuildRequires: rarian-devel >= %{rarian_version}
38BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
39BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
40BuildRequires: gnome-common >= %{gnome_common_version}
41BuildRequires: yelp-xsl-devel
42BuildRequires: WebKit3-gtk-devel
43BuildRequires: sqlite3-devel
44BuildRequires: libSM-devel
45
46Vendor: Project Vine
47Distribution: Vine Linux
48Packager: Takemikaduchi
49
50%description
51Yelp is the Gnome 2 help/documentation browser. It is designed
52to help you browse all the documentation on your system in
53one central tool.
54
55%description -l ja
56Yelp は Gnome 2 のヘルプ/ドキュメントブラウザです。このツール
57によってシステム内の全てのドキュメントを参照できることを目標に
58作られています。
59
60%package libs
61Summary: Libraries for yelp
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64
65%description libs
66This package contains libraries used by the yelp help browser.
67
68%package devel
69Summary: Development files for yelp-libs
70Group: Development/Libraries
71Requires: %{name}-libs = %{version}-%{release}
72
73%description devel
74This package contains header files and documentation for
75the libraries in the yelp-libs package.
76
77%prep
78%setup -q
79
80# autoreconf -f -i
81
82%build
83%configure \
84        --disable-static
85make
86
87%install
88rm -rf $RPM_BUILD_ROOT
89export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
90make install DESTDIR=$RPM_BUILD_ROOT
91unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
92
93mkdir -p -m 755 $RPM_BUILD_ROOT/%{_datadir}/gnome/help
94
95install -m755 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/yelp/
96
97rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
98
99%find_lang %{name}
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%post
105update-desktop-database %{_datadir}/applications >& /dev/null ||:
106update-mime-database %{_datadir}/mime >& /dev/null ||:
107
108touch %{_datadir}/icons/hicolor
109#if [ -x /usr/bin/gtk-update-icon-cache ]; then
110#  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
111#fi
112
113%postun
114update-desktop-database %{_datadir}/applications >& /dev/null ||:
115update-mime-database %{_datadir}/mime >& /dev/null ||:
116glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
117
118%posttrans
119glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
120
121%files -f %{name}.lang
122%defattr(-,root,root)
123%{_bindir}/*
124%{_datadir}/applications/*
125%{_datadir}/glib-2.0/schemas/org.gnome.yelp.gschema.xml
126%dir %{_datadir}/gnome/help
127%{_datadir}/%{name}
128#%{_datadir}/icons/hicolor/*
129
130%files libs
131%defattr(-,root,root,-)
132%{_libdir}/libyelp.so.*
133
134%files devel
135%defattr(-,root,root,-)
136%{_libdir}/libyelp.so
137%{_includedir}/libyelp
138%{_datadir}/gtk-doc/html/libyelp
139
140
141
142%changelog
143* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
144- new upstream release
145- add BuildRequires: libSM-devel
146
147* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-1
148- new upstream release
149
150* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.1-1
151- new upstream release
152- create -libs and -devel sub package
153- add BuildRequires: yelp-xsl-devel, WebKit3-gtk-devel, sqlite3-devel
154- remove BuildRequires: xulrunner-devel
155- change BuildRequires: gtk3-devel instead of gtk2-devel
156- change BuildRequires: xz-devel instead of lzma-devel
157- drop old Patches
158
159* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
160- update Patch2: yelp-2.30.2-add-mime-handling.patch
161
162* Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.2-2
163- rebuild with xulrunner-2.0
164- add Patch11 to build with xulrunner-2.0
165
166* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
167- new upstream release
168
169* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
170- new upstream release
171
172* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
173- new upstream release
174- change Requires: gecko-libs -> xulrunner
175- change BuildRequires: gecko-devel -> xulrunner-devel
176- drop Patch11
177
178* Mon Mar 01 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-1
179- new upstream release
180- build with xulrunner-1.9.2 (gecko-1.9.2)
181  - BR: gecko-devel instead of gecko-unstable-devel
182  - add patch11 to fix xulrunner-1.9.2 problem
183    - https://bugzilla.gnome.org/show_bug.cgi?id=603561
184    - http://git.gnome.org/browse/yelp/commit/?id=a5588114ed94d00ca64913aa5b248e09a5e13edc
185
186* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
187- new upstream release
188
189* Tue Aug 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
190- convert manpages from euc to utf8
191
192* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
193- rebuild with gecko-1.9.1
194
195* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
196- new upstream release
197- remove BR: libgnomeprintui-devel
198
199* Mon Jun 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1-2
200- use xulrunner-1.9 for gecko libs instead of firefox
201- add Patch7,8,9 to build with xulrunner-1.9
202
203* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
204- new upstream release
205
206* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
207- new upstream release
208- added Patches from Fedora Core
209  * Mon Mar 31 2008 Jon McCann <jmccann@redhat.com> - 2.22.0-4
210  - Disallow launchers when running under GDM.
211  * Thu Mar 13 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2
212  - Add patch for RH bug #437328 (searching with Beagle broken).
213  * Fri Nov 16 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-7
214  - Handle .HP tags in man pages
215  * Wed Sep  6 2006 Matthias Clasen  <mclasen@redhat.com> - 2.16.0-2.fc6
216  - Actually apply the Pango patch
217  * Thu Dec 15 2005 David Malcolm <dmalcolm@redhat.com> - 2.13.2-2
218  - Patched to include DocBook mimetype in desktop file, and added preun and
219    post hooks to update-desktop-database (#175880)
220  - Patched to ensure that Yelp recognizes that it can handle the mimetype of
221    the documentation as reported by gnomevfs (also #175880)
222
223* Sat Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
224- new upstream release
225- added BuildRequires: rarian-devel
226
227* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
228- rebuild with new environment/toolchain
229
230* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
231- new upstream release
232- drop Patch20
233
234* Thu Nov 16 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl3
235- added Patch20 (<BTS:0314>)
236- add BuildRequires: libgnomeprintui-devel
237
238* Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
239- rebuild with firefox-2.0
240
241* Sun Oct 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
242- updated to 2.14.3
243- changed Group to User Interface/Desktops
244
245* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl2
246- add Patch10 to fix corruption of help option message.
247- add Japanese summary and description
248
249* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
250- new upstream release
251
252* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
253- rebuild with firefox-1.5.0.2-0vl4
254
255* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
256- new upstream release
257- build with firefox-1.5.0.2
258
259* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
260- run gtk-update-icon-cache in %%post script.
261
262* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
263- new upstream release
264
265* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.6-0vl1
266- new upstream release
267
268* Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl2
269- rebuild with firefox-1.5.0.1
270
271* Fri Dec 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
272- new upstream release
273- build with firefox-1.5
274
275* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
276- new upstream release
277- build with mozilla-1.7.12
278
279* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
280- new upstream release
281
282* Sat Aug 20 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl4
283- rebuilt with mozilla-1.7.11 (doh! 0vl3 had stupid mistake in the changelog)
284
285* Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
286- rebuild with mozilla-1.7.8
287
288* Mon May 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
289- new upstream release
290
291* Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl4
292- rebuild with mozilla-1.7.7
293
294* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl3
295- add Requires/BuildRequires to gnome-doc-utils
296
297* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl2
298- include yelp.schemas
299- add versioned requires to mozilla
300
301* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl1
302- new upstream version
303- use mozilla's gecko engine, add Requires: mozilla
304
305* Mon Nov 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
306- new upstream release
307
308* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
309- new upstream release
310- rebuild with new toolchains
311
312* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
313- new upstream release
314
315* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
316- new upstream release
317
318* Thu May 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0-0vl1
319- new upstream release
320
321* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
322- new upstream release
323
324* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
325- new upstream release
326- build for Vine Linux
327
328* Mon Nov 18 2002 Tim Powers <timp@redhat.com>
329- rebuild for all arches
330
331* Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com>
332- Remove the strange copyright on the start page. Fixes #69106
333
334* Thu Aug  8 2002 Havoc Pennington <hp@redhat.com>
335- 1.0.2
336- include libexecdir stuff
337
338* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
339- rebuild with new gail
340- 1.0.1
341
342* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
343- automated rebuild
344
345* Tue Jun 18 2002 Havoc Pennington <hp@redhat.com>
346- put all the binaries in the file list... why is this package so hard?
347
348* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
349- put images in file list, this thing will be non-ugly yet
350
351* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
352- 1.0
353- use desktop-file-install to install/munge .desktop files
354- put the sgml stuff in file list
355
356* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
357- rebuild in different environment
358
359* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
360- 0.10
361
362* Sun May 26 2002 Tim Powers <timp@redhat.com>
363- automated rebuild
364
365* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
366- rebuild in different environment
367
368* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
369- 0.8
370
371* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
372- 0.6.1
373
374* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
375- 0.6
376
377* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
378- Rebuild for new gnome2 libraries
379
380* Mon Jan 28 2002 Alex Larsson <alexl@redhat.com>
381- Initial build.
Note: See TracBrowser for help on using the repository browser.