source: projects/specs/trunk/y/yelp/yelp-vl.spec @ 3237

Revision 3237, 11.2 KB checked in by daisuke, 13 years ago (diff)

yelp: rebuild with xul-2.0

Line 
1%define glib2_version 2.26.0
2%define pango_version 1.28.3
3%define gtk2_version 2.22.0
4%define desktop_file_utils_version 0.17
5%define gnome_doc_utils_version 0.20.0
6%define rarian_version 0.7.0
7%define xulrunner_version 2.0
8%define gnome_common_version 2.28.0
9
10Summary: A system documentation reader from the Gnome project.
11Summary(ja): GNOME プロジェクトのシステムドキュメントリーダ
12Name: yelp
13Version: 2.30.2
14Release: 2%{?_dist_release}
15
16URL: http://live.gnome.org/Yelp
17Source0: %{name}-%{version}.tar.bz2
18Source10: man-convert-helper
19# http://bugzilla.gnome.org/show_bug.cgi?id=319096
20Patch1: yelp-2.15.5-fedora-docs.patch
21Patch2: yelp-2.13.2-add-mime-handling.patch
22Patch3: yelp-2.15.91-use-pango.patch
23# http://bugzilla.gnome.org/show_bug.cgi?id=497559
24Patch6: hp.patch
25Patch7: yelp-libxul.patch
26Patch10: yelp-2.26.0-convert-euc-manpages.patch
27
28Patch11: yelp-2.30.2-xul20.patch
29
30License: GPL
31Group: User Interface/Desktops
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33Requires: gtk2 >= %{gtk2_version}
34Requires: gnome-doc-utils >= %{gnome_doc_utils_version}
35Requires: xulrunner >= %{xulrunner_version}
36Requires: nkf
37BuildRequires: glib2-devel >= %{glib2_version}
38BuildRequires: pango-devel >= %{pango_version}
39BuildRequires: gtk2-devel >= %{gtk2_version}
40BuildRequires: GConf2-devel
41BuildRequires: libxml2-devel >= 2.6.5
42BuildRequires: libxslt-devel >= 1.1.4
43BuildRequires: zlib-devel
44BuildRequires: lzma-devel
45BuildRequires: bzip2-devel
46BuildRequires: startup-notification-devel >= 0.8
47BuildRequires: dbus-glib-devel
48BuildRequires: rarian-devel >= %{rarian_version}
49BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
50BuildRequires: xulrunner-devel >= %{xulrunner_version}
51BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
52BuildRequires: gnome-common >= %{gnome_common_version}
53
54%description
55Yelp is the Gnome 2 help/documentation browser. It is designed
56to help you browse all the documentation on your system in
57one central tool.
58
59%description -l ja
60Yelp は Gnome 2 のヘルプ/ドキュメントブラウザです。このツール
61によってシステム内の全てのドキュメントを参照できることを目標に
62作られています。
63
64%prep
65%setup -q
66%patch1 -p1 -b .fedora-docs
67%patch2 -p1 -b .add-mime-handling
68%patch3 -p1 -b .use-pango
69%patch6 -p1 -b .hp
70%patch7 -p1 -b .libxul
71%patch10 -p1 -b .convert
72%patch11 -p1 -b .xul20
73
74autoreconf -f -i
75
76%build
77%configure \
78    --with-gecko=libxul-embedding \
79    --with-search=basic \
80    --disable-schemas-install
81make
82
83%install
84rm -rf $RPM_BUILD_ROOT
85export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
86%makeinstall
87unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
88
89desktop-file-install --vendor=gnome --delete-original       \
90  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
91  --add-only-show-in GNOME                                  \
92  $RPM_BUILD_ROOT%{_datadir}/applications/*
93
94mkdir -p -m 755 $RPM_BUILD_ROOT/%{_datadir}/gnome/help
95
96install -m755 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/yelp/
97
98%find_lang %{name}
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%post
104export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
105gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/yelp.schemas > /dev/null
106update-desktop-database %{_datadir}/applications >& /dev/null ||:
107
108touch %{_datadir}/icons/hicolor
109if [ -x /usr/bin/gtk-update-icon-cache ]; then
110  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
111fi
112
113%pre
114if [ "$1" -eq 0 ]; then
115  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
116  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/yelp.schemas >& /dev/null || :
117fi
118
119%preun
120if [ "$1" -eq 0 ]; then
121  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
122  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/yelp.schemas >& /dev/null || :
123fi
124
125%postun
126update-desktop-database %{_datadir}/applications >& /dev/null ||:
127
128%files -f %{name}.lang
129%defattr(-,root,root)
130%{_sysconfdir}/gconf/schemas/yelp.schemas
131%{_bindir}/*
132%{_datadir}/applications/*
133%dir %{_datadir}/gnome/help
134%{_datadir}/icons/hicolor/*
135%{_datadir}/yelp
136
137
138%changelog
139* Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.2-2
140- rebuild with xulrunner-2.0
141- add Patch11 to build with xulrunner-2.0
142
143* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
144- new upstream release
145
146* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
147- new upstream release
148
149* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
150- new upstream release
151- change Requires: gecko-libs -> xulrunner
152- change BuildRequires: gecko-devel -> xulrunner-devel
153- drop Patch11
154
155* Mon Mar 01 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-1
156- new upstream release
157- build with xulrunner-1.9.2 (gecko-1.9.2)
158  - BR: gecko-devel instead of gecko-unstable-devel
159  - add patch11 to fix xulrunner-1.9.2 problem
160    - https://bugzilla.gnome.org/show_bug.cgi?id=603561
161    - http://git.gnome.org/browse/yelp/commit/?id=a5588114ed94d00ca64913aa5b248e09a5e13edc
162
163* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
164- new upstream release
165
166* Tue Aug 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
167- convert manpages from euc to utf8
168
169* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
170- rebuild with gecko-1.9.1
171
172* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
173- new upstream release
174- remove BR: libgnomeprintui-devel
175
176* Mon Jun 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1-2
177- use xulrunner-1.9 for gecko libs instead of firefox
178- add Patch7,8,9 to build with xulrunner-1.9
179
180* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
181- new upstream release
182
183* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
184- new upstream release
185- added Patches from Fedora Core
186  * Mon Mar 31 2008 Jon McCann <jmccann@redhat.com> - 2.22.0-4
187  - Disallow launchers when running under GDM.
188  * Thu Mar 13 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2
189  - Add patch for RH bug #437328 (searching with Beagle broken).
190  * Fri Nov 16 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-7
191  - Handle .HP tags in man pages
192  * Wed Sep  6 2006 Matthias Clasen  <mclasen@redhat.com> - 2.16.0-2.fc6
193  - Actually apply the Pango patch
194  * Thu Dec 15 2005 David Malcolm <dmalcolm@redhat.com> - 2.13.2-2
195  - Patched to include DocBook mimetype in desktop file, and added preun and
196    post hooks to update-desktop-database (#175880)
197  - Patched to ensure that Yelp recognizes that it can handle the mimetype of
198    the documentation as reported by gnomevfs (also #175880)
199
200* Sat Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
201- new upstream release
202- added BuildRequires: rarian-devel
203
204* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
205- rebuild with new environment/toolchain
206
207* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
208- new upstream release
209- drop Patch20
210
211* Thu Nov 16 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl3
212- added Patch20 (<BTS:0314>)
213- add BuildRequires: libgnomeprintui-devel
214
215* Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
216- rebuild with firefox-2.0
217
218* Sun Oct 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
219- updated to 2.14.3
220- changed Group to User Interface/Desktops
221
222* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl2
223- add Patch10 to fix corruption of help option message.
224- add Japanese summary and description
225
226* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
227- new upstream release
228
229* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
230- rebuild with firefox-1.5.0.2-0vl4
231
232* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
233- new upstream release
234- build with firefox-1.5.0.2
235
236* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
237- run gtk-update-icon-cache in %%post script.
238
239* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
240- new upstream release
241
242* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.6-0vl1
243- new upstream release
244
245* Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl2
246- rebuild with firefox-1.5.0.1
247
248* Fri Dec 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
249- new upstream release
250- build with firefox-1.5
251
252* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
253- new upstream release
254- build with mozilla-1.7.12
255
256* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
257- new upstream release
258
259* Sat Aug 20 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl4
260- rebuilt with mozilla-1.7.11 (doh! 0vl3 had stupid mistake in the changelog)
261
262* Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
263- rebuild with mozilla-1.7.8
264
265* Mon May 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
266- new upstream release
267
268* Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl4
269- rebuild with mozilla-1.7.7
270
271* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl3
272- add Requires/BuildRequires to gnome-doc-utils
273
274* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl2
275- include yelp.schemas
276- add versioned requires to mozilla
277
278* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl1
279- new upstream version
280- use mozilla's gecko engine, add Requires: mozilla
281
282* Mon Nov 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
283- new upstream release
284
285* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
286- new upstream release
287- rebuild with new toolchains
288
289* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
290- new upstream release
291
292* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
293- new upstream release
294
295* Thu May 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0-0vl1
296- new upstream release
297
298* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
299- new upstream release
300
301* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
302- new upstream release
303- build for Vine Linux
304
305* Mon Nov 18 2002 Tim Powers <timp@redhat.com>
306- rebuild for all arches
307
308* Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com>
309- Remove the strange copyright on the start page. Fixes #69106
310
311* Thu Aug  8 2002 Havoc Pennington <hp@redhat.com>
312- 1.0.2
313- include libexecdir stuff
314
315* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
316- rebuild with new gail
317- 1.0.1
318
319* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
320- automated rebuild
321
322* Tue Jun 18 2002 Havoc Pennington <hp@redhat.com>
323- put all the binaries in the file list... why is this package so hard?
324
325* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
326- put images in file list, this thing will be non-ugly yet
327
328* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
329- 1.0
330- use desktop-file-install to install/munge .desktop files
331- put the sgml stuff in file list
332
333* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
334- rebuild in different environment
335
336* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
337- 0.10
338
339* Sun May 26 2002 Tim Powers <timp@redhat.com>
340- automated rebuild
341
342* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
343- rebuild in different environment
344
345* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
346- 0.8
347
348* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
349- 0.6.1
350
351* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
352- 0.6
353
354* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
355- Rebuild for new gnome2 libraries
356
357* Mon Jan 28 2002 Alex Larsson <alexl@redhat.com>
358- Initial build.
Note: See TracBrowser for help on using the repository browser.