source: projects/specs/trunk/y/yatex/yatex-vl.spec @ 7675

Revision 7675, 10.5 KB checked in by munepi, 11 years ago (diff)

new upstream release

Line 
1%define _noVersionedDependencies        1
2#% define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4Name:          yatex
5Version:       1.77
6Release:       1%{?_dist_release}
7License:       Distributable
8Source0:       http://www.yatex.org/yatex%{version}.tar.gz
9#Source0:       http://www.gentei.org/~yuuji/tmp/yatex11205111805.tar.gz
10Source1:       %{name}-install.sh
11Source2:       %{name}-remove.sh
12Source3:       %{name}-init.el
13Source4:       vine-default-%{name}.el
14Source5:       vine-default-yahtml.el
15
16## Vine Patch(es)
17Patch1:        yatexhlp-emacs.diff
18Patch2:        yatex-make.diff
19# based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
20# and modified to suit 1.70 release
21Patch3:        yahtml-1.70-timestamp.patch
22
23Patch10:       yatex-1.77-vine-vl7.patch
24Patch11:       yatex-1.77-vine-vl6.patch
25
26URL:           http://www.yatex.org/
27Group:         Applications/Editors/Emacs
28BuildRoot:     %{_tmppath}/%{name}-%{version}-root
29Summary:       YaTeX - Yet Another TeX mode for Emacs
30Summary(ja):   野鳥(YaTeX) - Yet Another TeX mode for Emacs
31BuildArch:     noarch
32
33Requires(post): emacsen
34Requires(post): emacsen-common
35Requires(post): make
36BuildRequires: emacsen-common
37BuildRequires: nkf perl
38Obsoletes:     yatex-xemacs
39
40Distribution:  Vine Linux
41Vendor:        Project Vine
42Packager:      munepi
43
44%description
45YaTeX is an intelligent, acquisitive and integrated package which reduces
46your efforts of composing LaTeX source on GNU Emacs.
47
48
49If you are YaTeX user and you install both yatex and auctex on your system,
50you may add the following configure in your emacs init file
51~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
52
53;; I am a YaTeX user!!!
54(setq vine-default-auctex nil
55      vine-default-preview-latex nil)
56
57
58%description -l ja
59YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
60してくれる、LaTeX 入力支援環境です。
61
62
63yatex と auctex パッケージの両方をインストールする場合、
64~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
65に以下の設定を追加するとよいでしょう。
66
67;; YaTeX ユーザです!!!
68(setq vine-default-auctex nil
69      vine-default-preview-latex nil)
70
71
72%prep
73%setup -n yatex%{version}
74%patch1 -p1
75%patch2 -p1
76%patch3 -p1
77
78%if %{?_dist_release} == "vl7"
79%patch10 -p1 -b .vine
80%endif
81%if %{?_dist_release} == "vl6"
82%patch11 -p1 -b .vine
83%endif
84
85(cd docs
86    # change permissions
87    chmod 644 *
88
89    # encode as utf-8 (LF)
90    # NOTE: This changes needs to entry info files to Info DIR
91    for i in yatexj yatexe yahtmlj yahtmle; do nkf --unix -w --overwrite $i; done
92)
93
94
95%build
96
97
98%install
99
100[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
101
102%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
103%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
104%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
105%__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
106
107
108#
109# install el files
110#
111
112%__cp -a *.el makefile help \
113      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
114%__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
115      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
116
117#
118# install info files
119#
120
121%__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
122   ${RPM_BUILD_ROOT}%{_infodir}
123
124
125#
126# install script (bytecompile el and install elc, remove)
127#
128
129%_installemacsenscript %{name} %{SOURCE1}
130
131%_removeemacsenscript  %{name} %{SOURCE2}
132
133
134%clean
135[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
136
137
138%post
139#
140# bytecompile and install
141#
142
143if [ "$1" = 2 ] ; then
144
145%_emacsenPackageRemove %{name}
146
147fi
148
149%_addemacsenlist %{name}
150
151%_emacsenPackageInstall %{name}
152
153for i in yatexe yatexj yahtmle yahtmlj; do
154    /sbin/install-info --dir-file %{_infodir}/dir --section="Emacs" \
155                       %{_infodir}/${i}.gz
156done
157
158
159%preun
160
161if [ "$1" = 0 ]; then
162
163%_emacsenPackageRemove %{name}
164
165%_removeemacsenlist %{name}
166
167for i in yatexe yatexj yahtmle yahtmlj; do
168    /sbin/install-info --delete --dir-file %{_infodir}/dir --section="Emacs" \
169                       %{_infodir}/${i}.gz
170done
171
172fi
173
174
175%files
176%defattr(-,root,root)
177%doc 00readme install manifest yatex.new
178%doc docs
179
180%{_datadir}/emacs/site-lisp/yatex/
181%{_infodir}/yahtmle*
182%{_infodir}/yahtmlj*
183%{_infodir}/yatexe*
184%{_infodir}/yatexj*
185%{emacsen_pkgdir}/install/%{name}
186%{emacsen_pkgdir}/remove/%{name}
187
188
189%changelog
190* Mon May 13 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.77-1
191- new upstream release
192- applied yatex-1.77-vine-vl{6,7}.patch instead
193
194* Tue May 22 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-2
195- new upstream release
196- updated yatex-1.76-vine-vl{6,7}.patch
197
198* Sat May 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-1.20120511
199- source snapshot 20120511: testing version 1.76 development
200- dropped obsoleted/upstreamed patches
201- applied yatex-1.76-vine-vl{6,7}.patch
202
203* Fri May 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-3
204- added BuildRequires: nkf perl
205- updated yatex-1.74-vine.patch as yatex-1.75-vine-vl{6,7}.patch
206- dropped pre-formatted info files
207- use original info files
208  - encode info files as utf-8
209  - add INFO-DIR-ENTRY
210
211* Thu May 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-2
212- fixed vine-default-yatex.el
213- applied yatex-1.74-vine.patch for vl6
214- updated yatex-1.74-vine.patch: support some extensions for \includegraphics
215
216* Thu Feb  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-1
217- new upstream release
218- updated vine-default-yatex.el
219
220* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-9
221- support TeX Live 2011
222- applied yatex-1.74-vine-vl7.patch
223- updated vine-default-yatex.el
224
225* Thu Aug 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-8
226- added Requires(post): make
227
228* Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-7
229- updated vine-default-yatex.el
230  - check 'YaTeX-inhibit-prefix-letter
231  - used "pbibtex -kanji=utf8" as default bibtex-command
232  - used "mendex -U" as default makeindex-command
233
234* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-6
235- updated vine-default-{yatex,yahtml}.el
236  - revived auto-fill-mode on {yatex,yahtml}-mode
237
238* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-5
239- updated yatex-init.el
240  - dropped all pathes of auctex and preview-latex from load-path
241
242* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
243- updated vine-default-yatex.el
244  - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
245  - supported TeX Live
246    - used "eplatex", "pxdvi", "pdvips" as default commands
247- updated yatex-init.el
248  - output "Loading vine-default-yatex ..." to the buffer *Messages*
249  - defined vine-default-yahtml
250- added vine-default-yahtml.el
251
252* Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
253- updated vine-default-yatex.el
254  - added bbl extension in auto-mode-alist to run yatex-mode
255
256* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
257- updated vine-default-yatex.el
258  - supported new vine-default
259
260* Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
261- new upstream release
262
263* Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
264- updated vine-default-yatex.el
265  - dropped (setq YaTeX-no-begend-shortcut t)
266- use %{emacsen_pkgdir}
267
268* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
269- updated vine-default-yatex.el
270  - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
271
272* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
273- updated yatex-install.sh
274  - *-init.el: changed from hard copy to symbolic link
275    on /etc/emacs-XX.YY/site-start.d
276
277* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
278- fixed yatex-init.el
279
280* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
281- added yatex-init.el, vine-default-yatex.el
282- updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
283
284* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
285- spec in utf8
286
287* Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
288- applied new versioning policy
289
290* Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
291- new upstream release
292
293* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
294- s/Copyright/License/
295- changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
296
297* Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
298- update yatex-1.72
299
300* Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
301- update yatex-1.71
302
303* Wed Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
304- added Patch3 to add hhmts timestamp feature
305
306* Mon May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
307- update yatex-1.70
308
309* Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
310- update yatex10203151806
311
312* Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
313- fixed: bytecompile yatex19
314
315* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
316- now emacsen-common aware
317- FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
318
319* Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
320- 1.68-0vl2
321- no kanji code conversion of documents
322
323* Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
324- 1.68-0vl1
325- update to 1.68
326
327* Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
328- 1.67-6vl5
329- YATEXHLP.{jp,eng} moved to appropriate dir
330
331* Fri Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
332- 1.67-6vl3
333- rebuilt for emacs-20.7
334
335* Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
336- 1.67-6vl2
337- oops ... fixed target dir for help files
338
339* Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
340- 1.67-6vl1
341- rebuilt for emacs-20.6
342
343* Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
344- 1.67-6
345- included forgotten info file for YaHTML
346
347* Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
348- 1.67-5
349- updated for emacs-20.5a release
350
351* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
352- 1.67-4
353- change Group to Applications/Editors/EmacsLisp
354
355* Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
356- 1.67-3
357- %post and %preun section modified
358
359* Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
360- 1.67-2
361- fixed minor problem in the %files section
362
363* Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
364- 1.67-1
365- updated to 1.67 release
366- rebuilt for emacs-20.4 on Vine Linux 1.9
367- updated URL for the new web site of YaTeX
368- some typo fix
369
370* Tue May  4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
371- Initial Release
Note: See TracBrowser for help on using the repository browser.