source: projects/specs/trunk/y/yatex/yatex-vl.spec @ 2599

Revision 2599, 8.1 KB checked in by munepi, 13 years ago (diff)

updated emacs, emacs24, yatex, howm

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4Name:          yatex
5Version:       1.74
6Release:       4%{?_dist_release}
7License:       Distributable
8Source0:       http://www.yatex.org/yatex%{version}.tar.gz
9#Source0:       http://www.yatex.org/yatex10203151806.tar.gz
10Source1:       %{name}-install.sh
11Source2:       %{name}-remove.sh
12Source3:       %{name}-init.el
13Source4:       vine-default-%{name}.el
14Source5:       vine-default-yahtml.el
15
16## pre-formatted info files here
17Source10:      yatexe
18Source11:      yatexj
19Source12:      yahtmle
20Source13:      yahtmlj
21
22## Vine Patch(es)
23Patch0:        yatex-info.diff
24Patch1:        yatexhlp-emacs.diff
25Patch2:        yatex-make.diff
26# based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
27# and modified to suit 1.70 release
28Patch3:        yahtml-1.70-timestamp.patch
29
30URL:           http://www.yatex.org/
31Group:         Applications/Editors/Emacs
32BuildRoot:     %{_tmppath}/%{name}-%{version}-root
33Summary:       YaTeX - Yet Another TeX mode for Emacs
34Summary(ja):   野鳥(YaTeX) - Yet Another TeX mode for Emacs
35BuildArch:     noarch
36
37PreReq:        emacsen
38%prereq_ge     emacsen-common
39BuildRequires: emacsen-common
40Obsoletes:     yatex-xemacs
41
42Distribution:  Vine Linux
43Vendor:        Project Vine
44
45
46%description
47YaTeX is an intelligent, acquisitive and integrated package which reduces
48your efforts of composing LaTeX source on GNU Emacs.
49
50%description -l ja
51YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
52してくれる、LaTeX 入力支援環境です。
53
54
55%prep
56%setup -n yatex%{version}
57%patch0 -p1
58%patch1 -p1
59%patch2 -p1
60%patch3 -p1
61
62
63%build
64
65(cd docs
66    chmod 644 *
67    %__install -v -m 644 %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} .
68)
69
70
71%install
72
73[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
74
75%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
76%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
77%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
78%__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
79
80
81#
82# install el files
83#
84
85%__cp -a *.el makefile help \
86      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
87%__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
88      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
89
90#
91# install info files
92#
93
94%__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
95   ${RPM_BUILD_ROOT}%{_infodir}
96
97
98#
99# install script (bytecompile el and install elc, remove)
100#
101
102%_installemacsenscript %{name} %{SOURCE1}
103
104%_removeemacsenscript  %{name} %{SOURCE2}
105
106
107%clean
108[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
109
110
111%post
112#
113# bytecompile and install
114#
115
116if [ "$1" = 2 ] ; then
117
118%_emacsenPackageRemove %{name}
119
120fi
121
122%_addemacsenlist %{name}
123
124%_emacsenPackageInstall %{name}
125
126
127/sbin/install-info %{_infodir}/yatexe.gz %{_infodir}/dir \
128  --section="Emacs"
129/sbin/install-info %{_infodir}/yatexj.gz %{_infodir}/dir \
130  --section="Emacs"
131/sbin/install-info %{_infodir}/yahtmle.gz %{_infodir}/dir \
132  --section="Emacs"
133/sbin/install-info %{_infodir}/yahtmlj.gz %{_infodir}/dir \
134  --section="Emacs"
135
136
137%preun
138
139if [ "$1" = 0 ]; then
140
141%_emacsenPackageRemove %{name}
142
143%_removeemacsenlist %{name}
144
145/sbin/install-info --delete %{_infodir}/yatexe.gz %{_infodir}/dir \
146  --section="Emacs"
147/sbin/install-info --delete %{_infodir}/yatexj.gz %{_infodir}/dir \
148  --section="Emacs"
149/sbin/install-info --delete %{_infodir}/yahtmle.gz %{_infodir}/dir \
150  --section="Emacs"
151/sbin/install-info --delete %{_infodir}/yahtmlj.gz %{_infodir}/dir \
152  --section="Emacs"
153
154fi
155
156
157%files
158%defattr(-,root,root)
159%doc 00readme install manifest yatex.new
160%doc docs
161
162%{_datadir}/emacs/site-lisp/yatex/
163%{_infodir}/*
164%{emacsen_pkgdir}/install/%{name}
165%{emacsen_pkgdir}/remove/%{name}
166
167
168%changelog
169* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
170- updated vine-default-yatex.el
171  - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
172  - supported TeX Live
173    - used "eplatex", "pxdvi", "pdvips" as default commands
174- updated yatex-init.el
175  - output "Loading vine-default-yatex ..." to the buffer *Messages*
176  - defined vine-default-yahtml
177- added vine-default-yahtml.el
178
179* Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
180- updated vine-default-yatex.el
181  - added bbl extension in auto-mode-alist to run yatex-mode
182
183* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
184- updated vine-default-yatex.el
185  - supported new vine-default
186
187* Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
188- new upstream release
189
190* Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
191- updated vine-default-yatex.el
192  - dropped (setq YaTeX-no-begend-shortcut t)
193- use %{emacsen_pkgdir}
194
195* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
196- updated vine-default-yatex.el
197  - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
198
199* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
200- updated yatex-install.sh
201  - *-init.el: changed from hard copy to symbolic link
202    on /etc/emacs-XX.YY/site-start.d
203
204* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
205- fixed yatex-init.el
206
207* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
208- added yatex-init.el, vine-default-yatex.el
209- updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
210
211* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
212- spec in utf8
213
214* Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
215- applied new versioning policy
216
217* Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
218- new upstream release
219
220* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
221- s/Copyright/License/
222- changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
223
224* Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
225- update yatex-1.72
226
227* Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
228- update yatex-1.71
229
230* Fri Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
231- added Patch3 to add hhmts timestamp feature
232
233* Tue May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
234- update yatex-1.70
235
236* Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
237- update yatex10203151806
238
239* Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
240- fixed: bytecompile yatex19
241
242* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
243- now emacsen-common aware
244- FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
245
246* Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
247- 1.68-0vl2
248- no kanji code conversion of documents
249
250* Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
251- 1.68-0vl1
252- update to 1.68
253
254* Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
255- 1.67-6vl5
256- YATEXHLP.{jp,eng} moved to appropriate dir
257
258* Thu Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
259- 1.67-6vl3
260- rebuilt for emacs-20.7
261
262* Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
263- 1.67-6vl2
264- oops ... fixed target dir for help files
265
266* Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
267- 1.67-6vl1
268- rebuilt for emacs-20.6
269
270* Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
271- 1.67-6
272- included forgotten info file for YaHTML
273
274* Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
275- 1.67-5
276- updated for emacs-20.5a release
277
278* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
279- 1.67-4
280- change Group to Applications/Editors/EmacsLisp
281
282* Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
283- 1.67-3
284- %post and %preun section modified
285
286* Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
287- 1.67-2
288- fixed minor problem in the %files section
289
290* Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
291- 1.67-1
292- updated to 1.67 release
293- rebuilt for emacs-20.4 on Vine Linux 1.9
294- updated URL for the new web site of YaTeX
295- some typo fix
296
297* Tue May  4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
298- Initial Release
Note: See TracBrowser for help on using the repository browser.