source: projects/specs/trunk/y/yatex/yatex-vl.spec @ 521

Revision 521, 7.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4Name:          yatex
5Version:       1.74
6Release:       1%{?_dist_release}
7License:       Distributable
8Source0:       http://www.yatex.org/yatex%{version}.tar.gz
9#Source0:       http://www.yatex.org/yatex10203151806.tar.gz
10Source1:       %{name}-install.sh
11Source2:       %{name}-remove.sh
12Source3:       %{name}-init.el
13Source4:       vine-default-%{name}.el
14
15## pre-formatted info files here
16Source10:      yatexe
17Source11:      yatexj
18Source12:      yahtmle
19Source13:      yahtmlj
20
21## Vine Patch(es)
22Patch0:        yatex-info.diff
23Patch1:        yatexhlp-emacs.diff
24Patch2:        yatex-make.diff
25# based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
26# and modified to suit 1.70 release
27Patch3:        yahtml-1.70-timestamp.patch
28
29URL:           http://www.yatex.org/
30Group:         Applications/Editors/Emacs
31BuildRoot:     %{_tmppath}/%{name}-%{version}-root
32Summary:       YaTeX - Yet Another TeX mode for Emacs
33Summary(ja):   野鳥(YaTeX) - Yet Another TeX mode for Emacs
34BuildArch:     noarch
35
36PreReq:        emacsen
37%prereq_ge     emacsen-common
38BuildRequires: emacsen-common
39Obsoletes:     yatex-xemacs
40
41Distribution:  Vine Linux
42Vendor:        Project Vine
43
44
45%description
46YaTeX is an intelligent, acquisitive and integrated package which reduces
47your efforts of composing LaTeX source on GNU Emacs.
48
49%description -l ja
50YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
51してくれる、LaTeX 入力支援環境です。
52
53
54%prep
55%setup -n yatex%{version}
56%patch0 -p1
57%patch1 -p1
58%patch2 -p1
59%patch3 -p1
60
61
62%build
63
64( cd docs
65  chmod 644 *
66  install -v -m 644 %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} .
67)
68
69
70%install
71
72[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
73
74mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
75mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
76mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
77mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
78
79
80#
81# install el files
82#
83
84cp -a *.el makefile help ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
85cp -a %{SOURCE3} %{SOURCE4} \
86    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
87
88#
89# install info files
90#
91
92install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
93   ${RPM_BUILD_ROOT}%{_infodir}
94
95
96#
97# install script (bytecompile el and install elc, remove)
98#
99
100%_installemacsenscript %{name} %{SOURCE1}
101
102%_removeemacsenscript  %{name} %{SOURCE2}
103
104
105%clean
106[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
107
108
109%post
110#
111# bytecompile and install
112#
113
114if [ "$1" = 2 ] ; then
115
116%_emacsenPackageRemove %{name}
117
118fi
119
120%_addemacsenlist %{name}
121
122%_emacsenPackageInstall %{name}
123
124
125/sbin/install-info %{_infodir}/yatexe.gz %{_infodir}/dir \
126  --section="Emacs"
127/sbin/install-info %{_infodir}/yatexj.gz %{_infodir}/dir \
128  --section="Emacs"
129/sbin/install-info %{_infodir}/yahtmle.gz %{_infodir}/dir \
130  --section="Emacs"
131/sbin/install-info %{_infodir}/yahtmlj.gz %{_infodir}/dir \
132  --section="Emacs"
133
134
135%preun
136
137if [ "$1" = 0 ]; then
138
139%_emacsenPackageRemove %{name}
140
141%_removeemacsenlist %{name}
142
143/sbin/install-info --delete %{_infodir}/yatexe.gz %{_infodir}/dir \
144  --section="Emacs"
145/sbin/install-info --delete %{_infodir}/yatexj.gz %{_infodir}/dir \
146  --section="Emacs"
147/sbin/install-info --delete %{_infodir}/yahtmle.gz %{_infodir}/dir \
148  --section="Emacs"
149/sbin/install-info --delete %{_infodir}/yahtmlj.gz %{_infodir}/dir \
150  --section="Emacs"
151
152fi
153
154
155%files
156%defattr(-,root,root)
157%doc 00readme install manifest yatex.new
158%doc docs
159
160%{_datadir}/emacs/site-lisp/yatex/
161%{_infodir}/*
162%{emacsen_pkgdir}/install/%{name}
163%{emacsen_pkgdir}/remove/%{name}
164
165
166%changelog
167* Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
168- new upstream release
169
170* Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
171- updated vine-default-yatex.el
172  - dropped (setq YaTeX-no-begend-shortcut t)
173- use %{emacsen_pkgdir}
174
175* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
176- updated vine-default-yatex.el
177  - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
178
179* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
180- updated yatex-install.sh
181  - *-init.el: changed from hard copy to symbolic link
182    on /etc/emacs-XX.YY/site-start.d
183
184* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
185- fixed yatex-init.el
186
187* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
188- added yatex-init.el, vine-default-yatex.el
189- updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
190
191* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
192- spec in utf8
193
194* Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
195- applied new versioning policy
196
197* Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
198- new upstream release
199
200* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
201- s/Copyright/License/
202- changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
203
204* Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
205- update yatex-1.72
206
207* Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
208- update yatex-1.71
209
210* Fri Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
211- added Patch3 to add hhmts timestamp feature
212
213* Tue May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
214- update yatex-1.70
215
216* Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
217- update yatex10203151806
218
219* Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
220- fixed: bytecompile yatex19
221
222* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
223- now emacsen-common aware
224- FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
225
226* Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
227- 1.68-0vl2
228- no kanji code conversion of documents
229
230* Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
231- 1.68-0vl1
232- update to 1.68
233
234* Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
235- 1.67-6vl5
236- YATEXHLP.{jp,eng} moved to appropriate dir
237
238* Thu Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
239- 1.67-6vl3
240- rebuilt for emacs-20.7
241
242* Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
243- 1.67-6vl2
244- oops ... fixed target dir for help files
245
246* Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
247- 1.67-6vl1
248- rebuilt for emacs-20.6
249
250* Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
251- 1.67-6
252- included forgotten info file for YaHTML
253
254* Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
255- 1.67-5
256- updated for emacs-20.5a release
257
258* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
259- 1.67-4
260- change Group to Applications/Editors/EmacsLisp
261
262* Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
263- 1.67-3
264- %post and %preun section modified
265
266* Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
267- 1.67-2
268- fixed minor problem in the %files section
269
270* Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
271- 1.67-1
272- updated to 1.67 release
273- rebuilt for emacs-20.4 on Vine Linux 1.9
274- updated URL for the new web site of YaTeX
275- some typo fix
276
277* Tue May  4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
278- Initial Release
Note: See TracBrowser for help on using the repository browser.