source: projects/specs/trunk/y/yatex/yatex-vl.spec @ 9952

Revision 9952, 10.5 KB checked in by munepi, 8 years ago (diff)

new upstream release

Line 
1%define _noVersionedDependencies        1
2#% define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4Name:          yatex
5Version:       1.78.4
6Release:       1%{?_dist_release}
7License:       Distributable
8Source0:       http://www.yatex.org/yatex%{version}.tar.gz
9#Source0:       http://www.gentei.org/~yuuji/tmp/yatex11205111805.tar.gz
10Source1:       %{name}-install.sh
11Source2:       %{name}-remove.sh
12Source3:       %{name}-init.el
13Source4:       vine-default-%{name}.el
14Source5:       vine-default-yahtml.el
15
16## Vine Patch(es)
17Patch1:        yatexhlp-emacs.diff
18Patch2:        yatex-make.diff
19# based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
20# and modified to suit 1.70 release
21Patch3:        yahtml-1.70-timestamp.patch
22
23Patch10:       yatex-1.78-vine-vl7.patch
24
25URL:           http://www.yatex.org/
26Group:         Applications/Editors/Emacs
27BuildRoot:     %{_tmppath}/%{name}-%{version}-root
28Summary:       YaTeX - Yet Another TeX mode for Emacs
29Summary(ja):   野鳥(YaTeX) - Yet Another TeX mode for Emacs
30BuildArch:     noarch
31
32Requires(post): emacsen
33Requires(post): emacsen-common
34Requires(post): make
35BuildRequires: emacsen-common
36BuildRequires: nkf perl
37Obsoletes:     yatex-xemacs
38
39Distribution:  Vine Linux
40Vendor:        Project Vine
41Packager:      munepi
42
43%description
44YaTeX is an intelligent, acquisitive and integrated package which reduces
45your efforts of composing LaTeX source on GNU Emacs.
46
47
48If you are YaTeX user and you install both yatex and auctex on your system,
49you may add the following configure in your emacs init file
50~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
51
52;; I am a YaTeX user!!!
53(setq vine-default-auctex nil
54      vine-default-preview-latex nil)
55
56
57%description -l ja
58YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
59してくれる、LaTeX 入力支援環境です。
60
61
62yatex と auctex パッケージの両方をインストールする場合、
63~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
64に以下の設定を追加するとよいでしょう。
65
66;; YaTeX ユーザです!!!
67(setq vine-default-auctex nil
68      vine-default-preview-latex nil)
69
70
71%prep
72%setup -n yatex%{version}
73%patch1 -p1
74%patch2 -p1
75%patch3 -p1
76
77%patch10 -p1 -b .vine
78
79(cd docs
80    # change permissions
81    chmod 644 *
82
83    # encode as utf-8 (LF)
84    # NOTE: This changes needs to entry info files to Info DIR
85    for i in yatexj yatexe yahtmlj yahtmle; do nkf --unix -w --overwrite $i; done
86)
87
88
89%build
90
91
92%install
93
94[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
95
96%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
97%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
98%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
99%__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
100
101
102#
103# install el files
104#
105
106%__cp -a *.el makefile help \
107      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
108%__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
109      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
110
111#
112# install info files
113#
114
115%__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
116   ${RPM_BUILD_ROOT}%{_infodir}
117
118
119#
120# install script (bytecompile el and install elc, remove)
121#
122
123%_installemacsenscript %{name} %{SOURCE1}
124
125%_removeemacsenscript  %{name} %{SOURCE2}
126
127
128%clean
129[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
130
131
132%post
133#
134# bytecompile and install
135#
136
137if [ "$1" = 2 ] ; then
138
139%_emacsenPackageRemove %{name}
140
141fi
142
143%_addemacsenlist %{name}
144
145%_emacsenPackageInstall %{name}
146
147for i in yatexe yatexj yahtmle yahtmlj; do
148    /sbin/install-info --dir-file %{_infodir}/dir --section="Emacs" \
149                       %{_infodir}/${i}.gz
150done
151
152
153%preun
154
155if [ "$1" = 0 ]; then
156
157%_emacsenPackageRemove %{name}
158
159%_removeemacsenlist %{name}
160
161for i in yatexe yatexj yahtmle yahtmlj; do
162    /sbin/install-info --delete --dir-file %{_infodir}/dir --section="Emacs" \
163                       %{_infodir}/${i}.gz
164done
165
166fi
167
168
169%files
170%defattr(-,root,root)
171%doc 00readme install manifest yatex.new
172%doc docs
173
174%{_datadir}/emacs/site-lisp/yatex/
175%{_infodir}/yahtmle*
176%{_infodir}/yahtmlj*
177%{_infodir}/yatexe*
178%{_infodir}/yatexj*
179%{emacsen_pkgdir}/install/%{name}
180%{emacsen_pkgdir}/remove/%{name}
181
182
183%changelog
184* Mon Jan 11 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.78.4-1
185- new upstream release
186- TeX Live 2015
187
188* Mon May 13 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.77-1
189- new upstream release
190- applied yatex-1.77-vine-vl{6,7}.patch instead
191
192* Tue May 22 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-2
193- new upstream release
194- updated yatex-1.76-vine-vl{6,7}.patch
195
196* Sat May 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-1.20120511
197- source snapshot 20120511: testing version 1.76 development
198- dropped obsoleted/upstreamed patches
199- applied yatex-1.76-vine-vl{6,7}.patch
200
201* Fri May 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-3
202- added BuildRequires: nkf perl
203- updated yatex-1.74-vine.patch as yatex-1.75-vine-vl{6,7}.patch
204- dropped pre-formatted info files
205- use original info files
206  - encode info files as utf-8
207  - add INFO-DIR-ENTRY
208
209* Thu May 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-2
210- fixed vine-default-yatex.el
211- applied yatex-1.74-vine.patch for vl6
212- updated yatex-1.74-vine.patch: support some extensions for \includegraphics
213
214* Thu Feb  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-1
215- new upstream release
216- updated vine-default-yatex.el
217
218* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-9
219- support TeX Live 2011
220- applied yatex-1.74-vine-vl7.patch
221- updated vine-default-yatex.el
222
223* Thu Aug 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-8
224- added Requires(post): make
225
226* Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-7
227- updated vine-default-yatex.el
228  - check 'YaTeX-inhibit-prefix-letter
229  - used "pbibtex -kanji=utf8" as default bibtex-command
230  - used "mendex -U" as default makeindex-command
231
232* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-6
233- updated vine-default-{yatex,yahtml}.el
234  - revived auto-fill-mode on {yatex,yahtml}-mode
235
236* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-5
237- updated yatex-init.el
238  - dropped all pathes of auctex and preview-latex from load-path
239
240* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
241- updated vine-default-yatex.el
242  - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
243  - supported TeX Live
244    - used "eplatex", "pxdvi", "pdvips" as default commands
245- updated yatex-init.el
246  - output "Loading vine-default-yatex ..." to the buffer *Messages*
247  - defined vine-default-yahtml
248- added vine-default-yahtml.el
249
250* Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
251- updated vine-default-yatex.el
252  - added bbl extension in auto-mode-alist to run yatex-mode
253
254* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
255- updated vine-default-yatex.el
256  - supported new vine-default
257
258* Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
259- new upstream release
260
261* Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
262- updated vine-default-yatex.el
263  - dropped (setq YaTeX-no-begend-shortcut t)
264- use %{emacsen_pkgdir}
265
266* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
267- updated vine-default-yatex.el
268  - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
269
270* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
271- updated yatex-install.sh
272  - *-init.el: changed from hard copy to symbolic link
273    on /etc/emacs-XX.YY/site-start.d
274
275* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
276- fixed yatex-init.el
277
278* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
279- added yatex-init.el, vine-default-yatex.el
280- updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
281
282* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
283- spec in utf8
284
285* Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
286- applied new versioning policy
287
288* Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
289- new upstream release
290
291* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
292- s/Copyright/License/
293- changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
294
295* Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
296- update yatex-1.72
297
298* Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
299- update yatex-1.71
300
301* Wed Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
302- added Patch3 to add hhmts timestamp feature
303
304* Mon May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
305- update yatex-1.70
306
307* Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
308- update yatex10203151806
309
310* Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
311- fixed: bytecompile yatex19
312
313* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
314- now emacsen-common aware
315- FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
316
317* Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
318- 1.68-0vl2
319- no kanji code conversion of documents
320
321* Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
322- 1.68-0vl1
323- update to 1.68
324
325* Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
326- 1.67-6vl5
327- YATEXHLP.{jp,eng} moved to appropriate dir
328
329* Fri Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
330- 1.67-6vl3
331- rebuilt for emacs-20.7
332
333* Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
334- 1.67-6vl2
335- oops ... fixed target dir for help files
336
337* Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
338- 1.67-6vl1
339- rebuilt for emacs-20.6
340
341* Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
342- 1.67-6
343- included forgotten info file for YaHTML
344
345* Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
346- 1.67-5
347- updated for emacs-20.5a release
348
349* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
350- 1.67-4
351- change Group to Applications/Editors/EmacsLisp
352
353* Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
354- 1.67-3
355- %post and %preun section modified
356
357* Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
358- 1.67-2
359- fixed minor problem in the %files section
360
361* Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
362- 1.67-1
363- updated to 1.67 release
364- rebuilt for emacs-20.4 on Vine Linux 1.9
365- updated URL for the new web site of YaTeX
366- some typo fix
367
368* Tue May  4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
369- Initial Release
Note: See TracBrowser for help on using the repository browser.