source: projects/specs/trunk/y/yatex/yatex-vl.spec @ 3080

Revision 3080, 9.1 KB checked in by munepi, 13 years ago (diff)

updated yatex-vl.spec

RevLine 
[521]1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4Name:          yatex
5Version:       1.74
[3080]6Release:       6%{?_dist_release}
[521]7License:       Distributable
8Source0:       http://www.yatex.org/yatex%{version}.tar.gz
9#Source0:       http://www.yatex.org/yatex10203151806.tar.gz
10Source1:       %{name}-install.sh
11Source2:       %{name}-remove.sh
12Source3:       %{name}-init.el
13Source4:       vine-default-%{name}.el
[2599]14Source5:       vine-default-yahtml.el
[521]15
16## pre-formatted info files here
17Source10:      yatexe
18Source11:      yatexj
19Source12:      yahtmle
20Source13:      yahtmlj
21
22## Vine Patch(es)
23Patch0:        yatex-info.diff
24Patch1:        yatexhlp-emacs.diff
25Patch2:        yatex-make.diff
26# based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
27# and modified to suit 1.70 release
28Patch3:        yahtml-1.70-timestamp.patch
29
30URL:           http://www.yatex.org/
31Group:         Applications/Editors/Emacs
32BuildRoot:     %{_tmppath}/%{name}-%{version}-root
33Summary:       YaTeX - Yet Another TeX mode for Emacs
34Summary(ja):   野鳥(YaTeX) - Yet Another TeX mode for Emacs
35BuildArch:     noarch
36
37PreReq:        emacsen
38%prereq_ge     emacsen-common
39BuildRequires: emacsen-common
40Obsoletes:     yatex-xemacs
41
42Distribution:  Vine Linux
43Vendor:        Project Vine
44
45
46%description
47YaTeX is an intelligent, acquisitive and integrated package which reduces
48your efforts of composing LaTeX source on GNU Emacs.
49
[2750]50
51If you are YaTeX user and you install both yatex and auctex on your system,
52you may add the following configure in your emacs init file
53%if %{?_dist_release} == "vl5"
54~/.emacs.el:
55%else
56~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
57%endif
58
59;; I am YaTeX user!!!
60(setq vine-default-auctex nil
61      vine-default-preview-latex nil)
62
63
[521]64%description -l ja
65YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
66してくれる、LaTeX 入力支援環境です。
67
68
[2750]69yatex と auctex パッケージの両方をインストールする場合、
70%if %{?_dist_release} == "vl5"
71~/.emacs.el:
72%else
73~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
74%endif
75に以下の設定を追加するとよいでしょう。
76
77;; YaTeX ユーザです!!!
78(setq vine-default-auctex nil
79      vine-default-preview-latex nil)
80
81
[521]82%prep
83%setup -n yatex%{version}
84%patch0 -p1
85%patch1 -p1
86%patch2 -p1
87%patch3 -p1
88
89
90%build
91
[2599]92(cd docs
93    chmod 644 *
94    %__install -v -m 644 %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} .
[521]95)
96
97
98%install
99
[2599]100[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
[521]101
[2599]102%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
103%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
104%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
105%__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
[521]106
107
108#
109# install el files
110#
111
[2599]112%__cp -a *.el makefile help \
113      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
114%__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
115      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
[521]116
117#
118# install info files
119#
120
[2599]121%__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
[521]122   ${RPM_BUILD_ROOT}%{_infodir}
123
124
125#
126# install script (bytecompile el and install elc, remove)
127#
128
129%_installemacsenscript %{name} %{SOURCE1}
130
131%_removeemacsenscript  %{name} %{SOURCE2}
132
133
134%clean
[2599]135[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
[521]136
137
138%post
139#
140# bytecompile and install
141#
142
143if [ "$1" = 2 ] ; then
144
145%_emacsenPackageRemove %{name}
146
147fi
148
149%_addemacsenlist %{name}
150
151%_emacsenPackageInstall %{name}
152
153
154/sbin/install-info %{_infodir}/yatexe.gz %{_infodir}/dir \
155  --section="Emacs"
156/sbin/install-info %{_infodir}/yatexj.gz %{_infodir}/dir \
157  --section="Emacs"
158/sbin/install-info %{_infodir}/yahtmle.gz %{_infodir}/dir \
159  --section="Emacs"
160/sbin/install-info %{_infodir}/yahtmlj.gz %{_infodir}/dir \
161  --section="Emacs"
162
163
164%preun
165
166if [ "$1" = 0 ]; then
167
168%_emacsenPackageRemove %{name}
169
170%_removeemacsenlist %{name}
171
172/sbin/install-info --delete %{_infodir}/yatexe.gz %{_infodir}/dir \
173  --section="Emacs"
174/sbin/install-info --delete %{_infodir}/yatexj.gz %{_infodir}/dir \
175  --section="Emacs"
176/sbin/install-info --delete %{_infodir}/yahtmle.gz %{_infodir}/dir \
177  --section="Emacs"
178/sbin/install-info --delete %{_infodir}/yahtmlj.gz %{_infodir}/dir \
179  --section="Emacs"
180
181fi
182
183
184%files
185%defattr(-,root,root)
186%doc 00readme install manifest yatex.new
187%doc docs
188
189%{_datadir}/emacs/site-lisp/yatex/
190%{_infodir}/*
191%{emacsen_pkgdir}/install/%{name}
192%{emacsen_pkgdir}/remove/%{name}
193
194
195%changelog
[3080]196* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-6
197- updated vine-default-{yatex,yahtml}.el
198  - revived auto-fill-mode on {yatex,yahtml}-mode
199
[2750]200* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-5
201- updated yatex-init.el
202  - dropped all pathes of auctex and preview-latex from load-path
203
[2599]204* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
205- updated vine-default-yatex.el
206  - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
207  - supported TeX Live
208    - used "eplatex", "pxdvi", "pdvips" as default commands
209- updated yatex-init.el
210  - output "Loading vine-default-yatex ..." to the buffer *Messages*
211  - defined vine-default-yahtml
212- added vine-default-yahtml.el
213
[2443]214* Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
215- updated vine-default-yatex.el
216  - added bbl extension in auto-mode-alist to run yatex-mode
217
218* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
219- updated vine-default-yatex.el
220  - supported new vine-default
221
[521]222* Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
223- new upstream release
224
225* Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
226- updated vine-default-yatex.el
227  - dropped (setq YaTeX-no-begend-shortcut t)
228- use %{emacsen_pkgdir}
229
230* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
231- updated vine-default-yatex.el
232  - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
233
234* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
235- updated yatex-install.sh
236  - *-init.el: changed from hard copy to symbolic link
237    on /etc/emacs-XX.YY/site-start.d
238
239* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
240- fixed yatex-init.el
241
242* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
243- added yatex-init.el, vine-default-yatex.el
244- updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
245
246* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
247- spec in utf8
248
249* Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
250- applied new versioning policy
251
252* Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
253- new upstream release
254
255* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
256- s/Copyright/License/
257- changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
258
259* Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
260- update yatex-1.72
261
262* Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
263- update yatex-1.71
264
265* Fri Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
266- added Patch3 to add hhmts timestamp feature
267
268* Tue May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
269- update yatex-1.70
270
271* Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
272- update yatex10203151806
273
274* Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
275- fixed: bytecompile yatex19
276
277* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
278- now emacsen-common aware
279- FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
280
281* Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
282- 1.68-0vl2
283- no kanji code conversion of documents
284
285* Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
286- 1.68-0vl1
287- update to 1.68
288
289* Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
290- 1.67-6vl5
291- YATEXHLP.{jp,eng} moved to appropriate dir
292
293* Thu Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
294- 1.67-6vl3
295- rebuilt for emacs-20.7
296
297* Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
298- 1.67-6vl2
299- oops ... fixed target dir for help files
300
301* Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
302- 1.67-6vl1
303- rebuilt for emacs-20.6
304
305* Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
306- 1.67-6
307- included forgotten info file for YaHTML
308
309* Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
310- 1.67-5
311- updated for emacs-20.5a release
312
313* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
314- 1.67-4
315- change Group to Applications/Editors/EmacsLisp
316
317* Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
318- 1.67-3
319- %post and %preun section modified
320
321* Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
322- 1.67-2
323- fixed minor problem in the %files section
324
325* Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
326- 1.67-1
327- updated to 1.67 release
328- rebuilt for emacs-20.4 on Vine Linux 1.9
329- updated URL for the new web site of YaTeX
330- some typo fix
331
332* Tue May  4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
333- Initial Release
Note: See TracBrowser for help on using the repository browser.