source: projects/specs/trunk/y/yatex/yatex-vl.spec @ 10271

Revision 10271, 11.3 KB checked in by munepi, 8 years ago (diff)

added fwdevince.py

RevLine 
[521]1%define _noVersionedDependencies        1
[6173]2#% define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
[521]3
4Name:          yatex
[9952]5Version:       1.78.4
[10271]6Release:       5%{?_dist_release}
[521]7License:       Distributable
[6216]8Source0:       http://www.yatex.org/yatex%{version}.tar.gz
9#Source0:       http://www.gentei.org/~yuuji/tmp/yatex11205111805.tar.gz
[521]10Source1:       %{name}-install.sh
11Source2:       %{name}-remove.sh
12Source3:       %{name}-init.el
13Source4:       vine-default-%{name}.el
[2599]14Source5:       vine-default-yahtml.el
[521]15
[10271]16Source10:      fwdevince.py
17
[521]18## Vine Patch(es)
19Patch1:        yatexhlp-emacs.diff
20Patch2:        yatex-make.diff
21# based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
22# and modified to suit 1.70 release
23Patch3:        yahtml-1.70-timestamp.patch
24
[10271]25Patch10:       yatex-1.78.4-vine-vl7.patch
[5257]26
[521]27URL:           http://www.yatex.org/
28Group:         Applications/Editors/Emacs
29BuildRoot:     %{_tmppath}/%{name}-%{version}-root
30Summary:       YaTeX - Yet Another TeX mode for Emacs
31Summary(ja):   野鳥(YaTeX) - Yet Another TeX mode for Emacs
32BuildArch:     noarch
33
[10271]34Requires:       evince python3
35
[6173]36Requires(post): emacsen
37Requires(post): emacsen-common
[4582]38Requires(post): make
[521]39BuildRequires: emacsen-common
[6173]40BuildRequires: nkf perl
[521]41Obsoletes:     yatex-xemacs
42
43Distribution:  Vine Linux
44Vendor:        Project Vine
[5257]45Packager:      munepi
[521]46
47%description
48YaTeX is an intelligent, acquisitive and integrated package which reduces
49your efforts of composing LaTeX source on GNU Emacs.
50
[2750]51
52If you are YaTeX user and you install both yatex and auctex on your system,
53you may add the following configure in your emacs init file
54~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
55
[6173]56;; I am a YaTeX user!!!
[2750]57(setq vine-default-auctex nil
58      vine-default-preview-latex nil)
59
60
[521]61%description -l ja
62YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
63してくれる、LaTeX 入力支援環境です。
64
65
[2750]66yatex と auctex パッケージの両方をインストールする場合、
67~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
68に以下の設定を追加するとよいでしょう。
69
70;; YaTeX ユーザです!!!
71(setq vine-default-auctex nil
72      vine-default-preview-latex nil)
73
74
[10271]75vine-default-yatex では、エディタ emacs と PDF プレビュー evince との
76forward/inverse search を設定済です。
77 - emacs -> evince (forward search): C-c C-g
78 - evince -> emacs (inverse search): Ctrl+左クリック
79
[521]80%prep
81%setup -n yatex%{version}
82%patch1 -p1
83%patch2 -p1
84%patch3 -p1
85
[5257]86%patch10 -p1 -b .vine
[521]87
[2599]88(cd docs
[6173]89    # change permissions
[2599]90    chmod 644 *
[6173]91
92    # encode as utf-8 (LF)
93    # NOTE: This changes needs to entry info files to Info DIR
94    for i in yatexj yatexe yahtmlj yahtmle; do nkf --unix -w --overwrite $i; done
[521]95)
96
97
[6173]98%build
99
100
[521]101%install
[10271]102%__rm -rf ${RPM_BUILD_ROOT}
[521]103
[10271]104install -Dpm 755 %{SOURCE10} ${RPM_BUILD_ROOT}%{_bindir}/fwdevince
[521]105
[2599]106%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
107%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
108%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
109%__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
[521]110
111
112#
113# install el files
114#
115
[2599]116%__cp -a *.el makefile help \
117      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
118%__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
119      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
[521]120
121#
122# install info files
123#
124
[2599]125%__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
[521]126   ${RPM_BUILD_ROOT}%{_infodir}
127
128
129#
130# install script (bytecompile el and install elc, remove)
131#
132
133%_installemacsenscript %{name} %{SOURCE1}
134
135%_removeemacsenscript  %{name} %{SOURCE2}
136
137
138%clean
[2599]139[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
[521]140
141
142%post
143#
144# bytecompile and install
145#
146
147if [ "$1" = 2 ] ; then
148
149%_emacsenPackageRemove %{name}
150
151fi
152
153%_addemacsenlist %{name}
154
155%_emacsenPackageInstall %{name}
156
[6173]157for i in yatexe yatexj yahtmle yahtmlj; do
158    /sbin/install-info --dir-file %{_infodir}/dir --section="Emacs" \
159                       %{_infodir}/${i}.gz
160done
[521]161
162
163%preun
164
165if [ "$1" = 0 ]; then
166
167%_emacsenPackageRemove %{name}
168
169%_removeemacsenlist %{name}
170
[6173]171for i in yatexe yatexj yahtmle yahtmlj; do
172    /sbin/install-info --delete --dir-file %{_infodir}/dir --section="Emacs" \
173                       %{_infodir}/${i}.gz
174done
[521]175
176fi
177
178
179%files
180%defattr(-,root,root)
181%doc 00readme install manifest yatex.new
182%doc docs
[10271]183%{_bindir}/fwdevince
[521]184%{_datadir}/emacs/site-lisp/yatex/
[6173]185%{_infodir}/yahtmle*
186%{_infodir}/yahtmlj*
187%{_infodir}/yatexe*
188%{_infodir}/yatexj*
[521]189%{emacsen_pkgdir}/install/%{name}
190%{emacsen_pkgdir}/remove/%{name}
191
192
[5257]193%changelog
[10271]194* Tue May 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.78.4-5
195- fixed fwdevince.py
196
197* Sun Jan 24 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.78.4-4
198- added Requires: evince python3
199
200* Sun Jan 24 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.78.4-3
201- updated vine-default-yatex.el
202  - supported forward search via fwdevince.py/python3
203  - supported inverse search via evince
204
205* Sun Jan 24 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.78.4-2
206- set uplatex+dvipdfmx as default
207
[9952]208* Mon Jan 11 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.78.4-1
209- new upstream release
210- TeX Live 2015
211
[7675]212* Mon May 13 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.77-1
213- new upstream release
214- applied yatex-1.77-vine-vl{6,7}.patch instead
215
[6216]216* Tue May 22 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-2
217- new upstream release
218- updated yatex-1.76-vine-vl{6,7}.patch
219
[6173]220* Sat May 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-1.20120511
221- source snapshot 20120511: testing version 1.76 development
222- dropped obsoleted/upstreamed patches
223- applied yatex-1.76-vine-vl{6,7}.patch
224
225* Fri May 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-3
226- added BuildRequires: nkf perl
227- updated yatex-1.74-vine.patch as yatex-1.75-vine-vl{6,7}.patch
228- dropped pre-formatted info files
229- use original info files
230  - encode info files as utf-8
231  - add INFO-DIR-ENTRY
232
233* Thu May 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-2
234- fixed vine-default-yatex.el
235- applied yatex-1.74-vine.patch for vl6
236- updated yatex-1.74-vine.patch: support some extensions for \includegraphics
237
[5603]238* Thu Feb  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-1
239- new upstream release
240- updated vine-default-yatex.el
241
[5257]242* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-9
243- support TeX Live 2011
244- applied yatex-1.74-vine-vl7.patch
245- updated vine-default-yatex.el
246
[4582]247* Thu Aug 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-8
248- added Requires(post): make
249
[3482]250* Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-7
251- updated vine-default-yatex.el
252  - check 'YaTeX-inhibit-prefix-letter
253  - used "pbibtex -kanji=utf8" as default bibtex-command
254  - used "mendex -U" as default makeindex-command
255
[3080]256* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-6
257- updated vine-default-{yatex,yahtml}.el
258  - revived auto-fill-mode on {yatex,yahtml}-mode
259
[2750]260* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-5
261- updated yatex-init.el
262  - dropped all pathes of auctex and preview-latex from load-path
263
[2599]264* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
265- updated vine-default-yatex.el
266  - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
267  - supported TeX Live
268    - used "eplatex", "pxdvi", "pdvips" as default commands
269- updated yatex-init.el
270  - output "Loading vine-default-yatex ..." to the buffer *Messages*
271  - defined vine-default-yahtml
272- added vine-default-yahtml.el
273
[2443]274* Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
275- updated vine-default-yatex.el
276  - added bbl extension in auto-mode-alist to run yatex-mode
277
278* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
279- updated vine-default-yatex.el
280  - supported new vine-default
281
[521]282* Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
283- new upstream release
284
285* Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
286- updated vine-default-yatex.el
287  - dropped (setq YaTeX-no-begend-shortcut t)
288- use %{emacsen_pkgdir}
289
290* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
291- updated vine-default-yatex.el
292  - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
293
294* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
295- updated yatex-install.sh
296  - *-init.el: changed from hard copy to symbolic link
297    on /etc/emacs-XX.YY/site-start.d
298
299* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
300- fixed yatex-init.el
301
302* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
303- added yatex-init.el, vine-default-yatex.el
304- updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
305
306* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
307- spec in utf8
308
309* Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
310- applied new versioning policy
311
312* Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
313- new upstream release
314
315* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
316- s/Copyright/License/
317- changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
318
319* Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
320- update yatex-1.72
321
322* Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
323- update yatex-1.71
324
[7675]325* Wed Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
[521]326- added Patch3 to add hhmts timestamp feature
327
[7675]328* Mon May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
[521]329- update yatex-1.70
330
331* Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
332- update yatex10203151806
333
334* Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
335- fixed: bytecompile yatex19
336
337* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
338- now emacsen-common aware
339- FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
340
341* Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
342- 1.68-0vl2
343- no kanji code conversion of documents
344
345* Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
346- 1.68-0vl1
347- update to 1.68
348
349* Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
350- 1.67-6vl5
351- YATEXHLP.{jp,eng} moved to appropriate dir
352
[7675]353* Fri Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
[521]354- 1.67-6vl3
355- rebuilt for emacs-20.7
356
357* Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
358- 1.67-6vl2
359- oops ... fixed target dir for help files
360
361* Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
362- 1.67-6vl1
363- rebuilt for emacs-20.6
364
365* Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
366- 1.67-6
367- included forgotten info file for YaHTML
368
369* Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
370- 1.67-5
371- updated for emacs-20.5a release
372
373* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
374- 1.67-4
375- change Group to Applications/Editors/EmacsLisp
376
377* Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
378- 1.67-3
379- %post and %preun section modified
380
381* Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
382- 1.67-2
383- fixed minor problem in the %files section
384
385* Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
386- 1.67-1
387- updated to 1.67 release
388- rebuilt for emacs-20.4 on Vine Linux 1.9
389- updated URL for the new web site of YaTeX
390- some typo fix
391
392* Tue May  4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
393- Initial Release
Note: See TracBrowser for help on using the repository browser.