source: projects/specs/trunk/y/yaml/yaml-vl.spec @ 11631

Revision 11631, 3.4 KB checked in by ara_t, 6 years ago (diff)

yaml: rebuild with ghc-8.4.2

Line 
1%define pkg_name    yaml
2%define pkg_version 0.8.30
3%define pkg_release 1%{?_dist_release}
4
5Summary: Support for parsing and rendering YAML documents
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: BSD3
11Group:   Applications/Text
12URL:     http://hackage.haskell.org
13
14Source0: packages
15
16Source11: exceptions-0.10.0.tar.gz
17Source12: exceptions.cabal
18Source13: unliftio-core-0.1.1.0.tar.gz
19Source14: unliftio-core.cabal
20Source15: vector-algorithms-0.7.0.1.tar.gz
21Source16: vector-algorithms.cabal
22Source17: resourcet-1.2.1.tar.gz
23Source18: resourcet.cabal
24Source19: mono-traversable-1.0.8.1.tar.gz
25Source20: mono-traversable.cabal
26Source21: conduit-1.3.0.2.tar.gz
27Source22: conduit.cabal
28Source23: yaml-0.8.30.tar.gz
29Source24: yaml.cabal
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32
33BuildRequires: ghc haskell-platform
34BuildRequires: libffi-devel gmp-devel zlib-devel
35BuildRequires: libghc-dlist
36BuildRequires: libghc-old-locale
37BuildRequires: libghc-aeson
38BuildRequires: libghc-semigroups
39
40
41BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
42
43Requires: ghc haskell-platform
44Requires: haskell-platform-dep
45Requires: libghc-dlist
46Requires: libghc-old-locale
47Requires: libghc-aeson
48Requires: libghc-semigroups
49
50
51Vendor: Project Vine
52Distribution: Vine Linux
53Packager: ara_t
54
55
56%description
57This package includes the full libyaml C library version 0.1.5
58 by Kirill Simonov in the package so you don't need to worry
59 about any non-Haskell dependencies.
60
61The package is broken down into two primary modules.
62"Data.Yaml" provides a high-level interface based around the JSON datatypes
63 provided by the @aeson@ package.
64"Text.Libyaml" provides a lower-level, streaming interface.
65For most users, "Data.Yaml" is recommended.
66#'
67
68
69 %prep
70%{__rm} -rf ${RPM_BUILD_ROOT}
71
72%build
73%ghc_pkg_init
74
75for pkg in `sed '$d' %{SOURCE0}`; do
76    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
77    pushd ${pkg}
78        %ghc_fix_dependencies ${pkg}
79        %cabal_configure2 %{name} ${pkg}
80        %cabal_build
81        %cabal_haddock
82        %cabal_copy_resister %{name}_${pkg}
83    popd
84done
85
86# build yaml
87for pkg in `tail -n 1 %{SOURCE0}`; do
88    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
89    pushd ${pkg}
90        %ghc_fix_dependencies ${pkg}
91        %cabal_configure2 %{name} ${pkg} \
92                              -f -no-exe
93        %cabal_build
94        %cabal_haddock
95        %cabal_copy_resister %{pkg_name}-%{version}
96    popd
97done
98
99
100%install
101# copy documents
102pushd %{_builddir}/%{pkg_name}-%{version}
103    %{__cp} ChangeLog.md README.md \
104     ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{pkg_name}-%{version}
105popd
106
107
108%clean
109%{__rm} -rf ${RPM_BUILD_ROOT}
110
111%post
112%ghc_pkg_recache
113
114%postun
115%ghc_pkg_recache
116
117
118%files
119%defattr(-, root, root)
120%{_bindir}/
121%{_libdir}/ghc-%{ghc_version}/
122%{_libdir}/ghc-lib/
123%{_docdir}/%{name}/
124
125
126%changelog
127* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.8.30-1
128- update to 0.8.30
129- rebuild using ghc-8.4.2
130- rewrite using macro
131
132* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.8.25.1-1
133- update to 0.8.25.1
134- build using ghc-8.2.2
135
136* Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 0.8.21.2-2
137- build using ghc-8.0.2
138
139* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.8.21.2-1
140- update to 0.8.21.2
141- build using ghc-8.0.1
142
143* Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.8.16-3
144- rebuilt
145
146* Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.8.16-2
147- correct SPEC file
148
149* Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.8.16-1
150- new package
Note: See TracBrowser for help on using the repository browser.