source: projects/specs/trunk/y/yaml/yaml-vl.spec @ 11993

Revision 11993, 3.8 KB checked in by ara_t, 5 years ago (diff)

yaml: update/build with ghc-8.6.3

RevLine 
[10166]1%define pkg_name    yaml
[11993]2%define pkg_version 0.11.0.0
3%define pkg_release 1%{?_dist_release}
[10166]4
5Summary: Support for parsing and rendering YAML documents
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: BSD3
11Group:   Applications/Text
12URL:     http://hackage.haskell.org
13
[11631]14Source0: packages
[10166]15
[11747]16Source11: transformers-compat-0.6.2.tar.gz
17Source12: transformers-compat.cabal
[11993]18Source13: unliftio-core-0.1.2.0.tar.gz
[11631]19Source14: unliftio-core.cabal
[11993]20Source15: vector-algorithms-0.8.0.1.tar.gz
[11631]21Source16: vector-algorithms.cabal
[11747]22Source17: exceptions-0.10.0.tar.gz
23Source18: exceptions.cabal
[11993]24Source19: mono-traversable-1.0.9.0.tar.gz
[11631]25Source20: mono-traversable.cabal
[11993]26Source21: resourcet-1.2.2.tar.gz
[11747]27Source22: resourcet.cabal
[11993]28Source23: conduit-1.3.1.tar.gz
[11747]29Source24: conduit.cabal
[11993]30Source25: libyaml-0.1.0.0.tar.gz
31Source26: libyaml.cabal
32Source27: yaml-0.11.0.0.tar.gz
33Source28: yaml.cabal
[10166]34
35BuildRoot: %{_tmppath}/%{name}-%{version}-root
36
[10915]37BuildRequires: ghc haskell-platform
[10166]38BuildRequires: libffi-devel gmp-devel zlib-devel
39BuildRequires: libghc-dlist
[11631]40BuildRequires: libghc-old-locale
[10166]41BuildRequires: libghc-aeson
[11631]42BuildRequires: libghc-semigroups
[10166]43
[11631]44
[10166]45BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
46
[10915]47Requires: ghc haskell-platform
[11631]48Requires: haskell-platform-dep
[10166]49Requires: libghc-dlist
[11631]50Requires: libghc-old-locale
[10166]51Requires: libghc-aeson
[11631]52Requires: libghc-semigroups
[10166]53
[11631]54
[10166]55Vendor: Project Vine
56Distribution: Vine Linux
57Packager: ara_t
58
59
60%description
61This package includes the full libyaml C library version 0.1.5
62 by Kirill Simonov in the package so you don't need to worry
63 about any non-Haskell dependencies.
64
65The package is broken down into two primary modules.
66"Data.Yaml" provides a high-level interface based around the JSON datatypes
67 provided by the @aeson@ package.
68"Text.Libyaml" provides a lower-level, streaming interface.
69For most users, "Data.Yaml" is recommended.
70#'
71
[11631]72
73 %prep
[10166]74%{__rm} -rf ${RPM_BUILD_ROOT}
75
76%build
[11631]77%ghc_pkg_init
[10166]78
[11631]79for pkg in `sed '$d' %{SOURCE0}`; do
80    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
81    pushd ${pkg}
82        %ghc_fix_dependencies ${pkg}
83        %cabal_configure2 %{name} ${pkg}
84        %cabal_build
85        %cabal_haddock
86        %cabal_copy_resister %{name}_${pkg}
87    popd
88done
[10166]89
[11631]90# build yaml
91for pkg in `tail -n 1 %{SOURCE0}`; do
92    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
93    pushd ${pkg}
94        %ghc_fix_dependencies ${pkg}
[11747]95        %cabal_configure2 %{name}/${pkg} \
96                          -f -no-exe
[11631]97        %cabal_build
98        %cabal_haddock
99        %cabal_copy_resister %{pkg_name}-%{version}
100    popd
[10166]101done
102
103
104%install
[11631]105# copy documents
106pushd %{_builddir}/%{pkg_name}-%{version}
107    %{__cp} ChangeLog.md README.md \
108     ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{pkg_name}-%{version}
109popd
[10166]110
111
112%clean
113%{__rm} -rf ${RPM_BUILD_ROOT}
114
115%post
[11631]116%ghc_pkg_recache
[10166]117
118%postun
[11631]119%ghc_pkg_recache
[10166]120
121
122%files
123%defattr(-, root, root)
124%{_bindir}/
125%{_libdir}/ghc-%{ghc_version}/
126%{_libdir}/ghc-lib/
[10237]127%{_docdir}/%{name}/
[10166]128
129
130%changelog
[11993]131* Mon Dec 17 2018 Toshiaki Ara <ara_t@384.jp> 0.11.0.0-1
132- update to 0.11.0.0
133- build using ghc-8.6.3
134
[11764]135* Thu Aug 09 2018 Toshiaki Ara <ara_t@384.jp> 0.9.0-2
136- rebuild with ghc-8.4.3-2
137
[11747]138* Sat Jul 21 2018 Toshiaki Ara <ara_t@384.jp> 0.9.0-1
139- update to 0.9.0
140- build using ghc-8.4.3
141
[11631]142* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.8.30-1
143- update to 0.8.30
144- rebuild using ghc-8.4.2
145- rewrite using macro
146
[11385]147* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.8.25.1-1
148- update to 0.8.25.1
149- build using ghc-8.2.2
150
151* Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 0.8.21.2-2
152- build using ghc-8.0.2
153
[10915]154* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.8.21.2-1
155- update to 0.8.21.2
156- build using ghc-8.0.1
157
[10237]158* Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.8.16-3
159- rebuilt
160
[10166]161* Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.8.16-2
162- correct SPEC file
163
164* Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.8.16-1
165- new package
Note: See TracBrowser for help on using the repository browser.