source: projects/specs/trunk/y/yaml/yaml-vl.spec @ 11747

Revision 11747, 3.6 KB checked in by ara_t, 6 years ago (diff)

yaml: rebuild with ghc-8.4.3

RevLine 
[10166]1%define pkg_name    yaml
[11747]2%define pkg_version 0.9.0
[10915]3%define pkg_release 1%{?_dist_release}
[10166]4
5Summary: Support for parsing and rendering YAML documents
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: BSD3
11Group:   Applications/Text
12URL:     http://hackage.haskell.org
13
[11631]14Source0: packages
[10166]15
[11747]16Source11: transformers-compat-0.6.2.tar.gz
17Source12: transformers-compat.cabal
[11631]18Source13: unliftio-core-0.1.1.0.tar.gz
19Source14: unliftio-core.cabal
20Source15: vector-algorithms-0.7.0.1.tar.gz
21Source16: vector-algorithms.cabal
[11747]22Source17: exceptions-0.10.0.tar.gz
23Source18: exceptions.cabal
[11631]24Source19: mono-traversable-1.0.8.1.tar.gz
25Source20: mono-traversable.cabal
[11747]26Source21: resourcet-1.2.1.tar.gz
27Source22: resourcet.cabal
28Source23: conduit-1.3.0.3.tar.gz
29Source24: conduit.cabal
30Source25: yaml-0.9.0.tar.gz
31Source26: yaml.cabal
[10166]32
33BuildRoot: %{_tmppath}/%{name}-%{version}-root
34
[10915]35BuildRequires: ghc haskell-platform
[10166]36BuildRequires: libffi-devel gmp-devel zlib-devel
37BuildRequires: libghc-dlist
[11631]38BuildRequires: libghc-old-locale
[10166]39BuildRequires: libghc-aeson
[11631]40BuildRequires: libghc-semigroups
[10166]41
[11631]42
[10166]43BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
44
[10915]45Requires: ghc haskell-platform
[11631]46Requires: haskell-platform-dep
[10166]47Requires: libghc-dlist
[11631]48Requires: libghc-old-locale
[10166]49Requires: libghc-aeson
[11631]50Requires: libghc-semigroups
[10166]51
[11631]52
[10166]53Vendor: Project Vine
54Distribution: Vine Linux
55Packager: ara_t
56
57
58%description
59This package includes the full libyaml C library version 0.1.5
60 by Kirill Simonov in the package so you don't need to worry
61 about any non-Haskell dependencies.
62
63The package is broken down into two primary modules.
64"Data.Yaml" provides a high-level interface based around the JSON datatypes
65 provided by the @aeson@ package.
66"Text.Libyaml" provides a lower-level, streaming interface.
67For most users, "Data.Yaml" is recommended.
68#'
69
[11631]70
71 %prep
[10166]72%{__rm} -rf ${RPM_BUILD_ROOT}
73
74%build
[11631]75%ghc_pkg_init
[10166]76
[11631]77for pkg in `sed '$d' %{SOURCE0}`; do
78    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
79    pushd ${pkg}
80        %ghc_fix_dependencies ${pkg}
81        %cabal_configure2 %{name} ${pkg}
82        %cabal_build
83        %cabal_haddock
84        %cabal_copy_resister %{name}_${pkg}
85    popd
86done
[10166]87
[11631]88# build yaml
89for pkg in `tail -n 1 %{SOURCE0}`; do
90    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
91    pushd ${pkg}
92        %ghc_fix_dependencies ${pkg}
[11747]93        %cabal_configure2 %{name}/${pkg} \
94                          -f -no-exe
[11631]95        %cabal_build
96        %cabal_haddock
97        %cabal_copy_resister %{pkg_name}-%{version}
98    popd
[10166]99done
100
101
102%install
[11631]103# copy documents
104pushd %{_builddir}/%{pkg_name}-%{version}
105    %{__cp} ChangeLog.md README.md \
106     ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{pkg_name}-%{version}
107popd
[10166]108
109
110%clean
111%{__rm} -rf ${RPM_BUILD_ROOT}
112
113%post
[11631]114%ghc_pkg_recache
[10166]115
116%postun
[11631]117%ghc_pkg_recache
[10166]118
119
120%files
121%defattr(-, root, root)
122%{_bindir}/
123%{_libdir}/ghc-%{ghc_version}/
124%{_libdir}/ghc-lib/
[10237]125%{_docdir}/%{name}/
[10166]126
127
128%changelog
[11747]129* Sat Jul 21 2018 Toshiaki Ara <ara_t@384.jp> 0.9.0-1
130- update to 0.9.0
131- build using ghc-8.4.3
132
[11631]133* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.8.30-1
134- update to 0.8.30
135- rebuild using ghc-8.4.2
136- rewrite using macro
137
[11385]138* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.8.25.1-1
139- update to 0.8.25.1
140- build using ghc-8.2.2
141
142* Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 0.8.21.2-2
143- build using ghc-8.0.2
144
[10915]145* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.8.21.2-1
146- update to 0.8.21.2
147- build using ghc-8.0.1
148
[10237]149* Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.8.16-3
150- rebuilt
151
[10166]152* Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.8.16-2
153- correct SPEC file
154
155* Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.8.16-1
156- new package
Note: See TracBrowser for help on using the repository browser.