source: projects/specs/trunk/y/yakuake/yakuake-vl.spec @ 1407

Revision 1407, 4.0 KB checked in by inagaki, 14 years ago (diff)

NEW: kaffeine, kde-partitionmanager, knemo, yakuake

Line 
1%define dt_vendor fedora
2
3Name:           yakuake
4Summary:        Terminal emulator
5Summary(ja):    端末エミュレータ
6Version:        2.9.7
7Release:        2%{?_dist_release}
8
9Group:          User Interface/Desktops
10License:        GPLv2+
11URL:            http://extragear.kde.org/apps/yakuake/
12Source0:        http://download.berlios.de/yakuake/%{name}-%{version}.tar.bz2
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  desktop-file-utils
16BuildRequires:  gettext
17BuildRequires:  kdelibs4-devel
18# konsolepart
19Requires:       kdebase4
20
21%description
22Yakuake is a "Quake console" like terminal emulator.
23
24%description
25Quake console ライクな端末エミュレータです.
26
27%prep
28%setup -q
29
30
31%build
32mkdir -p %{_target_platform}
33pushd %{_target_platform}
34unset QTDIR || : ; . /etc/profile.d/qt4.sh
35%{cmake} \
36    -DCMAKE_BUILD_TYPE=release \
37    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
38    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
39    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
40    ..
41popd
42
43make %{?_smp_mflags} -C %{_target_platform}
44
45
46%install
47rm -rf %{buildroot}
48make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
49
50## --vendor is discouraged/deprecated these days -- Rex
51#desktop-file-install --vendor=""                          \
52#        --dir=%{buildroot}%{_datadir}/applications         \
53#        --add-category=Utility                                  \
54#        --delete-original                                       \
55#        %{buildroot}%{_datadir}/applications/kde4/yakuake.desktop
56
57%find_lang %{name}
58
59
60%check
61desktop-file-validate  %{buildroot}%{_datadir}/applications/kde4/yakuake.desktop
62
63
64%post
65touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
66
67%posttrans
68gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
69
70%postun
71if [ $1 -eq 0 ] ; then
72touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
73gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
74fi
75
76
77%clean
78rm -rf %{buildroot}
79
80
81%files -f %{name}.lang
82%defattr(-,root,root,-)
83%doc AUTHORS COPYING ChangeLog TODO
84%{_bindir}/yakuake
85%{_datadir}/applications/kde4/yakuake.desktop
86%{_datadir}/kde4/apps/yakuake/
87%{_datadir}/icons/hicolor/*/*/*
88
89
90%changelog
91* Mon Jul 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.9.7-2
92- Initial build for Vine Linux
93
94* Sun Jul 18 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.9.7-1
95- 2.9.7
96- optimize scriptlets
97- use _kde4_ macros
98
99* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.6-2
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
101
102* Thu Jul 10 2009 Johan Cwiklinski <johan AT x-tnd DOT be> 2.9.6-1
103- 2.9.6
104
105* Sat Apr 17 2009 Johan Cwiklinski <johan AT x-tnd DOT be>  2.9.4-3
106- Fix crash with QT 4.5
107
108* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.4-2
109- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
110
111* Thu Sep 4 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 2.9.4-1
112- 2.9.4
113- change BR from kdelibs4-devel to kdelibs-devel
114
115* Fri Jun 20 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 2.9.3-1
116- 2.9.3
117- kdebase is required
118
119* Sat Apr 05 2008 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 2.9.1-1
120- 2.9.1
121- use of %%{cmake_kde4} macro
122- remove no longer needeed chrpath
123
124* Wed Apr 02 2008 Rex Dieter <rdieter@fedoraproject.org> - 2.9-2.beta1
125- BR: kdelibs4-devel
126- description/summary: s/for KDE//
127
128* Mon Feb 11 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 2.9-1.beta1
129- upstream release for KDE4
130
131* Mon Oct 30 2006 Dawid Gajownik <gajownik[AT]gmail.com> - 2.7.5-4
132- Add support for KonsoleScripts (#212862)
133
134* Fri Sep 15 2006 Dawid Gajownik <gajownik[AT]gmail.com> - 2.7.5-3
135- Rebuild for FE6
136- Update e-mail address
137- Fix mixed-use-of-spaces-and-tabs rpmlint warning
138
139* Sat May 20 2006 Dawid Gajownik <gajownik[AT]gmail.com> - 2.7.5-2
140- Add dist tag
141
142* Sat May 20 2006 Dawid Gajownik <gajownik[AT]gmail.com> - 2.7.5-1
143- Update to 2.7.5
144- Add `--disable-dependency-tracking' and `--enable-final' options
145- Include translations
146
147* Mon Oct 24 2005 Mickael <dreadyman@gmail.com>
148- initial release
149
Note: See TracBrowser for help on using the repository browser.