source: projects/specs/trunk/y/yakuake/yakuake-vl.spec @ 10581

Revision 10581, 4.4 KB checked in by Takemikaduchi, 8 years ago (diff)

xlockmore: new upstream release
others: rebuild with gcc-5.4.0

Line 
1Name:           yakuake
2Summary:        Terminal emulator
3Summary(ja):    端末エミュレータ
4Version:        2.9.9
5Release:        2%{?_dist_release}
6
7Group:          User Interface/Desktops
8License:        GPLv2+
9URL:            http://extragear.kde.org/apps/yakuake/
10Source0:        http://download.berlios.de/yakuake/%{name}-%{version}.tar.xz
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  desktop-file-utils
14BuildRequires:  gettext
15BuildRequires:  kdelibs4-devel
16BuildRequires:  soprano-devel
17# konsolepart
18Requires:       kdebase4
19
20%description
21Yakuake is a "Quake console" like terminal emulator.
22
23%description -l ja
24Quake console ライクな端末エミュレータです.
25
26%prep
27%setup -q
28
29
30%build
31mkdir -p %{_target_platform}
32pushd %{_target_platform}
33%{cmake} \
34    -DCMAKE_BUILD_TYPE=release \
35    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
36    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
37    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
38    ..
39popd
40
41make %{?_smp_mflags} -C %{_target_platform}
42
43
44%install
45rm -rf %{buildroot}
46make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
47
48## --vendor is discouraged/deprecated these days -- Rex
49#desktop-file-install --vendor=""                          \
50#        --dir=%{buildroot}%{_datadir}/applications         \
51#        --add-category=Utility                                  \
52#        --delete-original                                       \
53#        %{buildroot}%{_datadir}/applications/kde4/yakuake.desktop
54
55%find_lang %{name}
56
57
58%check
59desktop-file-validate  %{buildroot}%{_datadir}/applications/kde4/yakuake.desktop
60
61
62%post
63touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
64
65%posttrans
66gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
67
68%postun
69if [ $1 -eq 0 ] ; then
70touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
71gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
72fi
73
74
75%clean
76rm -rf %{buildroot}
77
78
79%files -f %{name}.lang
80%defattr(-,root,root,-)
81%doc AUTHORS COPYING ChangeLog TODO
82%{_bindir}/yakuake
83%{_datadir}/applications/kde4/yakuake.desktop
84%{_datadir}/config/yakuake.knsrc
85%{_datadir}/kde4/apps/kconf_update/yakuake-2.9.9-startupnotification.pl
86%{_datadir}/kde4/apps/kconf_update/yakuake.upd
87%{_datadir}/kde4/apps/yakuake/
88%{_datadir}/icons/hicolor/*/*/*
89
90
91%changelog
92* Sun Jul 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.9.9-2
93- rebuild with gcc-5.4.0
94
95* Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.9.9-1
96- new upstream release
97- add BuildRequires: soprano-devel
98
99* Mon Jul 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.9.7-2
100- Initial build for Vine Linux
101
102* Sun Jul 18 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.9.7-1
103- 2.9.7
104- optimize scriptlets
105- use _kde4_ macros
106
107* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.6-2
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
109
110* Thu Jul 10 2009 Johan Cwiklinski <johan AT x-tnd DOT be> 2.9.6-1
111- 2.9.6
112
113* Sat Apr 17 2009 Johan Cwiklinski <johan AT x-tnd DOT be>  2.9.4-3
114- Fix crash with QT 4.5
115
116* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.4-2
117- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
118
119* Thu Sep 4 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 2.9.4-1
120- 2.9.4
121- change BR from kdelibs4-devel to kdelibs-devel
122
123* Fri Jun 20 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 2.9.3-1
124- 2.9.3
125- kdebase is required
126
127* Sat Apr 05 2008 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 2.9.1-1
128- 2.9.1
129- use of %%{cmake_kde4} macro
130- remove no longer needeed chrpath
131
132* Wed Apr 02 2008 Rex Dieter <rdieter@fedoraproject.org> - 2.9-2.beta1
133- BR: kdelibs4-devel
134- description/summary: s/for KDE//
135
136* Mon Feb 11 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 2.9-1.beta1
137- upstream release for KDE4
138
139* Mon Oct 30 2006 Dawid Gajownik <gajownik[AT]gmail.com> - 2.7.5-4
140- Add support for KonsoleScripts (#212862)
141
142* Fri Sep 15 2006 Dawid Gajownik <gajownik[AT]gmail.com> - 2.7.5-3
143- Rebuild for FE6
144- Update e-mail address
145- Fix mixed-use-of-spaces-and-tabs rpmlint warning
146
147* Sat May 20 2006 Dawid Gajownik <gajownik[AT]gmail.com> - 2.7.5-2
148- Add dist tag
149
150* Sat May 20 2006 Dawid Gajownik <gajownik[AT]gmail.com> - 2.7.5-1
151- Update to 2.7.5
152- Add `--disable-dependency-tracking' and `--enable-final' options
153- Include translations
154
155* Mon Oct 24 2005 Mickael <dreadyman@gmail.com>
156- initial release
157
Note: See TracBrowser for help on using the repository browser.