source: projects/specs/trunk/y/yajl/yajl-vl.spec @ 7948

Revision 7948, 3.5 KB checked in by shaolin, 10 years ago (diff)
  • yajl: new upstream release
Line 
1Name: yajl
2Summary: Yet Another JSON Library (YAJL)
3Version: 2.0.4
4Release: 1%{?_dist_release}
5
6Group: System Environment/Libraries
7License: ISC
8URL: http://lloyd.github.com/yajl/
9
10#
11# NB, upstream does not provide pre-built tar.gz downloads. Instead
12# they make you use the 'on the fly' generated tar.gz from GITHub's
13# web interface
14#
15# The Source0 for any version is obtained by a URL
16#
17#   http://github.com/lloyd/yajl/tarball/1.0.7
18#
19# Which causes a download of a archive named after
20# the GIT hash corresponding to the version tag
21#
22#   eg lloyd-yajl-45a1bdb.tar.gz
23#
24# NB even though the tar.gz is generated on the fly by GITHub it
25# will always have identical md5sum
26#
27# So for new versions, update 'githash' to match the hash of the
28# GIT tag associated with updated 'Version:' field just above
29%global githash fee1ebe
30Source0: lloyd-%{name}-%{version}-0-g%{githash}.tar.gz
31Patch1: lloyd-%{name}-%{version}-pkgconfig-location.patch
32Patch2: lloyd-%{name}-%{version}-pkgconfig-includedir.patch
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35BuildRequires: cmake
36
37%description
38Yet Another JSON Library. YAJL is a small event-driven
39(SAX-style) JSON parser written in ANSI C, and a small
40validating JSON generator.
41
42%package devel
43Summary: Libraries, includes, etc to develop with YAJL
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46
47%description devel
48Yet Another JSON Library. YAJL is a small event-driven
49(SAX-style) JSON parser written in ANSI C, and a small
50validating JSON generator.
51
52This sub-package provides the libraries and includes
53necessary for developing against the YAJL library
54
55%prep
56%setup -q -n lloyd-%{name}-%{githash}
57%patch1 -p1
58%patch2 -p1
59
60%build
61# NB, we are not using upstream's 'configure'/'make'
62# wrapper, instead we use cmake directly to better
63# align with Fedora standards
64mkdir build
65cd build
66%cmake ..
67make VERBOSE=1 %{?_smp_mflags}
68
69
70%install
71rm -rf %{buildroot}
72cd build
73make install DESTDIR=%{buildroot}
74
75
76# No static libraries
77rm -f %{buildroot}%{_libdir}/libyajl_s.a
78
79
80%check
81cd test
82./run_tests.sh
83
84%clean
85rm -rf %{buildroot}
86
87%post -p /sbin/ldconfig
88
89%postun -p /sbin/ldconfig
90
91%files
92%defattr(-,root,root,-)
93%doc COPYING ChangeLog README TODO
94%{_bindir}/json_reformat
95%{_bindir}/json_verify
96%{_libdir}/libyajl.so.2
97%{_libdir}/libyajl.so.2.*
98
99%files devel
100%defattr(-,root,root,-)
101%doc COPYING
102%dir %{_includedir}/yajl
103%{_includedir}/yajl/yajl_common.h
104%{_includedir}/yajl/yajl_gen.h
105%{_includedir}/yajl/yajl_parse.h
106%{_includedir}/yajl/yajl_tree.h
107%{_includedir}/yajl/yajl_version.h
108%{_libdir}/libyajl.so
109%{_libdir}/pkgconfig/yajl.pc
110
111
112%changelog
113* Tue Oct 29 2013 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
114- updated to 2.0.4 release
115- Patch1 and Patch2 imported from Fedora
116- fix License tag: s/BSD/ISC/
117
118* Wed Mar 28 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-2
119- rebuild
120
121* Sun Nov 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.1-1
122- updated to 2.0.1
123
124* Thu Aug 18 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.12-2
125- Initial build for Vine Linux
126
127* Tue May  3 2011 Daniel P. Berrange <berrange@redhat.com> - 1.0.12-1
128- Update to 1.0.12 release
129
130* Fri Dec 17 2010 Daniel P. Berrange <berrange@redhat.com> - 1.0.11-1
131- Update to 1.0.11 release
132
133* Mon Jan 11 2010 Daniel P. Berrange <berrange@redhat.com> - 1.0.7-3
134- Fix ignoring of cflags (rhbz #547500)
135
136* Tue Dec  8 2009 Daniel P. Berrange <berrange@redhat.com> - 1.0.7-2
137- Change use of 'define' to 'global'
138
139* Mon Dec  7 2009 Daniel P. Berrange <berrange@redhat.com> - 1.0.7-1
140- Initial Fedora package
Note: See TracBrowser for help on using the repository browser.