source: projects/specs/trunk/y/yaboot/yaboot-vl.spec @ 521

Revision 521, 6.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _noVersionedDependencies 1
2
3Summary:     yaboot - Yet Another Bootloader for New World PowerMacs
4Summary(ja): yaboot - New World ROM PowerMac 用ブートローダ
5Name:        yaboot
6Version:     1.3.13
7Release:     2%{?_dist_release}
8License:     GPL
9Group:       System Environment/Base
10Source0:     http://penguinppc.org/projects/yaboot/yaboot-%{version}.tar.gz
11Patch4:      yaboot-1.3.13-yabootconfig.patch
12Patch7:      yaboot-1.3.10-ext3.patch
13Patch8:      yaboot-1.3.13-sbindir.patch
14Patch10:     yaboot-1.3.10-parted.patch
15Patch11:     yaboot-1.3.13-manpage.patch
16Patch12:     yaboot-1.3.13-gcc34.patch
17Patch23:     yaboot-1.3.13-malloc.patch
18Patch26:     yaboot-1.3.13-printversion.patch
19Patch27:     yaboot-ppc64.patch
20#Vine Patch(es)
21Patch100:    yaboot-1.3.6-vine.patch
22
23URL:         http://www.alaska.net/~erbenson/ybin/
24BuildRoot:   %{_tmppath}/%{name}-%{version}-root
25ExclusiveArch: ppc
26#Requires:    pmac-utils >= 2.0
27Requires:    powerpc-utils >= 1.0.0
28Requires:    hfsutils >= 3.2.6
29Obsoletes:   ybin
30Provides:    ybin = %{version}-%{release}
31
32
33%description
34ybin (YaBoot INstaller) is designed to install yaboot,
35an OpenFirmware bootloader for GNU/Linux written by Benjamin
36Harrenschmidt. When ybin is configured correctly you can simply
37type ybin, and the bootloader and its configuration file will be
38installed/updated on the bootstrap partition without any furthur
39user intervention.
40
41%description -l ja
42ybin (YaBoot Installer) は yaboot (Benjamin Harrenschmidt さんが
43作られた GNU/Linux 用 OpenFirmware ブートローダ) をインストール
44するために作られました.ybin が正しく設定されていれば,あとは
45ybin とタイプするだけで,あとは何もしなくてもブートローダと
46設定ファイルがインストール/更新されます.
47
48
49%prep
50%setup -q
51
52# fix Makefile for non-root users to build/install
53sed -e "s/ -o root//g" \
54    -e "s/ -g root//g" Makefile > Makefile.new
55mv -f Makefile.new Makefile
56
57%patch4 -p1 -b .yabootconfig
58%patch7 -p1 -b .ext3
59%patch8 -p1 -b .sbin
60%patch10 -p1 -b .parted
61%patch11 -p1 -b .manpage
62%patch12 -p1 -b .gcc34
63%patch23 -p1 -b .malloc
64%patch26 -p1 -b .printversion
65%patch27 -p1 -b .ppc64
66
67%patch100 -p1 -b .vine
68
69patch -p0 < man.patch
70
71
72%build
73make
74
75
76%install
77rm -rf ${RPM_BUILD_ROOT}
78make ROOT=${RPM_BUILD_ROOT} PREFIX=%{_prefix} MANDIR=share/man SBINDIR=/sbin install
79cp -a etc/yaboot.conf etc/yaboot.conf.sample
80
81# for temporal compatibility
82install -d -m 0755 ${RPM_BUILD_ROOT}/%{_sbindir}
83for X in ofpath ybin yabootconfig mkofboot ; do
84        ln -sf /sbin/$X ${RPM_BUILD_ROOT}/%{_sbindir}/$X
85done
86
87rm -f $RPM_BUILD_ROOT/etc/yaboot.conf
88touch $RPM_BUILD_ROOT/etc/yaboot.conf
89
90
91%clean
92rm -rf ${RPM_BUILD_ROOT}
93
94
95%files
96%defattr(-,root,root)
97
98%doc BUGS COPYING ChangeLog INSTALL README* THANKS TODO changelog
99%doc doc etc/yaboot.conf.sample
100
101%{_libdir}/yaboot/*
102/sbin/*
103%{_sbindir}/*
104%{_mandir}/man5/*
105%{_mandir}/man8/*
106%ghost %config(noreplace) %{_sysconfdir}/yaboot.conf
107
108
109%changelog
110* Sat Mar 28 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.13-2
111- Requires powerpc-utils now in place of pmac-utils
112
113* Tue Aug 12 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.13-1
114- new versioning policy, spec in UTF-8
115
116* Mon May 21 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.13-0vl3
117- rebuilt with new toolchain
118- import Patch{12,26,27} from 1.3.13-1.16.ydl.0
119
120* Wed Sep 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.13-0vl2
121- s/Copyright/License/
122- import Patch4/7/8/10/11/23 from YDL
123- move {ofpath,ybin,yabootconfig,mkofboot} from /usr/sbin/ to /sbin/
124  /usr/sbin/* are still there for temporal compabitility
125
126* Wed Sep 23 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.13-0vl1
127- updated to upstream 1.3.13 release
128
129* Fri Nov 21 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.11-0vl1
130- updated to upstream 1.3.11 release (Patch11's change was applied)
131
132* Wed Apr 09 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.10-0vl2
133- modified and added Patch11 again
134
135* Tue Mar 26 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.10-0vl1
136- updated to upstream 1.3.10 release
137  (fix ofpath support for early iMacs with current benh kernels)
138
139* Wed Feb 12 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.9-0vl1
140- updated to upstream 1.3.9 release (support newest PowerMac/PowerBook)
141- removed Patch11 (now we can determine the path with /proc/ide/*/devspec)
142  however this devspec entry is only in benh kernels on Oct.29 2002 and up
143
144* Tue Mar 05 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.6-0vl2
145- added Patch11 to detect AEC62XX-based IDE card
146  (although too ad-hoc to be for universal use. Yup, TODO. Sigh.)
147
148* Sat Dec 29 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.6-0vl1
149- updated to 1.3.6 release
150
151* Fri Nov 16 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.5-0vl1
152- updated to 1.3.5 release (first Vine release after ybin/yaboot merger...)
153
154* Wed Jun 13 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
155- 1.1.1-0vl3
156- detect /etc/vine-release and set <OS-VOLUME-NAME> in ofboot.b
157
158* Wed May 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
159- 1.1.1-0vl2
160- Doh! The patch was incorrect. Fixed now.
161
162* Wed May 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
163- 1.1.1-0vl1
164- ybin updated to 1.1.1, as well as yaboot to 1.2.1
165
166* Sat Feb 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
167- 0.30-0vl3
168- yaboot updated to 1.0 release
169
170* Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
171- 0.30-0vl2
172- use better macros
173- man pages moved under /usr/share/man
174
175* Tue Nov 21 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
176- 0.30-0vl1
177- updated to ybin-0.30 with yaboot-0.9
178
179* Wed Oct 18 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
180- 0.26-0vl3
181- modified ofboot (added to patch10) for newest iMac/iBook
182  (thanks K.Hanai-san!)
183
184* Mon Oct 16 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
185- 0.26-0vl2
186- modified ybin (patch10) to install dummy System/Finder file
187  (without this, MacOS may break bootstrap flag...)
188
189* Sat Oct 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
190- 0.26-0vl1
191- first rpm release for Vine Linux/ppc
192- replace yaboot with version 0.8 (from BenH's site)
Note: See TracBrowser for help on using the repository browser.