source: projects/specs/trunk/y/yaboot/yaboot-vl.spec @ 4735

Revision 4735, 6.7 KB checked in by shaolin, 13 years ago (diff)
  • yaboot: add Patch101 to support kernel >= 3.0
Line 
1%define _noVersionedDependencies 1
2
3Summary:     yaboot - Yet Another Bootloader for New World PowerMacs
4Summary(ja): yaboot - New World ROM PowerMac 用ブートローダ
5Name:        yaboot
6Version:     1.3.16
7Release:     2%{?_dist_release}
8License:     GPL
9Group:       System Environment/Base
10Source0:     http://penguinppc.org/projects/yaboot/yaboot-%{version}.tar.gz
11Patch4:      yaboot-1.3.16-yabootconfig.patch
12Patch7:      yaboot-1.3.10-ext3.patch
13Patch8:      yaboot-1.3.13-sbindir.patch
14Patch10:     yaboot-1.3.10-parted.patch
15#Patch11:     yaboot-1.3.13-manpage.patch
16#Patch12:     yaboot-1.3.13-gcc34.patch
17#Patch23:     yaboot-1.3.13-malloc.patch
18#Patch26:     yaboot-1.3.13-printversion.patch
19#Patch27:     yaboot-ppc64.patch
20Patch30:     yaboot-1.3.16-e2fsprogs-build-fix.patch
21#Vine Patch(es)
22Patch100:    yaboot-1.3.6-vine.patch
23Patch101:    yaboot-1.3.16-kernel3.patch
24
25URL:         http://www.alaska.net/~erbenson/ybin/
26BuildRoot:   %{_tmppath}/%{name}-%{version}-root
27ExclusiveArch: ppc
28#Requires:    pmac-utils >= 2.0
29Requires:    powerpc-utils >= 1.0.0
30Requires:    hfsutils >= 3.2.6
31Obsoletes:   ybin
32Provides:    ybin = %{version}-%{release}
33
34
35%description
36ybin (YaBoot INstaller) is designed to install yaboot,
37an OpenFirmware bootloader for GNU/Linux written by Benjamin
38Harrenschmidt. When ybin is configured correctly you can simply
39type ybin, and the bootloader and its configuration file will be
40installed/updated on the bootstrap partition without any furthur
41user intervention.
42
43%description -l ja
44ybin (YaBoot Installer) は yaboot (Benjamin Harrenschmidt さんが
45作られた GNU/Linux 用 OpenFirmware ブートローダ) をインストール
46するために作られました.ybin が正しく設定されていれば,あとは
47ybin とタイプするだけで,あとは何もしなくてもブートローダと
48設定ファイルがインストール/更新されます.
49
50
51%prep
52%setup -q
53
54# fix Makefile for non-root users to build/install
55sed -e "s/ -o root//g" \
56    -e "s/ -g root//g" Makefile > Makefile.new
57mv -f Makefile.new Makefile
58
59%patch4 -p1 -b .yabootconfig
60%patch7 -p1 -b .ext3
61%patch8 -p1 -b .sbin
62%patch10 -p1 -b .parted
63#%patch11 -p1 -b .manpage
64#%patch12 -p1 -b .gcc34
65#%patch23 -p1 -b .malloc
66#%patch26 -p1 -b .printversion
67#%patch27 -p1 -b .ppc64
68%patch30 -p1 -b .e2fsprogs
69
70%patch100 -p1 -b .vine
71%patch101 -p1 -b .kernel3
72
73patch -p0 < man.patch
74
75
76%build
77make
78
79
80%install
81rm -rf ${RPM_BUILD_ROOT}
82make ROOT=${RPM_BUILD_ROOT} PREFIX=%{_prefix} MANDIR=share/man SBINDIR=/sbin install
83cp -a etc/yaboot.conf etc/yaboot.conf.sample
84
85# for temporal compatibility
86install -d -m 0755 ${RPM_BUILD_ROOT}/%{_sbindir}
87for X in ofpath ybin yabootconfig mkofboot ; do
88        ln -sf /sbin/$X ${RPM_BUILD_ROOT}/%{_sbindir}/$X
89done
90
91rm -f $RPM_BUILD_ROOT/etc/yaboot.conf
92touch $RPM_BUILD_ROOT/etc/yaboot.conf
93
94
95%clean
96rm -rf ${RPM_BUILD_ROOT}
97
98
99%files
100%defattr(-,root,root)
101
102%doc BUGS COPYING ChangeLog INSTALL README* THANKS TODO changelog
103%doc doc etc/yaboot.conf.sample
104
105%{_libdir}/yaboot/*
106/sbin/*
107%{_sbindir}/*
108%{_mandir}/man5/*
109%{_mandir}/man8/*
110%ghost %config(noreplace) %{_sysconfdir}/yaboot.conf
111
112
113%changelog
114* Thu Sep  8 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.16-2
115- add Patch101 to get ofpath support kernel >= 3.0
116
117* Mon Apr 18 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.16-1
118- updated to the newest upstream release
119- remove patches that has been already merged into upstream
120- fix some patches for this version
121- add Patch30 to fix build failure with recent e2fsprogs headers
122
123* Sat Mar 28 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.13-2
124- Requires powerpc-utils now in place of pmac-utils
125
126* Tue Aug 12 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.13-1
127- new versioning policy, spec in UTF-8
128
129* Mon May 21 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.13-0vl3
130- rebuilt with new toolchain
131- import Patch{12,26,27} from 1.3.13-1.16.ydl.0
132
133* Wed Sep 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.13-0vl2
134- s/Copyright/License/
135- import Patch4/7/8/10/11/23 from YDL
136- move {ofpath,ybin,yabootconfig,mkofboot} from /usr/sbin/ to /sbin/
137  /usr/sbin/* are still there for temporal compabitility
138
139* Wed Sep 23 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.13-0vl1
140- updated to upstream 1.3.13 release
141
142* Fri Nov 21 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.11-0vl1
143- updated to upstream 1.3.11 release (Patch11's change was applied)
144
145* Wed Apr 09 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.10-0vl2
146- modified and added Patch11 again
147
148* Tue Mar 26 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.10-0vl1
149- updated to upstream 1.3.10 release
150  (fix ofpath support for early iMacs with current benh kernels)
151
152* Wed Feb 12 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.9-0vl1
153- updated to upstream 1.3.9 release (support newest PowerMac/PowerBook)
154- removed Patch11 (now we can determine the path with /proc/ide/*/devspec)
155  however this devspec entry is only in benh kernels on Oct.29 2002 and up
156
157* Tue Mar 05 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.6-0vl2
158- added Patch11 to detect AEC62XX-based IDE card
159  (although too ad-hoc to be for universal use. Yup, TODO. Sigh.)
160
161* Sat Dec 29 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.6-0vl1
162- updated to 1.3.6 release
163
164* Fri Nov 16 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.5-0vl1
165- updated to 1.3.5 release (first Vine release after ybin/yaboot merger...)
166
167* Wed Jun 13 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
168- 1.1.1-0vl3
169- detect /etc/vine-release and set <OS-VOLUME-NAME> in ofboot.b
170
171* Wed May 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
172- 1.1.1-0vl2
173- Doh! The patch was incorrect. Fixed now.
174
175* Wed May 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
176- 1.1.1-0vl1
177- ybin updated to 1.1.1, as well as yaboot to 1.2.1
178
179* Sat Feb 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
180- 0.30-0vl3
181- yaboot updated to 1.0 release
182
183* Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
184- 0.30-0vl2
185- use better macros
186- man pages moved under /usr/share/man
187
188* Tue Nov 21 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
189- 0.30-0vl1
190- updated to ybin-0.30 with yaboot-0.9
191
192* Wed Oct 18 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
193- 0.26-0vl3
194- modified ofboot (added to patch10) for newest iMac/iBook
195  (thanks K.Hanai-san!)
196
197* Mon Oct 16 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
198- 0.26-0vl2
199- modified ybin (patch10) to install dummy System/Finder file
200  (without this, MacOS may break bootstrap flag...)
201
202* Sat Oct 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
203- 0.26-0vl1
204- first rpm release for Vine Linux/ppc
205- replace yaboot with version 0.8 (from BenH's site)
Note: See TracBrowser for help on using the repository browser.