source: projects/specs/trunk/x/xz/xz-vl.spec @ 521

Revision 521, 4.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        LZMA compression utilities
2Summary(ja):    LZMA 圧縮ユーティリティ
3Name:           xz
4Version:        4.999.9
5Release:        1%{?_dist_release}
6License:        LGPLv2+
7Group:          Applications/File
8Source0:        http://tukaani.org/%{name}/%{name}-%{version}beta.tar.bz2
9URL:            http://tukaani.org/%{name}/
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
11Requires:       %{name}-libs = %{version}-%{release}
12
13%description
14XZ Utils are an attempt to make LZMA compression easy to use on free (as in
15freedom) operating systems. This is achieved by providing tools and libraries
16which are similar to use than the equivalents of the most popular existing
17compression algorithms.
18
19LZMA is a general purpose compression algorithm designed by Igor Pavlov as
20part of 7-Zip. It provides high compression ratio while keeping the
21decompression speed fast.
22
23%package        libs
24Summary:        Libraries for decoding LZMA compression
25Summary(ja):    LZMA圧縮をデコードするためのライブラリ
26Group:          System Environment/Libraries
27License:        LGPLv2+
28
29%description    libs
30Libraries for decoding files compressed with LZMA or XZ utils.
31
32%package        devel
33Summary:        Devel libraries & headers for liblzma
34Summary(ja):    liblzma の開発ライブラリとヘッダファイル
35Group:          Development/Libraries
36License:        LGPLv2+
37Requires:       %{name}-libs = %{version}-%{release}
38Requires:       pkgconfig
39
40%description  devel
41Devel libraries and headers for liblzma.
42
43%package        lzma-compat
44Summary:        Older LZMA format compatibility binaries
45Summary(ja):    旧式のLZMAフォーマット互換バイナリ
46Group:          Development/Libraries
47# lz{grep,diff,more} are GPLv2+. Other binaries are LGPLv2+
48License:        GPLv2+ and LGPLv2+
49Requires:       %{name} = %{version}-%{release}
50Obsoletes:      lzma < 5
51Provides:       lzma = 5
52
53%description  lzma-compat
54The lzma-compat package contains compatibility links for older
55commands that deal with the older LZMA format.
56
57%prep
58%setup -q -n %{name}-%{version}beta
59
60%build
61CFLAGS="%{optflags} -D_FILE_OFFSET_BITS=64" \
62CXXFLAGS="%{optflags} -D_FILE_OFFSET_BITS=64" \
63%configure --disable-static
64sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
65sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
66
67make %{?_smp_mflags}
68
69%install
70rm -rf %{buildroot}
71make install DESTDIR=%{buildroot} INSTALL="%{__install} -p"
72rm -f %{buildroot}/%{_libdir}/*.a
73rm -f %{buildroot}/%{_libdir}/*.la
74rm -rf %{buildroot}/%{_docdir}/%{name}
75
76%check
77LD_LIBRARY_PATH=$PWD/src/liblzma/.libs make check
78
79%clean
80rm -rf %{buildroot}
81
82%post libs -p /sbin/ldconfig
83
84%postun libs -p /sbin/ldconfig
85
86%files
87%defattr(-,root,root,-)
88%doc AUTHORS README THANKS COPYING.* ChangeLog
89%{_bindir}/*xz*
90%{_mandir}/man1/*xz*
91
92%files libs
93%defattr(-,root,root,-)
94%doc COPYING.*
95%{_libdir}/lib*.so.*
96
97%files devel
98%defattr(-,root,root,-)
99%dir %{_includedir}/lzma
100%{_includedir}/lzma/*.h
101%{_includedir}/lzma.h
102%{_libdir}/*.so
103%{_libdir}/pkgconfig/liblzma.pc
104
105%files lzma-compat
106%defattr(-,root,root,-)
107%{_bindir}/*lz*
108%{_mandir}/man1/*lz*
109
110%changelog
111* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  4.999.9-1
112- initial build for Vine Linux
113
114* Thu Feb 18 2010 Jindrich Novy <jnovy@redhat.com> 4.999.9-0.2.20091007.beta
115- move xz man pages to main package, leave lzma ones where they belong (#566484)
116
117* Wed Oct 07 2009 Jindrich Novy <jnovy@redhat.com> 4.999.9-0.1.20091007.beta
118- sync with upstream again
119
120* Fri Oct 02 2009 Jindrich Novy <jnovy@redhat.com> 4.999.9-0.1.20091002.beta
121- sync with upstream to generate the same archives on machines with different
122  endianess
123
124* Fri Aug 28 2009 Jindrich Novy <jnovy@redhat.com> 4.999.9-0.1.beta
125- update to 4.999.9beta
126
127* Mon Aug 17 2009 Jindrich Novy <jnovy@redhat.com> 4.999.8-0.10.beta.20090817git
128- sync with upstream because of #517806
129
130* Tue Aug 04 2009 Jindrich Novy <jnovy@redhat.com> 4.999.8-0.9.beta.20090804git
131- update to the latest GIT snapshot
132
133* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.999.8-0.8.beta
134- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
135
136* Fri Jul 17 2009 Bill Nottingham <notting@redhat.com> 4.999.8-0.7.beta
137- tweak summary
138- add %%check section (<tibbs@math.uh.edu>)
139 
140* Thu Jul 09 2009 Bill Nottingham <notting@redhat.com> 4.999.8-0.6.beta
141- fix release versioning to match guidelines
142- fix up lzma-compat summary/description
143- tweak licensing
144
145* Mon Jun 22 2009 Jindrich Novy <jnovy@redhat.com> 4.999.8beta-0.5
146- introduce lzma-compat subpackage
147
148* Fri Jun 19 2009 Jindrich Novy <jnovy@redhat.com> 4.999.8beta-0.4
149- try to not to conflict with lzma
150
151* Thu Jun 18 2009 Jindrich Novy <jnovy@redhat.com> 4.999.8beta-0.3
152- obsolete but don't provide lzma, they are largely incompatible
153- put beta to Release
154
155* Wed Jun 17 2009 Jindrich Novy <jnovy@redhat.com> 4.999.8beta-0.2
156- obsolete old lzma
157- add Requires: pkgconfig
158
159* Tue Jun 16 2009 Jindrich Novy <jnovy@redhat.com> 4.999.8beta-0.1
160- package XZ Utils, based on LZMA Utils packaged by Per Patrice Bouchand
Note: See TracBrowser for help on using the repository browser.