source: projects/specs/trunk/x/xulrunner/xulrunner-vl.spec @ 3951

Revision 3951, 26.2 KB checked in by daisuke, 13 years ago (diff)

xulrunner: update to 2.0.1

Line 
1%define nspr_version 4.8.7
2%define nss_version 3.12.9
3%define cairo_version 1.10.2-2
4%define libnotify_version 0.4
5%define tarballdir mozilla-2.0
6%define libjpeg-turbo_version 1.1.0
7
8%define build_vine6 0
9%define build_vine5 0
10%if "%{?_dist_release}" == "vl6"
11%define build_vine6 1
12%define build_vine5 1
13%endif
14%if "%{?_dist_release}" == "vl5"
15%define build_vine5 1
16%endif
17
18%if %build_vine6
19%define sqlite_version 3.7.5
20%endif
21
22%define version_internal  2.0
23%define mozappdir         %{_libdir}/%{name}-%{version_internal}
24
25# Separated plugins are supported on x86(64) only
26%ifarch %{ix86} x86_64
27%define separated_plugins 1
28%else
29%define separated_plugins 0
30%endif
31
32Summary:        XUL Runtime for Gecko Applications
33Summary(ja):    Gecko アプリケーションのための XUL ランタイム
34Name:           xulrunner
35Version:        2.0.1
36Release:        1%{?_dist_release}
37URL:            http://www.mozilla.org/projects/xulrunner/
38License:        MPLv1.1 or GPLv2+ or LGPLv2+
39Group:          Applications/Internet
40Source0:        %{name}-%{version}.source.tar.bz2
41Source10:       %{name}-mozconfig
42Source11:       %{name}-mozconfig-vine5
43Source12:       %{name}-vine-default-prefs.js
44Source21:       %{name}.sh.in
45Source23:       %{name}.1
46
47# locale sources
48%define MOZ_BUILD_LOCALES "ja"
49Source1000:     xulrunner-%{version}-ja.tar.bz2
50
51# build patches
52Patch0:         xulrunner-version.patch
53Patch1:         mozilla-build.patch
54Patch7:         xulrunner-1.9.2.1-build.patch
55#Patch8:         mozilla-plugin.patch
56Patch9:         mozilla-build-sbrk.patch
57Patch10:        mozilla-libjpeg-turbo.patch
58
59# patches from Fedora
60Patch100:       mozilla-193-pkgconfig.patch
61
62# Upstream patches
63Patch130:        xulrunner-omnijar.patch
64
65
66
67# ---------------------------------------------------
68
69BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
70BuildRequires:  nspr-devel >= %{nspr_version}
71BuildRequires:  nss-devel >= %{nss_version}
72BuildRequires:  cairo-devel >= %{cairo_version}
73BuildRequires:  libpng-devel
74BuildRequires:  libjpeg-turbo-devel >= %{libjpeg-turbo_version}
75BuildRequires:  bzip2-devel
76BuildRequires:  zlib-devel
77BuildRequires:  lcms-devel
78BuildRequires:  libIDL-devel
79BuildRequires:  gtk2-devel
80BuildRequires:  gnome-vfs2-devel
81BuildRequires:  libgnome-devel
82BuildRequires:  libgnomeui-devel
83BuildRequires:  pango-devel
84BuildRequires:  freetype2-devel >= 2.1.9
85BuildRequires:  libXt-devel
86BuildRequires:  libXrender-devel
87%if %{build_vine6}
88BuildRequires:  sqlite3-devel >= %{sqlite_version}
89%endif
90BuildRequires:  libnotify-devel >= %{libnotify_version}
91BuildRequires:  startup-notification-devel
92BuildRequires:  alsa-lib-devel
93BuildRequires:  lcms-devel
94BuildRequires:  zip
95# For -sqlite.patch
96BuildRequires:  autoconf213
97BuildRequires:  libvpx-devel
98
99Requires:       nspr >= %{nspr_version}
100Requires:       nss >= %{nss_version}
101
102Provides:       gecko-libs = %{version}
103
104%description
105XULRunner provides the XUL Runtime environment for Gecko applications.
106
107%package devel
108Summary: Development files for Gecko
109Group: Development/Libraries
110
111Obsoletes: mozilla-devel
112Obsoletes: firefox-devel < 2.1
113Obsoletes: xulrunner-devel-unstable
114
115Provides: gecko-devel = %{version}
116Provides: gecko-devel-unstable = %{version}
117
118Requires: xulrunner = %{version}-%{release}
119Requires: nspr-devel >= %{nspr_version}
120Requires: nss-devel >= %{nss_version}
121Requires: cairo-devel >= %{cairo_version}
122Requires: libjpeg-turbo-devel >= %{libjpeg-turbo_version}
123Requires: zip
124Requires: bzip2-devel
125Requires: zlib-devel
126Requires: lcms-devel
127Requires: libIDL-devel
128Requires: gtk2-devel
129Requires: gnome-vfs2-devel
130Requires: libgnome-devel
131Requires: libgnomeui-devel
132Requires: pango-devel
133Requires: freetype2-devel >= 2.1.9
134Requires: libXt-devel
135Requires: libXrender-devel
136%if %{build_vine6}
137Requires: sqlite3-devel >= %{sqlite_version}
138%endif
139Requires: startup-notification-devel
140Requires: alsa-lib-devel
141
142%description devel
143Gecko development files.
144
145#---------------------------------------------------------------------
146
147%prep
148%setup -q -c -b 1000
149cd %{tarballdir}
150
151sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' \
152    %{P:%%PATCH0} > version.patch
153%{__patch} -p1 -b --suffix .version < version.patch
154
155%patch1  -p2 -b .build
156%patch7  -p2 -b .del
157%patch9  -p2 -b .sbrk
158%patch10 -p2 -b .libjpeg-turbo
159
160%patch100 -p2 -b .pkgconfig
161%patch130 -p1 -b .omnijar
162
163
164%{__rm} -f .mozconfig
165%if %{build_vine6}
166%{__cp} %{SOURCE10} .mozconfig
167%else
168%{__cp} %{SOURCE11} .mozconfig
169%endif
170
171%if !%{?separated_plugins}
172echo "ac_add_options --disable-ipc" >> .mozconfig
173%endif
174
175#---------------------------------------------------------------------
176
177%build
178cd %{tarballdir}
179
180INTERNAL_GECKO=%{version_internal}
181MOZ_APP_DIR=%{_libdir}/%{name}-${INTERNAL_GECKO}
182
183# Mozilla builds with -Wall with exception of a few warnings which show up
184# everywhere in the code; so, don't override that.
185MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
186export CFLAGS=$MOZ_OPT_FLAGS
187export CXXFLAGS=$MOZ_OPT_FLAGS
188
189export PREFIX='%{_prefix}'
190export LIBDIR='%{_libdir}'
191
192MOZ_SMP_FLAGS=-j1
193%ifnarch ppc ppc64 s390 s390x
194[ -z "$RPM_BUILD_NCPUS" ] && \
195     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
196[ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j2
197%endif
198
199export LDFLAGS="-Wl,-rpath,${MOZ_APP_DIR}"
200make -f client.mk configure STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
201make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
202
203# build locales
204LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
205            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
206for dir in $LOCALEDIRS
207do
208  for lang in %{MOZ_BUILD_LOCALES} ; do
209    make -C $dir/locales AB_CD=$lang
210  done
211done
212
213#---------------------------------------------------------------------
214
215%install
216cd %{tarballdir}
217%{__rm} -rf $RPM_BUILD_ROOT
218
219INTERNAL_GECKO=%{version_internal}
220
221INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
222MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
223
224INTERNAL_APP_SDK_NAME=%{name}-sdk-${INTERNAL_GECKO}
225MOZ_APP_SDK_DIR=%{_libdir}/${INTERNAL_APP_SDK_NAME}
226
227# set up our default preferences
228%{__cat} %{SOURCE12} | %{__sed} -e 's,RPM_VERREL,%{version}-%{release},g' > vl-default-prefs
229%{__install} -p -D -m 644 vl-default-prefs $RPM_BUILD_ROOT/${MOZ_APP_DIR}/defaults/pref/all-vine.js
230%{__rm} vl-default-prefs
231
232DESTDIR=$RPM_BUILD_ROOT make install
233
234%{__mkdir_p} $RPM_BUILD_ROOT/${MOZ_APP_DIR} \
235             $RPM_BUILD_ROOT%{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
236             $RPM_BUILD_ROOT%{_includedir}/${INTERNAL_APP_SDK_NAME}
237
238%{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
239
240# Start script install
241%{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
242%{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{version_internal},g' > \
243  $RPM_BUILD_ROOT%{_bindir}/%{name}
244%{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
245
246%{__rm} -f $RPM_BUILD_ROOT${MOZ_APP_DIR}/%{name}-config
247
248cd $RPM_BUILD_ROOT${MOZ_APP_DIR}/chrome
249find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf {} \;
250cd -
251
252# install locales
253#for lang in %{MOZ_BUILD_LOCALES} ; do
254#  %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT/${MOZ_APP_DIR}/chrome/
255#done
256
257# Prepare our devel package
258%{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
259%{__mkdir_p} $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_SDK_NAME}
260%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
261
262%{__cp} -rL dist/include/* \
263  $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
264
265# Copy pc files (for compatibility with 1.9.1)
266%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
267        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
268%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
269        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
270
271# Fix multilib devel conflicts...
272%ifarch x86_64 ia64 s390x ppc64
273%define mozbits 64
274%else
275%define mozbits 32
276%endif
277
278function install_file() {
279genheader=$*
280mv ${genheader}.h ${genheader}%{mozbits}.h
281cat > ${genheader}.h << EOF
282// This file exists to fix multilib conflicts
283#if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__)
284#include "${genheader}64.h"
285#else
286#include "${genheader}32.h"
287#endif
288EOF
289}
290
291pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
292install_file "mozilla-config"
293install_file "jsautocfg"
294install_file "js-config"
295popd
296
297%{__install} -p -c -m 755 dist/bin/xpcshell \
298  dist/bin/xpidl \
299  dist/bin/xpt_dump \
300  dist/bin/xpt_link \
301  $RPM_BUILD_ROOT/${MOZ_APP_DIR}
302
303%{__rm} -rf $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
304%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_NAME}
305
306%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
307ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
308       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
309
310%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
311ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
312       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
313
314%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
315ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
316       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
317
318%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
319ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
320       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
321
322find $RPM_BUILD_ROOT/%{_includedir} -type f -name "*.h" | xargs chmod 644
323find $RPM_BUILD_ROOT/%{_datadir}/idl -type f -name "*.idl" | xargs chmod 644
324
325%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/*.so
326pushd $RPM_BUILD_ROOT${MOZ_APP_DIR}
327for i in *.so; do
328    ln -s ${MOZ_APP_DIR}/$i $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/$i
329done
330popd
331
332# GRE stuff
333%ifarch x86_64 ia64 ppc64 s390x
334%define gre_conf_file gre64.conf
335%else
336%define gre_conf_file gre.conf
337%endif
338
339MOZILLA_GECKO_VERSION=`./config/milestone.pl --topsrcdir=.`
340%{__mv} $RPM_BUILD_ROOT/etc/gre.d/$MOZILLA_GECKO_VERSION".system.conf" \
341        $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
342chmod 644 $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
343
344# Library path
345%ifarch x86_64 ia64 ppc64 s390x
346%define ld_conf_file xulrunner-64.conf
347%else
348%define ld_conf_file xulrunner-32.conf
349%endif
350
351%{__mkdir_p} $RPM_BUILD_ROOT/etc/ld.so.conf.d
352%{__cat} > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{ld_conf_file} << EOF
353${MOZ_APP_DIR}
354EOF
355                       
356# Copy over the LICENSE
357%{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT${MOZ_APP_DIR}
358
359# Use the system hunspell dictionaries
360%{__rm} -rf ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
361ln -s %{_datadir}/myspell ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
362
363# ghost files
364%{__mkdir_p} $RPM_BUILD_ROOT${MOZ_APP_DIR}/components
365touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/compreg.dat
366touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/xpti.dat
367
368#---------------------------------------------------------------------
369
370%clean
371%{__rm} -rf $RPM_BUILD_ROOT
372
373#---------------------------------------------------------------------
374
375%post
376/sbin/ldconfig
377
378%postun
379/sbin/ldconfig
380
381%preun
382# is it a final removal?
383if [ $1 -eq 0 ]; then
384  %{__rm} -rf ${MOZ_APP_DIR}/components
385fi
386
387%files
388%defattr(-,root,root,-)
389%{_bindir}/xulrunner
390%dir /etc/gre.d
391/etc/gre.d/%{gre_conf_file}
392%dir %{mozappdir}
393%doc %attr(644, root, root) %{mozappdir}/LICENSE
394%doc %attr(644, root, root) %{mozappdir}/README.txt
395%{mozappdir}/chrome
396%{mozappdir}/chrome.manifest
397%{mozappdir}/dictionaries
398%dir %{mozappdir}/components
399%ghost %{mozappdir}/components/compreg.dat
400%ghost %{mozappdir}/components/xpti.dat
401%{mozappdir}/components/*.so
402#%{mozappdir}/components/*.xpt
403%{mozappdir}/components/*.manifest
404#%attr(644, root, root) %{mozappdir}/components/*.js
405%{mozappdir}/defaults
406%dir %{mozappdir}/icons
407%attr(644, root, root) %{mozappdir}/icons/*
408%{mozappdir}/omni.jar
409#%{mozappdir}/modules
410%{mozappdir}/plugins
411#%{mozappdir}/res
412%{mozappdir}/*.so
413%{mozappdir}/mozilla-xremote-client
414%{mozappdir}/run-mozilla.sh
415%{mozappdir}/xulrunner
416%{mozappdir}/xulrunner-bin
417%{mozappdir}/xulrunner-stub
418%if %{?separated_plugins}
419%{mozappdir}/plugin-container
420%endif
421%{mozappdir}/platform.ini
422%{mozappdir}/dependentlibs.list
423#%{mozappdir}/greprefs.js
424%{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
425
426# XXX See if these are needed still
427%{mozappdir}/updater*
428%exclude %{mozappdir}/update.locale
429
430%files devel
431%defattr(-,root,root,-)
432%{_datadir}/idl/%{name}*%{version_internal}
433%{_includedir}/%{name}*%{version_internal}
434%{_libdir}/%{name}-sdk-*/
435%{_libdir}/pkgconfig/*.pc
436%{mozappdir}/xpcshell
437%{mozappdir}/xpidl
438%{mozappdir}/xpt_dump
439%{mozappdir}/xpt_link
440
441#---------------------------------------------------------------------
442
443%changelog
444* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-1
445- update to 2.0.1 (sync with firefox-4.0.1)
446
447* Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-1
448- update to 2.0 (sync with firefox-4.0)
449- BR: libjpeg-turbo-devel >= 1.1.0
450- BR: nspr-devel >= 4.8.7
451- BR: nss-devel >= 3.12.9
452- BR: cairo-devel >= 1.10.2-2
453- add Patch130 to use omni.jar (upstream patch)
454
455* Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.15-1
456- update to 1.9.2.15 (sync with firefox-3.6.15)
457
458* Wed Mar 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.14-1
459- update to 1.9.2.14 (sync with firefox-3.6.14)
460
461* Sat Jan 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.13-1
462- update to 1.9.2.13 (sync with firefox-3.6.13)
463
464* Thu Oct 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.11-1
465- update to 1.9.2.11 (sync with firefox-3.6.11)
466
467* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.2.9-2
468- rebuild with rpm-4.8.1 for pkg-config file
469
470* Mon Sep 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.9-1
471- update to 1.9.2.9 (sync with firefox-3.6.9)
472- add patch10 to build with libjpeg-turbo
473- build with sqlite-3.7.2
474- BR: nspr >= 4.8.6
475
476* Mon Jul 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.8-1
477- update tp 1.9.2.8 (sync with firefox-3.6.8)
478
479* Wed Jul 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.7-1
480- update tp 1.9.2.7 (sync with firefox-3.6.7)
481
482* Wed Jun 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2.4-2
483- enable ipc only on ix86/x86_64 arches
484
485* Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
486- update to 1.9.2.4 (sync with firefox-3.6.4)
487- add patch10 to fix build failure
488
489* Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
490- update to 1.9.2.3 (sync with firefox-3.6.3)
491
492* Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
493- update to 1.9.2.2 (sync with firefox-3.6.2)
494- add patch7,9 for fix build failure
495
496* Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
497- enable libnotify support
498  - add ac_add_options --enable-libnotify
499- disable Necko wifi monitor
500  - add ac_add_options --disable-necko-wifi
501  - remove BR: wireless-tools-devel
502- fix %%files devel
503- add patch3,5 to fix jemalloc alignment assertion
504- add Patch8 to fix mozilla-plugin.pc
505
506* Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
507- add BR: libnotify-devel, wireless-tools-devel
508
509* Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
510- update to 1.9.2 (sync with firefox-3.6)
511- obsoletes xulrunner-devel-unstable
512
513* Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
514- use internal sqlite3 on vine5
515
516* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
517- update to 1.9.1.7
518
519* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
520- update to 1.9.1.6
521- build with sqlite3-3.6.21
522
523* Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
524- update to 1.9.1.5
525
526* Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
527- update to 1.9.1.3
528
529* Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
530- really update to 1.9.1.2 (<BTS:0748>)
531
532* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
533- update to 1.9.1.2 (sync with firefox-3.5.2)
534
535* Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
536- update to 1.9.1.1 (sync with firefox-3.5.1)
537- add missing Requires to -devel
538- add missing BR
539
540* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
541- enable-system-cairo
542
543* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
544- update to 1.9.1 (based on firefox 3.5)
545
546* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
547- update to 1.9.1rc3 (sync with firefox 3.5rc3)
548
549* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
550- update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
551- remove old patches
552- require nspr >= 4.8
553
554* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
555- new upstream release
556
557* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
558- update mozconfig
559  - disable-system-cairo for stability
560
561* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
562- new upstream release
563
564* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
565- new upstream release
566- add ja locale
567
568* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
569- new upstream release
570
571* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
572- new upstream release
573
574* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
575- add Patch3
576
577* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
578- update to xulrunner 1.9.0.2 byild 6
579- build with gnome-2.24
580
581* Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
582- new upstream release
583
584* Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
585- initial build for Vine Linux
586
587* Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
588- Update to 1.9 final
589
590* Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
591- Simplify PS/PDF operators
592
593* Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
594- Upstream patch to fsync() less
595
596* Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
597- Ensure we enable startup notification; add BR and modify config
598  (bug #445543)
599
600* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
601- Some files moved to mozilla-filesystem; kill them and add the Req
602
603* Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
604- Clean up the %%files list and get rid of the executable bit on some files
605
606* Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
607- Fix font scaling
608
609* Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
610- Enabled phishing protection (#443403)
611
612* Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
613- Changed "__ppc64__" to "__powerpc64__",
614  "__ppc64__" doesn't work anymore
615- Added fix for #443725 - Critical hanging bug with fix
616  available upstream (mozbz#429903)
617
618* Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
619- Fixed multilib issues, added starting script instead of a symlink
620  to binary (#436393)
621
622* Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
623- Add upstream patches for dpi, toolbar buttons, and invalid keys
624- Re-enable system cairo
625
626* Mon Apr  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
627- Spec cleanups
628
629* Wed Apr  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
630- Beta 5
631
632* Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
633- Beta 5 RC2
634
635* Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
636- Update to latest trunk (2008-03-27)
637
638* Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
639- Update to latest trunk (2008-03-26)
640
641* Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
642- Update to latest trunk (2008-03-25)
643
644* Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
645- Update to latest trunk (2008-03-24)
646
647* Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
648- Update to latest trunk (2008-03-20)
649
650* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
651- Update to latest trunk (2008-03-17)
652
653* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
654- Revert to trunk from the 15th to fix crashes on HTTPS sites
655
656* Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
657- Update to latest trunk (2008-03-16)
658- Add patch to negate a11y slowdown on some pages (#431162)
659
660* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
661- Update to latest trunk (2008-03-15)
662
663* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
664- Avoid conflicts between gecko debuginfo packages
665
666* Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
667- Update to latest trunk (2008-03-12)
668
669* Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
670- Update to latest trunk (2008-03-11)
671
672* Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
673- Update to latest trunk (2008-03-10)
674
675* Sun Mar  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
676- Update to latest trunk (2008-03-09)
677
678* Fri Mar  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
679- Update to latest trunk (2008-03-07)
680
681* Thu Mar  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
682- Update to latest trunk (2008-03-06)
683
684* Tue Mar  4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
685- Update to latest trunk (2008-03-04)
686
687* Sun Mar  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
688- Update to latest trunk (2008-03-02)
689
690* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
691- Update to latest trunk (2008-03-01)
692
693* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
694- Update to latest trunk (2008-02-29)
695
696* Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
697- Update to latest trunk (2008-02-28)
698
699* Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
700- Update to latest trunk (2008-02-27)
701
702* Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
703- Update to latest trunk (2008-02-26)
704
705* Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
706- Update to latest trunk (2008-02-23)
707
708* Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
709- Update to latest trunk (2008-02-22)
710
711* Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
712- Update to latest trunk (2008-02-21)
713
714* Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
715- Update to latest trunk (2008-02-20)
716
717* Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
718- Update to latest trunk (2008-02-17)
719
720* Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
721- Update to latest trunk (2008-02-15)
722
723* Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
724- Update to latest trunk (2008-02-14)
725- Use system hunspell
726
727* Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
728- Update to latest trunk (2008-02-11)
729
730* Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
731- STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
732  you know, debuginfo.
733
734* Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
735- Update to latest trunk (2008-02-10)
736
737* Sat Feb  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
738- Update to latest trunk (2008-02-09)
739
740* Wed Feb  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
741- Update to latest trunk (2008-02-06)
742
743* Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
744- Update to latest trunk (2008-01-30)
745
746* Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
747- rebuild agains new nss
748- enabled gnome vfs
749
750* Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
751- fixed stable pkg-config files (#429654)
752- removed sqlite patch
753
754* Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
755- Update to latest trunk (2008-01-21)
756
757* Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
758- Update to latest trunk (2008-01-15)
759- Now with system extensions directory support
760
761* Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
762- Update to latest trunk (2008-01-13)
763- Use CFLAGS instead of configure arguments
764- Random cleanups: BuildRequires, scriptlets, prefs, etc.
765
766* Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
767- Provide gecko-devel-unstable as well
768
769* Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
770- divided devel package to devel and devel-unstable
771
772* Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
773- removed fedora specific pkg-config files
774- updated to the latest trunk (2008-01-07)
775- removed unnecessary patches
776- fixed idl dir (#427965)
777
778* Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
779- Re-enable camellia256 support now that NSS supports it
780
781* Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
782- updated to the latest trunk (2008-01-03)
783
784* Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
785- Don't Provide webclient (xulrunner is not itself a webclient)
786- Don't Obsolete old firefox, only firefox-devel
787- Kill legacy obsoletes (phoenix, etc) that were never in rawhide
788
789* Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
790- added java and plugin subdirs to plugin includes
791
792* Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
793- dependency fixes, obsoletes firefox < 3 and firefox-devel now
794
795* Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
796- updated to Beta 2.
797- moved SDK to xulrunner-sdk
798
799* Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
800- fixed mozilla-plugin.pc (#412971)
801
802* Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
803- export /etc/gre.d/gre.conf (it's used by python gecko applications)
804
805* Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
806- added xulrunner/js include dir to xulrunner-js
807
808* Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
809- update to beta 1
810
811* Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
812- packed all gecko libraries (#389391)
813
814* Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
815- registered xulrunner libs system-wide
816- added xulrunner-gtkmozembed.pc
817
818* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
819- added proper nss/nspr dependencies
820
821* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
822- more build fixes, use system nss libraries
823
824* Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
825- build fixes
826
827* Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
828- updated to the latest trunk
829
830* Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
831- build fixes for ppc/ppc64
832
833* Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
834- removed conflicts with the current gecko-based apps
835- added updated ppc64 patch
836
837* Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
838- build fixes
839
840* Wed Sep  5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
841- Initial cut at XULRunner 1.9 Alpha 7
842- Temporarily revert camellia 256 support since our nss doesn't support it yet
Note: See TracBrowser for help on using the repository browser.