source: projects/specs/trunk/x/xulrunner/xulrunner-vl.spec @ 2459

Revision 2459, 25.9 KB checked in by daisuke, 14 years ago (diff)

xulrunner: update to 1.9.2.13

Line 
1%define nspr_version 4.8.6
2%define nss_version 3.12
3%define cairo_version 1.8.6
4%define libnotify_version 0.4
5%define tarballdir mozilla-1.9.2
6
7%define build_vine6 0
8%define build_vine5 0
9%if "%{?_dist_release}" == "vl6"
10%define build_vine6 1
11%define build_vine5 1
12%endif
13%if "%{?_dist_release}" == "vl5"
14%define build_vine5 1
15%endif
16
17%if %build_vine6
18%define sqlite_version 3.7.2
19%endif
20
21%define version_internal  1.9.2
22%define mozappdir         %{_libdir}/%{name}-%{version_internal}
23
24# Separated plugins are supported on x86(64) only
25%ifarch %{ix86} x86_64
26%define separated_plugins 1
27%else
28%define separated_plugins 0
29%endif
30
31Summary:        XUL Runtime for Gecko Applications
32Summary(ja):    Gecko アプリケーションのための XUL ランタイム
33Name:           xulrunner
34Version:        1.9.2.13
35Release:        1%{?_dist_release}
36URL:            http://www.mozilla.org/projects/xulrunner/
37License:        MPLv1.1 or GPLv2+ or LGPLv2+
38Group:          Applications/Internet
39Source0:        %{name}-%{version}.source.tar.bz2
40Source10:       %{name}-mozconfig
41Source11:       %{name}-mozconfig-vine5
42Source12:       %{name}-vine-default-prefs.js
43Source21:       %{name}.sh.in
44Source23:       %{name}.1
45
46# locale sources
47%define MOZ_BUILD_LOCALES "ja"
48Source1000:     xulrunner-%{version}-ja.tar.bz2
49
50# build patches
51Patch0:         xulrunner-version.patch
52Patch1:         mozilla-build.patch
53Patch3:         mozilla-jemalloc.patch
54Patch7:         xulrunner-1.9.2.1-build.patch
55#Patch8:         mozilla-plugin.patch
56Patch9:         mozilla-build-sbrk.patch
57Patch10:        mozilla-libjpeg-turbo.patch
58
59# patches from Fedora
60Patch100:       mozilla-192-pkgconfig.patch
61
62# Upstream patches
63
64
65# ---------------------------------------------------
66
67BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
68BuildRequires:  nspr-devel >= %{nspr_version}
69BuildRequires:  nss-devel >= %{nss_version}
70BuildRequires:  cairo-devel >= %{cairo_version}
71BuildRequires:  libpng-devel
72BuildRequires:  libjpeg-turbo-devel
73BuildRequires:  bzip2-devel
74BuildRequires:  zlib-devel
75BuildRequires:  lcms-devel
76BuildRequires:  libIDL-devel
77BuildRequires:  gtk2-devel
78BuildRequires:  gnome-vfs2-devel
79BuildRequires:  libgnome-devel
80BuildRequires:  libgnomeui-devel
81BuildRequires:  pango-devel
82BuildRequires:  freetype2-devel >= 2.1.9
83BuildRequires:  libXt-devel
84BuildRequires:  libXrender-devel
85%if %{build_vine6}
86BuildRequires:  sqlite3-devel >= %{sqlite_version}
87%endif
88BuildRequires:  libnotify-devel >= %{libnotify_version}
89BuildRequires:  startup-notification-devel
90BuildRequires:  alsa-lib-devel
91BuildRequires:  lcms-devel
92BuildRequires:  zip
93# For -sqlite.patch
94BuildRequires:  autoconf213
95
96Requires:       nspr >= %{nspr_version}
97Requires:       nss >= %{nss_version}
98
99Provides:       gecko-libs = %{version}
100
101%description
102XULRunner provides the XUL Runtime environment for Gecko applications.
103
104%package devel
105Summary: Development files for Gecko
106Group: Development/Libraries
107
108Obsoletes: mozilla-devel
109Obsoletes: firefox-devel < 2.1
110Obsoletes: xulrunner-devel-unstable
111
112Provides: gecko-devel = %{version}
113Provides: gecko-devel-unstable = %{version}
114
115Requires: xulrunner = %{version}-%{release}
116Requires: nspr-devel >= %{nspr_version}
117Requires: nss-devel >= %{nss_version}
118Requires: cairo-devel >= %{cairo_version}
119Requires: libjpeg-turbo-devel
120Requires: zip
121Requires: bzip2-devel
122Requires: zlib-devel
123Requires: lcms-devel
124Requires: libIDL-devel
125Requires: gtk2-devel
126Requires: gnome-vfs2-devel
127Requires: libgnome-devel
128Requires: libgnomeui-devel
129Requires: pango-devel
130Requires: freetype2-devel >= 2.1.9
131Requires: libXt-devel
132Requires: libXrender-devel
133%if %{build_vine6}
134Requires: sqlite3-devel >= %{sqlite_version}
135%endif
136Requires: startup-notification-devel
137Requires: alsa-lib-devel
138
139%description devel
140Gecko development files.
141
142#---------------------------------------------------------------------
143
144%prep
145%setup -q -c -b 1000
146cd %{tarballdir}
147
148sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' \
149    %{P:%%PATCH0} > version.patch
150%{__patch} -p1 -b --suffix .version < version.patch
151
152%patch1  -p1 -b .build
153%patch3  -p1 -b .jemalloc
154%patch7  -p2 -b .del
155#%patch8  -p1 -b .plugin
156%patch9  -p2 -b .sbrk
157%patch10 -p1 -b .libjpeg-turbo
158
159%patch100 -p1 -b .pkgconfig
160
161
162%{__rm} -f .mozconfig
163%if %{build_vine6}
164%{__cp} %{SOURCE10} .mozconfig
165%else
166%{__cp} %{SOURCE11} .mozconfig
167%endif
168
169%if !%{?separated_plugins}
170echo "ac_add_options --disable-ipc" >> .mozconfig
171%endif
172
173#---------------------------------------------------------------------
174
175%build
176cd %{tarballdir}
177
178INTERNAL_GECKO=%{version_internal}
179MOZ_APP_DIR=%{_libdir}/%{name}-${INTERNAL_GECKO}
180
181# Mozilla builds with -Wall with exception of a few warnings which show up
182# everywhere in the code; so, don't override that.
183MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
184export CFLAGS=$MOZ_OPT_FLAGS
185export CXXFLAGS=$MOZ_OPT_FLAGS
186
187export PREFIX='%{_prefix}'
188export LIBDIR='%{_libdir}'
189
190MOZ_SMP_FLAGS=-j1
191%ifnarch ppc ppc64 s390 s390x
192[ -z "$RPM_BUILD_NCPUS" ] && \
193     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
194[ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j2
195%endif
196
197export LDFLAGS="-Wl,-rpath,${MOZ_APP_DIR}"
198make -f client.mk configure STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
199make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
200
201# build locales
202LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
203            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
204for dir in $LOCALEDIRS
205do
206  for lang in %{MOZ_BUILD_LOCALES} ; do
207    make -C $dir/locales AB_CD=$lang
208  done
209done
210
211#---------------------------------------------------------------------
212
213%install
214cd %{tarballdir}
215%{__rm} -rf $RPM_BUILD_ROOT
216
217INTERNAL_GECKO=%{version_internal}
218
219INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
220MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
221
222INTERNAL_APP_SDK_NAME=%{name}-sdk-${INTERNAL_GECKO}
223MOZ_APP_SDK_DIR=%{_libdir}/${INTERNAL_APP_SDK_NAME}
224
225#DESTDIR=$RPM_BUILD_ROOT make -f client.mk install STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
226DESTDIR=$RPM_BUILD_ROOT make install
227
228%{__mkdir_p} $RPM_BUILD_ROOT/${MOZ_APP_DIR} \
229             $RPM_BUILD_ROOT%{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
230             $RPM_BUILD_ROOT%{_includedir}/${INTERNAL_APP_SDK_NAME}
231%{__install} -p dist/sdk/bin/regxpcom $RPM_BUILD_ROOT/$MOZ_APP_DIR
232
233%{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
234
235# set up our default preferences
236%{__cat} %{SOURCE12} | %{__sed} -e 's,RPM_VERREL,%{version}-%{release},g' > vl-default-prefs
237%{__install} -p -D -m 644 vl-default-prefs $RPM_BUILD_ROOT/${MOZ_APP_DIR}/defaults/pref/all-vine.js
238%{__rm} vl-default-prefs
239
240# Start script install
241%{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
242%{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{version_internal},g' > \
243  $RPM_BUILD_ROOT%{_bindir}/%{name}
244%{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
245
246%{__rm} -f $RPM_BUILD_ROOT${MOZ_APP_DIR}/%{name}-config
247
248cd $RPM_BUILD_ROOT${MOZ_APP_DIR}/chrome
249find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf {} \;
250cd -
251
252# install locales
253for lang in %{MOZ_BUILD_LOCALES} ; do
254  %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT/${MOZ_APP_DIR}/chrome/
255done
256
257# Prepare our devel package
258%{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
259%{__mkdir_p} $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_SDK_NAME}
260%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
261
262%{__cp} -rL dist/include/* \
263  $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
264
265# Copy pc files (for compatibility with 1.9.1)
266%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
267        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
268%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
269        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
270
271# Fix multilib devel conflicts...
272%ifarch x86_64 ia64 s390x ppc64
273%define mozbits 64
274%else
275%define mozbits 32
276%endif
277
278function install_file() {
279genheader=$*
280mv ${genheader}.h ${genheader}%{mozbits}.h
281cat > ${genheader}.h << EOF
282// This file exists to fix multilib conflicts
283#if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__)
284#include "${genheader}64.h"
285#else
286#include "${genheader}32.h"
287#endif
288EOF
289}
290
291pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
292install_file "mozilla-config"
293popd
294
295pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
296install_file "jsautocfg"
297popd
298
299%{__install} -p -c -m 755 dist/bin/xpcshell \
300  dist/bin/xpidl \
301  dist/bin/xpt_dump \
302  dist/bin/xpt_link \
303  $RPM_BUILD_ROOT/${MOZ_APP_DIR}
304
305%{__rm} -rf $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
306%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_NAME}
307
308%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
309ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
310       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
311
312%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
313ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
314       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
315
316%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
317ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
318       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
319
320%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
321ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
322       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
323
324find $RPM_BUILD_ROOT/%{_includedir} -type f -name "*.h" | xargs chmod 644
325find $RPM_BUILD_ROOT/%{_datadir}/idl -type f -name "*.idl" | xargs chmod 644
326
327%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/*.so
328pushd $RPM_BUILD_ROOT${MOZ_APP_DIR}
329for i in *.so; do
330    ln -s ${MOZ_APP_DIR}/$i $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/$i
331done
332popd
333
334# GRE stuff
335%ifarch x86_64 ia64 ppc64 s390x
336%define gre_conf_file gre64.conf
337%else
338%define gre_conf_file gre.conf
339%endif
340
341MOZILLA_GECKO_VERSION=`./config/milestone.pl --topsrcdir=.`
342%{__mv} $RPM_BUILD_ROOT/etc/gre.d/$MOZILLA_GECKO_VERSION".system.conf" \
343        $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
344chmod 644 $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
345
346# Library path
347%ifarch x86_64 ia64 ppc64 s390x
348%define ld_conf_file xulrunner-64.conf
349%else
350%define ld_conf_file xulrunner-32.conf
351%endif
352
353%{__mkdir_p} $RPM_BUILD_ROOT/etc/ld.so.conf.d
354%{__cat} > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{ld_conf_file} << EOF
355${MOZ_APP_DIR}
356EOF
357                       
358# Copy over the LICENSE
359%{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT${MOZ_APP_DIR}
360
361# Use the system hunspell dictionaries
362%{__rm} -rf ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
363ln -s %{_datadir}/myspell ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
364
365# ghost files
366%{__mkdir_p} $RPM_BUILD_ROOT${MOZ_APP_DIR}/components
367touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/compreg.dat
368touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/xpti.dat
369
370#---------------------------------------------------------------------
371
372%clean
373%{__rm} -rf $RPM_BUILD_ROOT
374
375#---------------------------------------------------------------------
376
377%post
378/sbin/ldconfig
379
380%postun
381/sbin/ldconfig
382
383%preun
384# is it a final removal?
385if [ $1 -eq 0 ]; then
386  %{__rm} -rf ${MOZ_APP_DIR}/components
387fi
388
389%files
390%defattr(-,root,root,-)
391%{_bindir}/xulrunner
392%dir /etc/gre.d
393/etc/gre.d/%{gre_conf_file}
394%dir %{mozappdir}
395%doc %attr(644, root, root) %{mozappdir}/LICENSE
396%doc %attr(644, root, root) %{mozappdir}/README.txt
397%{mozappdir}/chrome
398%{mozappdir}/dictionaries
399%dir %{mozappdir}/components
400%ghost %{mozappdir}/components/compreg.dat
401%ghost %{mozappdir}/components/xpti.dat
402%{mozappdir}/components/*.so
403%{mozappdir}/components/*.xpt
404%attr(644, root, root) %{mozappdir}/components/*.js
405%{mozappdir}/defaults
406%{mozappdir}/greprefs
407%dir %{mozappdir}/icons
408%attr(644, root, root) %{mozappdir}/icons/*
409%{mozappdir}/modules
410%{mozappdir}/plugins
411%{mozappdir}/res
412%{mozappdir}/*.so
413%{mozappdir}/mozilla-xremote-client
414%{mozappdir}/run-mozilla.sh
415%{mozappdir}/regxpcom
416%{mozappdir}/xulrunner
417%{mozappdir}/xulrunner-bin
418%{mozappdir}/xulrunner-stub
419%if %{?separated_plugins}
420%{mozappdir}/plugin-container
421%endif
422%{mozappdir}/platform.ini
423%{mozappdir}/dependentlibs.list
424%{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
425
426# XXX See if these are needed still
427%{mozappdir}/updater*
428%exclude %{mozappdir}/update.locale
429%exclude %{mozappdir}/components/components.list
430
431%files devel
432%defattr(-,root,root,-)
433%dir %{_datadir}/idl/%{name}*%{version_internal}
434%{_datadir}/idl/%{name}*%{version_internal}/*
435%{_includedir}/%{name}*%{version_internal}
436%dir %{_libdir}/%{name}-sdk-*
437%dir %{_libdir}/%{name}-sdk-*/sdk
438%{_libdir}/%{name}-sdk-*/*
439%{_libdir}/%{name}-sdk-*/sdk/*
440%{_libdir}/pkgconfig/*.pc
441%{mozappdir}/xpcshell
442%{mozappdir}/xpidl
443%{mozappdir}/xpt_dump
444%{mozappdir}/xpt_link
445
446#---------------------------------------------------------------------
447
448%changelog
449* Sat Jan 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.13-1
450- update to 1.9.2.13 (sync with firefox-3.6.13)
451
452* Thu Oct 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.11-1
453- update to 1.9.2.11 (sync with firefox-3.6.11)
454
455* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.2.9-2
456- rebuild with rpm-4.8.1 for pkg-config file
457
458* Mon Sep 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.9-1
459- update to 1.9.2.9 (sync with firefox-3.6.9)
460- add patch10 to build with libjpeg-turbo
461- build with sqlite-3.7.2
462- BR: nspr >= 4.8.6
463
464* Mon Jul 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.8-1
465- update tp 1.9.2.8 (sync with firefox-3.6.8)
466
467* Wed Jul 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.7-1
468- update tp 1.9.2.7 (sync with firefox-3.6.7)
469
470* Wed Jun 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2.4-2
471- enable ipc only on ix86/x86_64 arches
472
473* Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
474- update to 1.9.2.4 (sync with firefox-3.6.4)
475- add patch10 to fix build failure
476
477* Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
478- update to 1.9.2.3 (sync with firefox-3.6.3)
479
480* Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
481- update to 1.9.2.2 (sync with firefox-3.6.2)
482- add patch7,9 for fix build failure
483
484* Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
485- enable libnotify support
486  - add ac_add_options --enable-libnotify
487- disable Necko wifi monitor
488  - add ac_add_options --disable-necko-wifi
489  - remove BR: wireless-tools-devel
490- fix %%files devel
491- add patch3,5 to fix jemalloc alignment assertion
492- add Patch8 to fix mozilla-plugin.pc
493
494* Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
495- add BR: libnotify-devel, wireless-tools-devel
496
497* Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
498- update to 1.9.2 (sync with firefox-3.6)
499- obsoletes xulrunner-devel-unstable
500
501* Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
502- use internal sqlite3 on vine5
503
504* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
505- update to 1.9.1.7
506
507* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
508- update to 1.9.1.6
509- build with sqlite3-3.6.21
510
511* Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
512- update to 1.9.1.5
513
514* Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
515- update to 1.9.1.3
516
517* Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
518- really update to 1.9.1.2 (<BTS:0748>)
519
520* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
521- update to 1.9.1.2 (sync with firefox-3.5.2)
522
523* Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
524- update to 1.9.1.1 (sync with firefox-3.5.1)
525- add missing Requires to -devel
526- add missing BR
527
528* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
529- enable-system-cairo
530
531* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
532- update to 1.9.1 (based on firefox 3.5)
533
534* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
535- update to 1.9.1rc3 (sync with firefox 3.5rc3)
536
537* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
538- update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
539- remove old patches
540- require nspr >= 4.8
541
542* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
543- new upstream release
544
545* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
546- update mozconfig
547  - disable-system-cairo for stability
548
549* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
550- new upstream release
551
552* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
553- new upstream release
554- add ja locale
555
556* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
557- new upstream release
558
559* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
560- new upstream release
561
562* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
563- add Patch3
564
565* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
566- update to xulrunner 1.9.0.2 byild 6
567- build with gnome-2.24
568
569* Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
570- new upstream release
571
572* Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
573- initial build for Vine Linux
574
575* Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
576- Update to 1.9 final
577
578* Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
579- Simplify PS/PDF operators
580
581* Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
582- Upstream patch to fsync() less
583
584* Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
585- Ensure we enable startup notification; add BR and modify config
586  (bug #445543)
587
588* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
589- Some files moved to mozilla-filesystem; kill them and add the Req
590
591* Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
592- Clean up the %%files list and get rid of the executable bit on some files
593
594* Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
595- Fix font scaling
596
597* Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
598- Enabled phishing protection (#443403)
599
600* Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
601- Changed "__ppc64__" to "__powerpc64__",
602  "__ppc64__" doesn't work anymore
603- Added fix for #443725 - Critical hanging bug with fix
604  available upstream (mozbz#429903)
605
606* Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
607- Fixed multilib issues, added starting script instead of a symlink
608  to binary (#436393)
609
610* Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
611- Add upstream patches for dpi, toolbar buttons, and invalid keys
612- Re-enable system cairo
613
614* Mon Apr  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
615- Spec cleanups
616
617* Wed Apr  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
618- Beta 5
619
620* Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
621- Beta 5 RC2
622
623* Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
624- Update to latest trunk (2008-03-27)
625
626* Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
627- Update to latest trunk (2008-03-26)
628
629* Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
630- Update to latest trunk (2008-03-25)
631
632* Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
633- Update to latest trunk (2008-03-24)
634
635* Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
636- Update to latest trunk (2008-03-20)
637
638* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
639- Update to latest trunk (2008-03-17)
640
641* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
642- Revert to trunk from the 15th to fix crashes on HTTPS sites
643
644* Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
645- Update to latest trunk (2008-03-16)
646- Add patch to negate a11y slowdown on some pages (#431162)
647
648* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
649- Update to latest trunk (2008-03-15)
650
651* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
652- Avoid conflicts between gecko debuginfo packages
653
654* Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
655- Update to latest trunk (2008-03-12)
656
657* Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
658- Update to latest trunk (2008-03-11)
659
660* Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
661- Update to latest trunk (2008-03-10)
662
663* Sun Mar  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
664- Update to latest trunk (2008-03-09)
665
666* Fri Mar  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
667- Update to latest trunk (2008-03-07)
668
669* Thu Mar  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
670- Update to latest trunk (2008-03-06)
671
672* Tue Mar  4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
673- Update to latest trunk (2008-03-04)
674
675* Sun Mar  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
676- Update to latest trunk (2008-03-02)
677
678* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
679- Update to latest trunk (2008-03-01)
680
681* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
682- Update to latest trunk (2008-02-29)
683
684* Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
685- Update to latest trunk (2008-02-28)
686
687* Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
688- Update to latest trunk (2008-02-27)
689
690* Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
691- Update to latest trunk (2008-02-26)
692
693* Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
694- Update to latest trunk (2008-02-23)
695
696* Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
697- Update to latest trunk (2008-02-22)
698
699* Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
700- Update to latest trunk (2008-02-21)
701
702* Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
703- Update to latest trunk (2008-02-20)
704
705* Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
706- Update to latest trunk (2008-02-17)
707
708* Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
709- Update to latest trunk (2008-02-15)
710
711* Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
712- Update to latest trunk (2008-02-14)
713- Use system hunspell
714
715* Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
716- Update to latest trunk (2008-02-11)
717
718* Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
719- STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
720  you know, debuginfo.
721
722* Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
723- Update to latest trunk (2008-02-10)
724
725* Sat Feb  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
726- Update to latest trunk (2008-02-09)
727
728* Wed Feb  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
729- Update to latest trunk (2008-02-06)
730
731* Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
732- Update to latest trunk (2008-01-30)
733
734* Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
735- rebuild agains new nss
736- enabled gnome vfs
737
738* Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
739- fixed stable pkg-config files (#429654)
740- removed sqlite patch
741
742* Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
743- Update to latest trunk (2008-01-21)
744
745* Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
746- Update to latest trunk (2008-01-15)
747- Now with system extensions directory support
748
749* Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
750- Update to latest trunk (2008-01-13)
751- Use CFLAGS instead of configure arguments
752- Random cleanups: BuildRequires, scriptlets, prefs, etc.
753
754* Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
755- Provide gecko-devel-unstable as well
756
757* Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
758- divided devel package to devel and devel-unstable
759
760* Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
761- removed fedora specific pkg-config files
762- updated to the latest trunk (2008-01-07)
763- removed unnecessary patches
764- fixed idl dir (#427965)
765
766* Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
767- Re-enable camellia256 support now that NSS supports it
768
769* Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
770- updated to the latest trunk (2008-01-03)
771
772* Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
773- Don't Provide webclient (xulrunner is not itself a webclient)
774- Don't Obsolete old firefox, only firefox-devel
775- Kill legacy obsoletes (phoenix, etc) that were never in rawhide
776
777* Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
778- added java and plugin subdirs to plugin includes
779
780* Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
781- dependency fixes, obsoletes firefox < 3 and firefox-devel now
782
783* Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
784- updated to Beta 2.
785- moved SDK to xulrunner-sdk
786
787* Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
788- fixed mozilla-plugin.pc (#412971)
789
790* Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
791- export /etc/gre.d/gre.conf (it's used by python gecko applications)
792
793* Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
794- added xulrunner/js include dir to xulrunner-js
795
796* Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
797- update to beta 1
798
799* Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
800- packed all gecko libraries (#389391)
801
802* Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
803- registered xulrunner libs system-wide
804- added xulrunner-gtkmozembed.pc
805
806* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
807- added proper nss/nspr dependencies
808
809* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
810- more build fixes, use system nss libraries
811
812* Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
813- build fixes
814
815* Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
816- updated to the latest trunk
817
818* Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
819- build fixes for ppc/ppc64
820
821* Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
822- removed conflicts with the current gecko-based apps
823- added updated ppc64 patch
824
825* Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
826- build fixes
827
828* Wed Sep  5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
829- Initial cut at XULRunner 1.9 Alpha 7
830- Temporarily revert camellia 256 support since our nss doesn't support it yet
Note: See TracBrowser for help on using the repository browser.