source: projects/specs/trunk/x/xterm/xterm-vl.spec @ 521

Revision 521, 11.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Terminal emulator for the X Window System
2Summary(ja): X ウィンドウシステム用ターミナルエミュレータ
3Name: xterm
4Version: 250
5Release: 1%{?_dist_release}
6URL: http://dickey.his.com/xterm
7License: MIT
8Group: User Interface/X
9
10Source0: ftp://invisible-island.net/xterm/%{name}-%{version}.tgz
11Source1: ftp://invisible-island.net/xterm/16colors.txt
12Source2: %{name}.desktop
13
14Patch1: xterm-245-resources.patch
15Patch2: xterm-222-can-2003-0063.patch
16Patch3: xterm-226-man-page_paths.patch
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: imake, pkgconfig, ncurses-devel
20#BuildRequires: libutempter-devel
21BuildRequires: libXft-devel, libXaw-devel, libXext-devel, desktop-file-utils
22
23%define x11_app_defaults_dir %(pkg-config --variable appdefaultdir xt)
24
25%description
26The xterm program is a terminal emulator for the X Window System. It
27provides DEC VT102 and Tektronix 4014 compatible terminals for
28programs that can't use the window system directly.
29
30%prep
31%setup -q
32
33%patch1 -p1 -b .redhat-resources
34%patch2 -p1 -b .can-2003-0063
35%patch3 -p1 -b .man-page_paths
36
37%build
38%configure \
39        --enable-256-color \
40        --enable-luit \
41%if %{with trace}
42        --enable-trace \
43%endif
44        --enable-warnings \
45        --enable-wide-chars \
46        --with-app-defaults=%{x11_app_defaults_dir} \
47        --with-utempter \
48        --with-tty-group=tty \
49        --disable-full-tgetent
50
51make %{?_smp_mflags}
52
53%install
54rm -rf $RPM_BUILD_ROOT
55make DESTDIR=$RPM_BUILD_ROOT install
56
57cp -fp %{SOURCE1} 16colors.txt
58
59desktop-file-install --vendor="" \
60        --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
61        %{SOURCE2}
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%files
67%defattr(-,root,root,-)
68%doc xterm.log.html ctlseqs.txt 16colors.txt README.i18n
69%{_bindir}/xterm
70%{_bindir}/koi8rxterm
71%{_bindir}/resize
72%{_bindir}/uxterm
73%{_mandir}/man1/koi8rxterm.1*
74%{_mandir}/man1/resize.1*
75%{_mandir}/man1/uxterm.1*
76%{_mandir}/man1/xterm.1*
77%{_datadir}/applications/xterm.desktop
78%{_datadir}/pixmaps/xterm*.xpm
79%{x11_app_defaults_dir}/KOI8RXTerm
80%{x11_app_defaults_dir}/UXTerm
81%{x11_app_defaults_dir}/XTerm
82%{x11_app_defaults_dir}/XTerm-color
83
84%changelog
85* Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 250-1
86- new upstream release
87
88* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 231-2
89- rebuild with libXaw.so.7 (libXaw-1.0.5)
90- spec in utf-8
91
92* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 231-1
93- new versioning policy
94
95* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 231-0vl1
96- initial build for Vine Linux
97
98* Mon Jan 07 2008 Miroslav Lichvar <mlichvar@redhat.com> 231-1
99- update to 231
100- remove setgid utempter from xterm binary (#229360)
101
102* Fri Jan 04 2008 Miroslav Lichvar <mlichvar@redhat.com> 230-1
103- update to 230
104
105* Wed Aug 22 2007 Miroslav Lichvar <mlichvar@redhat.com> 229-2
106- rebuild
107
108* Mon Aug 13 2007 Miroslav Lichvar <mlichvar@redhat.com> 229-1
109- update to 229
110
111* Mon Jul 23 2007 Miroslav Lichvar <mlichvar@redhat.com> 228-1
112- update to 228
113
114* Fri Jun 29 2007 Miroslav Lichvar <mlichvar@redhat.com> 227-1
115- update to 227
116
117* Fri Jun 22 2007 Miroslav Lichvar <mlichvar@redhat.com> 226-1
118- update to 226
119
120* Thu Apr 12 2007 Miroslav Lichvar <mlichvar@redhat.com> 225-2
121- fix sections in man pages
122
123* Tue Mar 27 2007 Miroslav Lichvar <mlichvar@redhat.com> 225-1
124- update to 225
125
126* Tue Mar 20 2007 Miroslav Lichvar <mlichvar@redhat.com> 224-2
127- fix background color setting in alternate screen
128- don't display xterm in menus (#231000)
129
130* Fri Feb 16 2007 Miroslav Lichvar <mlichvar@redhat.com> 224-1
131- update to 224
132- drop utempter group before creating pty
133- add Icon to desktop file (#227925)
134
135* Wed Feb 07 2007 Miroslav Lichvar <mlichvar@redhat.com> 223-3
136- spec cleanup (#226660)
137
138* Thu Jan 18 2007 Miroslav Lichvar <mlichvar@redhat.com> 223-2
139- make xterm binary sgid utempter (#222847)
140- fix font size changes with -fa option (#222340)
141- fix redrawing of internal border (#223027)
142- enable metaSendsEscape resource and set modifyFunctionKeys to 0 by default
143
144* Thu Dec 07 2006 Miroslav Lichvar <mlichvar@redhat.com> 223-1
145- update to 223
146
147* Thu Nov 23 2006 Miroslav Lichvar <mlichvar@redhat.com> 222-1
148- update to 222
149- link with libncurses instead of libtermcap
150- spec cleanup
151
152* Mon Sep 04 2006 Miroslav Lichvar <mlichvar@redhat.com> 215-3.fc6
153- fix segfault when /etc/termcap is missing (#201246)
154
155* Wed Jul 26 2006 Mike A. Harris <mharris@redhat.com> 215-2.fc6
156- Replace BuildRequires utempter with libutempter-devel
157- Change BuildRoot tag to comply with Fedora packaging guidelines
158- Use pkg-config to autodetect the location of the system app-defaults dir
159- Add BuildRequires: pkgconfig
160
161* Mon Jul 17 2006 Jason Vas Dias <jvdias@redhat.com> - 215-1.fc6
162- Upgrade to upstream version 215
163
164* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 213-2.1
165- rebuild
166
167* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> - 213-2.fc6
168- Use correct dist tag in Release string.
169
170* Wed May 31 2006 Jason Vas Dias <jvdias@redhat.com> - 213-1
171- Upgrade to upstream version 213 (fixes bug 192627)
172- fix bug 189161 : make -r/-rv do reverseVideo with or without
173  xterm*{fore,back}ground set
174 
175* Thu Apr 13 2006 Jason Vas Dias <jvdias@redhat.com> - 212-1
176- Upgrade to upstream version 212
177- fix bug 188031 : paths in man-page
178 
179* Wed Mar 29 2006 Jason Vas Dias <jvdias@redhat.com> - 211-4
180- fix bug 186935: cursor GCs must be freed with XtReleaseGC
181
182* Tue Mar 21 2006 Jason Vas Dias <jvdias@redhat.com> - 211-1
183- Upgrade to upstream version 211 (fixes bug 186094).
184- Enable new 'utf8Title' resource by default
185 
186* Tue Mar 07 2006 Jason Vas Dias <jvdias@redhat.com> - 209-4
187- fix bug 183993: call set_cursor_gcs in ReverseVideo
188
189* Wed Feb 22 2006 Jason Vas Dias <jvdias@redhat.com> - 209-2
190- fix bug 182382: check for (VWindow(screen)!=0) in set_cursor_gcs
191- further fix for bug 178302: allow *vt100*cursorColor to be same as fg
192
193* Tue Feb 14 2006 Jason Vas Dias <jvdias@redhat.com> - 209-1
194- Upgrade to upstream version 209 (fixes bug 180450)
195
196* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 208-1.2
197- bump again for double-long bug on ppc(64)
198
199* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 208-1.1
200- rebuilt for new gcc4.1 snapshot and glibc changes
201
202* Tue Jan 17 2006 Jason Vas Dias<jvdias@redhat.com> - 208-1
203- Upgrade to upstream version 208
204- Allow root user to grab the console, even if /dev/console
205  not owned by root
206- restore Red Hat '*VT100*scrollBar:1' default Xresource
207
208* Wed Dec 21 2005 Jason Vas Dias<jvdias@redhat.com> - 207-10
209- Fix bug 164210: tek4014 support should be enabled by default
210
211* Wed Dec 14 2005 Jason Vas Dias<jvdias@redhat.com> - 207-8
212- Fix bug 175684: compile with --enable-256-color
213- Fix bug 155538 addenda - restore '*VT100*backarrowKey:0'
214
215* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
216- rebuilt
217
218* Mon Nov 21 2005 Jason Vas Dias<jvdias@redhat.com> - 207-5
219- fix bug 173703: remove reference to /usr/X11R6/bin/luit :
220  PROJECTROOT should be /usr, not /usr/X11R6
221
222* Thu Nov 18 2005 Jason Vas Dias<jvdias@redhat.com> - 207-4
223- fix bug 173541: better fix for freetype configuration problem
224
225* Mon Nov 14 2005 Jason Vas Dias<jvdias@redhat.com> - 207-1
226- Upgrade to upstream version 207
227- Fix app-defaults directory for modular X11
228
229* Sun Nov 13 2005 Jeremy Katz <katzj@redhat.com> - 206-4
230- rebuild for newer modular X
231
232* Fri Nov 04 2005 Jason Vas Dias <jvdias@redhat.com> 206-1
233- Upgrade to upstream version 206
234
235* Wed Oct 12 2005 Jason Vas Dias <jvdias@redhat.com> 205-1
236- Upgrade to upstream version 205
237  fixes bugs: 124421, 129146, 159562, 161894, 169347
238 
239* Sat Sep 24 2005 Mike A. Harris <mharris@redhat.com> 200-10
240- Updated xterm-resources-redhat.patch to add "xterm*ttyModes: erase ^?"
241  resource to fix bug (#155538,160354,163812,162549)
242 
243* Wed Sep 14 2005 Mike A. Harris <mharris@redhat.com> 200-9
244- Updated xterm-resources-redhat.patch to remove utf8 resource which was
245  added in the 200-7 build, as it was incorrectly set to 'true' instead
246  of '1', and bug #138681 turned out to be a gdm bug instead of an xterm
247  bug.  This fixes bug (#163568).
248 
249* Mon Aug 29 2005 Mike A. Harris <mharris@redhat.com> 200-8
250- Added --disable-tek4014 to ./configure flags, to disable tek support
251  for bug (#164210)
252
253* Mon May 2 2005 Mike A. Harris <mharris@redhat.com> 200-7
254- Updated xterm-resources-redhat.patch to enable xterm utf8 resource by
255  default, as our default OS environment is UTF-8, for bug (#138681)
256
257* Sat Apr 16 2005 Mike A. Harris <mharris@redhat.com> 200-6
258- Added option to spec file to allow easy rebuilding with 256 color option
259  for those who prefer this non-default behaviour (#103402)
260
261* Tue Mar 8 2005 Soeren Sandmann <sandmann@redhat.com> 200-5
262- Ported xterm-resources-redhat.patch to newer xterms. (#126855)
263
264* Sun Mar 6 2005 Mike A. Harris <mharris@redhat.com> 200-4
265- Added libtermcap-devel and utempter to BuildRequires
266- Changed BuildRequires from XFree86-devel to xorg-x11-devel
267
268* Sun Mar 6 2005 Mike A. Harris <mharris@redhat.com> 200-3
269- Rebuild with gcc 4 for FC4 development
270
271* Mon Feb 7 2005 Mike A. Harris <mharris@redhat.com> 200-2
272- Removed chmod from prep, and updated comment to refect (#128341c12)
273
274* Mon Feb 7 2005 Mike A. Harris <mharris@redhat.com> 200-1
275- Updated main tarball to xterm-200 for FC4 devel
276- Disabled xterm-179-ppc-fix-bug-101472.patch for now, to see if the problem
277  occurs on ppc still or not.
278
279* Fri Jul 13 2004 Mike A. Harris <mharris@redhat.com> 192-1
280- Updated main tarball to xterm-192 for FC3 devel
281- Resolved bugs #126569,127132
282
283* Fri Jun 18 2004 Mike A. Harris <mharris@redhat.com> 191-1
284- Updated main tarball to xterm-191 for FC3 devel
285- Disabled xterm-resources-redhat.patch to see what if anything breaks, as
286  it no longer applies cleanly.  Hopefully we can just ship stock xterm
287  resources now, although I realize that is more likely to be a pie in the
288  sky fantasy once the bug reports trickle in from this change.  ;o)
289 
290* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 179-8
291- rebuilt
292
293* Thu Jun  3 2004 Mike A. Harris <mharris@redhat.com> 179-7
294- Rebuilt for FC3 devel
295
296* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 179-6.EL
297- rebuilt
298
299* Mon Sep  8 2003 Mike A. Harris <mharris@redhat.com> 179-5.EL
300- Rebuilt 179-5 for Taroon
301
302* Mon Sep  8 2003 Mike A. Harris <mharris@redhat.com> 179-5
303- Added xterm-179-ppc-fix-bug-101472.patch ifarch ppc ppc64 to fix bug (#101472)
304
305* Wed Aug 27 2003 Bill Nottingham <notting@redhat.com> 179-4.1
306- fix symlink
307- rebuild
308
309* Wed Aug 13 2003 Mike A. Harris <mharris@redhat.com> 179-3.EL
310- Rebuilt for Taroon with symlink fixes.
311
312* Wed Aug 13 2003 Mike A. Harris <mharris@redhat.com> 179-3
313- Added symlink /usr/X11R6/bin/xterm pointing to _bindir/xterm so that apps
314  and scripts which invoke xterm explicitly as /usr/X11R6/bin/xterm, will
315  continue to work correctly without surprises (#101994)
316
317* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> 179-2.EL
318- rebuilt
319
320* Fri May 30 2003 Mike A. Harris <mharris@redhat.com> 179-1.EL
321- Bump release to 1.EL for Red Hat Enterprise Linux build
322
323* Mon May 26 2003 Mike A. Harris <mharris@redhat.com> 179-1
324- Updated to upstream xterm 179
325- [SECURITY] Added xterm-can-2003-0063.patch from XFree86 4.3.0-12 package
326- Added Red Hat xterm-resources-redhat.patch from XFree86 4.3.0-12 package
327- Added "chmod -R u+w *" after source is decompressed or else patches can not
328  be applied due to upstream source being read only files
329- Built xterm 179-1 in rawhide
330
331* Mon May  5 2003 Mike A. Harris <mharris@redhat.com> 177-2.0.EL
332- Bump release to 2.0.EL for Red Hat Enterprise Linux build
333
334* Mon May  5 2003 Mike A. Harris <mharris@redhat.com> 177-2
335- Build fix for lib64:  _x11datadir == /usr/X11R6/lib
336- Another lib64 build fix:  xterm uses /usr/%%{_lib}/X11/app-defaults when it
337  should be using an arch-neutral dir {_x11datadir}/X11/app-defaults instead
338
339* Tue Apr 15 2003 Mike A. Harris <mharris@redhat.com> 177-1
340- Call configure with "--enable-luit --enable-warnings --enable-wide-chars
341  --with-utempter"
342- Initial build.
Note: See TracBrowser for help on using the repository browser.