source: projects/specs/trunk/x/xsp/xsp-vl.spec @ 521

Revision 521, 5.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define mono_dir %(/usr/bin/monodir)
2Summary: Small Web Server Hosting ASP.NET
3Summary(ja): ASP.NET を提供する小さなウェブサーバ
4Name: xsp
5URL: http://go-mono.com/
6License: GNU General Public License (GPL)
7Group: Applications/Internet
8#Autoreqprov: on
9Version: 2.6
10Release: 1%{?_dist_release}
11Source: http://mono.ximian.com/monobuild/preview/sources/xsp/xsp-%{version}.tar.bz2
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildArch: noarch
14BuildRequires: mono-devel mono-web
15BuildRequires: mono-data-sqlite mono-data-oracle mono-jscript mono-extras mono-nunit
16BuildRequires: pkgconfig
17# One of the test runs requires this
18BuildRequires: sqlite
19# This must be manually entered according to xsp's protocol version
20# Since this package is currently noarch, and mod_mono's name is different
21# on different distros, we can't use this... yet
22#Requires: mod_mono >= %{version}
23
24%description
25The XSP server is a small Web server that hosts the Mono System.Web
26classes for running what is commonly known as ASP.NET.
27
28
29%prep
30%setup -q
31
32%build
33export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
34# Cannot use the configure macro because noarch-redhat-linux is not recognized by the auto tools in the tarball
35./configure \
36        --prefix=%{_prefix} \
37        --libexecdir=%{_prefix}/lib \
38    --libdir=%{_prefix}/lib \
39    --mandir=%{_prefix}/share/man \
40    --infodir=%{_prefix}/share/info \
41    --sysconfdir=%{_sysconfdir}
42make
43
44
45%install
46rm -rf $RPM_BUILD_ROOT
47export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
48make install DESTDIR=$RPM_BUILD_ROOT
49mkdir -p ${RPM_BUILD_ROOT}%{_datadir}
50mv ${RPM_BUILD_ROOT}%{_prefix}/lib/pkgconfig ${RPM_BUILD_ROOT}%{_datadir}
51
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56
57%files
58%defattr(-,root,root)
59%doc NEWS README
60%{_bindir}/*
61%{_prefix}/lib/xsp
62%{mono_dir}/gac/Mono.WebServer
63%{mono_dir}/1.0/Mono.WebServer.dll
64%{mono_dir}/gac/Mono.WebServer2
65%{mono_dir}/2.0/Mono.WebServer2.dll
66%{mono_dir}/gac/xsp
67%{mono_dir}/1.0/xsp.exe
68%{mono_dir}/gac/xsp2
69%{mono_dir}/2.0/xsp2.exe
70%{mono_dir}/gac/mod-mono-server
71%{mono_dir}/1.0/mod-mono-server.exe
72%{mono_dir}/gac/mod-mono-server2
73%{mono_dir}/2.0/mod-mono-server2.exe
74%{mono_dir}/gac/fastcgi-mono-server
75%{mono_dir}/1.0/fastcgi-mono-server.exe
76%{mono_dir}/gac/fastcgi-mono-server2
77%{mono_dir}/2.0/fastcgi-mono-server2.exe
78%{_datadir}/pkgconfig/*
79%{_mandir}/*/*
80
81
82%changelog
83* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.6-1
84- updated to 2.6
85- rebuilt with new toolchain
86
87* Tue Dec 15 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-2
88- updated to 2.4.3
89
90* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
91- changed Group to Applications/Internet
92
93* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-1
94- updated to 2.4
95
96* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1
97- initial build for VineSeed
98        - updated xsp to 2.0
99        - added japanese summary
100        - applied vine versioning policy
101        - spec in utf-8
102
103* Tue Apr 22 2008 wberrier@suse.de
104- update to 1.9.1 (bugfix release)
105  - Output date header (instead of asp.net doing it)
106* Tue Mar 25 2008 wberrier@suse.de
107- update to 1.9
108  - minor test updates
109  - BaseRequestBroker fix: Check if the request ID is valid inside
110  the lock.
111* Mon Jan 14 2008 wberrier@suse.de
112- update to 1.2.6
113  - FastCGI support
114* Thu Aug 30 2007 wberrier@suse.de
115- xsp_1.2.5_p5_final.patch: Fix for regression in the request
116  broker
117* Fri Aug 17 2007 wberrier@suse.de
118- xsp_1.2.5_p4.patch.bz2: Bugfixes found in 1.2.5
119  - bugs: 81699, 81906, 82379, 82057
120  - fixes ability to handle large (GB) uploads (needed for iFolder)
121* Fri Aug  3 2007 wberrier@suse.de
122- Update to 1.2.5
123  - More robust exception handling
124  - Fixed permissions bits for non executable scripts
125  - virtual host support
126  - New Documentation for Mono.WebServer
127  - Improved event handling
128* Tue Jun  5 2007 wberrier@novell.com
129- Remove unnecessary path defines (prefix, sysconfdir)
130- Update to 1.2.4
131  - fix some race conditions and crashes
132  - add tracing support
133* Fri Apr 13 2007 wberrier@novell.com
134- add %%debug_package so debug packages get created
135* Wed Apr 11 2007 wberrier@novell.com
136- Add mono dep/req for older distros
137* Thu Mar  1 2007 wberrier@suse.de
138- Update Update to 1.2.3
139  - Bug fix #80230 (prevents possible nullref)
140  - Support for response header encoding
141* Mon Jan 22 2007 ro@suse.de
142- drop requires for gnome-filesystem
143* Sat Dec  2 2006 wberrier@suse.de
144- Update to 1.2.1 (Fate #301111)
145  - Bugfixes:
146  - close the connection if there's an error reading the headers
147  (including assembly loading exceptions due to a bad installation).
148  - kill the warning that everyone is worried about.
149* Fri Oct 20 2006 wberrier@suse.de
150- Update to 1.1.18
151  - 2.0 updates
152* Thu Oct 19 2006 wberrier@suse.de
153- Add mono-devel to fix bnc #213576 (missing provides)
154* Tue Sep  5 2006 wberrier@suse.de
155- Update to 1.1.17.1 bugfix release
156- Read from the stream, not the socket as the socket data is
157  encrypted when using SSL.
158* Wed Aug 30 2006 wberrier@suse.de
159- Update to 1.1.17
160  - Added support for X.509 client certificates
161  - Update to handle newly created AppDomains
162* Mon Jul 31 2006 wberrier@suse.de
163- update to 1.1.16.1
164- better connection handling
165- fixes bugs: 77698,78034,78621
166* Tue Apr 25 2006 wberrier@suse.de
167- Security update (remove all the duplicated slashes
168  and don't do an extra Replace on non-windows.) and minor fix for
169  [#78034].
170* Wed Jan 25 2006 mls@suse.de
171- converted neededforbuild to BuildRequires
172* Fri Jan  6 2006 wberrier@suse.de
173- Update to 1.1.13, clean up deps
174* Thu Nov 10 2005 wberrier@suse.de
175- Update to 1.1.10, set libdir to lib/
176* Fri Oct  7 2005 wberrier@suse.de
177- Update to 1.1.9.2 and cleanup (I Don't think noarch mono needs
178  libexec, so I disabled the patch)
179* Tue Jul 19 2005 sbrabec@suse.cz
180- Build as noarch (#81109).
181* Fri Jul 15 2005 sbrabec@suse.cz
182- Updated to version 1.0.9 (#96776).
183* Mon Feb 21 2005 clahey@suse.de
184- Updated to 1.0.6.
185* Sun Feb  6 2005 ro@suse.de
186- use /usr/lib/mono
187* Mon Dec 13 2004 clahey@suse.de
188- New package.
Note: See TracBrowser for help on using the repository browser.