source: projects/specs/trunk/x/xsp/xsp-vl.spec @ 2466

Revision 2466, 6.4 KB checked in by owa, 13 years ago (diff)

update mono to 2.8.2

Line 
1%define mono_dir %(/usr/bin/monodir)
2Summary: Small Web Server Hosting ASP.NET
3Summary(ja): ASP.NET を提供する小さなウェブサーバ
4Name: xsp
5URL: http://go-mono.com/
6License: GNU General Public License (GPL)
7Group: Applications/Internet
8Version: 2.8.2
9Release: 1%{?_dist_release}
10Source: http://mono.ximian.com/monobuild/preview/sources/xsp/xsp-%{version}.tar.bz2
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildArch: noarch
13BuildRequires: mono-devel mono-web
14BuildRequires: mono-data-sqlite mono-data-oracle mono-extras mono-nunit
15BuildRequires: pkgconfig
16# One of the test runs requires this
17BuildRequires: sqlite
18# This must be manually entered according to xsp's protocol version
19# Since this package is currently noarch, and mod_mono's name is different
20# on different distros, we can't use this... yet
21#Requires: mod_mono >= %{version}
22
23%description
24The XSP server is a small Web server that hosts the Mono System.Web
25classes for running what is commonly known as ASP.NET.
26
27
28%prep
29%setup -q
30
31%build
32export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
33# Cannot use the configure macro because noarch-redhat-linux is not recognized by the auto tools in the tarball
34./configure \
35        --prefix=%{_prefix} \
36        --libexecdir=%{_prefix}/lib \
37    --libdir=%{_prefix}/lib \
38    --mandir=%{_prefix}/share/man \
39    --infodir=%{_prefix}/share/info \
40    --sysconfdir=%{_sysconfdir}
41make
42
43
44%install
45rm -rf $RPM_BUILD_ROOT
46export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
47make install DESTDIR=$RPM_BUILD_ROOT
48mkdir -p ${RPM_BUILD_ROOT}%{_datadir}
49mv ${RPM_BUILD_ROOT}%{_prefix}/lib/pkgconfig ${RPM_BUILD_ROOT}%{_datadir}
50
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55
56%files
57%defattr(-,root,root)
58%doc NEWS README
59%{_bindir}/*
60%{_prefix}/lib/xsp
61%{mono_dir}/gac/Mono.WebServer2
62%{mono_dir}/gac/fastcgi-mono-server2
63%{mono_dir}/gac/fastcgi-mono-server4
64%{mono_dir}/gac/mod-mono-server2
65%{mono_dir}/gac/mod-mono-server4
66%{mono_dir}/gac/xsp2
67%{mono_dir}/gac/xsp4
68%{mono_dir}/2.0/Mono.WebServer2.dll
69%{mono_dir}/2.0/fastcgi-mono-server2.exe
70%{mono_dir}/2.0/mod-mono-server2.exe
71%{mono_dir}/2.0/xsp2.exe
72%{mono_dir}/4.0/Mono.WebServer2.dll
73%{mono_dir}/4.0/fastcgi-mono-server4.exe
74%{mono_dir}/4.0/mod-mono-server4.exe
75%{mono_dir}/4.0/xsp4.exe
76%{_prefix}/lib/monodoc/sources/Mono.WebServer.*
77%{_datadir}/pkgconfig/*
78%{_mandir}/*/*
79
80
81%changelog
82* Sat Jan 08 2011 Shu KONNO <owa@bg.wakwak.com> 2.8.2-1
83- updated xsp to 2.8.2
84
85* Sun Nov 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-1
86- updated xsp to 2.8.1
87
88* Fri Oct 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-1
89- updated xsp to 2.8
90- rebuilt with mono-2.8
91- dropt BR: mono-jscript
92
93* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-2
94- rebuild with rpm-4.8.1 for pkg-config file
95
96* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1
97- updated xsp to 2.6.5
98
99* Sat May 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
100- updated xsp to 2.6.4
101
102* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
103- updated xsp to 2.6.3
104
105* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.6-1
106- updated to 2.6
107- rebuilt with new toolchain
108
109* Tue Dec 15 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-2
110- updated to 2.4.3
111
112* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
113- changed Group to Applications/Internet
114
115* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-1
116- updated to 2.4
117
118* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1
119- initial build for VineSeed
120        - updated xsp to 2.0
121        - added japanese summary
122        - applied vine versioning policy
123        - spec in utf-8
124
125* Tue Apr 22 2008 wberrier@suse.de
126- update to 1.9.1 (bugfix release)
127  - Output date header (instead of asp.net doing it)
128* Tue Mar 25 2008 wberrier@suse.de
129- update to 1.9
130  - minor test updates
131  - BaseRequestBroker fix: Check if the request ID is valid inside
132  the lock.
133* Mon Jan 14 2008 wberrier@suse.de
134- update to 1.2.6
135  - FastCGI support
136* Thu Aug 30 2007 wberrier@suse.de
137- xsp_1.2.5_p5_final.patch: Fix for regression in the request
138  broker
139* Fri Aug 17 2007 wberrier@suse.de
140- xsp_1.2.5_p4.patch.bz2: Bugfixes found in 1.2.5
141  - bugs: 81699, 81906, 82379, 82057
142  - fixes ability to handle large (GB) uploads (needed for iFolder)
143* Fri Aug  3 2007 wberrier@suse.de
144- Update to 1.2.5
145  - More robust exception handling
146  - Fixed permissions bits for non executable scripts
147  - virtual host support
148  - New Documentation for Mono.WebServer
149  - Improved event handling
150* Tue Jun  5 2007 wberrier@novell.com
151- Remove unnecessary path defines (prefix, sysconfdir)
152- Update to 1.2.4
153  - fix some race conditions and crashes
154  - add tracing support
155* Fri Apr 13 2007 wberrier@novell.com
156- add %%debug_package so debug packages get created
157* Wed Apr 11 2007 wberrier@novell.com
158- Add mono dep/req for older distros
159* Thu Mar  1 2007 wberrier@suse.de
160- Update Update to 1.2.3
161  - Bug fix #80230 (prevents possible nullref)
162  - Support for response header encoding
163* Mon Jan 22 2007 ro@suse.de
164- drop requires for gnome-filesystem
165* Sat Dec  2 2006 wberrier@suse.de
166- Update to 1.2.1 (Fate #301111)
167  - Bugfixes:
168  - close the connection if there's an error reading the headers
169  (including assembly loading exceptions due to a bad installation).
170  - kill the warning that everyone is worried about.
171* Fri Oct 20 2006 wberrier@suse.de
172- Update to 1.1.18
173  - 2.0 updates
174* Thu Oct 19 2006 wberrier@suse.de
175- Add mono-devel to fix bnc #213576 (missing provides)
176* Tue Sep  5 2006 wberrier@suse.de
177- Update to 1.1.17.1 bugfix release
178- Read from the stream, not the socket as the socket data is
179  encrypted when using SSL.
180* Wed Aug 30 2006 wberrier@suse.de
181- Update to 1.1.17
182  - Added support for X.509 client certificates
183  - Update to handle newly created AppDomains
184* Mon Jul 31 2006 wberrier@suse.de
185- update to 1.1.16.1
186- better connection handling
187- fixes bugs: 77698,78034,78621
188* Tue Apr 25 2006 wberrier@suse.de
189- Security update (remove all the duplicated slashes
190  and don't do an extra Replace on non-windows.) and minor fix for
191  [#78034].
192* Wed Jan 25 2006 mls@suse.de
193- converted neededforbuild to BuildRequires
194* Fri Jan  6 2006 wberrier@suse.de
195- Update to 1.1.13, clean up deps
196* Thu Nov 10 2005 wberrier@suse.de
197- Update to 1.1.10, set libdir to lib/
198* Fri Oct  7 2005 wberrier@suse.de
199- Update to 1.1.9.2 and cleanup (I Don't think noarch mono needs
200  libexec, so I disabled the patch)
201* Tue Jul 19 2005 sbrabec@suse.cz
202- Build as noarch (#81109).
203* Fri Jul 15 2005 sbrabec@suse.cz
204- Updated to version 1.0.9 (#96776).
205* Mon Feb 21 2005 clahey@suse.de
206- Updated to 1.0.6.
207* Sun Feb  6 2005 ro@suse.de
208- use /usr/lib/mono
209* Mon Dec 13 2004 clahey@suse.de
210- New package.
Note: See TracBrowser for help on using the repository browser.