source: projects/specs/trunk/x/xsp/xsp-vl.spec @ 2222

Revision 2222, 6.4 KB checked in by owa, 14 years ago (diff)

new upstream

Line 
1%define mono_dir %(/usr/bin/monodir)
2Summary: Small Web Server Hosting ASP.NET
3Summary(ja): ASP.NET を提供する小さなウェブサーバ
4Name: xsp
5URL: http://go-mono.com/
6License: GNU General Public License (GPL)
7Group: Applications/Internet
8Version: 2.8.1
9Release: 1%{?_dist_release}
10Source: http://mono.ximian.com/monobuild/preview/sources/xsp/xsp-%{version}.tar.bz2
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildArch: noarch
13BuildRequires: mono-devel mono-web
14BuildRequires: mono-data-sqlite mono-data-oracle mono-extras mono-nunit
15BuildRequires: pkgconfig
16# One of the test runs requires this
17BuildRequires: sqlite
18# This must be manually entered according to xsp's protocol version
19# Since this package is currently noarch, and mod_mono's name is different
20# on different distros, we can't use this... yet
21#Requires: mod_mono >= %{version}
22
23%description
24The XSP server is a small Web server that hosts the Mono System.Web
25classes for running what is commonly known as ASP.NET.
26
27
28%prep
29%setup -q
30
31%build
32export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
33# Cannot use the configure macro because noarch-redhat-linux is not recognized by the auto tools in the tarball
34./configure \
35        --prefix=%{_prefix} \
36        --libexecdir=%{_prefix}/lib \
37    --libdir=%{_prefix}/lib \
38    --mandir=%{_prefix}/share/man \
39    --infodir=%{_prefix}/share/info \
40    --sysconfdir=%{_sysconfdir}
41make
42
43
44%install
45rm -rf $RPM_BUILD_ROOT
46export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
47make install DESTDIR=$RPM_BUILD_ROOT
48mkdir -p ${RPM_BUILD_ROOT}%{_datadir}
49mv ${RPM_BUILD_ROOT}%{_prefix}/lib/pkgconfig ${RPM_BUILD_ROOT}%{_datadir}
50
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55
56%files
57%defattr(-,root,root)
58%doc NEWS README
59%{_bindir}/*
60%{_prefix}/lib/xsp
61%{mono_dir}/gac/Mono.WebServer2
62%{mono_dir}/gac/fastcgi-mono-server2
63%{mono_dir}/gac/fastcgi-mono-server4
64%{mono_dir}/gac/mod-mono-server2
65%{mono_dir}/gac/mod-mono-server4
66%{mono_dir}/gac/xsp2
67%{mono_dir}/gac/xsp4
68%{mono_dir}/2.0/Mono.WebServer2.dll
69%{mono_dir}/2.0/fastcgi-mono-server2.exe
70%{mono_dir}/2.0/mod-mono-server2.exe
71%{mono_dir}/2.0/xsp2.exe
72%{mono_dir}/4.0/Mono.WebServer2.dll
73%{mono_dir}/4.0/fastcgi-mono-server4.exe
74%{mono_dir}/4.0/mod-mono-server4.exe
75%{mono_dir}/4.0/xsp4.exe
76%{_prefix}/lib/monodoc/sources/Mono.WebServer.*
77%{_datadir}/pkgconfig/*
78%{_mandir}/*/*
79
80
81%changelog
82* Sun Nov 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-1
83- updated xsp to 2.8.1
84
85* Fri Oct 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-1
86- updated xsp to 2.8
87- rebuilt with mono-2.8
88- dropt BR: mono-jscript
89
90* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-2
91- rebuild with rpm-4.8.1 for pkg-config file
92
93* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1
94- updated xsp to 2.6.5
95
96* Sat May 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
97- updated xsp to 2.6.4
98
99* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
100- updated xsp to 2.6.3
101
102* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.6-1
103- updated to 2.6
104- rebuilt with new toolchain
105
106* Tue Dec 15 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-2
107- updated to 2.4.3
108
109* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
110- changed Group to Applications/Internet
111
112* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-1
113- updated to 2.4
114
115* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1
116- initial build for VineSeed
117        - updated xsp to 2.0
118        - added japanese summary
119        - applied vine versioning policy
120        - spec in utf-8
121
122* Tue Apr 22 2008 wberrier@suse.de
123- update to 1.9.1 (bugfix release)
124  - Output date header (instead of asp.net doing it)
125* Tue Mar 25 2008 wberrier@suse.de
126- update to 1.9
127  - minor test updates
128  - BaseRequestBroker fix: Check if the request ID is valid inside
129  the lock.
130* Mon Jan 14 2008 wberrier@suse.de
131- update to 1.2.6
132  - FastCGI support
133* Thu Aug 30 2007 wberrier@suse.de
134- xsp_1.2.5_p5_final.patch: Fix for regression in the request
135  broker
136* Fri Aug 17 2007 wberrier@suse.de
137- xsp_1.2.5_p4.patch.bz2: Bugfixes found in 1.2.5
138  - bugs: 81699, 81906, 82379, 82057
139  - fixes ability to handle large (GB) uploads (needed for iFolder)
140* Fri Aug  3 2007 wberrier@suse.de
141- Update to 1.2.5
142  - More robust exception handling
143  - Fixed permissions bits for non executable scripts
144  - virtual host support
145  - New Documentation for Mono.WebServer
146  - Improved event handling
147* Tue Jun  5 2007 wberrier@novell.com
148- Remove unnecessary path defines (prefix, sysconfdir)
149- Update to 1.2.4
150  - fix some race conditions and crashes
151  - add tracing support
152* Fri Apr 13 2007 wberrier@novell.com
153- add %%debug_package so debug packages get created
154* Wed Apr 11 2007 wberrier@novell.com
155- Add mono dep/req for older distros
156* Thu Mar  1 2007 wberrier@suse.de
157- Update Update to 1.2.3
158  - Bug fix #80230 (prevents possible nullref)
159  - Support for response header encoding
160* Mon Jan 22 2007 ro@suse.de
161- drop requires for gnome-filesystem
162* Sat Dec  2 2006 wberrier@suse.de
163- Update to 1.2.1 (Fate #301111)
164  - Bugfixes:
165  - close the connection if there's an error reading the headers
166  (including assembly loading exceptions due to a bad installation).
167  - kill the warning that everyone is worried about.
168* Fri Oct 20 2006 wberrier@suse.de
169- Update to 1.1.18
170  - 2.0 updates
171* Thu Oct 19 2006 wberrier@suse.de
172- Add mono-devel to fix bnc #213576 (missing provides)
173* Tue Sep  5 2006 wberrier@suse.de
174- Update to 1.1.17.1 bugfix release
175- Read from the stream, not the socket as the socket data is
176  encrypted when using SSL.
177* Wed Aug 30 2006 wberrier@suse.de
178- Update to 1.1.17
179  - Added support for X.509 client certificates
180  - Update to handle newly created AppDomains
181* Mon Jul 31 2006 wberrier@suse.de
182- update to 1.1.16.1
183- better connection handling
184- fixes bugs: 77698,78034,78621
185* Tue Apr 25 2006 wberrier@suse.de
186- Security update (remove all the duplicated slashes
187  and don't do an extra Replace on non-windows.) and minor fix for
188  [#78034].
189* Wed Jan 25 2006 mls@suse.de
190- converted neededforbuild to BuildRequires
191* Fri Jan  6 2006 wberrier@suse.de
192- Update to 1.1.13, clean up deps
193* Thu Nov 10 2005 wberrier@suse.de
194- Update to 1.1.10, set libdir to lib/
195* Fri Oct  7 2005 wberrier@suse.de
196- Update to 1.1.9.2 and cleanup (I Don't think noarch mono needs
197  libexec, so I disabled the patch)
198* Tue Jul 19 2005 sbrabec@suse.cz
199- Build as noarch (#81109).
200* Fri Jul 15 2005 sbrabec@suse.cz
201- Updated to version 1.0.9 (#96776).
202* Mon Feb 21 2005 clahey@suse.de
203- Updated to 1.0.6.
204* Sun Feb  6 2005 ro@suse.de
205- use /usr/lib/mono
206* Mon Dec 13 2004 clahey@suse.de
207- New package.
Note: See TracBrowser for help on using the repository browser.